
 MicroSim PSpice Optimizer

Analog Performance Optimization Software

User’s Guide
MicroSim Corporation
20 Fairbanks

(714) 770-3022
Irvine, California 92618



roSim

g
,”

ks”)
arks in

marks

ystems

oduced
written

on one
porate
Version 8.0, June, 1997.

Copyright 1997, MicroSim Corporation. All rights reserved.
Printed in the United States of America.

TradeMarks
Referenced herein are the trademarks used by MicroSim Corporation to identify its products. Mic
Corporation is the exclusive owners of “MicroSim,” “PSpice,” “PLogic,” “PLSyn.” 

Additional marks of MicroSim include: “StmEd,” “Stimulus Editor,” “Probe,” “Parts,” “Monte Carlo,” “Analo
Behavioral Modeling,” “Device Equations,” “Digital Simulation,” “Digital Files,” “Filter Designer,” “Schematics
“PLogic,” ”PCBoards,” “PSpice Optimizer,” and “PLSyn” and variations theron (collectively the “Trademar
are used in connection with computer programs. MicroSim owns various trademark registrations for these m
the United States and other countries. 

SPECCTRA is a registered trademark of Cooper & Chyan Technology, Inc.

Microsoft, MS-DOS, Windows, Windows NT and the Windows logo are either registered trademarks or trade
of Microsoft Corporation.

Adobe, the Adobe logo, Acrobat, the Acrobat logo, Exchange and PostScript are trademarks of Adobe S
Incorporated or its subsidiaries and may be registered in certain jurisdictions.

EENET is a trademark of Eckert Enterprises.

All other company/product names are trademarks/registered trademarks of their respective holders. 

Copyri ght Notice
Except as permitted under the United States Copyright Act of 1976, no part of this publication may be repr
or distributed in any form or by any means, or stored in a data base or retrieval system, without the prior 
permission of MicroSim Corporation.

As described in the license agreement, you are permitted to run one copy of the MicroSim software 
computer at a time. Unauthorized duplication of the software or documentation is prohibited by law. Cor
Program Licensing and multiple copy discounts are available.

Technical Support
Internet Tech.Support@microsim.com

Phone (714) 837-0790
FAX (714) 455-0554
WWW http://www.microsim.com

Customer Service
Internet Sales@MicroSim.com
Phone (714) 770-3022



Contents
   xiii
  xiv
.  .  xv
  .  xv
.   xvi
 xvii

.   1-1

.   1-2
   1-3
   1-3
  1-4
.   1-5

.   2-1
 2-2
   2-3
 .   2-4
   2-5
   2-6
   2-7
.   2-8
.   2-8
   2-9
2-10
. 2-11
 2-12
 2-14
Before You Be gin
Welcome to MicroSim .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
MicroSim PSpice Optimizer Overview  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
How to Use this Guide .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Typographical Conventions .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Related Documentation  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
If You Have the Evaluation Version   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

Thin gs You Need to KnowChapter 1
Chapter Overview  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
What is the PSpice Optimizer?   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Designs that You Can Optimize .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Designs that You Cannot Optimize  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

Using the PSpice Optimizer with Other MicroSim Programs .  .  .  .  .  .  .  .  .  . 
Terms You Need to Understand .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Primer: How to Optimize a Desi gnChapter 2
Chapter Overview  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Optimizing a Diode Biasing Circuit—the Objective   .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Why Use Optimization? .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Phase One: Developing the Design  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

The PSpice Optimizer Advantage .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Phase Two: Setting Up the Optimization  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

Defining Design Parameters   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Setting Up Goals and Constraints .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Setting up analyses for each goal and constraint  .  .  .  .  .  .  .  .  .  .  .  
Developing performance measures .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Defining specifications: goals and constraints  .  .  .  .  .  .  .  .  .  .  .  .  . 

Phase Three: Running an Optimization  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Running the PSpice Optimizer   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Adding a Constraint and Rerunning the PSpice Optimizer .  .  .  .  .  .  .  .  .



iv Contents

 2-16
 2-18

  2-18
  2-19
 2-19

 .  3-1
  3-2
  3-2
.  3-2
  3-3
  3-3
 3-4
.  3-5
.  3-6
  3-6
  3-7
 .  3-8
.  3-9
  3-10
  3-10
  3-12
 3-13
 3-13
-17

 3-18
 3-18
3-18
3-19
 3-20
 3-21
-22

3-23
3-24
3-24
ns .  

 3-26
 3-26
 3-26
Changing the Constraint and Rerunning the PSpice Optimizer  .  .  .  .  .  .  
Using Standard Component Values  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Producing Reports  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Saving Results  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Updating the Schematic  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Usin g the PSpice OptimizerChapter 3
Chapter Overview   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Activating and Loading the PSpice Optimizer .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

Activating the PSpice Optimizer .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
From Schematics   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
From the Windows 95 Start Menu   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

Changing Activation Options   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Loading a Different Optimization File .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

The PSpice Optimizer Window   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Specifications Area   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Internal specifications  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
External specifications .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

Parameters Area  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Error Gauge Area   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Adding and Editing Parameters   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Adding a Parameter   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Selecting a Parameter to Edit   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

Adding and Editing Specifications .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Adding a Specification .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Defining an Evaluation for an External Specification .  .  .  .  .  .  .  .  .  .  .   3
Selecting a Specification to Edit .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Measuring and Optimizing Performance .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Optimizing Your Design .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   
Graphically Monitoring Progress   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   

Exploring the Effect of Parameter and Specification Changes   .  .  .  .  .  .  .  .  
Testing Performance when Changing Current Values .  .  .  .  .  .  .  .  .  .  .  

Automatically recalculating performance .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   3
Manually recalculating performance   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .   
Ensuring reliable results when tweaking values .  .  .  .  .  .  .  .  .  .  .  .   

Excluding Parameters and Specifications from Optimization .  .  .  .  .  .  .   
Testing Performance when Adding or Changing Parameters or Specificatio

3-25
Saving Intermediate Values  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Viewing Result Summaries   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Producing Optimization Reports .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  



Contents v

-28
3-28
 3-29
. 3-29
. 3-30
 3-31

.   4-1
 .   4-2
   4-3
   4-4
.   4-5
   4-6
  4-6
.   4-7
   4-8
.   4-8
 .   4-9
 .   4-9
. 4-10
 4-10
4-11
. 4-12
. 4-13

-13
-15
4-16
. 4-17
4-17

-17

-19

   5-1
.   5-2
.   5-3
.   5-4
Viewing the Optimization Log   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 3
Viewing Derivatives .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

Finalizing the Design   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Using Standard Component Values .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Saving Results .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Updating the Schematic .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

Understandin g Optimization Principles and OptionsChapter 4
Chapter Overview  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Goals versus Constraints .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Constrained Optimization  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

Types of Constraints   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Feasible and Infeasible Points .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Active and Inactive Constraints .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Lagrange Multipliers   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

Characteristics of Functions .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Global and Local Minima  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Starting Points  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Convergence .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Parameter Bounds  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Derivatives .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

How the PSpice Optimizer Estimates Derivatives   .  .  .  .  .  .  .  .  .  .  .  .  .
Limitations of Derivative Data   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

Target Value Scaling   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Default Options   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Controlling Finite Differencing when Calculating
Derivatives (Delta Option)  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 4

Limiting Simulation Iterations (Max. Iterations Option)  .  .  .  .  .  .  .  .  .  . 4
Specifying a Probe Display (Probe File and Display Options)  .  .  .  .  .  .  . 

Advanced Options .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Controlling Cutback (Cutback Option)  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Controlling Parameter Value Changes Between

Iterations (Threshold Option) .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 4
Choosing an Optimization Method for Single Goal

Problems (Least Squares/Minimization Options)   .  .  .  .  .  .  .  .  . 4

Tutorial: Optimizin g a Design (Passive Terminator)Chapter 5
Tutorial Overview  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
The Passive Terminator Design  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Loading the Design into Schematics   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Setting Component Values to Expressions   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  



vi Contents

.  5-5
.  5-6
 5-6

.  5-7
.  5-8
 .  5-9
 5-11
 5-11
  5-13
  5-13

.  6-1

.  6-2
 .  6-3
 .  6-3
 .  6-5
  6-5
 .  6-6
.  6-7
  6-8

.  7-1
  7-2
 .  7-3
.  7-4
 .  7-6

 7-7
.  7-8

.  8-1
.  8-2
 .  8-3
 .  8-4
.  8-5
.  8-5
 .  8-6
.  8-8
Defining Optimization Parameters .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Defining the Analysis Type   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Running an Initial Circuit Analysis   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Activating the PSpice Optimizer .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Viewing the Parameter Description   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Defining the Goals and Constraints   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Checking that the Design Will Simulate .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Starting the Optimization .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Changing a Goal to a Constraint  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Saving Results  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

Tutorial: Explorin g Design Tradeoffs (Active Filter)Chapter 6
Tutorial Overview   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
The Active Filter Design .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

The Parameters .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
The Goals   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

Testing Performance  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Calculating Derivatives   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Tweaking Parameters   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Tweaking Goals and Constraints   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Completing Optimization   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

Tutorial: Usin g Constrained Optimization (MOS Amplifier)Chapter 7
Tutorial Overview   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
The CMOS Amplifier Design   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

The Parameters .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
The Evaluations   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
The Goals and Constraints .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

Setting the Method for a 
Single-Goal Optimization  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

Performing the Optimization .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Tutorial: Fittin g Model Data (Bipolar Transistor)Chapter 8
Tutorial Overview   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Using the PSpice Optimizer to Fit Data to Model Parameters .  .  .  .  .  .  .  .  .  
The Bipolar Transistor Test Case   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

The Parameters .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
The Analysis .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
The External File of Measured Data .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
The Goals and Constraints .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 

Monitoring Progress with Probe  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  



Contents vii

. 8-10

  A-1
.  A-2

  B-1
.  B-2
B-4
B-5
.  B-6

  C-1
  C-2
  C-3
  C-4
  C-6
Fitting the Data   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Error Messa gesAppendix A
Appendix Overview  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Error Message Descriptions  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

File Types Used by
the PSpice OptimizerAppendix B
Appendix Overview  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
File and Program Relationships  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Measuring Performance Using Information in the Circuit File and .prb File  
Defining Specification Criteria in the External Data File .  .  .  .  .  .  .  .  .  .  

File Type Summary  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  

Optimizin g a 
Netlist-Based Desi gnAppendix C
Appendix Overview  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Optimizing without a Schematic   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Setting Up the Circuit File .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Setting Up and Running the PSpice Optimizer  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Example: Parameterizing the Circuit File  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .

Index



Figures
.   1-4
 .   2-2
.   2-4
   2-6
 . 2-11
. 2-13
. 2-14
 . 2-16
 . 2-17
. 2-19
  . 2-20
.   3-5
.   3-6
 .   3-8
. 3-14
 . 3-27
. 3-28
 . 3-28
.   4-2
   4-8
. 4-11
. 4-18
.   5-2
 .   5-3
. 5-12
.   6-2
   6-8
   7-2
.   7-8
   7-9
   8-3
 .   8-9
Figure 1-1 Optimization Design Flow .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 2-1 Diode Biasing Design Example  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Figure 2-2 “Phase One: Developing the Design” Design Flow .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 2-3 “Phase Two: Setting Up the Optimization” Design Flow .  .  .  .  .  .  .  .  .  .  .  .
Figure 2-4 “Phase Three: Running an Optimization” Design Phase   .  .  .  .  .  .  .  .  .  .  . 
Figure 2-5 PSpice Optimizer Automatic Optimization Process .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 2-6 Optimization Results for the Diode Design Example  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 2-7 Results after Adding the Power Constraint  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Figure 2-8 Results after Changing the Constraint Type .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Figure 2-9 Report Summary for the Diode Optimization .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 2-10 Updated Diode Schematic .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Figure 3-1 The PSpice Optimizer Window  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 3-2 Example of a Specification Box .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 3-3 Example of a Parameter Box   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Figure 3-4 Sample Format for an External Specification  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 3-5 Sample Excerpt from a Report   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Figure 3-6 Sample Excerpt from a Log File .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 3-7 Sample Derivative Data  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Figure 4-1 Resistive Terminator Circuit .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 4-2 Global and Local Minima of a Function .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Figure 4-3 Hypothetical Function .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 4-4 Hypothetical Data Glitch   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 5-1 Resistive Terminator Circuit .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 5-2 Schematic for the Terminator Example, term.sch .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Figure 5-3 Optimization Results for the Passive Terminator Example  .  .  .  .  .  .  .  .  .  .  
Figure 6-1 Schematic for the Active Filter Example, bpf.sch .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Figure 6-2 Optimized Values for the Active Filter Example  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Figure 7-1 Schematic for CMOS Amplifier Example, m2.sch  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Figure 7-2 Updated Performance Values for the Amplifier Example .  .  .  .  .  .  .  .  .  .  .  
Figure 7-3 Optimized Values for the Amplifier Example .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Figure 8-1 Schematic for the BJT Model Fitting Example  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Figure 8-2 Initial Traces for the Ic and Ib Parameters .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 



x Figures

 8-11
  8-11
 B-2
  .  B-5
Figure 8-3 Optimization Results for the BJT Model Fitting Example .  .  .  .  .  .  .  .  .  .  .  
Figure 8-4 Probe Display after Optimization is Complete .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Figure 8-5 MicroSim Program and File Interactions Important to Optimization  .  .  .  .  .  .
Figure B-1 Sample External Data File  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .



Tables
 .   1-5
. 1-11
. 3-11
 3-14
 .  A-2
.  B-6
Table 1-1 Optimization Problems   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Table 1-2 Valid Operators and Functions for PSpice Optimizer Expressions  .  .  .  .  .  .  
Table 3-1 Edit Parameter Dialog Box Controls   .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  
Table 3-2 Edit Specification Dialog Box Controls .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .
Table 8-1 Error Message Descriptions  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  .  . 
Table 8-2 Summary of PSpice Optimizer-Related File Types  .  .  .  .  .  .  .  .  .  .  .  .  .  .  



Before You Be gin
ill 
n 

, 
Welcome to MicroSim
Welcome to the MicroSim family of products. Whichever 
programs you have purchased, we are confident that you w
find that they meet your circuit design needs. They provide a
easy-to-use, integrated environment for creating, simulating
and analyzing your circuit designs from start to finish.
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MicroSim PSpice 
Optimizer Overview
The MicroSim PSpice Optimizer is a circuit optimization 
program that improves the performance of analog and mixe
analog/digital circuits. The PSpice Optimizer is fully integrate
with other MicroSim programs. This means you can design yo
circuit with MicroSim Schematics, simulate with MicroSim 
PSpice A/D (or MicroSim PSpice), analyze results with 
MicroSim Probe and optimize performance within the same 
environment. 
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For UNIX users:

All screen captures in this 
manual are of Windows 95 
dialog boxes and windows. 
Most options in these dialog 
boxes and windows are 
available in your operating 
environment. When certain 
options are not available to you, 
or you must do something 
differently than what is primarily 
outlined, information specific to 
your platform is provided.
How to Use this Guide
This guide is designed so you can quickly find the informatio
you need to use the PSpice Optimizer. 

This guide assumes that you are familiar with Microsoft 
Windows (NT or 95), including how to use icons, menus, an
dialog boxes. It also assumes you have a basic understand
about how Windows manages applications and files to perfo
routine tasks, such as starting applications and opening, an
saving your work. If you are new to Windows, please review
your Microsoft Windows User’s Guide.

Typo graphical Conventions
Before using the PSpice Optimizer, it is important to understa
the terms and typographical conventions used in this 
documentation.

This guide generally follows the conventions used in the 
Microsoft Windows 95 User’s Guide. Procedures for performing
an operation are generally numbered with the following 
typographical conventions.

Notation Examples Description

ALL CAPS ANALOG.SLB or 
CLIPPER.SCH

Library files and file names.

C+r Press C+r A specific key or key stroke 
on the keyboard.

monospace
 font

Type VAC... Commands/text entered from 
the keyboard.

Notation Examples Description



xvi Before You Begin

rd 
can 

p 

This manual...

MicroSim Schematics 
User’s Guide

MicroSim PCBoards
User’s Guide

MicroSim PSpice A/D & Basics+ 
User’s Guide nd 

 

MicroSim PSpice & Basics 
User’s Guide

MicroSim PLSyn
User’s Guide

t 

MicroSim FPGA 
User’s Guide

MicroSim Filter Designer 
User’s Guide

 

Related Documentation
Documentation for MicroSim products is available in both ha
copy and online. To access an online manual instantly, you 
select it from the Help menu in its respective program (for 
example, access the Schematics User’s Guide from the Hel
menu in Schematics).

Note The documentation you receive depends on the 
software configuration you have purchased.

The following table provides a brief description of those 
manuals available in both hard copy and online.

Provides information about how to use...

MicroSim Schematics, which is a schematic capture front-end program 
with a direct interface to other MicroSim programs and options.

MicroSim PCBoards, which is a PCB layout editor that lets you specify 
printed circuit board structure, as well as the components, metal, and 
graphics required for fabrication.

PSpice A/D, Probe, the Stimulus Editor, and the Parts utility, which are 
circuit analysis programs that let you create, simulate, and test analog a
digital circuit designs. It provides examples on how to specify simulation
parameters, analyze simulation results, edit input signals, and create 
models.

MicroSim PSpice & MicroSim PSpice Basics, which are circuit analysis 
programs that let you create, simulate, and test 
analog-only circuit designs.

MicroSim PLSyn, which is a programmable logic synthesis program tha
lets you synthesize PLDs and CPLDs from a schematic or hardware 
description language.

MicroSim FPGA—the interface between MicroSim Schematics and 
XACTstep—with MicroSim PSpice A/D to enter designs that include 
Xilinx field programmable gate array devices. 

MicroSim Filter Designer, which is a filter synthesis program that lets you
design electronic frequency selective filters.
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 Also included: detailed descriptions of the 
ecifications, start-up option definitions, and 
nd digital model libraries. User interface 
you on each of the screen commands.

ow a particular task can be accomplished 
mples that demonstrate a new or different 
 problem.

igital parts in the model and symbol 

 PCBoards, such as: file name extensions, 
tandards, footprint naming conventions, the 
at, and library expansion and 

ce to Cooper & Chyan Technology’s 
icroSim PCBoards.
The following table provides a brief description of those 
manuals available online only.

If You Have the 
Evaluation Version
The evaluation version of the PSpice Optimizer has the 
following requirements and limitations:

• Requires the MicroSim PSpice A/D with Schematics 
evaluation package.

• Is limited to one goal, one parameter, and one constrain

This online manual... Provides this...

MicroSim PSpice A/D
Online Reference Manual

Reference material for PSpice A/D.
simulation controls and analysis sp
a list of device types in the analog a
commands are provided to instruct 

MicroSim Application Notes 
Online Manual

A variety of articles that show you h
using MicroSim‘s products, and exa
approach to solving an engineering

Online Library List A complete list of the analog and d
libraries.

MicroSim PCBoards Online 
Reference Manual

Reference information for MicroSim
padstack naming conventions and s
netlist file format, the layout file form
compression utilities.

MicroSim PCBoards Autorouter 
Online User’s Guide

Information on the integrated interfa
(CCT) SPECCTRA autorouter in M
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Chapter Overview
This chapter introduces the purpose and function of the PSp
Optimizer, the optimization process, and related terms.

What is the PSpice Optimizer? on page 1-2 describes optimizer 
capabilities and the criteria designs must meet for successfu
optimization.

Using the PSpice Optimizer with Other MicroSim Programs on 
page 1-4 presents the high-level design flow for optimization 
and how other MicroSim programs are integrated into each 
design phase.

Terms You Need to Understand on page 1-5 defines the terms 
that are important for optimizing designs successfully.
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What is the PSpice 
Optimizer?
The MicroSim PSpice Optimizer is a circuit optimization 
program that improves the performance of analog and mixe
analog/digital circuits.

Run optimizations The PSpice Optimizer performs 
iterative simulations, while adjusting the values of design 
parameters until performance goals, subject to specified 
constraints, are nearly or exactly met. Constraints can includ
simple bounds on parameter values and nonlinear functions. 
PSpice Optimizer also computes Lagrange multipliers that 
provide information on the cost of each constraint on the 
solution.

Explore performance tradeoffs When you enter new 
values for design parameters, the PSpice Optimizer provide
graphical feedback showing performance. You can also twe
goal and constraint values to examine changes to paramete
values.

Fit model parameters Given a parameterized model, a
set of measured data points, and a good starting point for th
parameter values, the PSpice Optimizer fits a more accurate
model.
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Optimization problems are not 
always solvable by a particular 
algorithm.
Designs that You Can Optimize
A design that you can optimize must meet the following criter

• It works; that is, it simulates with PSpice to completion an
behaves as intended.

• One or more of its components have a variable value, an
each value that is varied relates to an intended performa
goal.

• An algorithm exists to measure its performance as a 
function of the variable value.

If you can visualize what factors should be adjusted to impro
performance, and how you would manually step through the
optimization process (even though the computations might se
unwieldy), then the design is a good candidate for the PSpic
Optimizer.

Designs that You Cannot 
Optimize
You cannot use the PSpice Optimizer to:

• Create a working design. This especially applies when y
begin with a design that is far from meeting specification

• Optimize a design in which the circuit has several states
where a small change in a parameter value causes a ch
of state.

Example: A flip-flop is on for some parameter value, and off 
for a slightly different value.
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Because you can use 
Schematics, PSpice, and Probe 
to design and simulate at the 
system, subcircuit, or component 
level, use the PSpice Optimizer 
to optimize at whatever level is 
most appropriate. 

See Chapter 2, “Primer: How to 
Optimize a Design” for a detailed 
description of each design 
phase.
Usin g the PSpice 
Optimizer with Other 
MicroSim Pro grams
The PSpice Optimizer is fully integrated with other MicroSim
programs. This means you can design your circuit with 
MicroSim Schematics, simulate with MicroSim PSpice A/D (o
MicroSim PSpice), analyze results with MicroSim Probe and
optimize performance within the same environment. Figure 1
illustrates the typical design flow for circuit optimization.

Figure 1-1 Optimization Design Flow

MicroSim
Schematics

MicroSim
PSpice A/D

MicroSim
Probe

MicroSim
PSpice
Optimizer

MicroSim
Schematics

MicroSim
PSpice A/D

MicroSim
PSpice
Optimizer

MicroSim
PSpice A/D

Develop
the

Design

Set Up
the

Optimization

Run
the

Optimization

Fit
Model

Parameters

Phase One

Phase Two

Phase Three
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wer consumption of the cell less than 
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en a terminator design, minimize 
 sum of squares of the errors in 
tput voltage and equivalent 
sistance

nimize the sum of squares of the 
ures of merit for an amplifier design 
ile keeping the open loop gain equal 
a specified value
Terms You Need to 
Understand

Optimization Optimization is the process of fine-tuning a 
design by varying design parameters between successive 
simulations until performance comes close to (or exactly meets)
ideal performance. 

The PSpice Optimizer solves four types of optimization problem
as described in Table 1-1.

*. All four cases allow simple bound constraints; that is, lower and upper bounds 

the parameters. The PSpice Optimizer also handles nonlinear goals and constra

**. Use unconstrained least squares when fitting model parameters to a set of 

measurements, or when minimizing more than one goal.

Table 1-1 Optimization Problems*

Problem Type PSpice Optimizer Action Exam

unconstrained minimization reduces the value of a single goal
thr

constrained minimization reduces the value of a single goal while
satisfying one or more constraints

mi
thr
po
a s

unconstrained least squares** reduces the sum of the squares of the 
individual errors (difference between 
the ideal and the measured value) for a 
set of goals 

giv
the
ou
re

constrained least squares reduces the sum of squares of the 
individual errors for a set of goals 
while satisfying one or more 
constraints

mi
fig
wh
to 
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See Chapter 6,Tutorial: 
Exploring Design Tradeoffs 
(Active Filter) starting on page 
6-1 for a working example 
showing parameterized slider 
values.

For more information, see Goal 
and Constraint on page 1-8.
Parameter A parameter defines a property of the design f
which the PSpice Optimizer attempts to determine the best va
within specified limits. A parameter can:

• Represent component values (such as resistance, R
a resistor).

• Represent other component attribute values (such a
slider settings in a potentiometer).

• Participate in expressions used to define component
values or other component attribute values.

The PSpice Optimizer can optimize designs with up to eight
variable parameters.

Example: A potentiometer symbol in a schematic uses the S
attribute to represent the slider position. You can assign a 
parameterized expression to this attribute to represent varia
slider positions between 1 and 0. During optimization, the 
PSpice Optimizer varies the parameterized value of the SET
attribute. 

Specification A specification describes the ideal behavior
of a design in terms of goals and constraints.

Examples: For a given design, the gain shall be 20 dB ±1 dB;
a given design, the 3 dB bandwidth shall be 1 kHz; for a giv
design, the rise time must be less than 1 usec. 

A design can have up to eight goals and constraints in any 
combination, but there must always be at least one goal. You can
easily change a goal to a constraint and vice-versa.

The PSpice Optimizer accepts specifications in two formats
internal and external.

Internal specifications

An internal specification is composed of goals and constrain
defined in terms of target values and ranges, which are ente
into the PSpice Optimizer through dialog boxes.
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Note Typically, the PSpice 
Optimizer measures 
performance using an 
evaluation that requires a 
simulation, and therefore, you 
must specify the circuit file for 
the simulation. However, 
when measuring performance 
using PSpice Optimizer 
expressions which do not 
require a simulation, you do 
not need to specify a circuit 
file. 
External specifications

An external specification is composed of measurement data
which are defined in an external data file that is read by the 
PSpice Optimizer.

Target value A target value is the ideal operating value fo
a characteristic of the design as defined by a goal or constra
specification. 

Goal A goal defines the performance level that the design
should attempt to meet (e.g., minimum power consumption).
goal specification includes:

• The name of the goal.

• A target value and an acceptable range.

• A circuit file to simulate.

• An evaluation for measuring performance.

• An analysis type used for simulation-based evaluations.

The goal specification can also include:

• The name of the file containing Probe goal function 
definitions (.prb  file).

• When using an external specification, the name of the fil
containing measured data and the columns of data to be u
as reference.
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See Optimization on page 1-5 
for more on least-squares and 
minimization algorithms.
Constraint A constraint defines the performance level tha
the design must fulfill in which the target value exceeds, falls 
below, or equals a specified value (e.g., an output voltage th
must be greater than a specific level). The constraint 
specification includes:

• The name of the constraint.

• A target value and an acceptable range.

• A circuit file to simulate. (See note on previous page.)

• An evaluation for measuring performance. 

• An analysis type used for simulation-based evaluations.

• An allowed relationship between measured values and t
target value, which can be one of the following:

The constraint specification can also include the name of the
containing Probe goal function definitions (.prb  file).

Constraints are often nonlinear functions of the parameters 
the design.

Example: Bandwidth can vary as the square root of a bias 
current and as the reciprocal of a transistor dimension.

Performance The performance of a design is a measure
how closely its specifications’ calculated values approach th
target values for a given set of parameter values. When there
multiple specifications (at least one of which is a goal), the 
PSpice Optimizer uses the sum of the squares of their deviat
from target to measure closeness. For a single specification
(goal), the PSpice Optimizer uses either the goal’s value, or
square of its deviation from target.

<= measured value must be less than or equal 
to the target value

= measured value must equal the target value

>= measured value must be greater than or 
equal to the target value 
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a Refer to the online MicroSim 
PSpice A/D Reference Manual 
for the variable formats and 
mathematical functions you can 
use to specify a trace function.
Each aspect of a design’s performance is found by either:

• first performing the appropriate simulation, then running 
Probe to measure characteristics of the resulting 
waveform(s), or

• evaluating PSpice Optimizer expressions. 

In many cases (particularly if there are multiple conflicting 
specifications), it is possible that the PSpice Optimizer will n
meet all of the goals and constraints. In these cases, optimu
performance is the best compromise solution—that is, the 
solution that comes closest to satisfying each of the goals a
constraints, even though it may not completely satisfy any sin
one.

Evaluation An evaluation is an algorithm that computes 
single numerical value, which is used as the measure of 
performance with respect to a design specification.

The PSpice Optimizer accepts evaluations in one of these th
forms:

• single-point Probe trace function

• Probe goal function

• PSpice Optimizer expression

Given evaluation results, the PSpice Optimizer determines 
whether or not the changes in parameter values are improvi
performance, and determines how to select the parameters 
the next iteration. 

Trace function A trace function defines how to evaluate 
design characteristic when running a single-point analysis (such 
as a DC sweep with a fixed voltage input of 5 V).

Examples: V(out) to measure the output voltage; I(d1) to 
measure the current through a component. 
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Refer to the Goal Function 
wizard in Probe and your PSpice 
user’s guide for information on 
how to develop and specify goal 
functions.

Here are some quick tips. In 
Probe:

• To test the value returned by 
a specified goal function, 
select Eval Goal Function 
from the Trace menu.

• To see the waveforms and 
marked points used to 
evaluate a goal function, 
select Display Evaluation in 
the Probe Options dialog box 
(from the Tools menu, select 
Options to display this dialog 
box).

See Gain on page 7-5 for an 
example of the YatX goal 
function definition.
Probe goal function A Probe goal function defines how
to evaluate a design characteristic when running any kind o
analysis other than a single-point sweep analysis. A goal 
function computes a single number from a Probe waveform.
This can be done by finding a characteristic point (e.g., time
a zero-crossing) or by some other operation (e.g., RMS value
the waveform).

For example, you can use Probe goal functions to:

• Find maxima and minima in a trace.

• Find distance between two characteristic points (such as
peaks).

• Measure slope of a line segment.

• Derive aspects of the circuit’s performance which are 
mathematically described (such as 3 dB bandwidth, pow
consumption, and gain and phase margin).

To write effective goal functions, determine what you are 
attempting to measure, then define what is mathematically 
special about that point (or set of points).

Note Be sure that the goal functions accurately measure 
what they are intended to measure. Optimization 
results highly depend on how well the goal 
functions behave. Discontinuities in goal functions 
(i.e., sudden jumps for small parameter changes) 
can cause the optimization process to fail.

PSpice Optimizer expression A PSpice Optimizer 
expression defines a design characteristic. The expression 
composed of optimizer parameter values, constants, and th
operators and functions shown in Table 1-2.

Example: To measure the sum of resistor values for two resis
with parameterized values named R1val and R2val, 
respectively, use the PSpice Optimizer expression R1val + 
R2val.
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See Derivatives on page 4-10 for 
a detailed discussion.
Note Unlike trace functions and Probe goal functions, 
PSpice Optimizer expressions are evaluated 
without using a simulation or Probe.

Derivative A derivative defines mathematically how a 
specification value changes with a small change in paramet
value. 

For a given design, the PSpice Optimizer calculates derivati
for each specification with respect to each parameter. Within
applicable range, the optimizer uses the derivatives to estim
new values for the goals and constraints.

Table 1-2 Valid Operators and Functions for PSpice 
Optimizer Expressions

Operator Meanin g

+ addition

- subtraction

* multiplication

/ division

** exponentiation

exp ex

log ln(x)

log10 log10(x)

sin sine

cos cosine

tan tangent

atan arctangent
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Chapter Overview
This chapter guides you through the basic steps needed to s
and run an optimization using a simple diode biasing design

Optimizing a Diode Biasing Circuit—the Objective on page 2-2 
describes the sample circuit and its ideal operating 
characteristics.

Why Use Optimization? on page 2-3 explains why fine-tuning 
your design using the PSpice Optimizer saves time.

Phase One: Developing the Design on page 2-4 walks you 
through the steps needed to create a working design.

Phase Two: Setting Up the Optimization on page 2-6 walks you 
through the steps needed to define the parameters, goals, a
constraints that describe the optimization.

Phase Three: Running an Optimization on page 2-11 walks you 
through the steps needed to optimize and finalize the design
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Optimizin g a Diode 
Biasin g Circuit—the 
Objective
Assume that you want to design a circuit that drives a curren
1 mA (±5 µA) through a diode (D1N914) using a 5 Vvoltage 
source and a series resistor to control the current through th
diode. A circuit such as this is shown in Figure 2-1. 

Figure 2-1 Diode Biasing Design Example

Your objective is to find a value for resistor R1 so that curre
through diode D1 falls in the range 0.995 mA to 1.005 mA.



Why Use Optimization? 2-3

y 

n 
for 
 to 

r of 
ted.

ing 

1 
ich 
.

can 

 
can 
ly 
fied 
 last 

When solving complex 
problems, the manual approach 
can be too unwieldy to consider. 
For example:

• When your design has 
multiple parameters or 
complicated parameter 
interactions, you may find it’s 
nearly impossible to know 
which parameters to change, 
and how best to change 
them.

• When solving for multiple 
specifications, the solution 
often depends on the order in 
which goals and constraints 
are optimized. This 
sequential approach can 
miss possible solutions since 
it is impractical to repeat the 
process starting with a 
different goal or constraint 
each time.
Why Use Optimization?
To solve the problem manually, you could assign an arbitrar
value to R1, manually calculate the current, then make an 
educated guess to adjust the values until a satisfactory solutio
is found. Or, you might use a simulation to sweep the value 
R1 with a DC Sweep analysis, carefully analyzing the results
find the best solution.

These manual methods have two major disadvantages:

• Because the diode is a non-linear device, manual 
calculations can be time-consuming. 

• Sweeping a parameterized value can take a large numbe
simulations, depending on the range and increment selec

The PSpice Optimizer automates these processes by handl
calculations for you and intelligently directing the series of 
simulations. Given results of the previous simulations, the 
optimizer automatically adjusts the parameterized value of R
for the next run, thus eliminating unnecessary iterations, wh
in turn, provides a solution more quickly and with less effort

Once the PSpice Optimizer settles on the best solution, you 
still explore available tradeoffs. When done manually, this 
iterative process can be difficult and frustrating.   With the 
optimizer, you can tweak the parameter(s) and immediately
determine whether the design still meets specifications. You 
also change the value of the specification(s) and immediate
determine how parameter values change. If you are dissatis
with the result after any change, you can always return to the
set of values.
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Phase 1 is also the time to 
investigate:

• The effects of individual 
components by replacing 
component values with 
parameters or parameterized 
expressions.

• Using PSpice to perform a 
DC, AC, or parametric sweep 
of each parameterized value.

Note When you initially place 
resistor R1, its value is 1k. 
Later, when you set up the 
optimization, you will 
parameterize R1’s value as 
shown in Figure 2-1.
Phase One: Developin g 
the Desi gn
Before optimizing, you must have a working circuit. This means 
first drawing the schematic, then iteratively simulating with 
PSpice and adjusting the design until the circuit operates wi
the intended behavior.

Figure 2-2 “Phase One: Developing the Design” Design 
Flow

To draw the schematic for the diode biasin g 
desi gn

1 In Schematics, from the Draw menu, use Get New Part 
select and place the following symbols on the schematic

R resistor R1

D1N914 diode D1

VSRC voltage source V1

AGND analog ground 0

Design
Schematic

Simulate

MicroSim
Schematics

MicroSim
PSpice A/D
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2 From the Draw menu, use Wire to connect the symbols 
shown in Figure 2-1.

3 From the Edit menu, use Attributes to set V1’s DC attribu
to 5v .

4 From the File menu, select Save As and enter 
mydiode.sch  in the File Name text box.

The PSpice Optimizer Advanta ge
To determine a value for R1 manually, you can set up a 
parametric analysis of a DC sweep where:

• the value of R1 steps from 4 k to 5 k in increments of 0.1
and

• the DC sweep analysis is a single-point voltage analysis 
V.

Such an analysis requires eleven PSpice simulations. Using 
Probe, the resistor value giving rise to 1 mA current through 
is 4.14 k.

The remainder of this chapter shows how to use the PSpice
Optimizer to determine the same solution automatically usin
fewer simulations.
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Phase Two: Settin g Up 
the Optimization
Now that preliminary design development is complete, you a
ready to define the optimization parameters, goals, and 
constraints.

Figure 2-3 “Phase Two: Setting Up the Optimization” Design
Flow

MicroSim
Schematics

MicroSim
Schematics

MicroSim
PSpice A/D

MicroSim
Probe

MicroSim
PSpice
Optimizer

Define
Design

Parameters

Set Up
Analyses

Simulate
Develop

Performance
Measures

Define
Goals &

Constraints
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You can also define optimization 
parameters in the PSpice 
Optimizer by selecting 
Parameters from the Edit Menu. 
See Adding and Editing 
Parameters on page 3-10 for 
more information.

The parameter settings are:

Name = R1Val

Initial Value= 5k

Current Value= 5k

Lower Limit= 100

Upper Limit= 10K

Tolerance= 10%

Later, in Schematics, when you 
select Run Optimizer from the 
Tune menu, the parameters 
specified with the OPTPARAM 
symbol are loaded into the 
PSpice Optimizer and displayed 
in its main window.
Definin g Design Parameters
To define parameters for optimization, you must:

• Identify the parameters to adjust for optimization and ass
a unique name to each one.

• Set up each parameter as a global optimization paramet
using the Schematic Editor and the OPTPARAM symbo

• Select which components in the design are affected by t
parameter and, for each component, replace its value (e
the value of its VALUE attribute) with an expression that
includes the parameter name.

To prepare the diode design example for optimization, you ne
to parameterize the value of R1 and specify its optimization
properties.

To set up the value of R1 as a parameter named 
R1Val

1 In Schematics, from the Draw menu, use Get New Part 
place an instance of the OPTPARAM symbol (from 
special.slb ). 

2 Double-click on the OPTPARAM symbol, then set R1val
properties as shown in the Optimizer Parameters dialog b

3 Click OK.

4 Double-click the 1k label for R1 and enter {R1val}  to 
parameterize the value of R1.

5 Click OK.
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Settin g Up Goals and 
Constraints 
Before you can evaluate and improve the circuit’s performan
you must answer these questions:

• What operating characteristics do I want to measure?

• How do the parameters affect the operating characterist

Once you’ve answered these questions, you are ready to:

• Set up the analyses needed to evaluate the performance
measures.

• Develop the performance measure algorithms.

• Fully define the goals and constraints in terms of these 
performance measures and analyses.

Settin g up anal yses for each goal and constraint

For each specification, you must define an analysis type: AC
DC, or transient. This is the analysis that PSpice will run to 
generate results used by the PSpice Optimizer to measure 
performance.

For the diode design example, you want to monitor the value
I(D1) at a fixed input voltage of 5 V while the optimization 
parameter, R1val, is varied. This means setting up a single-p
voltage sweep. 

To set up a sin gle-point volta ge sweep anal ysis at 
5 volts

1 In Schematics, from the Analysis menu, select Setup.

2 In the Analysis Setup dialog box, select the DC Sweep 
check box.
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The DC Sweep settings are:

Swept Var Type = Voltage 
Source

Sweep Type= Value List

Name = V1

Values = 5v

See Evaluation on page 1-9 and 
the sections that follow for a 
definitions of trace function, 
Probe goal function, and PSpice 
Optimizer expression.

MicroSim supplies standard goal 
functions for AC, DC, and 
transient analyses in the file 
msim.prb. This file resides in the 
MicroSim root directory. You can 
add goal functions to this file, or 
create a local .prb file for use 
with a specific design.

See Chapter 7,Tutorial: Using 
Constrained Optimization (MOS 
Amplifier) for examples of 
Probe goal functions used to 
evaluate performance.

Refer to your PSpice user’s 
guide for instructions on creating 
goal functions, and for a 
description of the global and 
local .prb files.
a To fix the voltage of V1, fill in the DC Sweep dialog 
box as shown. 

b Click OK to return to the Setup Analysis dialog box.

c Select the DC Sweep check box to enable it.

3 Clear all other analysis check boxes.

4 Click OK.

Developin g performance measures

To measure performance you must define an evaluation 
algorithm for each specification. There are three alternatives

• trace function (for single-point simulations)

• Probe goal function

• PSpice Optimizer expression

When the evaluation is anything other than a single-point 
simulation or PSpice Optimizer expression, you must develo
Probe goal functions to derive values from the simulation 
results. Developing goal functions is an iterative process tha
involves writing the goal function, simulating the design, and
testing the goal functions against actual results to make sure
are measuring the waveform characteristics you intended.

A Probe goal function is not required for the diode design 
example. You are examining the trace of R1Val versus I(D1
which shows the relationship between the value of R1 and t
diode forward current. Because only a single point on the cu
is of interest, the trace function, I(D1), is the appropriate 
evaluation. 
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The goal specification settings 
are:

Name = Id1

Target = 1ma

Range = 5ua

Analysis= DC

Circuit File= mydiode

Evaluate= I(d1)

The PSpice Optimizer 
appropriately defaults to the 
internal specification setting 
shown in the Reference control.
Definin g specifications: goals and constraints

Now that you’ve completed the preliminary groundwork, you
are ready to define the properties for goals and constraints. 
far, you have performed all steps in Schematics. To finalize 
setup, you must specify the goal for the diode design examp
using the PSpice Optimizer.

To define the desi gn goal, Id1, for the diode 
desi gn example

1 In Schematics, from the Tools menu, select Run Optimiz
to activate the PSpice Optimizer.

The PSpice Optimizer window appears showing the 
parameter R1val that you defined using the OPTPARAM
symbol in the schematic.

2 In PSpice Optimizer, from the Edit menu, select 
Specifications.

3 In the Specifications dialog box, click Add.

4 Enter Id1 properties as shown in the following Edit 
Specification dialog box.
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Phase Three: Runnin g 
an Optimization
Now that you have defined the parameters, specifications, a
evaluations for the design, you are ready to optimize, adjust, 
finalize your design. 

Figure 2-4 “Phase Three: Running an Optimization” Design
Phase

MicroSim
PSpice A/D

MicroSim
PSpice
Optimizer

MicroSim
Probe

Optimize

Simulate

Adjust
Specifications

Standardize
Component

Values

Save
Results

Generate

Reports

Update
the

Schematic

Improved
Design
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This is useful when initially 
validating the circuit or when 
restarting optimization after 
adjusting parameters or 
specifications.

This is useful when exploring 
design tradeoffs by tweaking 
parameter and specification 
values.
Runnin g the PSpice Optimizer
You can use the PSpice Optimizer to:

• Optimize the circuit to completion (from the Tune menu,
select Auto).

• Evaluate performance for a single set of parameter valu
(from the Tune menu, select Update Performance).

• Compute derivatives of each specification with respect t
each parameter (from the Tune menu, select Update 
Derivatives).

When you select Auto from the Tune menu, the PSpice 
Optimizer automatically computes the derivatives for each 
specification with respect to each parameter (Figure 2-5). Us
the derivatives, the optimizer determines the direction in whi
to vary the parameters, and changes parameter values 
accordingly until it achieves a reduction in the overall error. 
After updating the parameters, the optimizer computes new
derivatives and repeats the process until one of the followin
occurs:

• Specifications are met (success).

• No more progress can be made (failure).

• You manually interrupt the process.
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In the diode example, the 
derivative at R1=5 k is –1.62 x 10 
-7, or 

This indicates that a 1 ohm 
increase in R1 will produce a 
decrease of 0.162 uA in Id1. To 
verify this, try reducing the value 
of R1 by 100 ohms (to 4.9 kohm) 
and simulate. This increases the 
diode current by 16.2 uA and 
agrees with the derivative 
information.

R1∂
∂

Id( ) 1.62
7–×10–=

See The PSpice Optimizer 
Window on page 3-5 for a 
complete description of the 
window elements and how you 
can interact with them.
To start optimizin g the diode desi gn

1 From the Tune menu, select Auto and click Start.

The PSpice Optimizer performs several simulations. For
each iteration of the parameter values, the optimizer 
calculates overall performance and graphically displays t
results. The optimizer also calculates the value of the tra
function, I(d1), and displays the new value in the 
specifications area of the PSpice Optimizer window. Afte
three iterations, the optimizer should converge on a solut
of 4.131 K, as shown in Figure 2-6. 

Figure 2-6 Optimization Results for the Diode Design 
Example

Addin g a Constraint and 
Rerunnin g the PSpice Optimizer
So far, you have optimized for a single goal, Id1. Now suppo
you want to add a condition, or constraint, on the power 
dissipated in resistor R1. 

Constraints are defined like goals (using the Edit Specificati
dialog box) with two additions. In the Internal frame, you mu

• Select the Constraint check box.

• Choose the constraint type (>= target, = target, or, <= 
target).
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The constraint specification 
settings are:

Name = Pc

Target = 4mW

Range = 400uW

Constraintselected

Type = <=target

Analysis= DC

Circuit File= mydiode

Evaluate= i(r1)*v(r1:1,r1:2)

progress indicator

See Progress indicator on 
page 3-7 for more on the 
different kinds of progress 
indicators and how to interpret 
them.
The constraint type specifies the required relation betwe
what is evaluated (as defined in the Evaluate text box) a
the target value (defined in the Target text box). 

To define the constraint for power dissipation in 
R1

The power dissipated in R1 must be less than or equal to 
4 mW±400 uW. Define the constraint by doing the following:

1 In PSpice Optimizer, from the Edit menu, select 
Specifications.

2 In the Specifications dialog box, click Add.

3 Enter the power (Pc) constraint properties as shown in t
following Edit Specification dialog box. 

The Evaluate text box contains the expression for measu
dissipated power. For each iteration, Probe will compute
dissipated power by taking the product of the voltage acro
the resistance and the current through it.

4 To calculate the performance of the design for initial 
parameter and specification values only (one iteration):

a From the Edit menu, select Reset Values.

b From the Tune menu, select Update Performance. 

Note the appearance of the progress indicator in the
box. Since Pc is a less than or equal to constraint, the 
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progress indicator has a tick mark 1/4 of the way up.
The vertical bar within the indicator is below the tick 
mark; this means that the constraint is currently 
satisfied.

5 From the Tune menu, select Auto and click Start to start
optimization.

After a number of iterations, the optimization ends without 
satisfying the goal.

Figure 2-7 Results after Adding the Power Constraint

Note that the power dissipated in R1 is exactly equal to t
target value of the constraint (4 mW). In this example the
is no feasible solution to the problem. However, the PSp
Optimizer found the lowest value for Id1 which does not
violate the constraint.

Changing the Constraint and 
Rerunnin g the PSpice Optimizer
You can examine the effect the Pc constraint has on 
performance by changing its constraint type so the power 
dissipation in the resistor must be greater than or equal to 
4 mW.
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double-click here
To chan ge the Pc constraint t ype to “ greater than 
or equal”

1 In PSpice Optimizer, double-click the lower right-hand 
corner of the Pc box.

2 In the Edit Specifications dialog box, change Type to >=
target.

3 Click OK.

To run the optimization with the modified 
constraint

1 Test performance with the updated constraint:

a From the Edit menu, select Reset Values.

b From the Tune menu, select Update Performance. 

The Pc constraint is initially violated because the power 
dissipation is less than 4 mW.

2 From the Tune menu, select Auto and click Start to start
optimization.

The PSpice Optimizer finds a solution which satisfies bo
the goal (current of 1 mA) and the constraint (power 
dissipated in the resistor greater than 4 mW). Figure 2-8
shows the results.

Figure 2-8 Results after Changing the Constraint Type



2-18 Primer: How to Optimize a Design

 

nd 

 in 

nent 

run.

th 

 

See Using Standard Component
Values on page 3-29 for more 
information, including how the 
PSpice Optimizer uses 
tolerances and limits when 
standardizing values. 

rounded resistor value
Usin g Standard Component 
Values
When an optimization completes successfully, the optimizer
displays the new parameter values in the PSpice Optimizer 
window. However, each calculated value might not correspo
to an actual value that is available with off-the-shelf 
components. For example, resistors are not readily available
all possible values. 

You can use the PSpice Optimizer to select standard compo
values. The optimizer either:

• rounds to the nearest value, or

• computes values based on the most recent optimization 

To round to the nearest standard component 
value

1 From the Edit menu, select Round Nearest.

R1val’s current value changes to 3.9 k in accordance wi
the specified 10% tolerance.

Producin g Reports
You can use the PSpice Optimizer to generate a report 
summarizing:

• current settings for parameter, specification, and program
options.

• calculated derivatives and Lagrange multipliers.

To generate a summar y report

1 From the File menu, select Report.

The PSpice Optimizer writes the final results to 
mydiode.oot  as shown in Figure 2-9.
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Figure 2-9 Report Summary for the Diode Optimization

Savin g Results
When you have finished optimizing, you can save all of the 
optimizer data, including the current values for all paramete
and specifications.

To save the optimizer data for the diode desi gn

1 From the File menu, select Save.

The PSpice Optimizer updates the mydiode.opt  file. All 
of the options settings are also saved.

Updatin g the Schematic
Having completed the optimization, you can update the data
the schematic file to include the optimized parameter values
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To update the diode schematic with the current 
parameter values

1 From the Edit menu, select Update Schematic.

Recall that R1Val was initially set at 5.0 k in the schema
file. When you select Update Schematic, the PSpice 
Optimizer sends a message to Schematics to update the
schematic file. Schematics writes the new parameter va
of 3.9 k to the OPTPARAM symbol on the schematic (as t
current value).

Figure 2-10 shows the updated schematic for the diode 
design. 

Figure 2-10 Updated Diode Schematic
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Chapter Overview
This chapter describes in general terms how to complete an
task using the PSpice Optimizer, including:

• How to activate the PSpice Optimizer and load a design
page3-2.

• How to interact with the PSpice Optimizer window, 
page3-5.

• How to add and edit optimization parameters, page3-10.

• How to add and edit goals and constraints, page3-13.

• How to measure and optimize performance, page3-18.

• How to explore design tradeoffs, page3-20.

• How to generate result summaries including Lagrange 
multipliers and derivative values, page3-26.

• How to finalize the design: standardize component value
save results, and back-annotate the schematic, page3-26.
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Tools menu
Activatin g and Loadin g 
the PSpice Optimizer
This section describes how to:

• Start the PSpice Optimizer.

• Set special startup options.

• Load a design.

Activatin g the PSpice Optimizer
Start the PSpice Optimizer program either from:

• Schematics, or

• the Windows 95 Start menu.

From Schematics 

To activate the PSpice Optimizer from 
Schematics

1 In Schematics, from the Tools menu, select Run Optimiz

If you have an active schematic loaded into the Schema
Editor when you select Run Optimizer, any optimization 
parameters defined with the OPTPARAM symbol and an
existing setup information contained in the correspondin
optimization file (.opt ) are automatically loaded into the 
PSpice Optimizer. 

If no schematic is active, the PSpice Optimizer activates
without an optimization setup. Instead, you must load an
optimization file directly into the optimizer as described i
Loading a Different Optimization File on page 3-4.
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For UNIX users:

To activate the PSpice Optimizer 
on UNIX platforms, either 
double-click on the optimization 
file (.opt) in the File Manager 
window, or type “optimize” within 
a Shelltool window.

Because you can activate the 
PSpice Optimizer from either 
Schematics or from the Windows 
95 Start menu, we recommend 
that you change both 
occurrences of the command 
line definitions as follows:

• Use a text editor to open the 
msim.ini file and, in the 
[MICROSIM OPTIONS] 
section, change the 
OPTIMIZECMD line.

• In the Windows Explorer, 
change the Target text box in 
the optimizer’s Properties 
dialog box (click once on the 
PSpice Optimizer shortcut, 
then, from the File menu, 
select Properties and click 
the Shortcut tab).
From the Windows 95 Start Menu

From the Windows 95 Start menu, there is a program folder
which contains Windows 95 shortcuts for all installed MicroSi
programs, including the PSpice Optimizer. 

To activate the PSpice Optimizer from the 
Windows 95 Start menu

1 From the Windows 95 Start menu, select the MicroSim 
program folder and then the PSpice Optimizer shortcut t
start optimizer.

The optimizer activates without an optimization setup. S
Loading a Different Optimization File on page 3-4 for 
further instructions.

Changing Activation Options
The PSpice Optimizer supports two command line options, 
which are used to:

• Activate the optimizer with an initialization file other than
the default (msim.ini ).

• Automatically load an optimization file (.opt ) after startup. 

You can add one or both options to the command line.

To chan ge the initialization file used b y the 

PSpice Optimizer

1 In the optimizer command line, use the -i option as follow

OPTIMIZE -i initialization_file_name
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To automaticall y load an optimization file after 

startup

1 In the PSpice Optimizer command line, add the name of 
optimization file as follows:

OPTIMIZE optimization_file_name

The following command line example shows how to star
the optimizer at all times with an initialization file named 
myinit.ini  and an optimization file named 
mydesign.opt :

OPTIMIZE mydesign.opt -i myinit.ini

Loadin g a Different Optimization 
File
Once you have activated the PSpice Optimizer, you can cha
to a new or different optimization file at any time.

To start a new optimization

1 From the File menu, select New.

To load an existin g optimization setup

1 From the File menu, select Open.

2 Locate and select the appropriate optimization file.
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The PSpice Optimizer 
Window
The PSpice Optimizer window contains three areas: 

• specifications area

• parameters area

• error gauge area

Figure 3-1 illustrates their position in the window. 

Figure 3-1 The PSpice Optimizer Window

error gauge specifications area

parameters

area

area
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For more information on the 
enable/disable check box, see 
Excluding Parameters and 
Specifications from 
Optimization on page 3-24. For 
more information on the edit hot 
spot, see Selecting a 
Specification to Edit on 
page 3-18.

If derivative data is available, you 
can change the value in this field 
to explore how parameter values 
might change. See Testing 
Performance when Changing 
Current Values on page 3-21 for 
more information.
Specifications Area
The specifications area can show up to eight specification bo
where each box represents either a goal or a constraint. 
Figure 3-2 illustrates the fields contained in each box.

Figure 3-2 Example of a Specification Box

The contents of the box varies depending on the source for 
specifications—either internal or external. The following 
sections describe the differences in the initial and current va
fields, and the progress indicator.

Internal specifications

Initial value The initial value field displays a single 
performance measure that the PSpice Optimizer sets when 
start an optimization. The optimizer derives this value from t
initial optimization parameter values you defined in the 
schematic (or the optimizer).

Current value The current value field displays the 
performance measure that corresponds to the current param
values. Current values are updated each time an optimizatio
iteration makes progress. When the current value satisfies t
specification (that is, the current value is within the allowed 
range of the target) then the progress indicator turns from re
green, and the PSpice Optimizer considers the specification
satisfied.

initial value

current value

enable/disable check box

progress indicator

edit specification
hot spot
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goal or equality
constraint

less than or
equal to constraint

greater than or
equal to constraint
Progress indicator As mentioned above, the progress 
indicator shows red while the specification is violated, and 
changes to green when the specification is satisfied.

You can monitor progress as the optimization runs by watch
the progress indicator and observing the height of the vertic
black bar relative to the tick mark(s) to the right. The numbe
and relative position of the tick mark(s) varies depending on 
type of specification:

• Two tick marks for a goal or equality constraint denote th
acceptable range around the target value.

• A single tick mark one-quarter of the way up denotes a less 
than or equal to constraint.

• A single mark three-quarters of the way up denotes a 
greater than or equal to constraint.

External specifications

Initial value The initial value field is used in a different 
way from an internal specification: the field contains a pair o
numbers separated by a ‘/’ character. The first number is the
number of subgoals in the external specification that are 
satisfied. The second number is the total number of subgoal
the external specification.

Current value The current value field is used in a differen
way from an internal specification: the field contains a pair o
numbers as described above for initial value. 

Progress indicator The progress indicator shows the 
fraction of subgoals that are satisfied. The indicator turns fro
red to green when all of the subgoals are satisfied. 

Example: If an external specification has 20 subgoals and fi
are satisfied, the current value field reads 5/20  and the bar in the 
progress indicator rises to the one-quarter mark.



3-8 Using the PSpice Optimizer

. 

 
r in 
e 

 
 the 
 

 

For more information on the 
enable/disable check box, see 
Excluding Parameters and 
Specifications from 
Optimization on page 3-24. For 
more information on the edit hot 
spot, see Selecting a Parameter 
to Edit on page 3-12.

If derivative data is available, you 
can change the value in this field 
to explore how specification 
values might change. See 
Testing Performance when 
Changing Current Values on 
page 3-21 for more information.
Parameters Area
The parameters area can show up to eight parameter boxes
Figure 3-2 illustrates the fields contained in each box.

Figure 3-3 Example of a Parameter Box

The following sections explain the initial and current value 
fields in the parameter box.

Initial value The initial value field displays a single value
taken from the parameter specification that you set up eithe
Schematics (using the OPTPARAM symbol) or in the PSpic
Optimizer (from the Edit menu, select Parameters). 

Current value Initially, the current value is taken from the
parameter specification you set up in either the schematic or
PSpice Optimizer. With each iteration of an optimization, the
optimizer updates the current value field with the new set of
parameter values. 

initial value

current value

enable/disable check box

edit parameter
hot spot
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See Target Value Scaling on 
page 4-12 for a discussion of 
normalization and scaling.
Error Gau ge Area
The error gauge area has an error indicator and shows 
information reflecting the overall condition of the optimization

The error gauge shows how far the goals are from their targ
values. Initially, the indicator displays 100%. As the 
optimization proceeds, the error falls as the goals approach t
target values. The PSpice Optimizer displays the RMS of th
normalized value of the goals in the RMS Error field. 

If all of the specifications meet the target values exactly, the
error is zero. If the optimization succeeds by finding a soluti
that works within the set ranges, but does not meet the targ
values exactly, the error represents the combined error of al
the specifications.

Note The RMS error reflects only those goals that are 
enabled. The error does not include contributions 
from constraints, nor does it reflect any 
specifications that are disabled.
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You can also define parameters 
in Schematics using the 
OPTPARAM symbol. See 
Defining Design Parameters on 
page 2-7 for an example.
Addin g and Editin g 
Parameters
This section describes how to create and change optimizati
parameters using the PSpice Optimizer. This means you can
edit the properties of parameters that you defined in a schem

Note You are limited to eight parameters per 
optimization file. This limit includes parameters 
that you have defined but disabled for a given run.

Addin g a Parameter
There are two ways to add a parameter using the PSpice 
Optimizer: 

• Create the parameter from scratch.

• Copy an existing parameter and change its name.

To create a parameter from scratch

1 In the PSpice Optimizer, from the Edit menu, select 
Parameters.

Any optimization parameters that you have already 
established in the schematic appear in the selection list.

2 In the Parameters dialog box, either:

• click Add, or

• double-click the blank line following the parameter lis
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3 In the Edit Parameter dialog box, set the controls as 
described in Table 3-1.

To create a parameter based on an existin g 
parameter

1 In the PSpice Optimizer, from the Edit menu, select 
Parameters.

2 Select the parameter that you want to copy and click Co

Notice that the Insert button is now enabled (no longer 
grayed out)

3 Click Insert to add a copy of the selected parameter to th
parameter list. 

The optimizer inserts the new parameter immediately abo
the highlighted parameter.

4 Select the new parameter in the list and click Change.

5 Change the Name text box to a unique name, and chan
any other controls as needed.

Table 3-1 Edit Parameter Dialog Box Controls

Control Name Meanin g

Name Parameter name; for a new parameter, doubl
click <<new>> and enter a text string that is 
unique to the current optimization file.

Current Value Latest parameter value; for a new parameter
set Current Value equal to Initial Value.

Initial Value Starting value for the parameter.

Upper Limit Highest allowable value for the parameter.

Lower Limit Lowest allowable value for the parameter.

Tolerance Tolerance level (1%, 5%, etc.) to use when 
standardizing component values.

 Enabled When selected, includes the parameter in the
next optimization run. If cleared, excludes the 
parameter.
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Edit menu
6 When finished, click OK to return to the Parameters dialo
box.

Note You cannot copy a parameter description from one 
optimization file to another. Instead, save an entire 
optimization file under a new name, then edit the 
new version as needed.

Selectin g a Parameter to Edit
You can change the properties of an existing parameter at a
time using the Edit Parameter dialog box.

To displa y the Edit Parameter dialo g box for a 
parameter

1 Do one of the following:

• In the parameters area of the PSpice Optimizer windo
double-click the lower right-hand corner of the box fo
the parameter you want to edit.

• Select Parameters from the Edit menu, select the 
parameter you want to edit, and click Change.

e
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Addin g and Editin g 
Specifications
This section describes how to create and change 
specifications—that is, goals and constraints—using the PSp
Optimizer. 

Note You are limited to eight specifications per 
optimization file. This limit includes specifications 
that you have defined but disabled for a given run.

Addin g a Specification
There are two ways to add a specification using the PSpice 
Optimizer:

• Create the specification from scratch.

• Copy an existing specification and change its name.

To create a specification from scratch

1 In the PSpice Optimizer, from the Edit menu, select 
Specifications.

2 In the Specifications dialog box, either:

• click Add, or

• double-click the blank line following the specification
list.
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Figure 3-4 Sample Format for 
an External Specification

Vbe   Ic

4.0E-01   6.05E-06

4.1E-01   8.90E-06

4.2E-02   1.31E-05

X column name
Y column name
3 In the Edit Specification dialog box, set the controls as 
described in Table 3-2.

Table 3-2 Edit Specification Dialog Box Controls

Control Name Meanin g

Name Specification name; for a new 
specification, double-click <<new>> and 
enter a text string that is unique to the 
current optimization file.

 Reference • Select Internal when defining the 
specification’s target value and range in 
this dialog box.

• Select External when defining the 
specification’s measurement data using
a file (e.g., for curve fitting).

Weight Relative weight of the specification. To 
give a specification more weight, assign a 
number that is higher than that for the other
specifications.

 Enabled When enabled, includes the specification in
the next run. If cleared, excludes the 
specification.

Internal Specification

Target Ideal value for the specification.

Range Delta applied to Target, defining the 
acceptable range of values; i.e., Target ± 
Range.

Example: If Target=10 and Range=2, then 
the PSpice Optimizer accepts values from 9
to 11.

Constraint When enabled, defines the specification as
a constraint (not a goal).

Type Defines whether constraint values must 
equal the target value, be less than or equa
to the target value, or be greater than or 
equal to the target value.

External Specification
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*. See Defining an Evaluation for an External 
Specification on page 3-17 for the purpose and use of the ‘!’ 
symbol in the Evaluate edit control.

File Name of the file that contains the measured
data.

X Column Name Heading for the data column in File 
containing the independent (X) values.

Y Column Name Heading for the data column in File 
containing the dependent (Y) values

Tolerance Tolerance value used when standardizing
component values. 

Syntax: < 0 ≤ integer value ≤ 100 >%

Analysis Settin gs

(Analysis Type) Kind of analysis used for simulation-based
evaluations.

• Select AC for AC sweep analysis.

• Select DC for a DC sweep analysis.

• Select Tran for a transient analysis.

Circuit File Set to either:

• the name of the circuit file PSpice uses 
for simulation, or

• leave blank if the Evaluate text box 
contains a PSpice Optimizer expression

Evaluate* Trace function, Probe goal function, or 
PSpice Optimizer expression used to 
measure performance.

Table 3-2 Edit Specification Dialog Box Controls 

Control Name Meanin g
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To create a specification based on an existin g 
specification

1 In the PSpice Optimizer, from the Edit menu, select 
Specifications.

2 Select the specification that you want to copy and click 
Copy.

Notice that the Insert button is now enabled (no longer 
grayed out)

3 Click Insert to add a copy of the selected specification to t
parameter list. 

The optimizer inserts the new specifications immediately
above the highlighted specification.

4 Select the new specification in the list and click Change.

5 Change the Name text box to a unique name, and chang
any other controls as needed.

6 When finished, click OK to return to the Specifications 
dialog box.

Note You cannot copy a specification description from 
one optimization file to another. Instead, save an 
entire optimization file under a new name, then edit 
the new version as needed.
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After substitution, the PSpice 
Optimizer does one of the 
following depending on the kind 
of evaluation:

• For a Probe goal function, the 
optimizer sends the 
substituted goal function to 
Probe for evaluation.

• For a PSpice Optimizer 
expression, the optimizer 
evaluates the expression 
directly.

See Chapter 8,Tutorial: Fitting 
Model Data (Bipolar Transistor) 
for another example using this 
technique. 
Definin g an Evaluation for an 
External Specification
When defining evaluations for external specifications, use th
‘!’ symbol within the evaluation as a placeholder for data in th
external file. For each of the subgoals in the external file, th
PSpice Optimizer first replaces the ‘!’ character with the X 
column data value (defined in the X Column Name text box 
the Edit Specification dialog box), and then proceeds with 
evaluation. This approach allows a Probe goal function or 
PSpice Optimizer expression to track the independent data 
value.

To set up an evaluation for an external 
specification

1 Create the Probe goal function or PSpice Optimizer 
expression.

2 In the Edit Specification dialog box, enter the evaluation 
the Evaluate text box as follows:

Substitute the ‘!’ character for every X value argument; i.e
wherever a measured subgoal value should appear.

Example: Suppose that you want to fit a set of data 
measured at different values of Vtest (2.0, 2.5, and 3.0 
volts), using the Probe goal function:

YatX(V(out), x_value )

to measure the output of the design. To use this with an
external specification, replace x_value with the ‘!’ character 
and enter the evaluation:

YatX(V(out), !)

into the Evaluate text box for the specification.

As the fitting process proceeds, the PSpice Optimizer pas
the following goal functions (one for each measured data
point) to Probe:

YatX(V(out), 2.0)

YatX(V(out), 2.5)

YatX(V(out), 3.0)
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Selectin g a Specification to Edit
You can change the properties of an existing specification at 
time using the Edit Specification dialog box.

To displa y the Edit Specification dialo g box for a 
goal or constraint

1 Do one of the following:

• In the specifications area of the PSpice Optimizer 
window, double-click the lower right-hand corner of th
box for the specification you want to edit.

• Select Specifications from the Edit menu, then selec
the specification you want to edit, and click Change.

Measurin g and 
Optimizin g Performance
This section describes how to:

• Optimize your design once all of the parameters and 
specifications are defined.

• Monitor progress using Probe.

Optimizin g Your Desi gn
Optimization is a two-stage process:

1 Run one evaluation to ensure that the circuit is valid and t
it simulates.

2 Start the optimization process.
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Tune menu

Tune menu

See Viewing the Optimization 
Log on page 3-28 for information 
on the audit trail the PSpice 
Optimizer generates when 
running an optimization.
To optimize your desi gn

1  From the Tune menu, select Update Performance.

The PSpice Optimizer measures the design’s performan
using both the initial and current values for each of the 
parameters. The optimizer updates the initial and curren
fields, respectively, for each specification, and sets the 
progress indicators showing how closely these initial 
measures match each of the target values.

2 From the Tune menu, select Auto and click Start.

The PSpice Optimizer computes the derivatives for each
specification with respect to each parameter, and uses t
information to determine the direction in which to vary th
parameters. With each iteration, the optimizer tries 
parameter changes along the chosen direction and meas
performance until it achieves a reduction in the overall 
error. The optimizer then updates the parameters, calcula
new derivatives, and repeats the process until one of the
following occurs:

• Specifications are met (success).

• No more progress can be made (failure).

• You manually interrupt the process.

To abort the optimization run

1 From the Tune menu, select Auto and click Terminate.

Graphicall y Monitorin g Progress
To see how well specifications are approaching the optimizat
requirements, use Probe to monitor the simulation results fr
each of the iterations.

To monitor optimization pro gress

1 In Schematics, from the Analysis menu, select Simulate
simulate the circuit.
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2 Create a Probe display configuration.

a In Probe, add the traces (from the Trace menu, sele
Add) and modify the axes (from the Plot menu, select
Axis Settings or Y Axis Settings) to appear as you wa
them to when monitoring intermediate results.

b From the Tools menu, select Display Control.

c In the New Name text box, enter a name for the Prob
display and click Save.

d Click Close.

3 Define the Probe display to use when optimizing.

a In the PSpice Optimizer, from the Options menu, sele
Defaults.

b In the Display text box, enter the name of the Probe 
display.

c Select the analysis type corresponding to the Probe 
display.

d Click OK.

Explorin g the Effect of 
Parameter and 
Specification Chan ges
The PSpice Optimizer provides three easy ways to examine
tradeoffs between goals, constraints, and parameters. You 

• Tweak parameter values to explore performance effects
change specification values to see how parameters cha
by entering new current values directly into the PSpice 
Optimizer window.

• Exclude specifications and/or parameters that you 
previously defined. 
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See Derivatives on page 4-10 for 
more information on how the 
PSpice Optimizer computes 
derivative data. See Viewing 
Derivatives on page 3-28 for 
instructions on how to display the 
latest derivative data.
• Add new or edit existing parameter definitions and 
specification descriptions.

Testin g Performance when 
Changing Current Values
In the PSpice Optimizer window, you can quickly examine th
effects of a small change to either a parameter’s current valu
a specification’s current value.

Recalculation modes When changing current values, 
you can choose between automatic and manual recalculatio
performance.

• With automatic recalculation selected, you can change t
current value (upper text box) for one parameter or a 
specification value, and see the impact on other values 
almost immediately.

• With manual recalculation selected, you can change the
current value for several parameters or specifications, and
initiate recalculation when you are ready.

Derivative calculations When tweaking values, the 
PSpice Optimizer does not perform any simulations. Instead,
optimizer requires derivative data and uses this to estimate w
will happen when you change a parameter or specification. 

The PSpice Optimizer calculates derivatives either:

• once, when you select Update Derivatives from the Tune
menu, or

• for each iteration of an optimization run, when you selec
Auto from the Tune menu.

Use the first method (Update Derivatives) when you are 
exploring design tradeoffs.
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Recalculate dialog box

Tune menu

The PSpice Optimizer accepts 
numerical entries in any format 
supported by PSpice. Refer to 
the online MicroSim PSpice A/D 
Reference Manual for a 
complete list of supported 
numeric forms.
Note Because the performance of the design usually 
depends on the parameters in a highly nonlinear 
way, the results are typically reliable only for small 
changes in values. See “Ensuring reliable results 
when tweaking values” on page 3-24 for the steps 
you can take for best results.

Automaticall y recalculatin g performance  

The PSpice Optimizer automatically recalculates performan
after each change provided that:

• Automatic recalculation is selected (the default).

• Derivatives are available.

To test performance usin g automatic 
recalculation

1 Do the following to enable automatic recalculation:

a From the Options menu, select Recalculate.

b In the When frame, select Auto.

c Click Close.

2 From the Tune menu, select Update Derivatives.

When derivative calculations are complete, the message
Derivs. Avail  appears in the title bar.

3 Change the current value for the parameter or specificat
you want to investigate. 

a Double-click in the current value (upper) field for a 
parameter or specification.

b Enter the new value.

c Press J.

The PSpice Optimizer immediately recalculates the 
values. When you change parameter values, a small
appears next to the progress indicator for each 
recalculated specification to show that the value is a
estimate based on derivative data.
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When frame in the
Recalculate dialog box

Tune menu

The PSpice Optimizer accepts 
numerical entries in any format 
supported by PSpice. Refer to 
the online MicroSim PSpice A/D 
Reference Manual for a 
complete list of supported 
numeric forms.

click here to recalculate
specifications

click here to recalculate
parameters
Manuall y recalculatin g performance

When you want to change multiple values before recalculati
performance, disable recalculation. As with automatic 
recalculation, derivative data is required.

To test performance usin g manual recalculation

1 Disable automatic recalculation.

a From the Options menu, select Recalculate.

b In the When frame, select Manual.

c Click Close.

2  From the Tune menu, select Update Derivatives.

When derivative data is calculated, the message Derivs. 
Avail  appears in the title bar.

3 Change the current value for the parameter or specificat
you want to investigate. 

a Double-click in the current value (upper) field for a 
parameter or specification.

b Enter the new value.

c Press J.

4 From the Options menu, select Recalculate to 
recalculate performance.

5 Select the kind of recalculation as follows:

• If you entered a new parameter value, click Results.

The PSpice Optimizer recalculates performance. A 
small ‘e’ appears next to the progress indicator for ea
recalculated specification to show that the value is a
estimate based on derivative data.

• If you entered a new specification value, click 
Parameters.

The PSpice Optimizer recalculates values for all of th
parameters based on the current specification value
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Ensurin g reliable results when tweakin g values

Because the PSpice Optimizer uses derivative data to estim
what will happen when a parameter or a specification is 
changed, and because the design usually depends on the 
parameters in a highly nonlinear way, results are typically 
reliable only for small changes in values. Once you have 
significantly changed values, resimulate and recompute the
derivatives before adjusting values any further.

To ensure that results are reliable after si gnificant 
tweakin g

1 From the Tune menu, select Update Performance.

The PSpice Optimizer will run the appropriate simulation
and update the specifications.

2 From the Tune menu, select Update Derivatives. 

You are now ready to continue exploring the design.

Excludin g Parameters and 
Specifications from Optimization
Every specification and parameter has a check box that you
select to exclude that specification or parameter from the ne
optimization run.

To exclude a parameter or specification from an 
optimization

1 Do one of the following:

• In the PSpice Optimizer window, clear the check box
(check box should be empty) to the left of the parame
or specification name.

• Double-click the lower right-hand corner of the box fo
the parameter or specification you want to exclude, 
clear the Enabled check box (check box should be 
empty) in the dialog box, and click OK.
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Note When you exclude a specification from 
optimization, the PSpice Optimizer still re-
evaluates its performance when you update the 
parameters or derivatives. It is also included in the 
matrix of partial derivatives.

Testin g Performance when 
Addin g or Chan ging Parameters 
or Specifications
Even after running an optimization, you can add new parame
and specifications, or change the properties of existing 
definitions to see their effect on performance.

To test performance after chan ging the 
parameters or specifications

1 From the Edit menu, select Reset Values.

2 From the Tune menu, select Update Performance.
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3 If you want to run a complete optimization:

a From the Tune menu, select Auto.

b Click Start.

Savin g Intermediate Values
You can save a set of parameter and specification values, a
then continue to investigate performance.

To save intermediate values

1 From the Edit menu, select Store Values.

The PSpice Optimizer copies the current values to the ini
values for all specifications and parameters. 

To restore the previous settin gs

1 From the Edit menu, select Reset Values.

The PSpice Optimizer copies the initial values to the curre
value fields.

Viewin g Result 
Summaries
This section describes how to:

• Generate a report that summarizes the latest run.

• View the current derivative calculations.

Producin g Optimization Reports
You can produce a report containing:
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File menu

For UNIX users:

On UNIX platforms, the PSpice 
Optimizer displays the report 
using TextEdit, by default.

You can change the default text 
editor used by MicroSim 
programs by changing the path 
specified in the TEXTEDITCMD 
line in the [MICROSIM] section 
of the msim.ini file.
• settings for each of the parameters, specifications, and 
options

• performance results 

• partial derivatives

• Lagrange multipliers

To generate an optimization report

1 From the File menu, select Report.

The PSpice Optimizer generates the report and saves it t
ASCII file named design_name .oot . The optimizer 
also displays the report in the text editor configured for yo
installation (Notepad, by default). 

Figure 3-5 Sample Excerpt from a Report

To print an optimization report

1 Do one of the following:

• If you are using MicroSim TextEdit (the default), from
the File menu, select Print. 
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Figure 3-6 Sample Excerpt 
from a Log File

Figure 3-7 Sample Derivative 
Data
• If you are not using MicroSim TextEdit, use the Print
command for the text editor showing the report. 

Viewin g the Optimization Lo g
The PSpice Optimizer automatically creates an audit trail of
optimization progress and saves the information to a file nam
design_name .olg . You can use this file as a debugging too
when an optimization fails to converge.

To view the optimization lo g file

1 Activate Notepad or another text editor.

2 Open the log file for browsing.

Viewin g Derivatives
You can display a matrix showing the most recent derivative
data the PSpice Optimizer uses to calculate performance.

To displa y the derivative data

1 From the Tune menu, select Show Derivatives.

Each entry in the matrix represents the partial derivative
one specification (the row label) with respect to one activ
parameter (the column heading). If a specification is 
completely independent of a parameter, the derivative is
zero. 

2 When finished, click Close.



Finalizing the Design 3-29

nd 

ect 

 

the 
0% 

ce. 

Edit menu
Finalizin g the Desi gn
This section describes how to use the PSpice Optimizer to:

• Standardize component values once the optimization is 
complete.

• Save results.

• Back-annotate the schematic with the final component a
parameter values.

Usin g Standard Component 
Values
When optimization parameters directly correspond to 
component values, you can use the PSpice Optimizer to sel
standard component values by either:

• rounding to the nearest values, or

• computing values based on the most recent optimization
run.

The PSpice Optimizer considers the tolerance specified for 
parameters using tables of preferred values for 1%, 5% and 1
tolerance components. Other tolerance values cause the 
optimizer to use the nearest calculated value for that toleran
Parameters with zero tolerance are not changed.

To round component values to the nearest 
standard values

1 From the Edit menu, select Round Nearest.
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Edit menu
To compute standard component values based 
on the most recent optimization

1 From the Edit menu, select Round Calculated.

The PSpice Optimizer replaces the parameter values wi
the standardized values only if the new values remain with
the specified limits. If so, the optimizer automatically 
calculates new performance values (based on derivative
data) using the new parameter values, and displays an ‘e’ in 
the upper right-hand corner of each specifications area t
indicate that the performance measure is an estimate.

Savin g Results
Performance results are not written to the optimization file un
you deliberately initiate a save operation.

To save optimization results to the current 
optimization file

1 From the File menu, select Save.

By default, the PSpice Optimizer writes the results and t
latest optimization settings to a file named 
design_name .opt . If you started your design from a 
schematic, this file already exists. If not, the optimizer 
displays the Save As dialog box and you must enter the
name of a new file.

To save optimization results to a new or different 
file

1 From the File menu, select Save As.

2 Enter a new file name.

3 Click OK.

If an optimization file with this name already exists, the 
PSpice Optimizer requests confirmation to overwrite the
file.
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Edit menu
Updatin g the Schematic
Once the optimization is complete and you have optionally 
standardized component values, you can update the underly
schematic with the final parameter values.

To back-annotate the schematic with the latest 
parameter values

1 In the PSpice Optimizer, from the Edit menu, select Upda
Schematic.

The optimizer writes the optimized parameter values to t
schematic file. On the schematic, the new values appea
the Current column of the OPTPARAM symbol. 

To use the new parameter values in subsequent 
simulations run from Schematics

1 In Schematics, from the Tools menu, select Use Optimiz
Params.
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Chapter Overview
This chapter explains optimization concepts and how you ca
influence the outcome of an optimization.

The concepts covered in this chapter include: constrained 
optimization, function characteristics, convergence and the 
effect of starting points, and how the PSpice Optimizer 
computes derivatives and scales target values.

Default Options on page 4-13 describes the options you can se
to control derivative calculations, maximum simulation 
iterations, and the Probe display.

Advanced Options on page 4-17 describes the options you can
set to control cutback, threshold, and the method (least squa
minimization) that the PSpice Optimizer uses.
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If there is more than one goal, 
the PSpice Optimizer combines 
the errors by summing the 
squares of the normalized 
values.

Figure 4-1 Resistive 
Terminator Circuit
Goals versus 
Constraints
Goals and constraints represent the ideal behavior of a desig
practice, this behavior is often unattainable.

Example: A gate cannot achieve zero propagation delay, but
goal of the optimization process might be to come as close 
possible to that target value (that is, to reduce the error as m
as possible).

When solving problems involving both goals and constraints
the PSpice Optimizer trades off meeting the target values for
goals against violation of the constraints. This means that th
error indicator does not always reduce in value for a given 
iteration.

When setting up an optimization, you must decide which 
specifications are goals and which are constraints. In many 
cases, there are several legitimate ways to describe the des

Example: Assume you want to design a resistive terminator t
produces an output voltage of 3.75 V (± 0.1 V) at the junction of 
the two resistors, and the Thevenin equivalent resistance of
resistor combination must equal 100 Ω (±1 Ω). 

Your objective is to find the best resistor values to meet the
two specifications: 

• output voltage of 3.75 V (Ve)

• equivalent resistance of 100Ω (Re)

You can manually solve this problem using the following 
simultaneous equations:

    and   

These equations solve to R1 = 133.3 Ω and R2 = 400 Ω, an exact 
solution.

5R2

R1 R2+
------------------ 3.75=

R1 R2⋅
R1 R2+
------------------ 100=
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When using the PSpice Optimizer, you can set up this probl
in one of three ways:

• Consider Ve and Re as equally important; set up both as 
goals.

• Consider Ve as the most important requirement to meet, 
even at the expense of Re; set up Ve as a constraint and Re 
as a goal.

• Consider Re as the most important requirement to meet, 
even at the expense of Ve; set up Re as a constraint and Ve 
as a goal.

Note Because at least one optimization goal is 
necessary, the case where both Ve and Re are 
constraints is excluded. 

If the problem, like this one, has a solution, the PSpice 
Optimizer might arrive at the same answer for all three metho
However, most problems do not have a single, exact solution
this one does. For most designs, the result is a compromise
minimizes the goals while not violating the constraints. 

Constrained 
Optimization
Many problems in analog circuit optimization are naturally 
expressed as the minimization of a function representing a g
(e.g., power consumption) which is subject to one or more 
constraints (e.g., bandwidth). Constraints are typically 
complicated nonlinear functions of the parameters of the 
problem, so manual optimization is a difficult task.

Most other analog circuit optimizers implement only 
unconstrained optimization of a single goal or a sum-of-squa
of several goals. To tackle a problem like the problem outlin
above, other optimizers must combine the functions for the 
goals and constraints and then optimize the combination. 
Unfortunately, this scheme does not differentiate between 
reduction of the goals and violation of the constraints. In 
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general, constraints are given much greater weight than the
goals. 

This approach has a number of pitfalls. In particular: 

• If a very large value is used for the weight of the constrain
numerical problems occur. 

• If a more reasonable value is used, the result is not a tru
solution of the original problem. 

• Using a sequence of weights, and performing a series o
minimizations can lead to the true solution, but at the 
expense of a large increase in optimization time (becaus
all of the extra evaluations required to solve the intermedi
problems). 

The PSpice Optimizer implements both constrained and 
unconstrained minimization algorithms. This means that the
optimizer:

• Tackles constrained problems directly and efficiently.

• Calculates Lagrange multipliers for the solution, which 
provide valuable insight to design tradeoffs.

Types of Constraints
Constraints are restrictions placed on potential solutions to 
optimization problems. The simplest constraints are bound 
constraints—simple limits on the ranges of the parameters (e.
a resistor whose value has to be at least 100Ω).

More challenging constraints that frequently arise in analog 
circuit optimization have dependencies on other characteris
of the design. 

Example: Consider optimizing a MOS amplifier cell which mu
satisfy these specifications:

• Reduce power consumption. 

• Make sure gain-bandwidth product of the cell is greater th
or equal to some minimum value. 
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The PSpice Optimizer can also 
handle equality constraints 
where a performance measure is 
required to be equal to some 
defined value.
The power consumption of the cell is the goal (the characteristic 
to be minimized) and the gain-bandwidth product is the 
inequality constraint. 

To continue the example, consider the dependence of powe
consumption and gain-bandwidth product on bias current in o
of the amplifier stages. Power consumption is proportional t
the bias current, while the gain-bandwidth product is 
proportional to the square root of the bias current. Bias curre
must be reduced in order to reduce power consumption. Be
some critical bias current the minimum gain-bandwidth 
requirement will be violated. This critical value is the 
constrained minimum for this problem.

Feasible and Infeasible Points
The starting point for an optimization can satisfy all the 
constraints (a feasible point) or it can violate one or more of the
constraints (an infeasible point). Depending on the feasibility of
the starting point, the PSpice Optimizer does the following:

• From an infeasible point, it attempts to reduce the goals and 
to reduce the amount by which the constraints are violat

• From a feasible point, it attempts to reduce the goals while 
keeping the constraints satisfied. 

Note Because the PSpice Optimizer sometimes trades 
off reduction of the goals against violation of the 
constraints to make progress, an iteration can 
produce an infeasible point even though the initial 
starting point was feasible.
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To view Lagrange multipliers for 
your design, generate a report by 
selecting Reports from the File 
menu and browse the 
design_name.oot report file. 
See Producing Optimization 
Reports on page 3-26 for 
instructions.
Active and Inactive Constraints
An active constraint is one which affects the solution of the 
optimization problem—that is, the solution would probably b
different if the constraint were removed. Equality constraints a
always active (e.g., a constraint of the form Vout = 3.75 V is 
always active). Inequality constraints are considered active 
the solution violates the constraint or if it is equal to the 
constraint (e.g., a constraint of the form Req >= 100 is active if 
Req is less than or equal to 100 at the solution).

Lagrange Multipliers
The result of a constrained optimization is typically a 
compromise between further reduction of the goals and 
violation of one or more constraints. A set of numbers—the 
Lagrange multipliers—provide valuable information about the
tradeoffs between the goals and the constraints.

The PSpice Optimizer calculates Lagrange multipliers only f
those constraints which are active at the solution. A constra
which is inactive can be removed from the problem without 
affecting the solution, which means there is no tradeoff betwe
the goals and the constraint.

Think of Lagrange multipliers as the incremental cost of each 
active constraint on the solution. 

Example: Consider optimizing propagation delay through a g
subject to a constraint on gate width and a constraint on bia
current. Suppose that at the optimum, both constraints are 
active. There are two Lagrange multipliers for this problem:

• Incremental cost of propagation delay versus gate width

• Incremental cost of propagation delay versus bias curren

For this problem, the units of the Lagrange multipliers are 
seconds/meter and seconds/ampere, respectively. 

In a problem with several goals which have been combined a
sum-of-squares, the target value is dimensionless. In this ca
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To review, the PSpice Optimizer 
measures performance in one of 
three ways: by taking the value 
of the single-point trace (trace 
function) in Probe, by applying a 
Probe goal function to the trace, 
or by evaluating a PSpice 
Optimizer expression. Trace 
functions and Probe goal 
functions require a simulation; 
PSpice Optimizer expressions 
do not.
the units of the Lagrange multipliers are the reciprocal of the
units of their associated constraint.

Example: A multiplier associated with a width constraint has
units of meter-1.

Characteristics of 
Functions
The success of an optimization depends highly on the beha
of the functions related to each specification.

Generally, the PSpice Optimizer obtains values (measures 
performance) for each of the specifications by evaluating a trace 
which results from a simulation with varying parameter value
The optimizer can experience difficulties if the accuracy of th
measurement is decreased by:

• Discontinuities in the simulation results.

• An error in the Probe goal function definition.

• Inaccuracies in the simulation results on which the 
evaluation is based.

Generally, simulations and measurements using AC and DC
analyses behave better than simulations using transient analy
This is particularly true if the evaluations are set up to meas
the value of a single point (e.g., the time when a trace cross
specified level). This kind of measurement tends to behave 
discontinuously as the parameters change, creating difficult
for the optimizer.

To improve measurement accuracy, consider any of the 
following techniques:

• Use several points rather than a single point for the Prob
goal function. That is, specify several points on a wavefo
instead of a single point.

• Reduce the step ceiling in Transient analysis to produce
more finely sampled set of data.
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Figure 4-2 Global and Local 
Minima of a Function
• Increase simulator accuracy (e.g., reduce RELTOL).

The first proposed technique is preferred because it does no
affect the time required to run each simulation (usually the 
determining factor in how long an optimization run takes). 

Global and Local Minima
The curve in Figure 4-2 shows a 1-dimensional function with
minima. Point M1 is a local minimum; it satisfies the condition
for a minimum, but there is another minimum which is smalle
Point M2 is the global minimum for the function. There are n
points within the range of the function which are smaller.

All practical optimization techniques find local minima, 
including the algorithms used by the PSpice Optimizer. This
may or may not present a problem. The application may not
have any local minima within the domain of interest. If local 
minima do exist, the global minimum may be the nearest 
solution to the starting point. This is discussed further in Starting 
Points on page 4-8. 

Startin g Points
It is important to begin with a good estimate of the starting poi
There are two reasons for this:

• The process may converge to the wrong solution (a local 
minimum) rather than to the right solution (the global 
minimum). 

Example: Consider Figure 4-2. If point A is chosen, the 
PSpice Optimizer will most likely find local minimum M1.
If point B is chosen, the optimizer will most likely find the
global minimum M2. 

• The PSpice Optimizer may require a large number of 
simulations to find a region close to a solution. It is usua
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more efficient to find the approximate location of the 
desired solution (perhaps by performing a number of 
analyses sweeping out ranges of the parameters) before
starting the optimization process.

Conver gence
When running an optimization, the PSpice Optimizer varies t
parameter values and measures the resulting performance.
each subsequent iteration, the optimizer chooses each param
step to reduce the error between the design’s measured and
specified target performance.

If the optimizer finds a solution where all of the specification
are met, then the process has converged. There are several 
common reasons why the process may fail to converge:

• There is no solution to the problem as specified.

• The simulation and/or evaluations are not accurate enou
to allow the solution to be found.

• A limit on the number of simulations or elapsed time is 
encountered.

• The optimizer finds a spurious numerical minimum which 
not the desired solution.

To improve convergence, consider the following techniques

• In the second case, use more accurate measurement 
techniques (possibly with the aid of help circuitry).

• In the last case, restart from a different starting point whi
might lead to a different solution.

Parameter Bounds
The PSpice Optimizer performs bound-constrained 
minimization. This means it will solve problems where one o
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The PSpice Optimizer calculates 
derivatives either:

• once when you select Update 
Derivatives from the Tune 
menu, or

• automatically for each 
iteration when you start 
optimization by selecting 
Auto from the Tune menu.

See Exploring the Effect of 
Parameter and Specification 
Changes on page 3-20 for more 
information.
more of the parameters are limited by the specified upper or
lower bound for that parameter. In other words, the optimize
finds a solution (if one exists) even if one or more parameters
at their limit. 

However, solving this kind of problem is intrinsically more 
difficult than performing unconstrained minimization. 

If one or more parameters appear to be limited during the 
optimization run, and you don’t expect the final solution to ha
limited parameters, you could save time by using one or both
the following techniques:

• Use a starting point that is further from the parameter lim

• Loosen the limits on the parameter(s) in question.

Derivatives
To perform optimization, the PSpice Optimizer computes the
matrix of partial derivatives—the Jacobian. 

How the PSpice Optimizer 
Estimates Derivatives
The PSpice Optimizer approximates derivatives using a finit
difference approach. In one-dimensional terms, this method
computes an approximation to the first derivative of a functio
f(x) by:

   

where h is a small perturbation. 

The optimizer organizes the simulations and evaluations to 
compute the Jacobian in the most efficient way possible. 

f ′ x( )
f x h+( ) f x( )–

h
----------------------------------≅
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See Controlling Finite 
Differencing when Calculating 
Derivatives (Delta Option) on 
page 4-13 for more information 
on Delta.

Figure 4-3 Hypothetical 
Function
Example: If there are two specifications, each of which requir
a DC analysis of the same circuit file, the optimizer will run a
single simulation for each parameter, then load the data file
(.dat ) into Probe and evaluate the perturbed values of f.   If 
there are M specifications (all using the same analysis type 
the same circuit file) and N parameters, then forming the 
Jacobian takes:

• N simulations, and 

• M Probe goal function evaluations per simulation.

Note The time needed to simulate is usually much 
greater than the time needed to evaluate the Probe 
goal functions. This means that the time taken to 
optimize a design depends heavily on the number 
of variable parameters.

Limitations of Derivative Data 
A derivative analysis calculates a linear relationship betwee
parameter and a specification. It assumes that the function i
linear near the initial value within a region defined by the valu
set for the Delta option. If the data is well-behaved in this regio
then this is a valid assumption; the PSpice Optimizer can use
derivative to approximate specification values based on the 
linear relationship.

However, when the function is not well behaved in the regio
around the initial value, the approximation may not be valid.

Example: Assume that the function shown in Figure 4-3 is th
plot of a specification’s behavior vs. a parameter value. Note
that the function is approximately linear between the dashed
lines, but not necessarily linear outside of that region. 

If you pick an initial value for the parameter which is betwee
the two dashed lines, then subsequently compute the derivat
the derivative data provides a reasonable approximation for 
other parameter value between those lines. However, if you
to use the same derivative data to estimate new specificatio
values for parameter values outside of those lines, the estim
are not reliable.
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When, for a given parameter, the difference between its init
value and the value of interest is large (that is, the relative 
difference is much bigger than Delta), modify its initial value
and restart the simulation. 

Note When you modify the current value for a parameter 
to recalculate specification values (by editing the 
value appearing in the PSpice Optimizer window), 
the PSpice Optimizer uses the derivative data 
rather than a resimulation to determine the new 
values. Therefore, you should periodically verify 
the results with another simulation (see “Ensuring 
reliable results when tweaking values” on page 3-24).

Target Value Scalin g 
When there is more than one goal, or a combination of goals 
constraints, the PSpice Optimizer needs to scale the raw 
measurements before combining them. 

Example: Consider a least-squares optimization with two 
specifications: 

• collector-base capacitance

• collector resistance 

The first of these can have values of several picofarads; the
second of tens of kohms. Clearly, adding the squares of the
errors for these specifications will lose the significance of th
capacitance term. Instead, the optimizer scales the values a
follows:

Suppose the specified target and measured values are as s
below.

TScaled

Tmeasured Tt etarg–

Range
------------------------------------------------------=
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The PSpice Optimizer saves 
option settings to the .opt file so 
that they remain with the 
optimization’s parameter and 
specification settings. 

To generate a summary of the 
option settings for a given 
design, select Report from the 
File menu.
Then the scaled values are:

     and      ,

respectively.

Since these numbers are close enough in magnitude, the PS
Optimizer can combine them without losing numerical 
significance. 

Default Options 
This section describes the basic configuration options for th
PSpice Optimizer.

To displa y the Options dialo g box

1 From the Options menu, select Defaults.

Controllin g Finite Differencin g 
when Calculatin g
Derivatives (Delta Option)
The Delta option specifies the relative amount (as a percent
of current parameter value) by which the PSpice Optimizer 
perturbs each parameter from its initial value when calculati
the derivatives.

Specification
Target 
Value

Allowed 
Range

Measured 
Value

collector-base 
capacitance

10 pF ±1 pF 8 pF

collector resistance 10 k ±1 k 12 k

8pF 10pF–( )
1pF

--------------------------------- 2–=
25k 10k–

1k
------------------------ 15=
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The optimizer uses gradient-based optimization algorithms t
use a finite difference method to approximate the gradients 
(gradients are not known analytically). To implement finite 
differencing, the optimizer:

1 Perturbs each parameter in turn from its current value by
amount h.

2 Evaluates the function at the perturbed value.

3 Subtracts the old function value from the new.

4 Divides the result by h. 

Note There is a tradeoff. If h is too small, the difference 
in function values is unreliable due to numerical 
inaccuracies. However if h is too large, the result is 
a poor approximation to the true gradient. 
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To control parameter perturbation when 
calculatin g derivatives

1 Enter a value in the Delta text box that defines a fraction
the parameter’s total range.

Example: If a parameter has a current value of 10–8, and 
Delta is set to 1% (the default), then the PSpice Optimiz
perturbs the parameter by 10–10.

The 1% default value is suitable for the accuracy of typic
simulations. 

2 If the accuracy of your simulation is very different from 
typical (perhaps because of the use of a non-default valu
for either RELTOL or the time step ceiling for a Transien
analysis), then change the value of Delta as follows:

• If simulation accuracy is better, decrease Delta by an
appropriate amount.

• If simulation accuracy is worse, increase Delta by an
appropriate amount.

Note The optimum value of Delta varies as the square 
root of the relative accuracy of the simulation. For 
example, if your simulation is 100 times more 
accurate than typical, you should reduce Delta by 
a factor of 10.

Limitin g Simulation Iterations 
(Max. Iterations Option)
The Max. Iterations option defines how many attempts, at mo
the PSpice Optimizer can make before giving up on the solution, 
even if the optimizer is making progress. 

To limit the simulation iterations

1 In the Max. Iterations text box, enter an integer value tha
defines the maximum number of attempts you will allow th
PSpice Optimizer to make.
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Refer to online Help in Probe for 
information on using Probe 
Display Control options.
Specif ying a Probe Displa y 
(Probe File and Displa y Options)
The Display option defines the name of the Probe display th
PSpice Optimizer uses to display simulation results. The Pro
File option specifies a nondefault .prb file in which the Probe
display information has been stored. 

To use a specific Probe displa y when optimizin g

1 In Probe, configure the plots as you want to view them.

2 Save and name the display:

a From the Tools menu, select Display Control.

b Enter the name for the display.

c Click Save.

3 In the PSpice Optimizer, specify the Probe display.

a From the Options menu, select Defaults to display th
Defaults dialog box.

b In the Display frame, type the Probe display name in t
text box.

c Choose the appropriate analysis type (AC, DC, or 
Tran).

d If you saved the Probe display to a nondefault .prb fil
enter the name of the file in the Probe File text box.
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The PSpice Optimizer saves 
option settings to the .opt file so 
that they remain with the 
optimization’s parameter and 
specification settings. 

To generate a summary of the 
option settings for a given 
design, select Report from the 
File menu.
Advanced Options
This section describes the advanced configuration options f
the PSpice Optimizer.

To displa y the Advanced Options dialo g box

1 From the Options menu, select Defaults.

2 Click the Advanced Options button.

Controllin g Cutback (Cutback 
Option)
The Cutback option defines the minimum fraction by which a
internal step is reduced while the PSpice Optimizer searches
a reduction in the goal’s target value. 

To set cutback

1 In the Cutback text box, enter a decimal fraction that defin
the minimal percent reduction in internal step size.

If the data is noisy, consider increasing the Cutback valu
from its default of 0.25.

Controllin g Parameter Value 
Changes Between
Iterations (Threshold Option)  

The Threshold option defines the minimum step size the PSp
Optimizer uses to adjust the optimization parameters during 
optimization process.

The optimizer assumes that the values measured for the 
specifications change continuously as the parameters are va
In practice, this assumption is not justified. For some analys
especially transient analyses, the Probe goal function value
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Figure 4-4 Hypothetical Data 
Glitch

Glitch

Parameter

Goal
Function
show discontinuous behavior for small parameter changes. T
can be caused by accumulation of errors in iterative simulat
algorithms. 

Figure 4-4 demonstrates a typical case. The effect of the gli
is serious—the optimizer can get stuck in the spurious local
minimum represented by the glitch.

The optimizer’s threshold mechanism limits the effect of 
unreliable data. 

To control parameter perturbation between 
iterations

1 In the Threshold text box, enter a value that defines a 
fraction of the current parameter value.

Example: A Threshold value of 0.01 means that when th
PSpice Optimizer changes a parameter value, the value 
change by at least 1% of its current value. 

By default, Threshold is set to 0 so that small changes in
parameter values are not arbitrarily rejected. To obtain go
results, however, you may need to adjust the Threshold 
values. When making adjustments, consider the followin

• If data quality is good, and Threshold is greater than
zero, reduce the Threshold value to find more accura
parameter values.

• If data quality is suspect (has potential for spurious 
peaks or glitches), increase the Threshold value to 
ensure that the optimizer will not get stuck during the
run.
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Choosin g an Optimization 
Method for Sin gle Goal
Problems (Least Squares/
Minimization Options)
The PSpice Optimizer implements two general classes of 
algorithm to measure design performance: least squares an
minimization. These algorithms are applicable to both 
unconstrained and constrained problems.

Least squares  A reliable measure of performance for a
design with multiple targets is to take the deviation of each 
output from its target, square all deviations (so each term is
positive) and sum all of the squares. The PSpice Optimizer th
tries to reduce this sum to zero.

This technique is known as least squares. Note that the sum of 
the squares of the deviations becomes zero only if all of the
goals are met.

Minimization Another measure of design performance 
considers a single output and reduces it to the smallest valu
possible. 

Example: Power or propagation delay, each of which is a 
positive number with ideal performance corresponding to ze

Choosin g the al gorithm When optimizing for more 
than one goal, the PSpice Optimizer always uses the least-
squares algorithm. For a single goal, however, you must spe
the algorithm for the optimizer. 
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To set the optimization method for a sin gle goal

1 Do one of the following:

• Click the Least Squares button to minimize the squa
of the deviation between measured and target value

• Click Minimize to reduce a value to the smallest 
possible value.

If your optimization problem is to maximize a single goal, 
then set up the specification to minimize the negative of the
value.

Example: To maximize gain, set up the problem to 
minimize –gain.
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Tutorial Overview
The following tutorial takes you through the steps needed to
setup and run an optimization starting with the simple 
terminator example provided with your MicroSim programs.

In this tutorial, you will:

• Verify the schematic setup:

• Check that component values are parameterized. 

• Check that optimization parameters are defined.

• Check the analysis settings.

• Check the goal specification settings.

• Run the optimization.
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Figure 5-1 Resistive 
Terminator Circuit
The Passive Terminator 
Design
Figure 5-1 shows a simple terminator that you could use, for
example, for one line of a backplane. The top end of R1 conn
to a +5 v DC supply; the lower end of R2 connects to groun
The center point of the two resistors provides the line 
termination.

This design must meet two specifications: 

• Voltage at the junction of the two resistors (Vcenter) must lie 
within a specified range.

• Thevenin equivalent resistance of the combination (Requiv) 
must equal a specified value. 

Assume that the DC supply has negligible internal resistanc
and that:

• Vcenter must be 3.75±0.1 V.

• Requiv must be 100±1 Ω.

Your objective is to find the best values for R1 and R2 that m
the stated specifications. You can manually solve this proble
using the following simultaneous equations:

    and   

These equations solve to R1 = 133.3Ω and R2 = 400Ω, an exact 
solution. As you complete this tutorial, compare this solution
that produced by the PSpice Optimizer. 

5R2

R1 R2+
------------------ 3.75=

R1 R2⋅
R1 R2+
------------------ 100=
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nt Figure 5-2 Schematic for the 
Terminator Example, term.sch
Loadin g the Desi gn into 
Schematics
To begin, set up a schematic with:

• parameters for the resistor values, and

• a way to measure the performance of the two specificatio

Your MicroSim installation includes a schematic for the passi
terminator design.

To load the passive terminator schematic

1 From the Windows 95 Start menu, select the MicroSim 
program folder and then the Schematics shortcut to star
Schematics.

2 From the File menu, select Open.

3 Move to the directory containing term.sch  
(\MicroSim_root\examples\optimize\term) and, in the File
Name list, select the schematic file.

This schematic contains two sections. The first section 
connects an instance of the terminator to a DC source an
ground. The output is connected to a bubble port labeled 
The second section connects the top and bottom ends o
instance of the terminator to ground, and a 1 A current 
source to its output. This output is connected to a bubble
port labeled Vr. The voltage at Vc gives the value of the 
Vcenter specification. The voltage at Vr gives the equivale
resistance of the network, the Requiv specification.
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2 

e The curly braces are PSpice 
syntax for an expression. You 
can specify any expression that 
PSpice can evaluate.
Settin g Component 
Values to Expressions 
The parameters varied between iterations must relate to the
components you are optimizing. For this example, R1 and R
resistor values are already parameterized.

To see how the resistor values are set up to use 
optimization parameters

1 Double-click the symbol graphics for R1 or R2.

2 Within the symbol attribute dialog box, note the value of th
VALUE attribute: {R1val} or {R2val}, depending on the 
symbol you selected.

3 Click OK to close the symbol attribute dialog box.
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 this The optimization parameter 
settings are the same for R1val 
and R2val as follows: 

Setting Value

Initial Value 500

Current Value 500

Lower Limit 100

Upper Limit 5K

Tolerance 5%
Definin g Optimization 
Parameters 
Next, set up the optimization parameters that the PSpice 
Optimizer will vary between iterations; these are the same 
parameters used in the value expressions for R1 and R2. For
example, R1val and R2val are already defined using an 
OPTPARAM symbol as shown below.

 

To see the settin gs for R1val and R2val

1 On the schematic, double-click OPTIMIZER 
PARAMETERS.

By default, the settings for R1val are displayed. 

2 To view settings for R2val, click the R2val entry in the 
parameter list.

3 Click OK to close the Optimizer Parameters dialog box.
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To have Probe automatically run 
after simulation (the default)

1 In Schematics, from the 
Analysis menu, select Probe 
Setup.

2 In the Auto-Run Option 
frame, select Automatically 
Run Probe After Simulation.

3 Click OK.
Definin g the Anal ysis 
Type
For each specification, set up an analysis which PSpice will r
for each iteration of the optimization. This example is alread
set up for a 1-point DC analysis, with the supply set to 5 V. 

To see the anal ysis settin gs

1 From the Analysis menu, select Setup.

2 Click DC Sweep and verify the settings. 

3 Click Cancel to return to the Analysis Setup dialog box.

4 Verify that DC Sweep is the only enabled analysis. If 
needed, select the DC Sweep check box and clear any 
other selected check boxes.

5 If wanted, select Bias Point Detail. 

Runnin g an Initial Circuit 
Anal ysis 
Before optimizing, verify that the circuit works, and check th
the voltages at Vc and Vr are as you expect.

To test the circuit setup

1 In Schematics, from the Analysis menu, select Simulate

2 If Probe does not activate automatically, select Run Prob
from the Analysis menu.

3 In Probe, from the Trace menu, select Add and click V(Vc)  
and V(Vr) . 

4 Click OK.

5 Verify that the voltages at Vc and Vr are 2.5 V and 250 V
respectively.
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Activatin g the PSpice 
Optimizer
Assuming the circuit simulated successfully, you are now rea
to activate the PSpice Optimizer and complete optimization 
setup.

To activate the PSpice Optimizer

1 In Schematics, from the Tools menu, select Run Optimiz

The PSpice Optimizer window displays the current 
optimization file, term.opt , in the title bar.

The two parameters, R1val and R2val, appear in the 
parameters area. Because the specifications, Vc and Rt,
predefined for this example circuit, they also appear in th
specifications area. Initially, the error gauge area is emp
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Viewin g the Parameter 
Description
The PSpice Optimizer automatically loads the parameter 
descriptions defined earlier in Schematics. 

To verif y the parameter descriptions

1 From the Edit menu, select Parameters.

2 To see R1val settings.

a In the Parameters list, click R1val.

b Click Change to display the Edit Parameter dialog bo

3 Click Cancel to leave the parameter unchanged.

4 Optionally repeat steps 2 and 3 for R2val.

5 Click Close to exit the Edit Parameter dialog box.
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Definin g the Goals and 
Constraints 
To review, the specifications for this example are:

• Voltage, Vcenter, at the junction must be 3.75±0.1 V.

• Thevenin equivalent resistance, Requiv, must be 100±1 Ω.

One way to handle the optimization problem is to treat both 
specifications as a goal.

For each goal, you must define:

• its name

• its target value and range

• the analysis to use for simulation

• the circuit file containing the netlist description

• the way to measure performance

For this example, these are already defined.

To see the Vc and Rt goal settin gs

1 From the Edit menu, select Specifications.

2 Click Vc, then click Change.
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Notice that Vc is described as a goal (Constraint check b
is cleared). The analysis type is DC and the evaluation t
measure performance is the trace function V(Vc)—as in t
preliminary test simulation.

3 Click Cancel to leave the specification unchanged.

4 To see the settings for the Rt goal, click Rt, then click 
Change.

Again, the analysis type is DC, and the evaluation to 
measure performance is the trace function V(Vr).

5 Click Cancel to leave the specification unchanged.

6 Click Close to exit the Edit Specification dialog box.
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Checkin g that the 
Design Will Simulate
Before running a full optimization, you should run a single 
iteration to make sure the design still simulates (by selecting
Update Performance from the Tune menu). The PSpice 
Optimizer performs the simulations and trace function 
evaluations required to find the current value for each active
specification, and updates their initial values.

For this example, an initial iteration has already been run. T
Vc specification shows 2.5 and the Rt specification shows 2
in the initial value fields. Note that this example requires one
PSpice simulation to update the performance. 

Startin g the 
Optimization
You are now ready to run the full optimization to find resisto
values which satisfy the two specifications (output voltage 3.
V, equivalent resistance 100 Ω).

To start optimizin g

1 From the Tune menu, select Auto and click Start.

First, the PSpice Optimizer computes the derivative of ea
specification with respect to each parameter at the initia
value. While this is in progress, the message Updating 
Derivatives  appears in the status bar of the optimizer 
window. In this example, two simulations are performed—
one for each parameter. 

Using the derivative information, the optimizer selects a 
direction in which to vary the parameters. The optimizer 
tries parameter changes along this direction until it achiev
a reduction in the overall error. The optimizer then updat
the parameters, and computes new derivatives. 
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The optimizer repeats this process until it achieves succe
failure, or you terminate the process (from the Tune men
point to Auto and select Terminate).

For this example, let the process run to completion. This
takes 5 more simulations.

As the optimization proceeds, the vertical gauge and 
numeric display fields in the error gauge area (far left in t
PSpice Optimizer window) show updated values. The 
numeric field shows the total error (the sum of the squar
of the normalized errors for the active specifications) and
the gauge shows the error relative to the starting point. Fi
results are shown in Figure 5-3.

Figure 5-3 Optimization Results for the Passive Terminator
Example

Compare the parameter values of 133.5 for R1val and 39
for R2val with the calculated values on page 5-2. They are 
very close.
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For an example, see See Goals 
versus Constraints on page 4-2 
for more information.
Changing a Goal to a 
Constraint 
Try examining what happens when you change one of the 
specifications from a goal to a constraint. 

To chan ge a goal to a constraint

1 Edit a specification:

a In the PSpice Optimizer window, double-click the ho
spot (lower right-hand corner) in either the Vc or Rt 
specification box.

b Select the Constraint check box.

c In the Type list, choose the type of constraint.

2 From the Edit menu, select Reset Values to set the curre
values back to the original initial values. 

3 From the Tune menu, select Update Performance.

4 If you want to run a complete optimization: 

a From the Tune menu, select Auto.

b Click Start.

For this example, the PSpice Optimizer should produce 
approximately the same result for each configuration of t
two specifications (one goal and one constraint). 

Savin g Results 
At this point you would ordinarily select Save from the File 
menu to save the results. However, to avoid modifying the 
tutorial files, either:

• From the File menu, select Save As to store the results un
another file name, or

• omit the save process entirely. 
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Tutorial Overview
The following tutorial shows you how to use the PSpice 
Optimizer to explore design tradeoffs. Using the simple activ
filter example provided with your MicroSim programs, you 
will:

• Review the optimization setup in Schematics: paramete
definitions and parameterized expression assignments.

• Review the goal and constraint setup in the PSpice 
Optimizer.

• Change a parameter value to see the effect on goal and
constraint values.

• Change a goal value to see the effect on parameter valu
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The Active Filter Desi gn
The filter has three adjustable resistors. These resistors adj
center frequency, bandwidth, and gain. In this case, the 
adjustments are interdependent.

Requirements for the filter are:

• Center frequency (Fc) must be 10 Hz with 1% accuracy.

• 3 dB bandwidth (BW) must be 1 Hz with 10% accuracy.

• Gain (Gain) must be 10 with 10% accuracy.

To load the active filter desi gn

1 From the Windows 95 Start menu, select the MicroSim 
program folder and then the Schematics shortcut to star
Schematics.

2  From the File menu, select Open.

3 Move to the directory containing bpf.sch  
(\MicroSim_root\examples\optimize\bpf) and select the 
schematic file in the File Name list.

 

Figure 6-1 Schematic for the Active Filter Example, bpf.sch
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To see the assignment for SET, 
double-click on one of the 
variable resistor symbols to bring 
up its list of symbol attributes. 

To display the Optimizer 
Parameters dialog box, double-
click the OPTPARAM symbol in 
the schematic.
The Parameters
The three variable resistors—Rfc, Rbw, and Rgain—are 
implemented as potentiometers. The potentiometer symbol 
an attribute called SET which describes the slider position—
value between 0 and 1. 

To optimize slider position, the optimization parameters afc,
aBW, and AGain are assigned to the SET attribute for the 
symbols Rfc, Rbw, and Rgain, respectively.

The parameters are shown in the OPTPARAM symbol on th
schematic. Each parameter is set up to range from 0.1 to 0.9 
an initial value for each set to 0.5 (each potentiometer’s cen
point). The settings for aGain are shown below.   

The Goals
The example circuit is set up with predefined goals which yo
can view using the PSpice Optimizer.

To activate the PSpice Optimizer

1 From the Tools menu, select Run Optimizer.
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To display the Edit Specifications 
dialog box, double-click the 
lower right-hand corner of the 
specification box of interest in 
the PSpice Optimizer window.

When finished browsing, click 
Cancel.

double-click here
The PSpice Optimizer window shows the three parameters (a
aBW and aGain) and the three corresponding goals (Fc, BW
and Gain). The goals are defined as follows:

The Fc settings as they appear in the Edit Specification dial
box are shown below.   

Note that, to measure performance, all three goals are evalu
using Probe goal functions.

Settin g
Center 
Frequenc
y

Bandwidt
h

Gain

Name Fc BW Gain

Target 10 1 10

Range 0.1 0.1 1

Analysis AC AC AC

Circuit File bpf bpf bpf

Evaluate CenterFreq

(vdb(out), 1)

Bandwidth

(vdb(out), 3)

max(v(out))
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To remeasure performance, 
select Update Performance from 
the Tune menu.
Testin g Performance 
Initial performance has already been measured for the activ
filter ensuring that the design simulated as expected, that cur
values for the goals were calculated, and that initial values w
updated. Initial performance calculated to:

 

Calculatin g Derivatives
To estimate performance effects with small changes in 
parameters (or specifications), the PSpice Optimizer uses 
derivatives of each specification with respect to each of the 
parameters.

To calculate the derivatives

1 From the Tune menu, select Update Derivatives.

The message Updating Derivatives  appears in the 
status bar while this takes place.

Goal
Current/Initial 
Value

Target Value

Fc 8.322 Hz 10 Hz

BW 0.7122 Hz 1 Hz

Gain 14.81 10
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Tweakin g Parameters
Once the derivatives are calculated, you can use the PSpice
Optimize to explore how small changes in the parameters af
the performance of the design. 

To examine the performance effect when 
chan ging aGain from 0.5 to 0.4

1 Highlight the current value for aGain, and type 0.4.

2 Press J.

The value of the Gain specification changes from the init
value of 14.811 to a new value of 13.825. The target is 10
which is a change in the right direction. 

Center frequency and bandwidth also change. In the cas
center frequency, the change from its initial value of 8.32
to a new value of 8.298 is in the wrong direction.

This frequently occurs. You can try various strategies to g
closer to the target values. Two common approaches ar

• Adjust a given parameter to get the best results, then
vary the other parameters.

Example: Continue to adjust aGain until you are 
satisfied with the performance. Then incrementally 
change Fc until you are satisfied. And finally, change
BW.

• Change every parameter in the set by a small amoun
a time, and continue in this manner to get the best 
results. 

Example: Adjust aGain once by a small amount, the
Fc, then BW. Continue with this pattern of adjustmen
until you are satisfied.



Testing Performance 6-7

nce 
ese 

to a 

ers 
tch. 

ts. 

 is 

new goal value

updated parameter
values
Tweakin g Goals and Constraints
The PSpice Optimizer gives you the advantage of doing 
something not possible on the bench: changing the performa
results and seeing what parameter values would produce th
results. 

To investigate the parameter changes when changing Gain 
new target value of 10.

1 Make sure that automatic recalculation is selected.

a From the Options menu, select Recalculate.

b In the When frame, click Auto.

c Click OK.

2 Highlight the current value for Gain, and type 10.

3 Press J.

The PSpice Optimizer automatically adjusts the paramet
to satisfy the results, and then updates the results to ma
The result changes from the value you specified to the 
nearest value which still satisfies all of the parameter limi

In this case, the lower limit of the aGain parameter (0.1)
violated, so the optimizer uses the smallest allowed 
parameter value. This gives a value of 10.8 for Gain. 

Note Because the PSpice Optimizer computes 
estimates using the previously calculated 
derivatives, results are typically reliable for only 
small changes in parameter values. After 
significant tweaking, you should resimulate and 
recompute the derivatives to see true 
performance. See “Ensuring reliable results when 
tweaking values” on page 3-24.
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Completin g 
Optimization
To finish exploring the active filter design, run an optimizatio

To start optimizin g

1 From the Tune menu, select Auto and click Start.

The PSpice Optimizer finds a set of parameters for whic
the specifications are met. Figure 6-2 shows the results.

Figure 6-2 Optimized Values for the Active Filter Example

Note The number of simulations required to complete 
the optimization varies, depending on the starting 
values (in the current value fields) when you 
initiate optimization.
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Tutorial Overview
The following tutorial shows you how to use the PSpice 
Optimizer to set up and run constrained optimization. Using t
MOS amplifier example provided with your MicroSim 
programs, you will:

• Review the optimization setup in Schematics: paramete
definitions and parameterized expression assignments.

• Review the goal and constraint setup in the PSpice 
Optimizer including the evaluations used to measure 
performance.

• Review the optimization method selected for single-goal
problems.

• Run the optimization.
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The CMOS Amplifier 
Design 
For this optimization, the CMOS amplifier requirements are:

• Minimize power consumption.

• Maintain gain at 20.

• Maintain 3 dB bandwidth at 1 MHz or greater. 

To load the CMOS amplifier desi gn

1 From the Windows 95 Start menu, select the MicroSim 
program folder and then the Schematics shortcut to star
Schematics.

2 From the File menu, select Open.

3 Move to the directory containing m2.sch  
(\MicroSim_root\examples\optimize\m2) and select the 
schematic file in the File Name list.

Figure 7-1 Schematic for CMOS Amplifier Example, m2.sc

The circuit consists of a common source stage (M1) with act
load (M3 and M4) and a source follower (M2). 
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The Parameters
For this example, there are three circuit values that you mus
optimize, and three corresponding parameters that the PSp
Optimizer will vary:

• channel length for M1 (W1)

• channel width for M1 (L1)

• bias current for M3 and M4 (Iref)

Parameterized expression assi gnments In the 
schematic, you can see the parameterized component value
MOSFET M1 (W={W1}, L={L1} ) and the current source I1 
({Iref} ).

In preliminary tests, the parameter values W1 = 75 m, L1 = 5
and Iref = 100 mA produce the following performance 
characteristics:

These initial parameter values yield both excess gain and 
bandwidth, so a reduction in power consumption appears 
feasible. But because the gain, bandwidth, and power depe
nonlinearly on circuit parameters such as transistor dimensio
manual optimization is impractical.

gain 23.8

bandwidth 2.2 Mhz

power consumption 2.2 mW
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To display the Optimizer 
Parameters dialog box, double-
click the OPTPARAM symbol in 
the schematic.

To see the setup for the 
analyses:

1 In Schematics, from the 
Analysis menu, select Setup.

2 Click either the DC Sweep or 
AC Sweep button to browse 
the detail.

3 Click Cancel to return to the 
Analysis Setup dialog box.
PSpice Optimizer parameters For optimization, the 
parameters for the amplifier are set up using the OPTPARA
symbol as follows:

The Evaluations
The amplifier is set up with three performance characteristic
power, gain, and 3 dB bandwidth. To measure performance,
PSpice Optimizer needs to know how to calculate response
each of these.

Power The objective, to minimize power consumption, is 
single-point goal. This means that a trace function appropriate
measures the power response of the circuit.

The amplifier design is set up to measure power by perform
a single-point DC analysis and then applying the trace funct

-I(V2)*10V

to the simulation results.

Property Parameters

W1 L1 Iref

Initial Value 75u 5u 100uA

Current Value 75u 5u 100uA

Lower Limit 10u 2u 10uA

Upper Limit 150u 50u 500uA

Tolerance 0 0 0
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The goal functions, YatX and 
LPBW, are contained in the file, 
msim.prb. Every MicroSim 
installation includes this file. 

When loading a data file into 
Probe, Probe automatically 
loads the global msim.prb file 
(located, by default, in your 
MicroSim root directory), and 
any local .prb file (located in the 
working directory) corresponding 
to the current design.

You can freely update msim.prb 
or any other .prb file with new 
goal function definitions.

Refer to online Help in Probe for 
more information on the .prb files 
and Probe.
Gain The amplifier design is set up to measure the spot g
at 1 kHz (assuming that the bandwidth is much greater than t
by performing an AC analysis and then applying the Probe g
function:

YatX(V(Vout), 1k)

to the simulation results.

YatX is provided with your MicroSim programs. The goal 
function definition is as follows:

; value at given x

YatX(1, where) = y1 

{ 1 | sf xvalue(where) !1;}

YatX(V(Vout), 1k)  gives the Y value on the V(Vout) trace
for the X value corresponding to 1 k.

3 dB bandwidth The amplifier design is set up to find the
frequency where the output has fallen by 3 dB from its low-
frequency value by performing an AC analysis (same as for
Gain) and then applying the Probe goal function:

LPBW(Vdb(Vout), 3)

LPBW is provided with your MicroSim programs. The goal 
function definition is as follows:

; bandwidth of low pass response

LPBW(1, db_level) = y1 

{ 1 | sf level(max-db_level, n) !1;}

LPBW(Vdb(Vout), 3) gives the low pass cutoff value on the
Vdb(Vout) trace where the output is 3 dB below the maximu
value on the trace.
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The Goals and Constraints
The example circuit is set up with predefined goals and 
constraints which you can view using the PSpice Optimizer.

To activate the PSpice Optimizer

1 In Schematics, from the Tools menu, select Run Optimiz

The PSpice Optimizer window shows the three paramet
(W1, L1, and Iref) and the three specifications. Power is
defined as a goal, and gain and bandwidth are defined a
constraints as shown below.

*. Since Power is a goal, constraint type does not apply.

**. Gain is defined as a constraint because circuit gain must remain at 20±1.

***. BW is defined as a constraint because the 3 dB bandwidth must be at 
least 900 kHz or greater.

Settin g Power Gain Bandwidth

Name Power Gain BW

Target 1uw 20 1Meg

Range 100uw 2 100k

Constraint Type N/A* = target** >= target***

Analysis DC AC AC

Circuit File m2 m2 m2

Evaluate -i(v2)*10v YatX

(v(vout), 1k)

LPBW

(vdb(vout),3)
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To display the Edit Specifications 
dialog box, double-click the 
lower right-hand corner of the 
specification box of interest in 
the PSpice Optimizer window.

When finished browsing, click 
Cancel.

double-click here

To see the Minimize setting, 
select Defaults from the Options 
menu, and click Advanced 
Options.
The Power settings as they appear in the Edit Specificat
dialog box are shown below.   

Settin g the Method for a 
Single-Goal 
Optimization
The amplifier design is set up to use minimization to assess 
performance because this optimization has one goal: minim
the power consumption. The default method, least squares, is 
appropriate when minimizing the square of a function.
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You are now ready to run the optimization.

To optimize the amplifier desi gn

1 From the Tune menu, select Update Performance to 
calculate initial performance. The results are as shown i
Figure 7-2.

Figure 7-2 Updated Performance Values for the Amplifier 
Example

2 From the Tune menu, select Update Derivatives to comp
the partial derivatives of each goal and constraint with 
respect to each parameter.

3 Display the derivatives:

a From the Tune menu, select Show Derivatives.

b Click Close, when finished.

4 From the Tune menu, select Auto and click Start to start 
optimization.
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Notice that the performance indicators change as the 
optimization proceeds. When complete, optimized value
should appear as shown in Figure 7-3. 

Figure 7-3 Optimized Values for the Amplifier Example

This optimization stops after reaching the maximum 
number of allowed iterations. Even so, power consumpti
is minimized (the objective) within the iteration limits. 

Note For a minimization problem like this one, you can 
still effectively use the PSpice Optimizer to 
improve the circuit’s performance even though the 
goal is not attainable.
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Tutorial Overview
The following tutorial shows you how to use the PSpice 
Optimizer to fit a parameterized model to a set of measured d
points. Using the bipolar transistor example provided with yo
MicroSim programs, you will:

• Review the bipolar transistor test case: schematic, 
parameter definitions and parameterized expression 
assignments, analysis, and external file with measured d

• Review the goal setup in the PSpice Optimizer.

• Set up Probe and the PSpice Optimizer to monitor 
intermediate waveform results.

• Run the fitting process.



8-2 Tutorial: Fitting Model Data (Bipolar Transistor)

 or 

ile 
ts. 

l 
ists 
 

rnal 
Usin g the PSpice 
Optimizer to Fit Data to 
Model Parameters
The PSpice Optimizer can fit a parameterized model to one
more sets of data points. The source for this external data might 
be:

• Results from measuring a real device (e.g., using a 
semiconductor curve tracer).

• A manufacturer’s data sheet.

• A PSpice simulation.

To fit a model using the PSpice Optimizer, you need a text f
containing the measured values and the measurement poin

Example: For static I-V characteristic of a diode, the externa
data file would contain pairs of values where each pair cons
of the voltage at which the measurement was made and the
current through the device at that voltage.

The PSpice Optimizer performs a least squares estimation of the 
parameter values that result in the best fit between the exte
data and the values produced by the model. More formally, 
given a set of N data points {xi,yi} , a model that has M 
parameters {aj}, and a model relationship of the form:

,

the optimizer chooses the parameters {aj} to minimize:

y x( ) y x a1…aM;( )=

yi y– xi a1…aM;( )[ ]2

i 1=

N

∑
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The QX model definition for this 
example is contained in the 
bjtpar.inc include file. To check 
whether this file is included, from 
the Analysis menu, select Library 
and Include Files.
The Bipolar Transistor 
Test Case
This tutorial fits parameters to a bipolar transistor (BJT) mod
using measured data for Ic and Ib versus Vbe at constant V

To load the BJT desi gn

1 From the Windows 95 Start menu, select the MicroSim 
program folder and then the Schematics shortcut to star
Schematics.

2 From the File menu, select Open.

3 Move to the directory containing bjtpar.sch  
(\MicroSim_root \examples\optimize\bjtpar) and, in the File
Name list, select the schematic file.

 

 
Figure 8-1 Schematic for the BJT Model Fitting Example

The circuit has voltage sources for Vbe and Vce and an insta
Q1, of a BJT. Q1 is a QbreakN device with its model referen
set to Qx—the name of a BJT model.

The schematic also includes an instance of a 2N3055. This is
model that was used to produce the measured data. The 2N3
in the schematic works as a reference during model fitting. 
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Property P

Is

Initial Value 1

Current Value

Lower Limit 1

Upper Limit 1

Tolerance

Refer to Q devices in the online 
MicroSim PSpice A/D Reference
Manual for more information on 
the parameters used for bipolar 
transistor models. 

To display the Optimizer 
Parameters dialog box, double-
click the OPTPARAM symbol in 
the schematic.

To see the parameterized 
expression assignments for the 
model parameters:

1 Click Q1.

2 From the Edit menu, select 
Model.

3 Click Edit Instance Model 
(Text).

4 When finished, click Cancel.
The Parameters
The model parameters to fit are: Is, Ikf, Br, Bf, Ise, and Ne. 
These parameters are a subset of the parameters PSpice u
determine the BJT’s DC characteristics. (To fit all of the BJT
model parameters, you would need more measured data tha
provided in this tutorial.) 

PSpice Optimizer parameters There are six PSpice 
Optimizer parameters, each corresponding to one of the BJ
model parameters listed above. The initial and current values
each of these parameters are set up using the OPTPARAM
symbol as follows:

Parameterized expression assi gnments The 
model definition is set up with parameterized expression 
assignments for the model parameters the PSpice Optimizer
vary. All other model parameters are left unchanged.

Example: Using the Model Editor, the forward beta is specifi
as bf = {bf} .

arameters

Ikf Br Bf Ise Ne

e-13 5 5 50 1e-10 1.5

1e-13 5 5 50 1e-10 1.5

e-14 1 1 20 1e-11 1.2

e-11 10 10 200 1e-8 2

0 0 0 0 0 0
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The Anal ysis 
The BJT example is set up for a DC sweep of the voltage sou
which provides a range of values for Vbe. These values sho
match the measurement points contained in the external da
file. Ic and Ib are measured at values of Vbe starting from 0.4
incrementing by 0.01 Vto a maximum of 0.82 V.

The External File of Measured 
Data 
There are two measured curves: Ic and Ib. Each of these ha
associated PSpice Optimizer specification. When fitting mod
parameters, specifications are different from those used in o
kinds of optimizations because they reference an external d
file. 

For the BJT example, both sets of measured data are conta
in the 3055.mdp  file. A portion of this file is shown below. 

The file contains 3 columns of data: Vbe, Ic, and Ib. The firs
non-blank line in the file contains names for the columns of da
These map to the specification setup in the PSpice Optimize

   Vbe         Ic          Ib

4.000E-01   6.047E-06   2.655E-06

4.100E-01   8.900E-06   3.253E-06

4.200E-01   1.310E-05   3.989E-06

4.300E-01   1.928E-05   4.897E-06

•

•

•

8.100E-01   8.002E+00   1.922E-01

8.200E-01   9.092E+00   2.371E-01
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g To display the Edit Specifications 
dialog box, double-click the 
lower right-hand corner of the 
specification box of interest in 
the PSpice Optimizer window.

When finished browsing, click 
Cancel.

double-click here
The Goals and Constraints 
The example circuit is set up with predefined goals which yo
can view using the PSpice Optimizer.

To activate the PSpice Optimizer

1 From the Tools menu, select Run Optimizer.

The PSpice Optimizer window shows the six parameters (Is, 
Br, Bf, Ise, and Ne) and the two specifications (Ic and Ib). Ic a
Ib are defined as a goals as shown below.

The Ib settings as they appear in the Edit Specification dialo
box are shown below.

Settin g Ic Ib

Name Ic Ib

Reference External External

File 3055.mdp 3055.mdp

X Column Name Vbe Vbe

Y Column Name Ic Ib

Tolerance 5% 5%

Analysis DC DC

Circuit File bjtpar bjtpar

Evaluate YatX(ic(q1),!) YatX(ib(q1),!)
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Mappin gs to the external data file Note the 
reference to the external data file, 3055.mdp , and the values 
assigned to X Column Name and Y Column Name. The colu
values map to the column names defined in 3055.mdp , such 
that the X column gives the data points at which the Y colum
values were measured. For the BJT example, the Y column
contains measured collector current corresponding to the 
specified base-emitter voltages in the X column.

The evaluations To measure performance, both goals u
the Probe goal function, YatX (see The Evaluations on 
page 7-4). Notice the ‘!’ character appearing in the expressio
This character allows Probe to make measurements at the 
multiple X column values. 

When the PSpice Optimizer encounters this character, it 
replaces it with the current X column value before sending it
Probe for evaluation. 
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Refer to online Help in Probe for 
more on Probe display control.
Example: If Evaluate is set to YatX(Ic(Q1),!)  and if the X 
column of the external data file contains the values (1v , 2v , 3v ), 
then the PSpice Optimizer will form the Probe goal function 
expressions YatX(Ic(Q1),1v) , YatX(Ic(Q1),2v) , and 
YatX(Ic(Q1),3v) , and send each one to Probe for evaluati
against the simulation results. 

Monitorin g Progress 
with Probe 
When optimizing, the PSpice Optimizer (with the help of 
PSpice) generates intermediate results which you can have 
to Probe for viewing. This is especially useful when fitting 
model parameters. For the BJT example, this means you ca
monitor how closely the Ic and Ib values match the target valu

To set up Probe and the PSpice Optimizer to 
monitor the fittin g process

1 In Schematics, from the Analysis menu, select Simulate
simulate the circuit. 

2 Create or use an existing Probe display configuration. F
the BJT example, a display named icibe is predefined. T
see what the icibe display looks like: 

a In Probe, from the Tools menu, select Display Contr

b In the display list, click icibe(DC) .

c Click Restore.

d Click Close.

e From the File menu, select Close.
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In some regions of the device 
characteristic, the measured 
currents are relatively insensitive 
to changes in the parameters. 
Because of this, the value of 
Delta is increased to 3% from its 
default value of 1%. See 
Controlling Finite Differencing 
when Calculating Derivatives 
(Delta Option) on page 4-13 for 
more information.
3 Define the display configuration to use when optimizing.
For the BJT example, this is predefined. To verify the 
display name:

a In the PSpice Optimizer, from the Options menu, sele
Defaults. 

The display name, icibe , appears in the Display text 
box and the DC analysis type is selected.

b When finished, click Cancel.

4 Measure performance and redisplay the traces in Probe

a In the PSpice Optimizer, from the Tools menu, selec
Update Performance.

The optimizer automatically updates the Probe displa
When the iteration is complete, the Probe display 
should look something like the one shown in Figure 8-
This display compares the curves for Ic and Ib with 
curves for an instance of a 2N3055. The percentage
error for Ic and Ib is also displayed in the uppermost
plot. 

Figure 8-2 Initial Traces for the Ic and Ib Parameters
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Fittin g the Data 
The PSpice Optimizer looks for a set of parameters which 
minimizes the total squared error between the measured an
simulated curves. When using external data, the optimizer u
the relative error at each measured point. This means that a
points have equal weight, regardless of the absolute value. T
is essential for fitting semiconductor curves, where the curre
may range over many orders of magnitude. Automatic 
normalization is discussed in detail in Target Value Scaling on 
page 4-12.

To fit the data to the model parameters

1 From the Tune menu, select Auto and click Start.

The following table compares the model parameter valu
estimated by the PSpice Optimizer to the data values 
measured by PSpice for the 2N3055 transistor. 

The estimated parameters compare well with the origina
values. 

The results of the optimization are shown in Figure 8-3.

Parameter
Estimated by 
the PSpice 
Optimizer

Measured from 
PSpice

Is 9.744e-13 9.744e-13

Ikf 4.071 4.029

Br 5 2.949

Bf 98.465 99.49

Ise 9.920e-10 9.025e-10

Ne 1.960 1.941
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Figure 8-3 Optimization Results for the BJT Model Fitting 
Example

The Probe plot in Figure 8-4 compares fitted and measu
curves, and shows the percent relative error in Ic and Ib

Figure 8-4 Probe Display after Optimization is Complete
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Appendix Overview
This appendix lists and explains the error messages you mi
encounter while using the PSpice Optimizer, and, where 
appropriate, what action to take.
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Table 8-1 Error Message Des

Error Messa ge Descri

[11002] 
No More Resets

No imp
derivat

[11003] 
Mismatched Parentheses

Check 

[11004] 
Undefined Symbol

A symb

[11005] 
Divide by 0

A divis
offset, ay 
need to

[11006] 
0 to the y

Try add u 
may ne

[11007]
Unknown Operator

Valid o p, 
log, log

[11008] 
Invalid Number

PSpice p, 
f, mil, %

[11009] 
Log of Number <= 0

Log fun e 
the low

[11010] 
Can't Start PSpice

Try run  
the Win ice 
A/D (or
messa

• “ins

• “Ca

In Sche
Setting or 
PSPIC
Error Messa ge 
Descriptions

criptions

ption

rovement was made by going back to the last good step and recalculating 
ives. Try refining the specifications.

for mismatched parentheses in the evaluation expression.

ol in a PSpice Optimizer expression was not recognized.

ion by zero in a PSpice Optimizer expression occurred. Try adding a small 
e.g., 1e-3, to the denominators of fractional terms in the expressions. You m
 change the lower or upper limit of a parameter.

ing a small offset, e.g., 1e-3, to bases in PSpice Optimizer expressions. Yo
ed to change the lower or upper limit of a parameter.

perators and functions in PSpice Optimizer expressions are (+, -, *, /, **, ex
10, sin, cos, tan, atan).

 Optimizer numbers are reals with an optional suffix (T, G, Meg, k, m, u, n, 
) and an optional symbol for units.

ction (log or log10) can not have a zero argument. You may need to chang
er or upper limit of a parameter. 

ning a PSpice simulation (with the PSpice Optimizer window still open). From
dows 95 Start menu, select the MicroSim program folder and then the PSp
 PSpice) shortcut. Open a .cir  file to run the simulation. Observe any 
ges that come up. Here are typical problems and resolutions:

ufficient memory”; at least 8 MB is required and 16 MB is recommended.

nnot obtain a license”.

matics, from the Options menu, select Editor Configuration. Click App 
s. Verify that the correct path, used to run PSpice from Schematics, is set f
ECMD. 
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izer window still open). From the Windows 
am folder and then the Probe shortcut. Open 
messages that come up. Here are typical 

 required and 16 MB is recommended.

elect Editor Configuration. Click App 
d to start Probe from Schematics, is set for 

 for the circuit being optimized. Click on the 
ct Close from the File menu.

ircuit being optimized. The PSpice 
t_0.dat  and opt_1.dat ). Try 
e the problem. If PSpice does not create a 
eep, or transient analysis has been selected, 
e.

arked points in the goal function (error 
). Try loading the .dat  file into Probe, 
 menu to test the goal function. Refer to 
 on writing goal functions.

error or user termination. 

ers with an optional suffix (T, G, Meg, k, m, 
for units.

e in an ASCII string in the Name text box in 

eter must be greater than the Lower Limit. 
TPARAM symbol in Schematics, or select 
pice Optimizer.

greater than the Lower Limit and less than 
an be changed on the OPTPARAM symbol 
 the Edit menu in the PSpice Optimizer.
Error Messa ge Description

[11011] 
Can't Start Probe

Try running Probe (with the PSpice Optim
95 Start menu, select the MicroSim progr
a .dat  file after simulation. Observe any 
problems and resolutions:

• “insufficient memory”; at least 8 MB is

• “Can not obtain a license”.

In Schematics, from the Options menu, s
Settings. Verify that the correct path, use
PROBECMD. 

[11012] 
.dat File In Use

You must unload the data file from Probe
Probe window to make it active, then sele

[11013] 
No Simulation Result

Probe could not open the .dat  file for the c
Optimizer uses two files for optimization (op
running a PSpice simulation to investigat
.dat  file, check that a DC sweep, AC sw
and that there is adequate hard disk spac

[11014] 
G.F. Evaluation Failed

Probe could not find one or more of the m
message will contain goal function name
select Eval Goal Function from the Trace
online Help in Probe for more information

[11015] 
Aborted

Optimization was aborted because of an 

[11016] 
Bad Numeric Field

PSpice Optimizer numbers are real numb
u, n, p, f, mil, %) and an optional symbol 

[11017] 
Name Required

Specifications must be given names. Typ
the Edit Specification dialog box.

[11018] 
MAX Must Be > MIN

The current and initial values for a param
These values can be changed on the OP
Parameters from the Edit menu in the PS

[11019] 
Must Be Between MIN & 
MAX

The Upper Limit of a parameter must be 
the Upper Limit specified. These values c
in Schematics, or select Parameters from
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Error Messa ge Descri

[11020] 
Evaluation Field Required

The Ev
output 
applica

[11021] 
Column Name Required

The firs he 
first co
contain t 
line) m e, 
Y Colu

[11022] 
Would Exceed Max #Params

There i

[11023] 
Would Exceed Max #Specs

There i

[11024] 
All Params Are Disabled

At leas

[11025] 
Can't Open File

The .op e 
is not lo

[11026] 
Problem With External Spec

See [11

[11027] 
Max #Iterations Exceeded

The ma e 
Option  
specific

[11028] 
Terminated

The op

[11029] 
Can't Make Progress

No imp
derivat

[11030] 
No External File

The ex  
[11021

[11031] 
External Spec - Bad Format

A colum  of 
the form

[11032] 
Unrecognized Expression

The ex
could n
problem , *, 
/, **, ex
ption

aluate text box in the Specification dialog box must contain a valid Probe 
variable, Probe goal function, or PSpice Optimizer expression. Refer to 
tion examples in the your PSpice user’s guide.

t line of an external data file must contain names for each column of data. T
lumn should contain the X axis data, and each succeeding column should 
 Y axis data for each external specification. The column names (on the firs
ust be identical to those used in the Specification dialog box (X Column Nam
mn Name).

s a maximum of 8 parameters allowed for an optimization.

s a maximum of 8 specifications allowed for an optimization.

t one parameter must be selected to perform an optimization.

t  file could not be opened by the PSpice Optimizer. Make sure that this fil
cked by a word processor or other application.

021] for a description of the external specification data file.

ximum number of iterations can be increased by selecting Defaults from th
s menu. The default limit is 20 iterations. It is often more helpful to refine the
ations than to increase this limit.

timization was terminated by the user.

rovement was made by going back to the last good step and recalculating 
ives. Try refining the specifications.

ternal file typed in the Edit Specification dialog box could not be found. See
] for a description of the format of this file.

n could not be found in the external data file. See [11021] for a description
at for this file.

pression used in the Evaluate text box of the Edit Specification dialog box 
ot be parsed. See errors [11014] and [11016] for aids in debugging the 
. PSpice Optimizer expressions can only use the following operators: (+, -

p, log, log10, sin, cos, tan, atan).



Error Message Descriptions A-5

mization. An optimization can not be 

sed in the external data file.

contain names for each column of data. The 
a, and each succeeding column should 
cification. The column names (on the first 
e Specification dialogs (X Column Name, Y 

imum of 1 goal and 1 constraint. 
Error Messa ge Description

[11033] 
Need At Least 1 
Enabled Goal

At least one goal must be used in an opti
performed with constraints only.

[11034] 
Max External Items = 250

A maximum of 250 lines of data can be u

[11035] 
Missing External Column

The first line of an external data file must 
first column should contain the X axis dat
contain Y axis data for each external spe
line) must be identical to those used in th
Column Name).

[11036] 
Eval Limits: 1 Goal, 
1 Constraint

The evaluation version is limited to a max
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Appendix Overview
This appendix describes how MicroSim programs, used to 
capture and optimize your design, interact and share informa
with each other.

File and Program Relationships on page B-2 illustrates and 
describes the data flow amongst MicroSim programs.

File Type Summary on page B-6 explains the contents of each
file type.
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Figure 8-5 MicroSim Program and File Interactions 
Important to Optimization
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Typically, you capture your design using Schematics and us
this as the basis for optimization with the PSpice Optimizer.
Each schematic produces a single circuit file 
(design_name .cir ) which is created when either you:

• select Create Netlist or Simulate in the Analysis menu, o

• select Run Optimizer in the Tools menu.

In the latter case, Schematics also produces:

• An optimization file (design_name .opt ) which 
contains optimization settings describing parameters, 
specifications, and other options. The PSpice Optimizer 
adds to and keeps the information in this file up-to-date.

• A parameters file (design_name .par ) which contains 
parameter values as of the last optimization iteration. Th
PSpice Optimizer keeps the information in this file up-to-
date. 

Note The circuit file produced by Schematics 
automatically references the .par file. If you are 
entering your design using a circuit file instead of a 
schematic, add a .inc (“include”) command naming 
the .par file. See “Appendix C, Optimizing a Netlist-
Based Design” for details.
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Measurin g Performance Usin g 
Information in the Circuit File 
and .prb File
Remember that for a simulation-based optimization, you mu
define how to evaluate performance. This means that, for ea
specification (goal or constraint), you must define the followin

What circuit file to use Typically, an optimization uses 
only one schematic/circuit file—based on the schematic tha
active when you activate the PSpice Optimizer. But you can
up the optimization to use a different circuit file for each 
specification.

Which anal ysis to run The circuit file contains the 
analysis directives for any PSpice simulations (e.g., DC swe
transient, etc.) that you set up for the schematic. However, y
control which analyses are actually run for an optimization 
when you define how to evaluate each specification in the E
Specifications dialog box.

How to measure performance If, to evaluate 
performance, your optimization is based on a multi-point 
simulation, you must define goal functions. Goal functions 
reside in the [GOAL FUNCTIONS] section of a .prb  file. By 
default, a given design references the global .prb  file shipped 
with all MicroSim programs (msim.prb  in the MicroSim root 
directory) and a local .prb  file (design_name .prb  in the 
working directory).
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file, 

Vbe  Ic Ib

4.000E-01   6.047E-06   2.655E-06

4.100E-01   8.900E-06   3.253E-06

4.200E-01   1.310E-05   3.989E-06

4.300E-01   1.928E-05   4.897E-06

•

•

•

8.100E-01   8.002E+00   1.922E-01

8.200E-01   9.092E+00   2.371E-01

Figure B-1 Sample External Data File
Definin g Specification Criteria in 
the External Data File
The external data file contains the measured data used in th
optimization (e.g., when fitting data to model parameters). Da
is formatted as labeled columns of values. 

Typically, the first column contains the independent values a
which all other data was measured; this corresponds to the 
X Column Name in the optimizer’s Edit Specification dialog 
box. All other columns contain the dependent measured val
and correspond to the Y Column Name in the dialog box.

To set up an external file

Using a standard text editor:

1 On line 1, enter the column headings for the data separa
by spaces or tabs.

2 On all lines following line 1:

a Enter data values that correspond to the column 
headings, separated by spaces or tabs.

b Sort the lines of data in ascending X Column Name 
order.

3 Save the file using any file extension that does not confl
with other MicroSim standard file extensions. We 
recommend using the naming convention 
design_name .mdp .

For an example of an optimization that uses an external data 
see Chapter 8,Tutorial: Fitting Model Data (Bipolar 
Transistor).
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Table 8-2 Summary of PSpice

File Type Source

.cir

.net

.als

generated by Schem
user-entered with a t n 

.mdp user-entered with a t
n 

.olg generated by the PS
Optimizer when runn
optimization

.oot generated by the PS
Optimizer when gene
report

g 

.opt generated by Schem
activating the PSpice
or by the PSpice Opt
when saving results

r 

opt_0.dat

opt_1.dat

generated by the PS
Optimizer for each si
in a run

.par generated by Schem
activating the PSpice
and updated by the o
when running an opt
File Type Summar y
Table 8-2 briefly describes all of the file types that the PSpice
Optimizer uses directly.

 Optimizer-Related File Types

Description

atics or 
ext editor

Circuit file, netlist file, and alias file, respectively. Define 
components and connectivity, analysis directives, and simulatio
control directives for the circuit. Refer to your PSpice user’s 
guide for more information.

ext editor External data file. Contains measured data to which the 
optimization must adhere. (You can use any file extension for a
external data file.)

pice 
ing an 

Optimization log file. Contains an optimization audit trail that is 
useful as a debugging aid when the optimization doesn't 
converge. Have this file available when contacting Technical 
Support.

pice 
rating a 

Optimization report file. Provides a formatted description of the 
optimization specifications and parameters, and results includin
derivatives and Lagrange multipliers.

atics when 
 Optimizer, 
imizer 

Optimization file. Defines the optimization settings for the 
circuit. When an optimization is complete, the PSpice Optimize
saves results (on command) to this file. Schematics also reads 
this file (on command) to back-annotate the schematic.

pice 
mulation 

Interim data files. Contain simulation results which are read by 
Probe to evaluate performance.

atics when 
 Optimizer 
ptimizer 

imization

Parameters file. Contains the latest optimization parameter 
values.
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Appendix Overview
This appendix describes how to set up and run an optimizat
for a design defined in a circuit file.

Optimizing without a Schematic on page C-2 gives an overview 
on optimizing a netlist-based design.

Setting Up the Circuit File on page C-3 describes the steps tha
you must complete using a text editor to parameterize the circ
file for optimization.

Setting Up and Running the PSpice Optimizer on page C-4 
describes the steps that you must complete using the PSpic
Optimizer to define parameters and specifications, run the 
optimization, and save the results.

Example: Parameterizing the Circuit File on page C-6 steps 
through parameterizing a simple diode biasing circuit file.
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Optimizin g without a 
Schematic
Although the PSpice Optimizer is designed to optimize a 
Schematics-based design, you can optimize a design for wh
a netlist, but no schematic, is available. 

To optimize your desi gn without usin g 
Schematics

1 Implement your design as a circuit file in PSpice-
compatible format.

2 Create a separate file containing the optimization parame
definitions.

3 Using the PSpice Optimizer, complete the setup and run 
optimization as usual.

Refer to your PSpice user’s guide for any questions you mig
have on circuit-file syntax. The remaining sections explain wh
you need to do once your design is defined as a circuit file.



Setting Up the Circuit File C-3

r to 

C 

pice 
u 
teps 

the 
Settin g Up the Circuit 
File
To use the PSpice Optimizer to optimize a desi gn 
defined as a netlist

1 Decide on the design parameters you want the optimize
vary.

2 Place parameter definitions (.PARAM) in a separate 
parameters file (.par ).

3 Include the parameters file in the circuit file using the .IN
command.

4 Replace component values that are dependent on the 
parameters with expressions.

All of these steps use standard PSpice syntax; see your PS
user’s guide for details. The following section explains why yo
need to set up a separate parameters file, and how to do it (s
2 and 3 above).

The parameters file (.PAR) When optimizing, the 
PSpice Optimizer uses a separate parameters file to track 
changes to parameter values with each iteration. This file 
contains nothing but PSpice parameter definitions reflecting 
last-used values. 

The optimizer automatically looks for a file with the name 
circuit_file_name .par .

Example: If the design is contained in myamp.cir , the 
optimizer writes updated parameter definitions to myamp.par .

To create a parameters file for a desi gn

1 Activate any text editor.

2 For each parameter in the circuit, enter a line using the 
syntax:

.PARAM parameter _name = starting _value

3 Save the file as circuit_file_name .par .
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To make the parameter definition in the .par file 
available to PSpice

1 Insert a  .INC command anywhere after the first line of th
circuit file using the syntax:

.INC parameters_file_name

where parameters_file_name is the same file in which you 
entered the .PARAM statements for the circuit. 

Example: To myamp.cir , add the following statement 
anywhere after the first line in the file:

.INC “myamp.par”

Settin g Up and Runnin g 
the PSpice Optimizer
Before optimizing, you need to define for the PSpice Optimiz
all of the parameters declared in the circuit file, and the goa
and constraints. Setup is exactly the same as for a schemat
based design.

To complete setup and optimize the desi gn

1 Activate the PSpice Optimizer by doing one of the 
following:

• From the Windows 95 Start menu, select the MicroSi
program folder and then the PSpice Optimizer shortc

• From the Windows 95 Start menu, select Run, enter 
command line for optimize.exe , and click OK.

2 Add a parameter definition for each of the parameters us
in the circuit file: 

a From the Edit menu, select Parameters.

b Click Add.

c Fill in the dialog box.
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Had you started with a design in 
Schematics, this step is 
equivalent to selecting Update 
Schematic from the Edit menu.
3 Add a specification definition for each goal and constrain

a From the Edit menu, select Specifications.

b Click Add.

c Fill in the dialog box. 

In the Analysis frame, be sure to enter the name of the 
circuit file you parameterized earlier.

4 Run the optimization.

a From the Tune menu, select Update Performance.

b From the Tune menu, select Auto and click Start.

To save the optimization results

1 Write the results to the optimization file:

a From the File menu, select Save As.

b Enter the name of the optimization file (.opt ) to 
contain the setup and results information.

2 From the File menu, select Report to create a PSpice 
Optimizer report file (.oot ) containing a readable summary
of the setup and results information. 
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Example: 
Parameterizin g the 
Circuit File
The following circuit file (call it dbias.cir ) contains the 
netlist for a voltage source/resistor/diode series combination

 * diode bias circuit
.LIB
V1 1 0 5v
R1 1 2 5k
D1 2 0 D1N914
.DC  V1  LIST  5V
.Probe
.END

Suppose you want to optimize the bias current in a voltage 
source/resistor/diode series combination. Specifically, your g
is to achieve a current of 1 mA through the diode. To realize t
goal, you must vary the value of resistor R1 (call the variabl
value, or parameter, Rbias). 

To parameterize the circuit file

1 Create the dbias.par  file containing the parameter 
definition for Rbias using this syntax:

.PARAM Rbias = 5k

2 Parameterize the circuit file as shown (added or change
items are in bold):

* diode bias circuit
.INC “dbias.par” ; this line added
.LIB
V1 1 0 5v
R1 1 2 {Rbias} ; this line modified
D1 2 0 D1N914
.DC  V1  LIST  5V
.Probe
.END

Now you are ready to activate the PSpice Optimizer, 
complete setup, and run the optimization.
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Symbols
!, 3-17
.als file, B-6
.cir file, B-3, B-6
.dat file, 4-11
.mdp file, B-5, B-6
.net file, B-6
.olg file, 3-28, B-6
.oot file, 3-27, B-6
.opt file, 3-2, 3-30, B-3, B-6
.par file, B-3, B-6, C-3
.prb file, 2-9, B-4

A
accuracy

and Delta value, 4-15
and derivatives, 4-11
and failed convergence, 4-9
and RELTOL, 4-15
and Threshold value, 4-18
improving, 4-7, 4-15

activation
automatically loading an optimization file, 3-4
changing startup options, 3-3

from Schematics, 3-2
from Windows 95, 3-3
with a different initialization file, 3-3

active constraint, 4-6
Add, Parameters command (Edit menu), 3-10
Add, Specifications command (Edit menu), 3-13
Advanced Options, Defaults command (Options menu), 

4-17
alias file (.als), B-6
analysis type options, 3-15
Auto submenu,Tune menu, 3-19
automatic recalculation, 3-21, 3-22

B
back-annotation, 3-31
bound constraint, 4-4

C
Change, Parameter command (Edit menu), 3-11
Change, Specifications command (Edit menu), 3-16
circuit file (.cir), B-3, B-6

as alternative to a schematic, C-2
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including a parameters file (netlist-based design), C-
4

Circuit File text box, 3-15
component values

tolerance, 3-29
using standard, 3-29

constraint, 1-6, 1-8
active, 4-6
bound, 4-4
compared to goals, 4-2
equality, 4-5
inactive, 4-6
inequality, 4-4
nonlinear, 4-4
progress indicator, 3-7
target value, 1-7
See Also specification

Constraint check box, 3-14
convergence, 4-9
Copy, Parameters command (Edit menu), 3-11
Copy, Specifications command (Edit menu), 3-16
current value

changing interactively, 3-22, 3-23
external specification, 3-7
internal specification, 3-6
parameter, 3-8

Current Value text box, 3-11
Cutback option, 4-17

D
Defaults command, Options menu, 4-13
Delta option, 4-13
derivatives, 1-11

accuracy, 4-11
and linearity, 4-11
and tweaking values, 3-21
calculating, 3-21, 4-10, 4-13
finite differencing, 4-10, 4-13
limitations, 4-11
viewing, 3-28
when excluding specifications, 3-25

Display Control option, 4-16

E
Edit menu

Parameters command
Add, 3-10

Change, 3-11
Copy, 3-11
Insert, 3-11

Reset Values command, 3-25, 3-26
Round Calculated command, 3-30
Round Nearest command, 3-29
Specifications command

Add, 3-13
Change, 3-16
Copy, 3-16
Insert, 3-16

Store Values command, 3-26
Update Schematic command, 3-31

Edit Parameter dialog box
Current Value, 3-11
Enabled, 3-11
Initial Value, 3-11
Initial Value text box, 3-11
Lower Limit, 3-11
Name, 3-11
Tolerance, 3-11

Edit Specification dialog box
analysis type, 3-15
Circuit File, 3-15
Constraint, 3-14
Enabled, 3-14
Evaluate, 3-15
File, 3-15
Name, 3-14
Range, 3-14
Reference, 3-14
Target, 3-14
Tolerance, 3-15
Type, 3-14
Weight, 3-14
X Column Name, 3-15
Y Column Name, 3-15

Enabled check box, 3-11, 3-14
equality constraint, 4-5
error gauge area, 3-9
Evaluate text box, 3-15
evaluation, 1-9

for external specifications, 3-17
See Also goal function, Probe
See Also PSpice Optimizer expression
See Also trace function, Probe

examples
active filter, 6-1
bipolar transistor, 8-1
diode biasing circuit (primer), 2-2
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MOS amplifier, 7-1
parameterizing a diode-biasing circuit file, C-6
passive terminator, 5-1

exploration, design, 3-20
active filter example, 6-1
ensuring reliable results, 3-24
tweaking values, 3-21

expression, PSpice Optimizer, 1-9, 1-10
external data file (.mdp), B-5, B-6
external specification

progress indicator, 3-7
setting up the data file, B-5

F
File menu

New command, 3-4
Open command, 3-4
Print command, 3-28
Report command, 3-27
Save As command, 3-30
Save command, 3-30

File text box, 3-15
files

alias (.als), B-6
circuit (.cir), B-3, B-6
external data (.mdp), B-5, B-6
log (.olg), 3-28, B-6
netlist (.net), B-6
opt_0.dat, B-6
opt_1.dat, B-6
optimization (.opt), 3-2, 3-30, B-3, B-6
parameter (.par), C-3
parameters (.par), B-3, B-6
Probe goal functions (.prb), 2-9, B-4
report (.oot), 3-27, B-6

fitting data to model parameters, 8-10
bipolar transistor example, 8-1

G
global minima, 4-8
goal, 1-6, 1-7

compared to constraints, 4-2
progress indicator, 3-7
target value, 1-7
See Also specification

goal function, Probe, 1-10
defining .prb file, 2-9, B-4

discontinuities, 1-10

I
inactive constraint, 4-6
inequality constraint, 4-4
initial value

external specification, 3-7
internal specification, 3-6
parameter, 3-8

Initial Value text box, 3-11
Insert, Parameters command (Edit menu), 3-11
Insert, Specifications command (Edit menu), 3-16
interactive design exploration, 2-3
interim data file (opt_x.dat), B-6
iterations

and Cutback, 4-17
controlling parameter value changes, 4-17
limiting, 4-15

L
Lagrange multipliers, 4-4, 4-6
least squares, 4-19

constrained, 1-5
unconstrained, 1-5

Least Squares option, 4-20
local minima, 4-8
log file (.olg), B-6

viewing, 3-28
Lower Limit text box, 3-11

M
manual recalculation, 3-23
Max. Iterations option, 4-15
minima

and starting points, 4-8
constrained, 4-5
global, 4-8
local, 4-8

minimization, 4-19
bound-constrained, 4-9
constrained, 1-5
unconstrained, 1-5, 4-10

Minimize option, 4-20
model parameters, fitting, 8-10

bipolar transistor example, 8-1
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N
Name text box, 3-11, 3-14
netlist file (.net), B-6
netlist-based design, C-2
New command, File menu, 3-4
nonlinear constraint, 4-4

O
Open command, File menu, 3-4
opt_0.dat file, B-6
opt_1.dat file, B-6
optimization, 1-5

aborting, 3-19
adding/editing parameters and specifications, 3-25
and specification functions, 4-7
choosing least squares or minimization, 4-19
constrained least squares, 1-5
constrained minimization, 1-5
constrained vs. unconstrained, 4-3
controlling parameter

perturbation, 4-13
value changes, 4-17

excluding parameters and specifications, 3-24
for one goal, 4-19
improving convergence, 4-9
limiting iterations, 4-15
log, 3-28
loosening parameter bounds, 4-10
purpose, 2-3
restoring previous results, 3-26
running, 3-19
saving final results, 3-30
saving intermediate values, 3-26
scaling, 4-12
setting Cutback value, 4-17
setting the Probe display, 4-16
starting points, 4-5
tweaking values, 3-21
unconstrained least squares, 1-5
unconstrained minimization, 1-5
using a netlist-based design, C-2

optimization file (.opt), 3-2, B-3, B-6
loading, 3-2, 3-4
saving results, 3-30

optimizer window, 3-24
error gauge area, 3-9
parameters area

current value, 3-8
edit hot spot, 3-24
initial value, 3-8

specifications area, 3-6
current value, 3-6, 3-7
edit hot spot, 3-24
Enable check box, 3-24
initial value, 3-6, 3-7
progress indicator, 3-7

options
activation, 3-3
Cutback, 4-17
Delta, 4-13
Display Control, 4-16
Least Squares, 4-20
Max. Iterations, 4-15
Minimize, 4-20
Threshold, 4-17

Options menu
Defaults command, 4-13

Advanced Options, 4-17
Recalculate command, 3-22, 3-23

OPTPARAM symbol, Schematics, 2-7, 3-2, 3-8, 3-31

P
parameter, 1-6

adding from scratch, 3-10
back-annotating values to the schematic, 3-31
bounds, 4-9
controlling changes between iterations, 4-17
controlling perturbation, 4-13
copying, 3-11
Edit Parameter dialog box controls, 3-11
editing, 3-12
enable/disable, 3-24
excluding from optimization, 3-24
fitting, 8-10
loosening bounds, 4-10
tolerance on component values, 3-29
tweaking values, 3-21
using standard component values, 3-29

parameters area, Optimizer Window
Enable check box, 3-24

parameters area, optimizer window, 3-8
current value, 3-8
edit hot spot, 3-24
initial value, 3-8

parameters file (.par), B-3, B-6, C-3
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creating for netlist-based designs, C-3
including in a circuit file (netlist-based design), C-4

Parameters, Recalculate command (Options menu), 3-23
performance, 1-8

derivative calculations, 3-21
evaluating, 3-19
excluding parameter and specifications, 3-24
measuring

when adding/editing parameters and specifica-
tions, 3-25

recalculating
automatically, 3-22
manually, 3-23

saving results, 3-30
scaling measured values, 4-12
tweaking values, 3-21

Print command, File menu, 3-28
Probe, 1-4, 1-9

.prb file, 2-9, B-4
data file (.dat), 4-11
display, 4-16
goal function, 1-10

See Also goal function, Probe
monitoring simulations, 3-19
trace function, 1-9

Probe data file (.dat), 4-11
Probe goal functions file (.prb), 2-9, B-4
progress indicator

external specification, 3-7
internal specification, 3-7

PSpice, 1-4
PSpice Optimizer

activating, 3-2
loading, 3-2, 3-4

PSpice Optimizer expression, 1-9, 1-10

R
Range text box, 3-14
Recalculate command, Options menu, 3-22, 3-23
recalculation, 3-21

automatic, 3-22
manual, 3-23

Reference frame, 3-14
RELTOL option, 4-15
Report command, File menu, 3-27
reports, 3-26

.oot file, 3-27
generating, 3-27

printing, 3-27
reports file (.oot), 3-27, B-6
requirements, see specifications, 1-9
Reset Values command, Edit menu, 3-25, 3-26
results

.opt file, 3-30
improving convergence, 4-9
restoring, 3-26
saving final values, 3-30
saving for netlist-based design, C-5
saving intermediate values, 3-26
setting the Probe display, 4-16

Results, Recalculate command (Options menu), 3-23
RMS error, 3-9
Round Calculated command, Edit menu, 3-30
Round Nearest command, Edit menu, 3-29

S
Save As command, File menu, 3-30
Save command, File menu, 3-30
Schematics, 1-4

back-annotating, 3-31
defining optimization parameters (OPTPARAM 

symbol), 2-7
OPTPARAM symbol, 3-2, 3-8, 3-31

Show Derivatives command, Tune menu, 3-28
simulation

monitoring with Probe, 3-19
single-point analyses, 1-9
specification, 1-6

adding from scratch, 3-13
conflicting, 1-9
copying, 3-16
Edit Specification dialog box controls, 3-14
enable/disable, 3-24
excluding from optimization, 3-24
external, 1-7, 3-7, B-5
function behavior and accuracy, 4-7
internal, 1-6, 3-6
target value, 1-7
tweaking values, 3-21
See Also constraint
See Also goal

specifications area, Optimizer Window
Enable check box, 3-24

specifications area, optimizer window, 3-6
edit hot spot, 3-24
external
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current value, 3-7
initial value, 3-7

internal
current value, 3-6
initial value, 3-6
progress indicator, 3-7

progress indicator, 3-7
Start command, Auto submenu (Tune menu), 3-19
starting points

and global and local minima, 4-8
and parameter bounds, 4-10
feasible, 4-5
improving convergence, 4-9
infeasible, 4-5

Store Values command, Edit menu, 3-26
subgoal

progress indicator, 3-7

T
Target text box, 3-14
target value, 1-7

scaling raw measurements, 4-12
Terminate command, Auto submenu (Tune menu), 3-19
Threshold option, 4-17
Tolerance text box, 3-11, 3-15
tolerance, component values, 3-29
trace function, Probe, 1-9
tradeoffs, design, 2-3, 3-20

active filter example, 6-1
and starting points, 4-5
between goals and constraints, 4-2
ensuring reliable results, 3-24
tweaking values, 3-21

Tune menu
Auto submenu, 3-19

Start command, 3-19
Terminate command, 3-19

Show Derivatives command, 3-28
Update Derivatives command, 3-22, 3-23
Update Performance command, 3-19

Type list (constraints), 3-14

U
Update Derivatives command, Tune menu, 3-22, 3-23
Update Performance command, Tune menu, 3-19
Update Schematic command, Edit menu, 3-31

W
Weight text box, 3-14

X
X Column Name text box, 3-15

Y
Y Column Name text box, 3-15
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