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Welcome to MicroSim
Welcome to the MicroSim family of products. Whichever 
programs you have purchased, we are confident that you w
find they meet your circuit design needs. They provide an ea
to-use, integrated environment for creating, simulating, and 
analyzing your circuit designs from start to finish. 
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MicroSim Schematics 
Overview
MicroSim Schematics is a schematic capture front-end progr
with a direct interface to other MicroSim programs and option. 

All in one environment you can do the following using 
Schematics:

• design and draw circuits

• simulate circuits using MicroSim PSpice

• analyze simulation results using MicroSim Probe

• graphically characterize simulation stimuli using the fully
integrated Stimulus Editor, so stimulus definitions are 
automatically associated with the appropriate symbols 

• graphically characterize simulation models using the full
integrated MicroSim Parts utility, so model definitions ar
automatically associated with the appropriate symbols

• interface to MicroSim PSpice Optimizer for analog circui
performance optimization

• interface to MicroSim PLSyn and MicroSim FPGA for 
programmable logic synthesis

• interface to MicroSim PCBoards for printed circuit board
layout 

The MicroSim family of products is fully integrated, giving you
the flexibility to work through your circuit design in a consisten
environment. The following illustration demonstrates how th
MicroSim family of products work together, with Schematics a
the central point of control.
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For UNIX users:

All screen captures in this 
manual are of Windows dialog 
boxes and windows. Most 
options in these dialog boxes 
and windows are available in 
your operating environment. 
When certain options are not 
available to you, or you must do 
something differently than what 
is primarily outlined, 
information specific to your 
platform is provided.

Scug.bk : 00CHAP.FMK  Page iv  Monday, June 16, 1997  10:10 AM
How to Use this Guide
This guide is designed so you can quickly find the informatio
you need to use Schematics. 

This guide assumes that you are familiar with Microsoft 
Windows (NT or 95), including how to use icons, menus, an
dialog boxes. It also assumes you have a basic understandi
about how Windows manages applications and files to perfo
routine tasks, such as starting programs and opening and sa
your work. If you are new to Windows, please review your 
Microsoft Windows User’s Guide.

Typographical Conventions
Before using Schematics, it is important to understand the te
and typographical conventions used in this documentation.

This guide generally follows the conventions used in the 
Microsoft Windows User’s Guide. Procedures for performing an
operation are generally numbered with the following 
typographical conventions.

Notation Examples Description

C+r Press C+r A specific key or key stroke 
on the keyboard.

monospace
font

Type VAC... or

analog.slb

Commands/text entered from 
the keyboard, or file names.
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 schematic capture front-end program 
croSim programs and options.

CB layout editor that lets you specify 
 well as the components, metal, and 

 Editor, and the Parts utility, which are 
you create, simulate, and test analog and 
 examples on how to specify simulation 
esults, edit input signals, and create 

pice Basics, which are circuit analysis 
ulate, and test 

h is an analog performance 
u fine tune your analog circuit designs.

rammable logic synthesis program that 
LDs from a schematic or hardware 

etween MicroSim Schematics and 
e A/D to enter designs that include 
ray devices. 

s a filter synthesis program that lets you 
tive filters.
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Related Documentation
Documentation for MicroSim products is available in both ha
copy and online. To access an online manual instantly, you 
select it from the Help menu in its respective program (for 
example, access the Schematics User’s Guide from the Hel
menu in Schematics).

Note The documentation you receive depends on the 
software configuration you have purchased.

The following table provides a brief description of those 
manuals available in both hard copy and online.

This manual... Provides information about how

MicroSim Schematics 
User’s Guide

MicroSim Schematics, which is a
with a direct interface to other Mi

MicroSim PCBoards
User’s Guide

MicroSim PCBoards, which is a P
printed circuit board structure, as
graphics required for fabrication.

MicroSim PSpice A/D & Basics+ 
User’s Guide

PSpice A/D, Probe, the Stimulus
circuit analysis programs that let 
digital circuit designs. It provides
parameters, analyze simulation r
models.

MicroSim PSpice & Basics 
User’s Guide

MicroSim PSpice & MicroSim PS
programs that let you create, sim
analog-only circuit designs.

MicroSim PSpice Optimizer 
User’s Guide

MicroSim PSpice Optimizer, whic
optimization program that lets yo

MicroSim PLSyn
User’s Guide

MicroSim PLSyn, which is a prog
lets you synthesize PLDs and CP
description language.

MicroSim FPGA 
User’s Guide

MicroSim FPGA—the interface b
XACTstep—with MicroSim PSpic
Xilinx field programmable gate ar

MicroSim Filter Designer 
User’s Guide

MicroSim Filter Designer, which i
design electronic frequency selec
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MicroSim PSpice A/D
Online Reference Manual
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MicroSim Application Notes 
Online Manual
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Online Library List A
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MicroSim PCBoards Online 
Reference Manual
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MicroSim PCBoards Autorouter 
Online User’s Guide
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The following table provides a brief description of those 
manuals available online only.

Online Help
Selecting Search for Help On from the Help menu brings up
extensive online Help system. 

The online Help includes:

• step-by-step instructions on how to use Schematics feat

• reference information about Schematics

• technical support information

If you are not familiar with the Windows (NT or 95) Help 
System, select How to Use Help from the Help menu.

ovides this...

eference material for PSpice A/D. Also included: detailed descriptions of th
imulation controls and analysis specifications, start-up option definitions, an
 list of device types in the analog and digital model libraries. User interface
ommands are provided to instruct you on each of the screen commands.

 variety of articles that show you how a particular task can be accomplishe
sing MicroSim‘s products, and examples that demonstrate a new or differe
pproach to solving an engineering problem.

 complete list of the analog and digital parts in the model and symbol 
braries.

eference information for MicroSim PCBoards, such as: file name extension
adstack naming conventions and standards, footprint naming conventions, 
etlist file format, the layout file format, and library expansion and 
ompression utilities.

formation on the integrated interface to Cooper & Chyan Technology’s 
CT) SPECCTRA autorouter in MicroSim PCBoards.
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What’s New for Release 
8

Design Journal is a very powerful analysis and tracking
tool. When creating a schematic design, you can make a 
checkpoint of the schematic, which is a copy of the schema
you are working on, in its current stage of development. All fil
(even non-EDA files) associated with your design can be 
automatically saved. You can then explore alternative solutio
and mark other checkpoints. Probe displays simulation result
all the checkpoints in colors to match the same simulation fi
(including multi-run simulations) so you can compare results
Return to the checkpoint that displayed the best results and
continue on with your design, marking and comparing other
checkpoints to improve your design.

Design Manager allows you to browse, manage, archive
and restore your design files. It organizes all files (such as 
symbols, sub-schematics, and also any non-EDA document
associated with your design as a single, self-contained entit
Design Manager gathers this information, arranges and displ
it in categories that show the relationships of the files to one
another. Checkpoints in Design Journal with attached notes
even a Microsoft Word file can be archived as components o
single design within Design Manager. 

Ortho gonal Rubberbandin g makes it easier to 
rearrange your schematic for new parts and to clean up the 
schematic when necessary. You can move one or more sele
objects to a new location while maintaining connectivity. 

Annotation Graphics provides the ability to add non-
electrical information, such as polylines, circles, arcs, and mu
line text. Bitmap and metafile images can be placed on the 
schematic or within symbols.
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Gettin g Started
 and 
1

Overview
This chapter describes Schematics: what it is, what it can do,
how you can use it.

This chapter has the following sections:

Using Schematics on page 1-2 provides a broad overview and 
describes various functions.

Example—Drawing a Schematic on page 1-4 provides a step-
by-step example of creating a schematic.
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Usin g Schematics
Schematics is a schematic capture front-end program that 
provides a convenient system for:

• creating and managing circuit drawings.

• setting up and running simulations.

• evaluating simulation results using MicroSim Probe.

• creating netlists (for MicroSim PCBoards and other extern
PCB layout packages).

An important prerequisite to building a schematic is availabili
of proper symbols for assembly. Schematics has extensive 
symbol libraries and a fully integrated symbol editor for creatin
your own symbols or modifying existing symbols. 

The main functions of Schematics are:

• creating and editing designs

• creating and editing symbols

• creating and editing hierarchical designs

• preparing a design for simulation

• preparing a design for board layout

These primary functions are described in the following chapte
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Figure 1-1 Interaction of MicroSim Software Programs and Files
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Example—Drawin g a Schematic
The following example demonstrates the basic drawing features for drawing a schematic. It sh
you how to:

• start the schematic editor and begin a new design.

• find out which libraries are configured for Schematics.

• place parts on a schematic.

• connect the part using wires and buses.

• label wires and buses.

• change reference designators and part values.

• move parts, wires and text.

• use ports on a schematic.

• place power and ground symbols on a schematic.

• save your design.

Follow this example to create the circuit shown in Figure 1-2.
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Figure 1-2 Opto-isolated, Addressable Serial-to-parallel Converter Circuit
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For Unix Users:

Do one of the following:

• In the File Manager, double-
click a schematic (.sch) file.

• In the shelltool, type 
psched <options>

where <options>  are any of the 
options described in the 
Command Line Options section 
on this page.
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Startin g a New Desi gn
Start the schematic editor by double-clicking on the Schema
icon in the MicroSim program group. An empty schematic pa
displays.

If you already have Schematics running with another schem
displayed, click the New File icon to start a new schematic.

Command Line Options
Schematics supports a number of command line options tha
enable you to customize the start-up mode. You can add on
more of these options to the Command Line text box of the 
Program Item Properties dialog box (File/Properties from with
the Program Manager) for the Windows Schematics program
icon.

The command line options are:

Option Description

-i 
<filename.ini>

activates Schematics using a specific file 
(specified by <filename.ini>) for 
configuration settings, rather than the defau
msim.ini

-sym activates Schematics with a new Symbol Ed
document window

<filename> activates Schematics and loads the schema
file specified by <filename.sch>
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Note If you are using the 
evaluation version of 
Schematics, you will be using 
“eval.slb”.
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Checkin g Symbol Libraries 
Confi guration
When you installed Schematics, you selected a set of librarie
be installed. These are global libraries, which means the 
symbols contained in them are available to be used in any n
or existing schematic.

Check to see that you have the correct symbol libraries 
configured for this example:

1 From the Options menu, select Editor Configuration.

2 Check that the following libraries are included in the 
Libraries list box:

7400 [.slb,.plb]
analog [.slb,.plb]
opto [.slb,.plb]
port [.slb]
1_SHOT [.slb]
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The Full List in the Part Browser 
dialog box represents all the 
parts in the configured symbol 
libraries that are available for 
your use.

One of two Part Browser dialog 
boxes may appear: the Part 
Browser Advanced or the Part 
Browser Basic. If in the Part 
Browser Advanced dialog 
appears, click <<Basic to display 
the Part Browser Basic.

Another method of selecting a 
part is to use the Get Recent Part 
list box on the toolbar. You can 
scroll and select a previously 
placed part, or you can type the 
name of the part you want to 
place. 
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Selectin g and Placin g Parts
1 From the Draw menu, select Get New Part to display the

Part Browser dialog box.

2 There are several ways to select a part in the Part Brow
dialog box:

• If you know the name of the part, type the name in th
Part Name text box.

• Select the part name from the Full List of part names

• Click Libraries to view the Library Browser dialog box
select a library, and select the part name from that 
library’s list of parts.

3 Click Place to place the part (with the browser remaining
open) or click Place & Close (to place the part and close 
browser). If you leave the browser open, click the title ba
of the dialog box and drag it to a new location.
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As you place parts, the 
numerical portion of the 
reference designator is 
automatically assigned. For 
instance, if you place resistor R2, 
the next resistor you place will be 
designated R3.
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Placin g resistors R1 and R2

1 From the Draw menu, select Get New Part to display the
Part Browser dialog box (shown on 1-8).

2 Type R in the Part Name text box.

3 Click Place & Close.

The outline of the resistor becomes attached to the poin

Note that as you move the pointer, the X and Y coordina
at the left of the Status Bar (bottom of the window) chang
These coordinates show the location of the pointer from
origin 0,0 (upper left corner) to the closest 0.01 inch (or 
closest mm if you are using a metric page size).

4 Press C+R to rotate the resistor before placing it.

5 Move the pointer to the 2.40, 1.80 coordinates (within a fe
hundredths of the inch is close enough) and click to plac
the resistor on the schematic. If the Stay-on-Grid option 
enabled, parts are automatically placed on the nearest g
point.

6 Move the pointer to 2.40, 3.90 and click again to place th
second resistor on the schematic.

7 Right-click to stop placing the part.

Placin g resistors R3 throu gh R6

You can quickly place resistors R3 through R6 using the Au
Repeat function.

1 From the Options menu, select Auto-Repeat to display t
Auto-Repeat dialog box.

a Set Horizontal Offset to 00.00 and Vertical Offset to 
00.20.

b Select the Enable Auto-Repeat check box.

c Click OK.

2 From the Get Recent Part list box on the toolbar, select R.

3 Place the pointer in the approximate position for the 
placement of R3 and click to place the part.
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Table 1-1 Remaining Parts to 
be Placed

Reference 
Designator

Part
Name

C1

U1

C

A4N25

U2 A4N25

U3 74164

U4 74164

U5 74174

U6 74174

U7 7485

U8A 74123

U9A 74123
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4 Press M three times to place three more resistors abov
the first.

Placin g resistors R7 throu gh R10

1 From the Get Recent Part list box on the toolbar, select R.

2 Press C+R to rotate the resistor before placing it.

3 Place four resistors in the approximate locations of R7, R
R9, and R10.

4 Right-click to stop placing resistors.

Placin g the remainin g parts on the schematic

1 Click the Get New Part button.

2 In the Part Browser dialog box, select each part listed in
Table 1-1 from the Part list box.

3 Place the part on the schematic in the approximate locat
shown in Figure 1-2.
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Drawin g and Labelin g Wires
Draw the wire labeled dataclk  to connect pin 8 (CLK) on U3 
and pin 1 (A) on U8A.

Drawin g the dataclk wire 

1 Click the Draw Wire button.

The pencil pointer indicates that you are ready to draw a
wire.

2 Click pin 8 of U3 to begin the wire.

3 Following the illustration in Figure 1-2, click where you 
want each vertex of the wire. Each click ends a wire segm
and starts a new one.

4 Click pin 1 of U8A

Notice that the wire is now ended where you clicked to pla
a pin. The pointer remains in the shape of a pencil and y
are ready to start another wire.

5 Wire the rest of the schematic to the bus, except for the 
wires of the right sides of U5 and U6.

6 Right-click to stop drawing wires.

Labelin g the dataclk wire

Label the wire connecting the CLK pin of U3 to the A pin of 
U8A.

1 Double-click any segment of the wire to display the Set 
Attribute Value dialog box.

2 Type dataclk  in the LABEL text box.

3 Click OK.
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Buses must be labeled. 
Examples of legal bus names 
are:

DB[0-12]
DB[0:12]
DB[0..12]
DB0, DB1, CLK

You can use the Auto-Repeat 
function to place the wires that 
connect the pins to the bus 
because the wires will be the 
same length and fixed distances.
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Drawin g and Labelin g Buses
Draw the bus labeled DB[1-12]. 

Drawin g the bus

1 Click the Draw Bus button.

The pointer is now shaped like a pencil (as it was when y
were drawing wires).

2 Click where you want to start the bus.

3 Click the pointer where you want to end the bus.

4 Right-click to stop drawing buses.

Labelin g the bus

1 Double-click any segment of the bus to display the Set 
Attribute Value dialog box.

2 Type DB[1-12]  in the LABEL text box.

3 Click OK.

Connectin g wires to the bus

1 From the Options menu, select Auto-Repeat to display t
Auto-Repeat dialog box.

a Set the Vertical Offset to 00.10.

b Ensure that Enable Auto-Repeat is enabled.

c Click OK.

2 Click the Draw Wire button and draw a wire from pin 2 o
U5 to the bus.

3 Press M five times to place five more wires.

4 Click the Draw Wire button and draw a wire from pin 2 o
U6 to the bus.

5 Press M five times to place five more wires.
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Note Each wire connecting 
to a bus must be labeled with 
the name of one of the signals 
on the bus.
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Labelin g the wires connected to the bus

You can use Auto-Naming to label a uniform collection of 
wires.

1 From the Options menu, select Auto-Naming to display t
Auto Naming dialog box.

a In the Wire/Port Labels frame, select the Enable Aut
Increment check box.

b In the Label Template text box, type DB1, which is the 
label for the first wire in the series.

Wires will be labeled incrementally from DB1 and up

c Click OK.

2 Select the first (lower-most) wire to be labeled.

3 Press C+E to label the wire.

4 Repeat steps 2 and 3 for each wire segment, in the order 
are to be labeled (from bottom to top).
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When you place a part on the 
schematic, the part is 
automatically assigned a 
reference designator and a gate 
(if it is a multi-part component). 
For instance, when you placed 
the 74123 part, it was assigned 
something like U8A (that is, 
reference designator U8 and 
gate A).
If you placed any of the 
components in an order other 
than the sequential order shown 
in Figure 1-2, use this feature 
now to change the reference 
designators to match the 
schematic in Figure 1-2.

Scug.bk : 01GETSTD.FMK  Page 14  Monday, June 16, 1997  10:10 AM
Changing Reference 
Designators and Part Values
Change part values and reference designators by double-
clicking them and typing a new value in the dialog box.

Changing U8A to U9B

1 Double-click U8A to display the Edit Reference Designat
dialog box.

2 Type U9 in the Package Reference Designator text box.

3 Type B in the Gate text box.

4 Click OK.

Changing R9 from 1 kohm to 100 kohm

1 Double-click 1k (next to resistor R9) to display the Set 
Attribute Value dialog box.

2 Change 1k to 100k.

3 Click OK.

Now, change the value of R10 to 100k and the values of R3
through R8 to 10k.



Example—Drawing a Schematic 1-15

and 
en 
tion.

ved 

ted.

r is 

e 

For information on how to enable 
the rubberbanding option, see 
Rubberbanding on page 4-35.

The color of the selected resistor 
is the color specified for the 
Selection display layer in the 
Display Preferences dialog box 
(see Configuring Colors on 
page 3-37).
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Movin g Parts, Wires, and Text
Move parts, wires, buses, and text by clicking to select them, 
dragging them to a new location. To maintain connectivity wh
moving parts, wires, or buses, enable the rubberbanding op

Movin g resistor R1 up one grid

1 Click the resistor to select it.

2 Drag the resistor up one grid.

3 Place the resistor at the new location.

Part values, reference designators, and other text can be mo
in the same way.

Movin g the value of R10

1 Click the 100k value of the resistor.

The box outline around the value indicates that it is selec

The box outline around the resistor shows that the resisto
the owner of the selected value.

2 Drag the value of the resistor to a new location.

The box representing the 100k value follows as you mov
the pointer.
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Placin g Ports
Ports in Schematics identify signals that are inputs or outputs
a schematic. Place ports in the same way that you place oth
parts.

Placin g the port

1 From the Draw menu, select Get New Part to display the
Part Browser dialog box (shown on 1-8).

2 Click Libraries to display the Library Browser dialog box

3 In the Library list box, select port.slb.

4 In the Part list box, select GLOBAL (which is the name of
global port symbol).

5 Click OK.

6 In the Part Browser dialog box, click Place & Close.

7 Move the pointer to the location for the DAT port and clic
to place the part.

8 Right-click to stop placing ports.
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Labelin g the port

1 Double-click the port symbol to display the Set Attribute 
Value dialog box.

2 Type DAT in the LABEL text box.

3 Click OK.

Now place two more ports and label them CLK and RTN as
shown in Figure 1-2.

Placin g Power and Ground 
Symbols
Power and ground symbols are types of global port symbols
Schematics. The label on the port defines the name of the po
supply.

Placin g +5-volt power supplies

1 Type +5V in the Get Recent Part list box on the toolbar.

2 Press R to select the part.

3 Move the pointer to the location of the +5V symbol and 
click to place the symbol.

4 Move the pointer and click to place the other nine +5V 
symbols.

5 Right-click to stop placing parts.

All signals tied to power supplies of the same name are 
connected.
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Placin g ground s ymbols

1 In the Get Recent Part list box on the toolbar, type EGND.

2 Press R to select the part.

3 Move the pointer to the location of the ground symbol an
click to place the symbol.

4 Move the pointer and click to place the other four ground
symbols.

5 Right-click to stop placing parts.

Savin g Your Work
Click the File Save button, or select Save (or Save As) from 
File menu to save the schematic.

If this is a new design, you are prompted to enter a file nam
where the new schematic will be saved.
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Usin g Design Manager
 

2

Overview
This chapter provides introductory information about the 
Design Manager. 

This chapter has the following sections:

Understanding Design Manager on page 2-2 describes the 
purpose and uses for Design Manager.

Managing Your Files in the Workspace on page 2-4 explains 
what a workspace is and how to manage your files within it.

Design Manager Functions on page 2-5 describes Design 
Manager functions and activities.

Starting the Design Manager on page 2-7 describes how to start
the Design Manager.

Design Manager Help on page 2-7 describes where to find 
Design Manager Help.
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Understandin g Design 
Manager
Design Manager allows you to browse, manage, archive, an
restore your design files.

When you open a design file, Design Manager searches the
Windows Explorer for the following information:

• the name of the top-level folder where the file is stored

• the names of all files within the top-level folder and its su
folders

• the names of files in folders outside the top-level folder th
are linked to files within the top-level folder

Design Manager gathers this information, arranges and displ
it in categories that show the relationships of the files to one
another. For instance, all Schematics .sch  files are listed in the 
Design Entry Files category, while all simulation .dat  and 
.out  files are listed in the Simulation Results category. 
Hierarchical schematics are shown as child schematics to th
parents.
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Multiple workspaces, in their own 
windows, can be open 
simultaneously for browsing and 
file management activities.

Because categories are for 
display purposes only, you 
cannot move or copy files from 
one category type to another 
category type.
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Managing Your Files in 
the Workspace
Design Manager views a file’s top-level folder (as seen in 
Windows Explorer) as a workspace and assigns it the name of 
the top-level folder.

Although workspaces are actual folders, categories are not.
Categories only display files found after Design Manager 
searches the top-level folder and its sub-folders, making it e
for you to identify and manage them. Dependent files (such 
hierarchical sub-schematic and symbol library files) that are
stored outside the workspace, show a reference to their loca

You can copy and move all files, or a selected sub-set, from 
workspace to another workspace. This principle applies to 
deleting files as well. Because categories are for display 
purposes only, you cannot move or copy files from one categ
type to another category type.

Design Manager also provides cut, copy, paste, and delete 
operations at an individual file level, that work similar to the 
same functions in Windows Explorer.

When files are copied, moved, or saved to a workspace, Des
Manager automatically arranges their display into the 
appropriate file-type categories. Windows Explorer (when 
opened or refreshed) reflects the action taken in the worksp

Note To get the optimal use of Design Manager, it is 
recommended that only files related to one design 
be stored in one top-level folder, and therefore in 
one workspace. Also, because Design Manager 
can perform operations on a design file and all of 
its dependent files simultaneously, perform file 
management functions within Design Manger, 
rather than Windows Explorer.
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Design Manager 
Functions
The following describes Design Manager functions and 
activities:

General characteristics

• automatic activation upon opening any MicroSim progra

• availability for use without other MicroSim programs 
running

• automatic categorization of design-related files, sorted in
file-type categories, within a workspace

• ability to have multiple workspaces, in their own windows
open simultaneously

• two methods (view by Category and view by Name) with
which you can view and manage all files within a selecte
workspace, as well as external references to files outside
selected workspace

File mana gement

• copy, move, and delete all files (or optionally a selected s
set), from one workspace to another

• optionally cut, delete, copy, and archive all dependent fi

• cut, delete, copy, and paste files as similarly done in 
Windows Explorer

• drag-and-drop functionality

• acceptance of files from Windows Explorer, through 
commands or drag-and-drop

• ability to create top-level folders in Windows Explorer from
Design Manager
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Archive and restore

• archive and restore to save a design and all of its referen
package files for shipment to another location, save disk
space, and localize externally referenced and shared file
into a selected workspace
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Startin g the Desi gn 
Manager
The Design Manager is automatically opened and minimize
when you open any MicroSim program. Activate it by clickin
the MicroSim Design Manager icon on the task bar.

You can also open Design Manager to view and manage file
when other MicroSim programs are not open.

Openin g the Desi gn Manager outside of MicroSim 
pro grams

1 On the task bar, click the Start button.

2 Point to Programs.

3 Point to the MicroSim folder.

4 Click MicroSim Design Manager.

Design Manager opens with the Category view in effect.

Hints and Tips
• To get optimal use of Design Manager, place only files 

related to one design in one workspace.

• It is beneficial to perform file management functions withi
Design Manger, rather than Windows Explorer. Design 
Manager can perform operations on a design file and all
its dependent files simultaneously.

Design Manager Help
Refer to Schematics Help and Design Manager Help for 
procedures on how to use Design Manager.
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Usin g the Schematic Editor
 the 
.

3

Overview
This chapter provides background information about the 
schematic editor. For specific step-by-step instructions for 
creating a design, see Chapter 4,Creating and Editing Designs.

This chapter has the following sections:

Components of a Design on page 3-3 introduces and explains 
the components of a design.

Main Window on page 3-6 describes the user interface to the 
schematic editor. This section describes the uses of menus,
toolbar and toolbar buttons, the status line and the keyboard

Configuring Schematics on page 3-15 provides information on 
configuring the schematic editor to suit your requirements.

Controlling the Display in Schematics on page 3-34 describes 
how to control the display and printing of layers of your 
schematic, in addition to specifying colors and sizes.
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Zooming and Panning in Schematics on page 3-42 tells how to 
zoom in and out of the drawing, refresh the screen display, p
to various sections of the drawing and fit the drawing to the 
page.

Using the Message Viewer on page 3-47 describes the Message
Viewer that displays system messages and explains the var
displays and controls.
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Schematics uses two basic types 
of parts: primitive and 
hierarchical.

Primitive parts are at the lowest 
level and explicitly contain all of 
the information required by the 
netlister. Most symbols in the 
symbol libraries are primitive 
parts.

Hierarchical parts have the same 
appearance as primitive parts. 
The difference is that 
hierarchical parts represent one 
or more levels of schematics and 
primitive parts do not.

A hierarchical part is modified by 
pushing into it from within the 
schematic editor or symbol editor 
and editing the associated 
schematic. 

A primitive part is modified by 
editing its graphics, pins, and 
attributes.
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Components of a Desi gn
A schematic consists of:

• symbols

• attributes

• wires

• buses

• text items

Schematics can have either a flat or hierarchical structure, 
depending on the way you decide to implement your design

Parts
Parts are electrical devices that make up a circuit, such as:

• resistors

• operational amplifiers

• diodes

• voltage sources

• digital gates

The graphical representation of a part is a symbol. Symbols 
stored in symbol libraries.
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Ports are not physical 
connectors. If you want a specific 
pin (such as a DB25 pin) you 
must use a symbol for such a 
connector from the “connect.slb” 
symbol library. 

Two attributes of a resistor are 
PKGTYPE (package type) and 
VALUE.

Attribute 
Name

Value

PKGTYPE = RC05

VALUE = 1K
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Symbols
Symbols are the graphical representation of parts, ports, an
other schematic elements. They are grouped by functionalit
into symbol libraries. Each symbol contains a specific set of
attributes that define the symbol. You can edit these attribute
well as create new attributes. Symbols can share similar 
attributes and graphics. Hierarchical symbols represent 
schematics and are the mechanism that you use to create 
hierarchical designs.

Ports
Ports are symbols that form connecting points leading into or 
of the schematic page. Ports provide connectivity between 
schematic pages and between levels of hierarchy. They play
important role in determining names of electrical nets.

Attributes
Parts, ports, wires (nets), buses, and most other symbols ha
associated attributes. An attribute consists of a name and a
associated value. Attributes are used for Bill of Materials 
reports, and simulation and layout netlists.

Annotations
Text, graphics, and annotation symbols are used to show no
electrical information on the schematic, such as comments a
tables. Annotation symbols primarily consist of text and 
graphics. Title blocks and page borders are considered 
annotations. For more information on adding annotations to
your schematic, see Adding Non-Electrical Information on 
page 4-50.
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Connections
Parts and ports contain one or more pins where connections
made. Electrical connections are formed by wire and bus 
segments joining pins and other wire and bus segments. 
Connections are also formed by attaching pins directly to pin
Schematics represents each such electrical connection by a
junction. Junctions are made visible when three or more 
connected items converge at the junction. Junctions are cre
and removed automatically.

Some parts have hidden pins. Hidden pins are most often u
for power and ground connections to digital parts. Hidden pi
are not connected by wires and buses, but rather through a
attribute that names the net, which they belong (the 

IPIN(<pinname>)=<netname> attribute) to.
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Note Drop-down menu items 
sometimes appear dimmed. 
In some cases, you must 
select an object first or 
perform some other operation 
before you can choose 
unavailable items.
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Main Window
When you start Schematics, a schematic editor window ope
and displays a single schematic page. You have the option 
opening additional schematic editor windows. Use these 
windows to:

• display different schematics.

• display different portions of a single schematic page.

• display different pages of the same schematic.

• display different levels of hierarchy from the same 
schematic.

• display a separate symbol editor window.

Menus
The display and operation of the menus and submenus in 
Schematics follows a standard Windows layout and operatio
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To “dock” toolbars:

1 Click anywhere on the toolbar 
(except on the buttons).

2 Drag it to the desired location 
in the schematic window or 
on your desktop.

The next time you open 
Schematics, the toolbars will be 
where you last placed them.

To display toolbars:

1 From the View menu, select 
Toolbars.

2 Select or clear the check box 
for each toolbar to enable or 
disable its display.

3 Click Close and the selected 
toolbars will display.
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Toolbars 
Toolbar buttons provide shortcuts for performing common 
actions. All toolbars are dockable, so they may be moved to any
location on the schematic.

Standard Schematics

The Standard Schematics toolbar provides shortcuts to stan
Windows commands. 

Table 3-1 Standard Schematics Toolbar

Button Name Function Pa ge

New File opens a new schematic file4-3

Open File opens an existing 
schematic file

4-3

Save File saves a schematic file 4-70

Print 
(immediate)

prints the active schematic 4-64

Cut deletes a selected object 
and copies it to the 
clipboard

4-43

Copy copies a selected object to 
the clipboard

4-43

Paste pastes the most recently cut 
or copied object from the 
clipboard

4-43

Undo undoes the previous action4-44
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Redo redoes what was just 
undone

4-44

Redraw refreshes the active 
schematic page screen 
display

3-15

Zoom In views a smaller area of 
schematic

3-42

Zoom Out views a larger area of 
schematic

3-42

Zoom Area views a selected area of 
schematic

3-42

Zoom to Fit 
Page

fits the view to show all 
items on the page

3-44

Table 3-1 Standard Schematics Toolbar

Button Name Function Pa ge
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Note You can also type the 
name of the part directly into 
the text box.
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Drawin g

The Drawing toolbar provides shortcuts for drawing and editi
items on your schematic.

Table 3-2 Drawing Toolbar

Button Name Function Pa ge

Draw Wire enables drawing of wires 
on the schematic

4-28

Draw Bus enables the drawing of 
buses on the schematic

4-31

Draw Block enables the placing of 
blocks on the schematic

7-4

Get New Part displays Part Browser 
dialog box for selecting 
parts for placement

4-6

Get Recent Part drop-down list box to 
select and place a recent 
part without having to 
open the part browser

4-9

Edit Attributes edits the attributes of 
selected objects

4-17

Edit Symbol opens the symbol editor for 
the selected symbol

5-5
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Simulation

The Simulation toolbar provides shortcuts for setting up 
analyses, running a simulation, and viewing results. 

Refer to the Viewing Results on the Schematic chapter of your 
PSpice user’s guide for further information on simulation in 
Schematics.

Table 3-3 Simulation Toolbar

Button Name Function Pa ge

Analysis Setup sets up simulation analyses 
for the active schematic

8-8

Simulation starts a simulation of the 
current schematic

8-8

Marker Color drop-down list box to 
change marker colors on 
an instance basis

*

Voltage/Level 
Marker

enables placing of voltage/
level markers on the 
schematic

*

Current Marker enables placing of current 
markers on the schematic

*

Enable Bias 
Voltage Display

toggles the display of bias 
voltage

*

Show/Hide 
Voltage on 
Selected Net(s)

toggles the display of 
voltages for selected wires

*

Enable Bias 
Current Display

toggles the display of bias 
current

*

Show/Hide 
Currents on 
Selected Part(s)

toggles the display of 
currents for selected 
device pins

*
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*. Refer to the Viewing Results on the Schematic chapter in your PSpice 
user’s guide for information about how to use these toolbar buttons.
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Annotation Graphics

The Annotation Graphics toolbar provides shortcuts for drawi
or inserting non-electrical information onto your schematic. 

Table 3-4 Annotation Graphics Toolbar

Button Name Function Pa ge

Draw Arc draws an arc shape on the 
page

6-10

Draw Box draws a box on the page 6-11

Draw Circle draws a circle on the page 6-11

Draw Polyline draws a polyline on the 
page

6-11

Draw Text places of a single line of 
text on the page

4-53,
6-12

Draw Text 
Box

places multiple lines of text 
on the schematic

4-50

Insert Picture places a bitmap (.bmp, 
.dib) or Windows metafile 
(.wmf) on the page

4-57
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Status Bar
The status bar is located at the bottom of the schematic edit
window and provides the following:

• X and Y coordinates of the pointer. 

Use the Display Options selection under the Options me
to toggle display of X and Y coordinates.

• A message area that provides:

• a brief description of the function that will be performe
if you click the toolbar button at the present pointer 
location.

• a brief description of the function to be performed.

The description will display by selecting the menu ite
at the present pointer location.

• prompts and warning messages that only appear whe
is necessary for you to take a specific action. 

If anything must be done by the user or if there is a 
warning, the prompt will display in the status bar.

• the name of the function to be performed when you use 
Repeat command (the name of the function will display 
when you use the Repeat function).

Use the Status Bar selection from the View menu to enable 
disable the status bar.

Refreshin g the Screen
To refresh the screen, click the Redraw button on the toolba
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Function keys 4 through 9 
are toggle keys. Pressing the key 
enables the feature, and 
pressing S plus the key 
disables the feature.
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Keyboard
Table 3-5 lists the function keys in the schematic editor that 
permit you to enable or disable specific commands. 

Table 3-5 Schematic Editor Function Keys

Key Action Menu Selection

1 Online Help Help Help

2 Move to lower level in the 
schematic hierarchy

Navigate Push

3 Move up one level
in the schematic hierarchy

Navigate Pop

4 Text stay-on-grid Options Display 
Options

5 Orthogonal Options Display 
Options

6 Stay-on-grid Options Display 
Options

7 Auto-increment Options Auto-
Naming

8 Auto-repeat Options Auto-
Repeat

9 Rubberbanding Options Display 
Options

0 View errors, warnings, 
and messages

File View 
Messages

! Start the simulator Analysis Simulate

@ Start MicroSim Probe Analysis Run Probe



Configuring Schematics 3-15

u 
ns 

r 

cing, 

itor

 

cts

ox 

s 
 

Scug.bk : 03USESCD.FMK  Page 15  Monday, June 16, 1997  10:10 AM
Confi gurin g Schematics
The following list summarizes the different types of options yo
can configure in Schematics. Customizing configurable optio
allows you to use Schematics in the way that best suits you
needs and requirements. 

Librar y settin gs

• changes the set of configured symbol libraries 

Page settin gs

• sets the page size for your schematic

• specifies other page settings such as paper size, pin spa
and borders

Displa y options and preferences

• changes the grid and gravity settings of the schematic ed

• sets the time interval between automatic saves of your 
schematics

• changes the font used for displaying and printing text on
your schematics

• determines which elements of a schematic are to be 
displayed and printed

• changes the colors used for drawing and displaying obje

Application settin gs

• specifies the number of items in the Get Recent Part list b
on the toolbar

• changes where to find the .exe files for MicroSim program
that interface with Schematics and which initialization file
to use other than the installed default initialization file 
(msim.ini)

• specifies the use of a different text editor
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A library name must be in the 
library search list to be available 
for placing its symbols.
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Confi gurin g Symbol Libraries
There are two major elements that work together in Schema
that let you place symbols into your design:

• symbol libraries

• library search list

Symbol libraries are located in library directories. The library
search list is in the Part Browser and the Editor Configuratio
dialog box under the Options menu.

It is important to remember that libraries and the search list h
two distinct functions. You can create a symbol library, but if t
library name is not in the library search list, it is not available to 
the design for placing symbols. Conversely, you can 
inadvertently create an error condition by having a library nam
in the search list, for a library that doesn’t exist.

Configuring a symbol library is adding a library name to the 
library search list.

Note When adding a symbol library to the library search 
list, placement in the list is important. If more than 
one library contains the same symbol name, 
Schematics uses only the first one it encounters.

You must ensure the library actually exists in the location 
specified during the configuration procedure.
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Note To maintain the 
integrity of your default 
symbols, we recommend 
making a copy of the default 
symbol libraries. If you use 
the symbol editor to make 
changes to a default symbol, 
it will overwrite the default 
symbol if you save using the 
default file name. Also, if you 
import symbol files into the 
default library and an 
imported file has the same 
name as the default file, the 
imported file will overwrite the 
default file.
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Types of Libraries

Schematics recognizes two types of libraries:

Default Librar y Director y

Schematics includes a default library directory where all the
symbol libraries (.slb ) you selected during installation reside. I
is not required to configure these libraries. They are already
configured in the search list as global libraries.

However, if you prefer, you can:

• change the order in which libraries appear in the search 
thereby changing the order in which they are searched

• remove library names from the search list (without deletin
the libraries)

• add new libraries

• delete libraries

• reconfigure libraries from global to local

This library... Is available...

global to all schematic designs. They are listed
the msim.ini  file and are automatically 
loaded into the library search list for ever
design.

Global libraries appear in the library sear
list with an asterisk (*) preceding the libra
name.

local to designs within which they are saved.

Schematics always places local library 
names at the top of the library search list
Local libraries are always searched first.
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User-Defined S ymbol Libraries

You can create global and local symbol libraries, and add th
to the default directory or to another directory of your choice
Once created, you can perform all the same actions as liste
Default Library Directory on page 3-17.

Note When adding a symbol library to the library search 
list, placement in the list is important. If more than 
one library contains the same symbol name, 
Schematics uses only the first one it encounters.

If you add local library names to the library search list, 
Schematics places them before global library names, becau
they are searched first. You can control their placement withi
group of local library names, but you cannot integrate them into 
the global names.

Addin g a librar y

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box.

2 Click Library Settings to display the Library Settings dialo
box.
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3 In the list of libraries, select the location for the new librar

A new global library will be added directly above the library 
you select. A new local library will be placed above the fir
global library name in the list.

4 If the library you are adding is a symbol library, select th
Symbol check box. If the library you are adding has an 
associated package library, select the Package check b

5 In the Library Name text box, type the name of the librar

Do not type a file name extension if the library you are usi
is listed in the dialog box; the file name extension is 
appended automatically. 

6 Click Add* for a global library, or click Add Local for a 
local library.

If you are adding a global library, Schematics writes the 
library name to the msim.ini  file so it is available to all 
schematic designs.

7 Click OK to exit the Library Settings dialog box.

8 In the Editor Configuration dialog box, click OK.
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When removing a library name, it 
is only removed from the 
configured libraries list. The 
library is not deleted.

Options Menu
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Removin g Librar y Names

If you no longer need a library name in the list of configured
libraries, you can remove it from the list of configured librarie

Removin g a librar y name

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box (shown on 
3-18).

2 Click Library Settings to display the Library Settings dialo
box (shown on 3-19).

3 In the list of libraries, select the library name that you wa
to remove.

The selected library name is displayed in the Library Nam
text box.

4 Click Delete.

5 Click OK to exit the Library Settings dialog box.

6 In the Editor Configuration dialog box, click OK.

Correctin g Librar y Names

If you type a library name incorrectly, you can change the na
as it appears in the list of configured libraries.

Correctin g a librar y name

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box (shown on 
3-18).

2 Click Library Settings to display the Library Settings dialo
box (shown on 3-19).

3 In the list of libraries, select the library that you want to 
change.

The name of the selected library displays in the Library 
Name text box.

4 In the Library Name text box, type a new name for the 
library.
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Do not type a file name extension; the file name extensio
is appended automatically.

5 Click Change.

6 Click OK to exit the Library Setting dialog box.

7 In the Editor Configuration dialog box, click OK.

Changing the Search Order

The way that Schematics searches libraries for a symbol follo
the order in which the libraries are configured in the list. You
can change the position of a library in the list.

Changing the position of the librar y in the list

1 From the Options menu, click Editor Configuration to 
display the Editor Configuration dialog box (shown on 
3-18).

2 Click Library Settings to display the Library Settings dialo
box (shown on 3-19).

3 In the list of libraries, select the library name that you wa
to move.

The name of the selected library displays in the Library 
Name text box.

4 Click Delete.

5 In the list of libraries, select the name above which the 
repositioned name will be inserted.

6 In the Library Name text box, type the name of the librar
you want to reposition.

Do not type a file name extension; the file name extensio
is appended automatically.

7 If the library is a symbol library, select the Symbol check
box. If the library has an associated package library, sel
the Package check box.

8 Click Add* for a global library or click Add Local for a local
library.



3-22 Using the Schematic Editor

ted 

ied 

y 

Note Local libraries are first 
looked for in the directory 
where the schematic resides.

Scug.bk : 03USESCD.FMK  Page 22  Monday, June 16, 1997  10:10 AM
The repositioned library name is inserted above the selec
name.

9 Click OK to exit the Library Setting dialog box.

10 In the Editor Configuration dialog box, click OK.

Changing the Search Path

Schematics looks for a library according to the path(s) specif
by the Library Path in the Editor Configuration dialog box.

Changing the librar y search path

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box.

2 Type a new path or add to the existing path in the Librar
Path text box.

Specify multiple directories by separating them with a 
semicolon:

c:\msim\lib
c:\msim\lib;c:\project\lib

3 Click OK.
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Changing Page Size
Schematics supports standard page sizes A through E and 
through A4. It also allows you to specify a user defined page
size.

Changing the pa ge size

1 From the Options menu, click Page Size to display the Pa
Size dialog box.

2 Click the appropriate button to select a pre-defined page
size, or indicate a User Defined Size by typing the page
dimensions in the Horiz: and Vert: text boxes.

3 Click OK to change the page size of the currently active 
page and to establish the default page size for all later pa
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Note If you are using zoned 
borders, make sure the 
Display check box for the 
Page Boundary layer in the 
Display Preferences dialog 
box is enabled (see 
Controlling the Display in 
Schematics on page 3-34).

Note Drawing areas for the 
zoned and outline border 
types are the same size, as 
shown in Figure 3-1.
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Changing Page Settin gs
For all page sizes, you can change the border style, the draw
area, and the pin-to-pin spacing.

Border St yle

Schematics provides two border styles: zoned and outline. 
Figure 3-1 illustrates the two styles.

Figure 3-1 Border Styles

You can configure a zoned border for all decimal and metric
page sizes, including custom sizes (see Changing the border 
style on page 3-26.)

The following table lists the default decimal page sizes and th
configurations.

zoned 

outline 

Drawing
area

Margin

Zone
designator

Drawing
area
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The following table lists the default metric page sizes and th
configurations.

Note If your design doesn’t require a zoned border, 
Outline Border will display the page with fewer 
details.

*. in inches

*. in millimeters

Table 3-6 Zoned Border Default Decimal Parameters

Type Dimension * Vertical Horizontal

Zones Mar gin Zones Mar gin

A 8.5 x 11 2 .25 2 .38

B 11 x 17 2 .62 4 .38

C 17 x 22 4 .5 4 .75

D 22 x 34 4 1.0 8 .5

E 34 x 44 8 .5 8 1.0

Table 3-7 Zoned Border Default Metric Parameters

Type Dimension * Vertical Horizontal

Zones Mar gin Zones Mar gin

A4 210 x 297 2 6.35 2 9.65

A3 297 x 420 2 15.75 4 9.65

A2 420 x 594 4 12.7 4 19.5

A1 594 x 841 4 25.4 8 12.7

A0 841 x 1189 8 12.7 8 25.4
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Changing the border st yle

You can specify which border style to use through the Edito
Configuration dialog box. The current drawing and all 
subsequent new drawings use the style you select.

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box.

2 Click Page Settings to display the Page Settings dialog b

3 Select the page size for which you want to set the borde
style.

You can select either style for each page size.
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To round the corners on the 
outside border line, select the 
Rounded Corners check box.
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4 Select the Outline or Zoned border style.

Note Line widths for the page boundary are specified in 
the Display Preferences dialog box. See Setting the 
default graphics properties through Display Preferenc
on page 4-56 for more information.

For style... Do this...

Outline 1 In the Borders frame, click the Outline 
button.

2 Click OK to accept the Outline border 
and exit the Page Settings dialog box.

Zoned 1 In the Borders frame, click the Zoned 
button.

2 Type the number of zones for each 
axis.

3 Type the margin sizes for each axis.

4 Select letters or numbers for zone 
designators in each plane.

5 Select Ascending or Descending (in 
reference to the upper-left corner of the 
page), in each plane.

6 Click OK to accept the Zoned border 
and exit the Page Settings dialog box.
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Figure 3-1 on page 3-24).
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Drawin g Area

Changing the drawin g area size

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box (shown on 
3-26).

2 Click Page Settings to display the Page Settings dialog b

3 In the Width and Height text boxes, type the drawing are
dimensions for the page size.

4 Click OK to exit the Page Settings dialog box.

5 In the Editor Configuration dialog box, click OK.
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Pin-to-Pin Spacin g

You can scale symbols so they will appear larger or smaller
the schematic. You do this by changing the pin-to-pin spacin
for a given page size.

Changing the pin-to-pin spacin g

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box (shown on 
3-26).

2 Click Page Settings to display the Page Settings dialog b
(shown on 3-28).

3 In the Pin-to-Pin Spacing text box, type a new value.

4 Click OK.

Changing Grid and Gravit y
The grid and gravity functions of Schematics ease your draw
tasks and can help make your schematic more precise.

Grid On

When Grid On is enabled, the grid is displayed in the drawin
area of the schematic editor window.

Enablin g or disablin g the grid displa y

1 From the Options menu, select Display Options.

2 Select or clear the Grid On check box to enable or disab
the grid display.

3 Click OK.
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command must be enabled 
for the Snap-to-Grid 
command to be effective.

Scug.bk : 03USESCD.FMK  Page 30  Monday, June 16, 1997  10:10 AM
Stay-on-Grid

Stay-on-grid controls the method of object placement. When
Stay-on-Grid is enabled, the objects are forced onto grid wh
placed. We recommend that you enable this so that electric
connections are made correctly.

Enablin g or disablin g stay-on-grid

1 From the Options menu, select Display Options.

2 Select or clear the Stay-on-Grid check box to enable or 
disable Stay-on-Grid.

3 Click OK.

Snap-to-Grid

Snap-to-grid controls the movement of the object while bein
moved for placement when Stay-on-Grid is enabled. If Snap
Grid and Stay-on-Grid are both enabled, movement during 
object placement is in increments equal to the current grid 
spacing. If Snap-to-Grid is not selected, the object moves 
smoothly.

Enablin g or disablin g snap-to- grid

1 From the Options menu, select Display Options.

2 Select or clear the Snap-to-Grid check box to enable or 
disable snap-to-grid.

3 Click OK.
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Snap-to-Pin

Snap-to-pin, when enabled, causes the endpoint of a wire or
segment to snap to the nearest pin if one is found inside the
radius defined by the Gravity setting.

Enablin g or disablin g snap-to-pin

1 From the Options menu, select Display Options.

2 Select or clear the Snap-to-Pin check box to enable or 
disable snap-to-pin.

3 Click OK.

Grid Spacin g

Grid Spacing defines the horizontal and vertical grid spacing
your drawing area. The default spacing is 10 units. This 
corresponds to (and displays as) 0.10 inches for US-standa
page sizes, and 2.5 millimeters for metric page sizes. The 
minimum grid spacing allowed is 0.01 inch, or .25 millimeter

Specif ying grid spacin g

1 From the Options menu, select Display Options.

2 In the Grid Spacing frame, type the grid spacing value.

3 Click OK.

Gravit y

The gravity setting specifies how close an object must be to a
to snap to it. Gravity is only functional when snap-to-pin is 
enabled.

Specif ying gravit y

1 From the Options menu, select Display Options.

2 In the Snap-to-Pin frame, type the snap-to-pin gravity val

3 Click OK.
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Text Grid

Text Grid allows you to set the grid spacing for text separate
from the drawing grid spacing. The text grid is usually set to
some smaller percentage of the drawing grid. This allows you
align text between drawing grid points.

Enablin g text grid and specif ying text grid size

1 From the Options menu, select Display Options.

2 In the Text Grid frame, select the Stay-on-Grid check box
enable the text grid.

3 In the Grid Size text box, type the text grid spacing value

4 Click OK.

Settin g the Autosave Interval
The autosave interval specifies the time interval, in minutes,
which Schematics automatically saves any modified schema
or libraries.

Settin g the Autosave interval

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box.

2 In the Autosave interval box, type the number of minutes f
the autosave interval.

3 Click OK.
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When Autosave is enabled, Schematics creates a temporary
with the same name as the active working file, and a file nam
extension ending in ‘v ’ (for example, “.scv,” “.slv,” “.plv”). If 
you have a power outage or system failure, you can retrieve y
work from these files.

The temporary files are deleted each time a schematic or libr
is successfully closed or saved.   When you open a file, 
Schematics compares the saved file to the autosave file, if on
present. If the autosave file is more recent than the requeste
file, Schematics provides a warning and allows you to restor
the file as the active schematic or library.   

While an autosave is in progress, a message appears in the s
line and the hourglass symbol displays in place of the pointe
Wait until the autosave is finished before continuing.

Disablin g Autosave

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box (shown on 
3-22).

2 In the Autosave interval text box, type 0 (zero).

3 Click OK.
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Controllin g the Displa y 
in Schematics
Schematics allows you to define what elements of a design 
want to display and print. This means you can set different 
display properties for each element of your schematic. In the
Display Preferences dialog box, the default colors, styles, fon
and sizes of each display layer are established. 

You can either display or not display (and print or not print) t
following: 

Annotation Graphics Attribute Text Buses

Hidden Pins Junctions Labels

Markers and 
Viewpoints

Page Boundary Part Names

Pin Names Pin Numbers Ports

Reference Designators Simulation Currents Simulation 
Voltages

Stimulus Symbol Text Symbols

Text Text Box Title and Border

User-specified text Wires
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To select more than one layer 
consecutively:

1 Hold down S.

2 Click the first desired layer in 
the list and the last.

Every layer in between will be 
selected.

To select more than one layer 
non-consecutively:

1 Hold down C.

2 Click each desired layer.
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Displa ying or printin g default properties

1 From the Options menu, select Display Preferences to 
display the Display Preferences dialog box.

2 From the Display Layers list, select the appropriate displ
layer (or layers).

3 Click the General tab.

4 Select or clear the Display check box to enable or disab
display of the selected layers.

5 Select or clear the Print check box to enable or disable 
printing of the selected layers.

6 Click Apply to apply the changes and keep the dialog bo
displayed for further changes, or click OK to apply the 
changes and close the dialog box.
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Changing Fonts
To change the default fonts Schematics uses to display and p
text, use the Display Preferences dialog box.

Selectin g a font

1 From the Options menu, select Display Preferences to 
display the Display Preferences dialog box.

2 Select one or more layers from the Display Layers list.

3 Click the Text tab.

4 Click Browse to display the Font dialog box.
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5 Select a font and size from their corresponding list boxe
and click OK. 

A sample of the selected font is shown in the Sample bo

6 Enter a size in either inches or millimeters, or accept the
system default for the selected font.

7 Select a color from the Color list box.

8 Click Apply to apply the changes and keep the dialog bo
displayed for further changes, or click OK to apply the 
changes and close the dialog box.

Confi gurin g Colors
The colors for all layers in Schematics are configured in the
Display Preferences dialog box. The colors you specify beco
the defaults, however, they may be changed as often as 
necessary.

Confi gurin g Colors in your Schematic

1 From the Options menu, select Display Preferences to 
display the Display Preferences dialog box (shown on pa
3-36).

2 Select one or more layers from the Display Layers list.

3 Click the tab that applies to the layers you have selected

For example, if you want to change a text color, select th
layer, click the Text tab, and select the appropriate displ
settings.

4 Select a color from the Color drop-down list.

5 Click Apply to apply the changes and keep the dialog bo
open for further changes, or click OK to apply the chang
and close the dialog box.
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Changing Application Settin gs
You have the option to change the location of the .exe files 
the MicroSim programs that Schematics interfaces with. You
can also configure a different text editor (besides MicroSim’
Textedit) and specify an initialization file other than the 
installed default initialization file.

Changing where to find MicroSim pro grams

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box.

2 Click App Settings to display the App Settings dialog bo
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Note The Simulate 
Command frame will show 
either PSpice or PSpiceAD, 
depending on the package 
that you have purchased. If 
you are using a network 
licensed version that has both 
PSpice and PSpice A/D 
available, you can choose 
which simulator you want to 
use.

To change the configuration file 
for Schematics:

1 In the Windows Program 
Manager, select the 
Schematics icon.

2 Select Properties from the 
File menu.

3 Append -i<configuration file 
name> to the Command Line.

4 Click OK.
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The Simulate Command frame shows the path that 
Schematics uses to run PSpice A/D.

3 To change the path name, type a new path name in the 
Command text box.

4 Similarly, to change any of the other command lines, clic
to select the command in the Other Commands list box a
type a new path name in the Command text box.

5 Click OK to exit the App Settings dialog box.

6 In the Editor Configuration dialog box, click OK.

Changing the confi guration file

A configuration file other than the default msim.ini  file can 
be used for any of the MicroSim programs that Schematics 
interfaces with.

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box (shown on 
3-39).

2 Click App Settings to display the App Settings dialog box
(shown on 3-39).

3 In the Configuration File frame, select Other.
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4 Type the file name of the configuration file in the text box

5 Click OK to exit the App Setting dialog box.

6 In the Editor Configuration dialog box, click OK.

Specif ying a different text editor

Editing text in Schematics is done through MicroSim’s Texted
program. You have the option to specify a different text edito

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box (shown on 
3-39).

2 Click App Settings to display the App Settings dialog bo
(shown on 3-39).

3 In the Other Commands box, select Text Editor.

4 Type a new path name in the Command text box to spec
the path and name of the text editor you want to use.

5 Click OK to exit the App Settings dialog box.

6 In the Editor Configuration dialog box, click OK.
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Changing the Get Recent Part 
List Size
The Get Recent Part list box on the toolbar contains a scroll
down list of recently placed parts. The default length of this l
is ten items.

To change the length of the list, use a text editor to edit the 
MRPLISTSIZE item in the [SCHEMATICS] section of the 
msim.ini  file.

MRPLISTSIZE=<length of list>
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Zoomin g and Pannin g in 
Schematics

Zoomin g
When working on a design, you can zoom in (enlarge the vie
or zoom out (reduce the view) to view a larger or smaller porti
of the schematic window. Zooming in reduces the area view
and enlarges the objects viewed. Zooming out increases the 
viewed and reduces the size of the objects viewed.

Zoomin g in

1 From the View menu, select In.

2 Move the pointer to the desired center of the zoom actio
and click.

Zoomin g in about the center of the window

1 Click the Zoom In button.

The amount of magnification is determined by the Zoom
Scale Factor (see Setting Zoom Parameters on page 3-43).

Zoomin g in on a selected area of the pa ge

1 Click the Zoom Area button, or select Area from the View
menu.

2 Drag a selection rectangle to select the desired display a

Zoomin g out

1 From the View menu, select Out.

2 Move the pointer to the desired center of the zoom actio
and click.

Zoomin g out about the center of the window

1 Click the Zoom Out button.
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The amount of reduction is determined by the Zoom Sca
Factor (see Setting Zoom Parameters on page 3-43).

Zoomin g out to view the full schematic pa ge

1 From the View menu, select Entire Page.

Settin g Zoom Parameters

Settin g scale factor and fit

The Zoom parameters tailor how the work space will be 
magnified or reduced when you make selections from the Vi
menu, or click any of the zoom buttons.

1 From the Options menu, select Pan & Zoom to display t
Pan & Zoom dialog box.

2 In the Scale Factor text box, type a value.

This value defines the factor by which the screen is 
magnified or reduced when you select Zoom In or Zoom
Out. A Scale Factor of 2 will double (or halve) the size o
objects viewed.

3 In the Fit text box, type a value.

This value defines the percentage of the work space to b
filled with the complete schematic when you select View
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Fit. Type a decimal value between 50 and 100. A typical
value is 90.

4 Click OK.

Fittin g to a Page
All of the parts, wires and text within the active window 
(excluding the title block) are displayed by fitting the view to th
page.

Fittin g the view to the pa ge

1 Click the Zoom to Fit Page button, or select Fit from the 
View menu.

Pannin g
Panning allows you to select a new window centering point. T
current zoom scale remains the same. When you select the 
center point, the schematic is panned until the selected poin
in the center of the window.

Pannin g to a new center

1 From the View menu, select Pan—New Center.

2 Move the pointer to the desired window center and click
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Options Menu

When panning, click the right 
mouse button to pan 
immediately, rather than waiting 
for the pan time to elapse.

Scug.bk : 03USESCD.FMK  Page 45  Monday, June 16, 1997  10:10 AM
Automatic Pannin g

If Auto Pan is enabled, the pointer turns to a solid black arro
when you move it to the edge of the window. If you leave th
arrow at the edge of the window for a few moments, the view
pans in the direction of the arrow. You can pan up, down, le
and right using this method.

Enablin g Automatic Pannin g

1 From the Options menu, select Pan & Zoom to display t
Pan & Zoom dialog box.

2 In the Auto Pan frame, select the Enable check box.

3 Click OK.

Settin g hot zone size

The Hot Zone Size determines the width of the zone where 
pointer has to rest to trigger the Auto Pan function.

1 From the Options menu, click Pan & Zoom to display the
Pan & Zoom dialog box.

2 In the Hot Zone Size text box, type a value.

Values must be in the range from 1 to 10. If the value is 
to 1 (default value), the hot zone is 1% of the dimensions
the screen.

3 Click OK.
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Settin g Auto Pan sensitivit y

The Auto Pan sensitivity setting determines how long the 
pointer must remain on the window border before the pannin
takes place.

1 From the Options menu, click Pan & Zoom to display the
Pan & Zoom dialog box (shown on page 3-45).

2 In the Auto Pan frame, type a value in the Sensitivity tex
box.

The value in the text box is the time delay in millisecond
The default is 1000 milliseconds.

3 Click OK.

Settin g Pan Coarse Delta and Fine Delta

The Pan parameters determine the degree of movement of 
work space when you use the scroll bars.

1 From the Options menu, click Pan & Zoom to display the
Pan & Zoom dialog box (shown on page 3-45).

2 In the Coarse Delta text box, type a value.

The value in the text box is the degree of movement of t
design when you click in a scroll bar on either side of the
slider. The value must be between 1 and 50 and represen
percentage of the visible work space.

3 In the Fine Delta text box, type a value.

Fine Delta defines the percentage of movement of the 
design when you pan by clicking on one of the scroll bar
arrows. The value must be between 1 and 5 and represe
percentage of the visible work space.

4 Click OK.
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The Message Viewer uses all 
standard Windows controls for 
scrolling, sizing, and selecting.
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Usin g the Messa ge 
Viewer
The Message Viewer displays text describing a condition, sta
or other information concerning the operation of MicroSim 
programs.

The Message Viewer appears when any condition generate
message that requires you to be informed. For example, 
warnings and error messages that occur during netlisting wi
appear in the Message Viewer.

If you have more than one design open and close one of the o
designs, the messages pertaining to the design you close n
longer display. When you close the last design, the Messag
Viewer closes. Also, the message viewer closes when all 
MicroSim programs are closed or when you explicitly close 
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Another way to view online Help 
is:

1 Right-click in the message 
area to display a menu.

2 Click Help On to view a 
context-sensitive Help 
message.

Another way to locate the 
message source:

1 Right-click the message line 
to display a menu.

2 Click Find In Design.
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Online Help
The Message Viewer has an online Help feature that allows 
to view a help message directly relating to the currently selec
message.

To view a context-sensitive Help message:

1 In the message viewer window, select the message.

2 Press 1.

Locatin g the Source of a 
Message
Many messages displayed in the Message Viewer contain a
hypertext link that points to the source of the message. This
allows you to go to the location in the design that caused th
message to be generated.

To locate the source of a message, double-click the messag
the Message Viewer window.

Indicated Severit y
Each message is preceded by a  marker. The color of the 
marker indicates the severity of the message.

Color Indication

Blue Informational message. No user action is required.

Yellow Warning message. May require some user action.

Red Error message. Must be corrected before continuin

Black Fatal error message. Indicates a non-recoverable 
error condition.
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Another way to view additional 
information:

1 Right-click the message line 
to display a menu.

2 Click Additional Info to 
display the Additional Info 
dialog box.

File Menu
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Additional Information
Some messages contain additional text. That is, the messag
contains several lines of information while only one line 
displays. Lines containing additional information are indicate
by a plus sign in the severity marker preceding the message 

When the Message Viewer contains any messages with 
additional information, the More Info button on the tool bar is
active. 

1 Click either the plus sign in the line of text or the More Inf
button to display the Additional Info dialog box.

2 Click OK to dismiss the dialog box.

Closin g the Messa ge Viewer
To close the Message Viewer, do one of the following:

• From the File menu, select Exit.

• In the upper right corner of the window, click the Close 
button.
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Overview
This chapter contains the step-by-step procedures for creati
editing, and printing a schematic, which includes:

Starting the Schematic Editor on page 4-3 describes how to start
the schematic editor and how to open a new or existing file.

Finding Parts on page 4-4 describes how to find parts by name
or description, and by searching the symbol libraries.

Placing and Editing Parts on page 4-9 describes the detailed 
steps for placing parts, changing the orientation of parts prio
placing them, editing part attributes, placing multiple instanc
of a part, and automatically assigning reference designators

Placing Power and Ground Symbols on page 4-26 describes 
how to place and edit power and ground symbols.

Using Wires and Buses on page 4-28 describes drawing and 
labeling wires and buses, in addition to describing the drawi
options that affect the placement of wires and buses.
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Using Ports on page 4-38 describes the use of off-page and 
global ports.

Selecting and Moving Objects and Attributes on page 4-40 
describes how to select and move parts, wires, and attribute

Creating and Editing Title Blocks on page 4-46 describes how 
to create and edit the title block on your schematic.

Adding Non-Electrical Information on page 4-50 describes how 
to create and edit annotation items (non-electrical informatio

Creating and Editing Multi-sheet Designs on page 4-60 
describes how to create and edit multi-sheet designs.

Printing Your Design on page 4-64 describes how to print your 
design.

Closing the Schematic Editor on page 4-70 describes how to 
save a schematic and how to close the schematic editor.



Starting the Schematic Editor 4-3

tics 
ge 

tic 

, 

Scug.bk : 04DESGNS.FMK  Page 3  Monday, June 16, 1997  10:10 AM
Startin g the Schematic 
Editor
Start the schematic editor by double-clicking on the Schema
icon in the MicroSim program group. An empty schematic pa
appears.

If you already have Schematics running with another schema
open, click the New File button to start a new schematic.

Openin g a File
To open a new file, click the New File button. An empty 
schematic page appears.

To open an existing file and display the schematic for editing
click the Open File button. Previously opened schematics 
remain open until closed.

To close files or to close the schematic editor, see Closing the 
Schematic Editor on page 4-70.
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Simulation Checklist

When you are drawing a design 
for simulation, keep the following 
in mind:

• The symbols that you place 
must have corresponding 
simulation models associated 
with them.

• The design will need sources 
of stimulus.

• For any part that has an 
associated simulation model, 
unmodeled pins are indicated 
by a broken pin.
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Findin g Parts
Parts represent electrical devices such as resistors, operatio
amplifiers, diodes, voltage sources, and digital gates that 
comprise the circuit diagram.

The graphical representation of a part is a symbol stored in a 
symbol library.

For those parts with a simulation model available, the model 
definition is stored in a model library.

For parts applicable to PCB layout, the package definition is 
stored in the package library.

You can use symbols supplied with Schematics, or you can
create your own symbols and store them in user-defined sym
libraries. You can select a symbol from a library by name or 
browsing the list of available parts.

The available parts are only those contained in configured 
libraries. If you have a library of parts and they are not availab
you need to add the library to the list of configured libraries.
Refer to Configuring Symbol Libraries on page 3-16.
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Gettin g Parts b y Name
The Get Recent Part list box on the toolbar provides a list of 
most recently used parts. You can also type a name in the G
Recent Part list box to select a part.

Selectin g a part b y name

1 In the Get Recent Part list box, type the name of the part y
want to place.

2 Press R.

3 Move the outline of the selected symbol to any location o
the schematic and click to place the part.

4 Right-click to stop placing parts.

Placin g a previousl y selected part

After you select a part for placement, the part name is listed
the Get Recent Part list on the toolbar and can easily be reca

1 Click the Get Recent Part list arrow.

A scrollable list appears containing the names of the last 
parts that have been placed.

2 Click the name of the part you want to place.

3 Move the outline of the selected symbol to any location o
the schematic and click to place the part.

4 Right-click to stop placing parts.
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Note One of two Part Browser 
dialog boxes may appear: the Part 
Browser Advanced or the Part 
Browser Basic. If the Part Browser 
Basic dialog box appears, click 
Advanced to display the Part 
Browser Advanced dialog box. If 
the Part Browser Advanced dialog 
box appears, click Basic to display 
the Part Browser Basic dialog box. 
The steps to find a part by name 
are the same in either dialog box.

When typing a part name or a 
description, you can use the “*” and 
“?” wildcard characters.

An “*” is a wildcard that matches zero 
or more characters. For example, 
74LS1* matches 74LS10, 74LS107A, 
and 74LS197.

A “?” is a wildcard that matches any 
single character. For example, 
74LS1? matches 74LS10 but not 
74LS107A.
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Searchin g for Parts in the 
Libraries
Symbol libraries contain symbols for many parts. There are 
three methods for selecting parts from libraries:

• Search for the part by name.

• Search for the part by description.

• Browse through the symbol libraries.

Each of these methods are described below.

Selectin g a part b y name

1 From the Draw menu, select Get New Part to display one
the Part Browser dialog boxes.

2 Type the name of the part in the Part Name text box, or 
select the part name from the list of available parts at the 
side of the dialog box.

3 Click Place to place the part (with the browser remaining
open) or click Place & Close (to place the part and close 
browser).
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 When typing a description, you 
can use the “*” and “?” wildcard 
characters.
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4 Move the outline of the selected symbol to any location o
the schematic and click to place the part.

5 Right-click to stop placing parts.

Selectin g a part b y description

1 Click the Get New Part button to display the Part Browse
dialog box (see 4-6).

Note You may display one of two Part Browser dialog 
boxes: the Part Browser Advanced or the Part 
Browser Basic. If the Part Browser Basic dialog 
box appears, click Advanced to display the Part 
Browser Advanced dialog box. You can only use 
the Part Browser Advanced dialog box to search 
for a part by description.

2 In the Description Search text box, type a description of t
part.

3 Click the arrow and select one of the options in the list:

• Create New Part List—creates a new (sub)list of parts
the parts list.

• Add to Part List—adds to the set of parts.

• Search within Part List—restricts the search to the 
(partial) list of parts.

4 Click Search.

The number of items found in the search is shown bene
the parts list.

The search function searches all configured symbol librar
for parts whose descriptions match the description enter
When the search is complete, all parts with matching 
descriptions are shown in the partial list at the left of the
dialog box.

5 Select the part from the parts list.

Preview a part symbol by clicking the part name in the pa
list. 
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symbol libraries supplied with 
Schematics and device types.
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6 Click Place to place the part (with the browser remaining
open), or click Place & Close (to place the part and close 
browser).

7 Move the outline of the selected symbol to any location o
the schematic and click to place the part.

8 Right-click to stop placing parts.

Browsin g symbol libraries to select a part

1 Click the Get New Part button to display the Part Browse
dialog box (see 4-6).

Note One of two Part Browser dialog boxes may appear: 
the Part Browser Advanced and the Part Browser 
Basic. If the Part Browser Basic dialog box 
appears, click Advanced to display the Part 
Browser Advanced dialog box. If the Part Browser 
Advanced dialog box appears, click Basic to 
display the Part Browser Basic dialog box. The 
steps in finding a part by browsing symbol libraries 
are the same with either dialog box.

2 Click Libraries to display the Library Browser dialog box
(see 3-19).

Use the Library Browser dialog box to select a library an
view a list of parts contained in each library. 

When you select a part, the part name appears in the Pa
Name text box in the Part Browser dialog box and the pa
is selected for placing.

3 Click OK.

4 Click Place to place the part (with the browser remaining
open) or click Place & Close (to place the part and close 
browser).

5 Move the outline of the selected symbol to any location o
the schematic and click to place the part.

6 Right-click to stop placing parts.
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If you type C in the Part Name 
text box to select a capacitor, 
you will see an outline of the 
capacitor symbol attached to the 
pointer (as shown below).

See also Repeating Part 
Placements on page 4-19 and 
Global Editing of Attributes on 
page 4-17.
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Placin g and Editin g 
Parts
After you have selected a part, you can place one or more 
instances of the part on the schematic. When the part is selec
an outline of the selected part appears attached to the point

Placin g a symbol on the schematic

1 Click the Get New Part button to select the part from a 
symbol library.

2 Move the symbol outline to the location you want to plac
the symbol and click.

Place as many instances of the symbol as you want by 
moving to another location and clicking again. Each time
you point and click, another instance of the part is placed
the page.

Stoppin g placement

To stop placing a symbol, do one of the following:

• Double-click to place the last instance of the symbol. 

• Right-click to stop placing the symbol without placing an
additional symbol.

The outline changes back to a pointer. 
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Rotatin g and Flippin g Parts
In Schematics, you can rotate and flip (mirror) parts or entire
areas of a schematic. A rotated part is rotated 90° counter-
clockwise. A flipped part is mirrored about the Y axis.

Rotating and flipping can occur during one of the following:

• while dragging (before placement)

• after placement

Rotatin g Parts

Rotatin g a part before placin g it

1 Select a part to be placed.

2 Press C+R to rotate it while still in the drag mode.

The image rotates 90° counter-clockwise. Each time you
press C+R, the image will rotate 90° counter-clockwise

Rotatin g an alread y placed part 

1 Select the part.

2 Press C+R to rotate it 90° counter-clockwise.

Rotatin g an area of the schematic

1 Drag the pointer to select and outline the area to be rota

2 Press C+R to rotate the area.

The selected area rotates 90° counter-clockwise about t
center point of the selected area.
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Flippin g Parts

Flippin g a part before placin g it

1 Select the part to be placed.

2 Press C+F to flip it.

The symbol outline is a mirror image of the original imag
Each time you press C+F, the image will flip about the 
vertical axis. 

Flippin g an alread y placed part

1 Select the part.

2 Press C+F to flip it.

Flippin g an area of the schematic

1 Drag the mouse to select and outline the area to be flipp

2 Press C+F to flip the area about its vertical axis.
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Note You can quickly change 
the value of a displayed 
attribute, such as a resistor 
value, by double-clicking it.

Note If you double-click 
when selecting the attribute, 
the pointer is placed on the 
current value in the Value text 
box.
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Editin g Part Attributes
Parts, ports, wires (nets), buses and most other symbols ha
associated attributes. An attribute consists of a name and a
associated value. (See Attributes on page 3-4.)

You can create new attributes or edit existing attributes of a p
on the schematic. These functions are performed in the Attrib
Editing dialog box.

Editin g Attributes

Editin g an attribute

1 Double-click the part to display the Attribute Editing dialo
box.

 

2 In the list of attributes and values, select the attribute to 
edited.

The attribute name appears in the Name text box and th
current value in the Value text box.

3 Edit the value in the Value text box.

4 Click Save Attr.

5 Click OK.

An attribute with an asterisk (* ) next to it indicates that the 
attribute cannot be changed or deleted in the schematic edi
because the attribute was made an intrinsic property when t
symbol was created. These attributes can only be modified in
symbol editor.
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The letter a indicates that the attribute has been annotated a
result of back annotation or has been assigned by the packa

Any changes you make to the part attributes are made to th
individual part instance you selected. The original part 
contained in the symbol library remains unchanged.

Attribute names can contain any alphanumeric characters (A
0–9) and the underscore character. Attributes cannot be sel
referencing. 

The two check boxes at the bottom of the Edit Attribute dialo
box enable you to control whether or not non-changeable or
system defined attributes are included in the display.

System defined attributes have reserved attribute names. 
Schematics uses these attributes for specific purposes, prima
during netlisting and packaging. See Appendix E, Attribute List 
for a complete list and explanations of attributes. System 
defined attributes are as follows:

BIASVALUE
COMPONENT
COLOR
ERC
FAMILY
FLOAT
GATE
GATETYPE
IMPL
LABEL
MARKERTYPE
MODEL
NODE
PAGECOUNT
PAGENO

PAGESIZE
PAGETITLE
PART
PKGREF
PKGTYPE
PLMODEL
PROBEVAR
REFDES
SIMULATIONONLY
SOURCE
STIMTYPE
STIMULUS
SWAP
TAG
TEMPLATE
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Note You cannot delete non-
changeable or system-
defined attributes.

Note You cannot change the 
display of non-changeable 
attributes.
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Addin g Attributes

Addin g a new attribute

1 Double-click the part to display the Attribute Editing dialo
box (see 4-12).

2 Double-click in the Name text box and type the new 
attribute name.

3 Press F and type the new attribute value in the Value te
box.

4 Click Save Attr.

5 Click OK.

The new attribute and its value apply only to the part 
instance you are editing on the current schematic. The 
attribute and value are saved only with the schematic; th
are not saved in the symbol library.

Deletin g Attributes

Deletin g an attribute

1 Double-click the part to display the Attribute Editing dialo
box (see 4-12).

2 Select the attribute to delete.

3 Click Delete.

4 Click OK.

Changing the Displa y of Attributes

You can change how specific attributes appear on the schem

Displa ying attributes

1 Double-click the part to display the Attribute Editing dialo
box (see 4-12).

2 Select the attribute whose display you want to enable (o
disable).
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Your choices are:

• Display the value of the 
attribute only.

• Display the name of the 
attribute only.

• Display both the name and 
the value of the attribute.

• Display both the name and 
value of the attribute only if 
the attribute is defined.

• Display neither the name nor 
the attribute.
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3 Click Change Display to display the Change Attribute 
dialog box.

4 Select one of the option buttons in the What to Display 
frame.

With many attributes such as the package reference and
reference designator, only the value displays. With other
such as package type, neither the name nor the value 
displays.

5 Click OK to close the Change Attribute dialog box.

6 In the Attribute Editing dialog box, click OK.

Changing other displa y characteristics of the 
attributes of a part instance

1 Double-click the part to display the Attribute Editing dialo
box (see 4-12).

2 Select the attribute whose display characteristics you wa
to change.

3 Click Change Display to display the Change Attribute 
dialog box.

The name of the attribute and the current attribute value 
displayed.
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4 Select or type a value for any of the Display Characterist

You can change any of the characteristics as described 
Table 4-1.

5 Click OK to close the Change Attribute dialog box.

6 Click OK to close the Attribute Editing dialog box.

This procedure only changes the display characteristics for 
attributes of the one instance of this part on the current 
schematic. To change display characteristics for the attribute
a part for every instance placed on every schematic, you hav
change the global characteristics of the symbol. See Editing the 
Default Attributes of a Symbol on page 4-18.

Table 4-1 Attribute Text Characteristics

Characteristic Explanation

Orient: Enables you to position the text 
horizontally, vertically, upside down, or 
down in relation to the defining point of the 
text string.

Layer: Specifies a text display level as defined by 
the Set Display Level function under the 
Options menu. Defaults to Attribute Text 
Layer. You can specify a user-defined 
layer.

Size: Determines the size of the text of a 
displayed text item. The size is expressed a
a percentage of the default size (the defaul
size is the font size for the selected layer).

Hjust: Sets the horizontal justification for the 
placement of text items (left, center, or 
right).

Vjust: Sets the vertical justification for placing 
text items (top, normal, or bottom).
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Note Click Browse to view a 
list of attributes for the 
selected items. If the value of 
an attribute is the same for all 
selected items, the value 
appears. Otherwise, no value 
appears.
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Global Editin g of Attributes
Schematics allows you to change an attribute on multiple pa
at the same time.

Assi gnin g the same attribute value to multiple 
parts

1 Select more than one part, or select an area of the draw
enclosing the parts.

2 Select the Edit Attributes button.

A confirmation dialog box appears asking if you want to 
globally edit attributes of all selected items.

3 Click Yes to display the Global Edit Attributes dialog box

4 In the Attribute Name text box, type the name of the 
attribute.

5 In the Value text box, type a value for the attribute.

6 Click OK.

The named attribute is changed to the specified value for
selected parts having that attribute.
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Save any custom symbol 
changes that you make in your 
own custom library.

If you save symbol changes 
within the MicroSim libraries, 
your changes will be overwritten 
when you install a new version of 
the software.
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Editin g the Default Attributes of 
a Symbol
When placing parts, you might want to change the value of 
attribute for all parts of a certain type, such as a resistor. Fo
example, you might want to change the default value for all 
resistors being placed from a value of 1 Kohm to 10 Kohm.

Changing the default value of a resistor 

1 Select a resistor symbol on the schematic.

2 Click the Edit Symbol button to display the resistor symb
in the symbol editor window.

Note the name of the symbol library analog.slb  in the 
title bar of the symbol editor window.

3 Click the New File button to display a new (blank) symbo
editor window.

4 Select Copy from the Part menu to display the Copy Par
dialog box.

5 Click Select Lib to display the Open dialog box.

6 Select Analog.slb  from the scroll list.

7 Click Open.

8 Double-click R in the Part list.

9 From the File menu, select Close.

The prompt “Save changes to part R?” will appear.

10 Click Yes.

You are prompted for a library file name.
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By default, the Enable Auto-
Repeat check box is disabled, 
the Horizontal Offset spacing is 
set to 00.00, and the Vertical 
Offset is set to 00.10.
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11 Type a name in the File Name text box.

12 Click Save.

You are prompted to add the library to the list of configure
libraries.

13 Click Yes.

Repeatin g Part Placements
If you are placing parts in line with each other and evenly 
spaced, use the Auto-Repeat function.

Automaticall y repeatin g part placements

Before selecting the part for placement, enable the Auto-Rep
function and set the offset spacing.

1 From the Options menu, select Auto-Repeat to display t
Auto-Repeat dialog box. 

2 Select the Enable Auto-Repeat check box.

3 Specify a horizontal and vertical offset for the part 
placements.

Figure 4-1 illustrates parts that are placed at various verti
and horizontal offsets.
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Note Use 8 and S8 
to enable and disable Auto-
Repeat, respectively. If you 
do not need to change the 
offsets, this is a convenient 
way to quickly place arrays of 
parts and wires.
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4 Select the part from the symbol library.

5 Place the first instance of the part.

6 Press M once to place each subsequent instance of th
same part.

Manuall y repeatin g part placements

1 If Auto-Repeat is not enabled, press M to repeat the last 
action. 

If the last action was placing a part, pressing M changes 
the pointer to the symbol outline of the last part placed.

2 Move the symbol outline to any location on the schemat
and click to place the part.

3 To stop placing the part, do one of the following:

• Double-click to place the last instance of the part. 

Figure 4-1 Placing Resistors with Various Vertical and 
Horizontal Offsets

Horiz. Offset 00.00
Vertical Offset 00.30

Horiz. Offset 00.00
Vertical Offset 00.50

Horiz. Offset 00.30
Vertical Offset 00.00

Horiz. Offset 00.50
Vertical Offset 00.100
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• Right-click to stop placing the part without placing an
additional part.

The outline changes back to a pointer. 

Automaticall y Assi gnin g 
Reference Desi gnators
The Auto Naming function is useful for assigning reference 
designators to parts as they are placed. The default starting
reference designator number is 1. When placing resistors, th
first one placed is R1, the second R2, and so on. You can se
starting reference designator to any number, depending on 
way you package or organize your design.

Enablin g Auto Namin g of reference desi gnators

1 From the Options menu, select Auto Naming to display t
Auto Naming dialog box.

2 Select the Enable Auto Naming check box.

3 Type a starting designator number if you want the 
numbering to start at a number other than one.

4 Click OK.
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Example—Usin g Auto-Repeat 
and Auto Namin g
Use the following procedure to create part of the drawing sho
in Figure 4-2 using the Auto-Repeat and Auto Naming 
functions. 

Placin g the bus and part

1 Click the Draw Bus button.

2 Move the pencil-shaped pointer to the location of one end
the first bus segment. Click to start drawing the bus.

3 Click at each vertex of the bus. Double-click at the end o
the bus.

4 Type 74273  in the Get Recent Part list box on the toolba

5 Press R.

6 Move the outline pointer to the location of U1 and double
click to place a single instance of the 74273 part.

Figure 4-2 Auto Naming for Bus Labels
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Drawin g the first wire se gment connectin g the 
part to the bus

1 Click the Draw Wire button.

2 Move the pencil-shaped pointer to a point on the bus wh
wire segment A[0] attaches to the bus. Click to start drawi
the wire.

3 Move to pin D1 on U1 and double-click.

Usin g Auto-Repeat to create the remainin g wire 
segments

1 Enable Auto-Repeat (see Automatically repeating part 
placements on page 4-19).

2 Set the horizontal offset to 00.00 and the vertical offset t
00.10.

3 Press M seven times to draw seven additional wire 
segments.

Usin g Auto Namin g to quickl y label the wire 
segments

1 From the Options menu, select Auto Naming to display t
Auto Naming dialog box.

2 In the Wire/Port Labels frame, select the Enable Auto-
Increment check box.

3 Type A[0] in the Label Template text box.

4 Click OK.

5 Select the first wire to be labeled.

6 From the Edit menu, select Label to label the wire.

7 To label each of the remaining wire segments:

a Select the wire.

b Press M.
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Replacin g Parts
A single part on a schematic may be replaced easily. In addit
all parts of a given type on a page, or all pages of a multi-pa
design may be replaced. Instead of having to delete one pa
find another in a library, and place the new part, you can repl
the old with the new in one operation.

Replacin g a sin gle part

1 Select the part to be replaced.

2 From the Edit menu, select Replace to display the Repla
Part dialog box.

Note that Target Part is unavailable because you have 
already selected a part and don’t need to specify one in 
dialog box.

3 In the Replacement text box, type the name of the 
replacement part.

4 If you want the attribute values of the part being replace
applied to the replacement parts, select the Keep Attribu
Values check box.

5 Click OK.

The selected part is replaced.

Replacin g multiple parts in a selected set

1 Select the group of parts to be replaced. (See Selecting more 
than one object on page 4-40.)

2 From the Edit menu, select Replace to display the Repla
Part dialog box.

3 In the Replacement text box, type the name of the 
replacement parts.

4 If you want the attribute values of the parts being replace
applied to the replacement parts, select the Keep Attribu
Values check box.

5 Click OK.

All of the selected parts are replaced.
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Replacin g all parts of the same name

1 From the Edit menu, select Replace to display the Repla
Part dialog box.

2 In the Target Part text box, type the name of the parts to
replaced.

3 In the Replacement text box, type the name of the 
replacement parts.

4 If you want the attribute values of the parts being replace
applied to the replacement parts, select the Keep Attribu
Values check box.

5 Click the Current Page Only option button to replace all 
target parts on the current schematic page or click the A
Pages option button to replace all target parts on all page
a multi-page design.

6 Click OK.

All of the named target parts are replaced.
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Placing and editing power and 
ground symbols is the same as 
placing and editing other part 
symbols with the following 
considerations:

• Power and ground symbols 
are contained in the “port.slb” 
symbol library.

• You can use the symbol 
editor to create your own 
custom power and ground 
symbols.

The power and ground symbols 
contained in “port.slb” library and 
available for placing on a 
schematic are:

AGND
EGND
+5V
-5V
BUBBLE
GND_ANALOG
GND_EARTH
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Placin g Power and 
Ground S ymbols
In Schematics, power and ground symbols are a type of glo
port symbol. The label on the port defines the name of the po
supply.

Placin g Power and Ground 
Symbols

Placin g a symbol on the schematic

1 From the Draw menu, select the Get New Part button (s
Finding Parts on page 4-4) to select a port symbol from the
part browser.

2 Move the outline pointer to where you want the part locat
and click.

To place several instances, point and click at each additio
location.

Stoppin g part placement

To stop placing the symbol, do one of the following:

• Double-click to place the last instance of the symbol. 

• Right-click to stop placing the symbol without placing an
additional symbol.

The outline changes back to a pointer. 
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Creatin g Custom Power and 
Ground S ymbols
Because power and ground symbols are just like any other 
symbols, you can use the symbol editor to create your own 
custom power and ground symbols.

See Drawing Symbol Graphics on page 6-10.
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Usin g Wires and Buses
Parts and ports contain one or more pins to which connectio
can be made. Electrical connections are formed by joining p
of parts and ports with wires and buses.

A junction dot appears where three items are joined.

Drawin g and Labelin g Wires

Drawin g a wire

1 Click the Draw Wire button to change the pointer to a pen
shape.

2 Click to start the wire.

3 Click at each vertex of the wire.

4 Click a pin, another wire or a bus to end the wire (or doub
click to end at any point).

If you end the wire on a pin, another wire, or a bus and d
not double-click, draw-wire mode remains active, which 
allows you to start and draw additional wires.

5 To stop drawing the wire, do one of the following:

• Double-click to place the last segment of the wire. 

• Right-click to stop drawing the wire without drawing a
additional segment.

The outline changes back to a pointer. 

If a wire segment meets the end of another wire segment, th
become part of the same wire, without a junction being creat
This principle also applies to bus segments.
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Note A wire connected to a 
bus must be labeled with one 
of the signals on the bus.

By default, wires with the same 
label are not treated as 
connected. If you want to 
connect them, you must connect 
each wire to an off-page port with 
the same label.

To change the default:

1 Select Restricted Operations 
from the Options menu.

2 Select the Connectivity Via 
Wire Labels check box.

3 Click OK.

Shortcut: press C+D
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If a wire segment is added so its end-point intersects anothe
wire segment (at a point other than its end-points), a junction
created and the original wire is split into two segments. All thr
segments become part of the same wire.

You can place a label on selected wires, bus segments, or p
Wire and bus segments may have multiple labels.

Labelin g a wire

You can assign labels to wires for clarity. Labels are not 
required except on wires that are connected to buses.

1 Double-click the wire segment that you want to label, whic
will display the Set Attribute Value dialog box.

2 Type the label in the LABEL text box.

3 Click OK.

Editin g a wire label

Use the following procedure to edit existing labels.

1 Double-click the wire (or the label) to display the Set 
Attribute Value dialog box with the existing label displaye
in the LABEL text box.

2 Edit the existing label or delete it and type in a new labe

Rewirin g

The Rewire function reroutes a selected wire or bus segmen
without disconnecting its end points. The results of rewiring 
depend on the Rubberbanding setting (see Rubberbanding on 
page 4-35).

1 From the Draw menu, select Rewire to change the pointe
a cross symbol.

2 Click the wire segment that you want to change.

3 Click to place a vertex.
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4 Double-click to place the last vertex and stop rewiring.

Drawin g and Labelin g Buses
The connectivity of buses and bus segments in Schematics
controlled by labeling. The rules of connectivity are:

• A bus label specifies the signals it carries and the order 
the signals.

• A bus can connect to another bus only if one is a subset
the other (such as A[0-31] and A[16-31]).

• A bus electrically connects to a pin of a part or port if the p
name indicates the same number of signals. Connection 
the order specified; for example, a bus labeled A[31-0] 
connected to a port labeled Addr[32-63] will electrically 
connect A[31] with Addr[32], A[30], with Addr[33], and so
on.

• For a wire to be connected to a bus, the wire must be labe
with one of the signals on the bus.

• Valid syntax for labeling a bus is:

CLK[0-15] 

CLK[0:15]

CLK[0..15]

CLK[0-3, 12-15]

CLK1, CLK2, data1, data2, input,...

In the latter form, each and every signal in the bus must
included in the series. The signals are separated by com
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Drawin g a bus

1 Click the Draw Bus button to change the pointer to a pen
shape.

2 Click to start the bus.

3 Click at each vertex of the bus.

4 Right-click to end the bus and change the pencil back to
pointer.

Labelin g a bus

1 Double-click the bus segment to display the Set Attribute
Value dialog box (see 4-29).

2 Type the label in the LABEL text box.

3 Click OK.

Editin g a bus label

1 Double-click the bus (or the label) to display the Set 
Attribute Value dialog box (see 4-29) and the existing label 
in the LABEL text box.

2 Edit the existing label or delete it and type in a new labe

Connectin g wires to buses

1 Draw a wire so that it ends on the bus.

2 Label the wire with one of the signals on the bus. For 
example, you can label the wire DB[12] or DB12 if the bu
is labeled DB[0:16].

Splittin g buses

Connecting a bus segment to the middle of another bus segm
creates a junction. The bus segments become part of the sa
bus unless labeled differently. This allows sub-buses to be ta
off a main bus, for example A[0-7] from A[0-31].

1 Draw a bus segment and end it on the main bus.

2 Label the bus segment with a subset of the signals on th
main bus.
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For example, you can label the bus segment DB[0:8] if t
main bus is labeled DB[0:16].

Automaticall y Labelin g Wires 
and Buses
Use the Auto Naming function to set up the labeling of wires a
ports. The syntax specified in the Label Template text box 
allows you to name a uniform collection of wires.

Namin g a collection of wires connected to a bus

1 From the Options menu, select Auto Naming to display t
Auto Naming dialog box.

2 In the Wire/Port Labels frame, select the Enable Auto-
Increment check box.

3 In the Label Template text box, type the label for the firs
wire in the series, for example, CLK[0]. Wires will be 
labeled incrementally in the order selected, as CLK[0], 
CLK[1], CLK[2], and so on.

4 Click OK.

5 Select the first wire to be labeled.

6 From the Edit menu, select Label to label the wire.

7 To label each of the remaining wires in the series:

a Select the wire.

b Press M.
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Specif ying Drawin g Options
Several options aid in drawing wires and buses and in placin
parts.

• The Orthogonal option constrains wires and buses to 
vertical and horizontal lines.

• The Snap-to-Grid option keeps parts, wires, and buses 
aligned to grid lines.

• The Snap-to-Pin option constrains wire and bus placeme
to the nearest pin.

• The Rubberband option maintains connectivity between
parts when they are moved.

Ortho gonalit y

Orthogonal allows wires and buses to be drawn only as 
horizontal and vertical lines. 

Figure 4-3 illustrates two resistors connected by a wire draw
with Orthogonal enabled. The wire was drawn by clicking at t
bottom of R1 and moving directly to R2 and clicking again. Th
wire was drawn by vertical and horizontal lines even though 
movement of the pointer was diagonal.

Figure 4-3 Orthogonal Wire Drawing
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Stay-on-Grid must be enabled 
for Snap-to-Grid to be effective.
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Enablin g ortho gonal drawin g

1 From the Options menu, select Display Options.

2 In the Options frame, select or clear the Orthogonal che
box to enable or disable orthogonality.

3 Click OK.

Snap-to-Grid

Snap-to-grid controls the movement of the object while bein
moved for placement when Stay-on-Grid is enabled. If Snap
Grid and Stay-on-Grid are both enabled, movement during 
object placement is in increments equal to the current grid 
spacing. If Snap-to-Grid is not selected, the object moves 
smoothly.

Enablin g snap-to- grid

1 From the Options menu, select Display Options.

2 In the Options frame, select or clear the Snap-to-Grid che
box to enable or disable snap-to-grid.

3 Click OK.

Snap-to-Pin

Snap-to-pin, when enabled, causes the end-point of a wire or
segment to snap to the nearest pin if one is found inside the
radius defined by the Gravity setting.

Enablin g snap-to-pin

1 From the Options menu, select Display Options.

2 In the Options frame, select or clear the Snap-to-Pin che
box to enable (or disable) snap-to-pin.

3 Click OK.

Gravit y

Gravity specifies how close an object must be to a pin to sna
it. Gravity is only functional when snap-to-pin is enabled.
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Gravity is only functional when 
snap-to-pin is enabled.
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Specif ying gravit y

1 From the Options menu, select Display Options (shown 
page 4-34).

2 In the Snap-to-Pin frame, in the Gravity box, type the sn
to-pin gravity value.

3 Click OK.

Grid Spacin g

Grid Spacing defines the horizontal and vertical grid spacing
your drawing area. The default spacing is 10 units. This 
corresponds to 0.10 inches for US-standard page sizes, and
millimeters for metric page sizes. The minimum grid spacing
allowed is 0.01 inch, or .25 millimeters.

Specif ying grid spacin g

1 From the Options menu, select Display Options.

2 In the Grid Spacing frame, type the grid spacing value 
(shown on page 4-34).

3 Click OK.

Rubberbandin g

Rubberbanding makes it easier to rearrange your schematic
new parts and clean up the schematic when necessary. You
move one or more selected objects to a new location while 
maintaining connectivity. 

Results vary according to whether Orthogonal is enabled or
disabled. Figure 4-4 illustrates a rubberbanding move with 
Orthogonal enabled, while Figure 4-5 shows the same move
with Orthogonal disabled.
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Figure 4-4 Rubberbanding with Orthogonal enabled

Figure 4-5 Rubberbanding with Orthogonal disabled
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Shortcut: press 5
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While you are moving an object (whether orthogonal is enab
or disabled), an X appears where a new connection will be m
if the object is placed, and the pointer changes to a caution s
(see Figure 4-6 below). If you continue to move the object 
(away from the connection), the X disappears and the point
returns to normal.

New connections are formed when:

• a pin, wire, or bus is placed on another pin, wire, or bus

• the path of a wire or bus crosses over a pin, wire segme
endpoint, or bus segment endpoint

Figure 4-6 shows a path with a potential new connection.

Figure 4-6 Rubberbanded path showing a potential 
connection

Enablin g Rubberbandin g

1 From the Options menu, select Display Options.

2 In the Display Options dialog box (see 4-34):

a Select the Rubberband check box.

b Select the Orthogonal check box, if you want 
rubberbanding to be orthogonal.

3 Click OK.
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A third type of port, interface port 
provides connections between 
the pins of a hierarchical block or 
symbol and the underlying 
schematic. Refer to Chapter 
7,Creating and Editing 
Hierarchical Designs, the 
section on Using Interface Ports 
on page 7-12.
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Usin g Ports
Signals can be connected without using wires or buses by 
connecting them to global or off-page ports and labeling the
ports with the same name.

Off-Page Ports

Off-page ports connect to other off-page ports with the same
name on the same page or on other pages within the same 
schematic. If you are working on a schematic and you need
connect signals between pages, use off-page ports.

Figure 4-7 Off-page Port

Global Ports

Global ports connect to other global ports of the same name
anywhere in the schematic hierarchy.

The symbol library port.slb  contains several port symbols. 
You can also create your own port symbols using the symbo
editor.

Figure 4-8 Global Ports

OFFPAGE

GLOBAL

BUBBLE

EXTERNAL_IN

EXTERNAL_OUT

EXTERNAL_BI
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Note A quick way to place 
the global port is to type 
“global” in the Get Recent 
Part list box on the toolbar.
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Placin g a global port

1 Click the Get New Part button to display a Part Browser 
dialog box, (see 4-6).

2 Click Libraries to display the Library Browser dialog box 
(see 3-19).

3 In the Library list, select port.slb .

4 In the Part list, double-click GLOBAL.

5 Click Place to place the global port, or click Place & Clos
to close the dialog box and place the global port.

Labelin g a global port

1 Double-click the port to display the Set Attribute Value 
dialog box (see 4-29).

2 Type the label in the LABEL text box.

3 Click OK.
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Figure 4-9 Selection rectangle

selection rectangle
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Selectin g and Movin g 
Objects and Attributes
Before performing any operation on a schematic object, you
have to select the object. You can make multiple selections 
select whole areas of the schematic.

After you select an object, you can move, copy, delete, edit, c
and paste that object.

Selectin g

Selectin g an ob ject (a part, wire, or bus on the 
schematic)

1 Point to the object with the pointer and click to select it.

The object color change (the default is red) indicates it is 
selected.

After the object is selected, you are ready to perform an acti
Selecting a new object causes the selection of any previous
selected objects to be cancelled.

Selectin g more than one ob ject

1 Hold down S while selecting multiple objects 
individually.

The objects change color to indicate they are selected.

Selectin g all ob jects within a given area of your 
schematic

1 Draw a selection rectangle around the group of objects y
want to select. 

Only objects entirely contained within the box are selected.

Selectin g an ob ject attribute

1 Point to the attribute and click.
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A rectangle is drawn around the attribute; a selection rectan
also appears around the object that the attribute belongs to.

De-selectin g selected ob jects

1 Click to select an object other than the selected object, o
click in a blank area of the schematic.

Movin g

Movin g an ob ject

1 Select an object (or group of objects).

2 Click the pointer on the object, or in the area designated
the selection rectangle.

3 Drag the selection to the desired location.

4 Release the mouse button to place the object.

Searchin g for and Selectin g 
Parts
In a large design, you may have to find an object to select it.
save you time, Schematics allows you to search for objects 
specify search criteria. It then selects objects located in the 
search.

Use the Find command from the Edit menu to search for an
object. You can search for parts, wires and buses that conta
attributes.
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When typing an attribute name 
and value, you can specify an 
exact value or use wildcards.

An asterisk (*) is a wildcard that 
matches zero or more 
characters. For example, R* 
matches R, R1 and R12.

A question mark (?) is a wildcard 
that matches any single 
character. For example, R? 
matches R1 but not R or R12.
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Findin g a part

1 From the Edit menu, select Find to display the Find dialo
box.

2 Specify the search criteria:

a Type an attribute name in the Name text box.

b Type the attribute value in the Value text box.

c Click Add Criterion to add the search criteria to the 
Additional Criteria text box.

d Repeat steps a through c as many times as necessa
add more search criteria.

3 Click the Current Page Only button to search only on the
current page, or click the All Pages button to search all 
pages in a multi-page design.

4 Click the Select All button to have all items meeting the 
search criteria selected, or click the Select Next button t
have only the next item meeting the search criteria selec

5 Click OK to begin the search.

The status line indicates the number of items found and 
selected.
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Shortcut: press C+C
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Cuttin g, Copying, and Pastin g
Schematics provides several editing features that allow you
cut, copy, paste, copy to clipboard, delete, and undelete sele
objects. All of these functions are available under the Edit me
Most can be accessed from the keyboard.

The cut, copy, copy to clipboard, and delete functions only 
apply when an object is selected. To learn how to select sin
and multiple objects as well as objects within a given area, s
Selecting on page 4-40.

Cuttin g

Cut deletes the selected object (or group of objects) from th
schematic and copies it to the clipboard for use with the Pas
function. The clipboard retains only the object last cut.

Cuttin g a selected ob ject

1 Select an object to cut.

2 From the Edit menu, select Cut.

Copying

The Copy function makes a copy of the selected object for 
pasting. The selected object remains on the schematic and 
copy is placed to the clipboard.

Copying a selected ob ject

1 Select the object to copy.

2 From the Edit menu, select Copy.

Pastin g

Paste places one or more copies of the last object stored in
buffer (from a Cut or Copy operation) onto the schematic.



4-44 Creating and Editing Designs

 the 

k 

d or 

red 

ing 
o 
y 

 the 

Shortcut: press C+V

With Auto-Repeat enabled (see 
Repeating Part Placements on 
page 4-19), press M to place 
repeated copies of items from 
the buffer.

C+Y for Redo
Shortcut: press C+Z for Undo and 
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Pastin g an ob ject

1 From the Edit menu, select Paste to change the pointer to
shape of the object last cut or copied.

2 Click to place the object at the current pointer location.

Continue moving the pointer to various locations and 
clicking to place additional copies of the object. Right-clic
to stop pasting.

Deletin g

Delete removes an object. A deleted object cannot be copie
pasted.

Deletin g a selected ob ject

1 Select an object to delete.

2 Press D.

The object is placed in the recycle bin and can only be recove
with the undo function (see Undo/Redo on page 4-44).

Undo/Redo

Undo reverses changes made such as placing parts, chang
attributes, moving objects, or drawing wires and buses. Red
will re-do what was just undone. There is no limit to how man
steps can be undone or redone. However, Undo/Redo 
information is only stored for changes to the schematic since
last time the file was saved.

To undo/redo what was just done

1 From the Edit menu, select Undo or Redo.

Note Undo/Redo does not apply to operations that do 
not change the page content. For example, 
panning and zooming, editing a library or a symbol, 
creating a netlist, or adding, creating, or copying a 
page.



Selecting and Moving Objects and Attributes 4-45

se 

de 

rd 
d, 

.

d 

e 
t 

ned 

Edit Menu

Scug.bk : 04DESGNS.FMK  Page 45  Monday, June 16, 1997  10:10 AM
Copying to the Clipboard

The Copy to Clipboard function copies objects within a 
selection rectangle to the Microsoft Windows Clipboard for u
in other Windows programs. Electrical or connectivity 
information is not copied to the clipboard. This function is 
useful if you want to make a copy of your schematic to inclu
in another type of file, such as a word processor file.

If the grid is enabled, the grid dots are copied to the clipboa
along with the schematic. If you don’t want the grid dots copie
disable the grid before copying. See Grid On on page 3-29.

Copying an area of the schematic to the Windows 
Clipboard

1 Using a selection rectangle, select the area to be copied

2 From the Edit Menu, select Copy to Clipboard.

The area is copied to the Windows Clipboard. The copie
area remains unchanged on the schematic.

Importin g a schematic into Microsoft Word

Before selecting the area to be copied, disable the grid. If th
grid is enabled, the grid dots will be copied into the Microsof
Word document.

1 From the Options menu, select Display Options.

2 In the Display Options dialog box (see 4-34), clear the Grid 
On check box to disable the grid.

3 Copy an area of the schematic to the clipboard, as explai
in Copying an area of the schematic to the Windows 
Clipboard on page 4-45.

4 In Microsoft Word, insert a frame where you want the 
schematic to be placed.

5 Press C+V to paste the contents of the clipboard.
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Creatin g and Editin g 
Title Blocks
Each new schematic is created with a title block in the lower
right corner of the page. The title block is treated as an 
annotation symbol and each text field is an attribute. As suc
you can edit the attributes of the title block much the same a
you would the attributes of other objects. You can type 
information into the title block in the default format, or you ca
create a custom title block.

Editin g Page Title
The page title, when specified, appears in the title block.

Changing the pa ge title

1 From the Navigate menu, select Edit Page Info to displa
the Page Info dialog box.

2 Type a page title in the Page Title text box.

The Simulation Only check box, when enabled, (displays
check mark), indicates the entire page is to be ignored fo
purposes other than simulation (for instance, it will be 
ignored for PCB layout).

3 Click OK.
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title block to display the Attribute 
Editing dialog box.
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Enterin g Information into the 
Title Block
Entering information into the existing title block can be done 
one of two ways: (1) by editing the attributes of the title bloc
in which case you can type information into any, or all fields 
the title block, or (2) by editing an individual attribute of the titl
block.

Enterin g information into multiple attributes of 
the title block

1 Select the title block, then select Attributes from the Edit
menu to display the Attribute Editing dialog box.

2 In the attribute list, double-click the attribute.

3 Type the information in the Value text box.

4 Click Save Attr.

5 Select another attribute or click OK.



4-48 Creating and Editing Designs

et 

the 
e 

y 

Scug.bk : 04DESGNS.FMK  Page 48  Monday, June 16, 1997  10:10 AM
Editin g one attribute of the title block

1 Double-click the attribute of the title block to display the S
Attribute Value dialog box.

2 Type or correct the information in the text box.

3 Click OK.

Creatin g a Custom Title Block
Because the title block is treated as a symbol, you can use 
symbol editor to create your own custom title block or edit th
existing title block to suit your requirements. See Chapter 
6,Creating and Editing Symbols.

Instead of creating a title block each time you start a new 
schematic, you can copy the TITLEBLK symbol from the 
“special.slb” symbol library to your own custom symbol librar
and modify it to suit your needs. You must configure your 
custom symbol library into the library search list for your 
custom title block symbol to be available for use.
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Usin g a Custom Title Block S ymbol

After you have created a custom title block, you have to spec
that block in order to use it in the current schematic.

Specif ying a new title block s ymbol

1 From the Options menu, select Editor Configuration to 
display the Editor Configuration dialog box (see 3-18).

2 In the Title Block Symbol text box, type the name of the tit
block symbol.

3 Click OK.
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The text will wrap as it is entered, 
however, you must resize the 
text box to view text that flows 
beyond its bottom boundary.
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Addin g Non-Electrical 
Information
Non-electrical information such as comments, tables, and 
graphics can be added to the schematic.

There are three types of non-electrical information:

• text—multiple lines or a single line, such as comments o
instructions

• graphics—lines, circles, and arcs

• annotation symbols

Text

Multiple Line Text Editin g

With the multiple line text option, you can enter text at any 
location on the schematic by creating an editable, resizable 
box. This is the best way to add more than one line of text to
schematic. The text properties can be changed to specify th
font, color, point size, and frame of the text box.

Drawin g the text box

1 From the Edit menu, select Draw Text Box to change the
pointer to a pencil shape

2 Click the pointer at a location on the schematic and do th
following:

a Move the pointer down and to the right.

b Click to set the lower-right corner of the text box.

3 Type the text.
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To rotate the box, select it and 
press C+R. (See Rotating 
Parts on page 4-10.)

Note The text will 
automatically wrap within the 
box as it is entered.
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Resizin g the text box

1 Select the text box to display its handles.

2 Click one of the handles and drag to resize the text box.

Editin g Text

1 Click inside the text box to modify or add text.

Single Line Text Editin g

With the single line text option, you can continuously type te
on one line. This is a quick way to enter text onto a schema
and is especially useful if the amount of text is minimal. In th
schematic editor, once the text has been placed, it may be ed
and the text box may be resized. 

Addin g a sin gle line of text

1 From the Draw menu, select Text to display the Add Tex
dialog box.

2 Type the text in the text box.

3 Click OK.

An outline box follows the pointer that indicates the outlin
of the text string.

4 Move the outline to the desired location and click to plac
the text.

The outline box remains on the screen. You can click to 
place the same text string in several locations.

5 To stop placing the text string, do one of the following:

• Double-click to place the last instance of the text. 

• Right-click to stop placing the text string without placing a
additional one.

The outline changes back to a pointer. 
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To rotate the box, select it and 
press C+R. (See Rotating 
Parts on page 4-10.)

Note The text will 
automatically wrap within the 
box as it is entered.

You can also double-click the 
frame of the text box to display 
the Text Properties dialog box.
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Resizin g the text box

1 Select the text to display the text box handles.

2 Click one of the handles and drag to resize the box to th
size needed.

Editin g text

1 Click inside the box to edit or enter more text.

Changing the Properties of the Text

There are two ways to change text properties in Schematics

• changing properties on an instance basis through the Te
Properties dialog box

• setting the defaults for all annotation text in the Display 
Preferences dialog box (see Controlling the Display in 
Schematics on page 3-34 for further explanation)

Changing the text properties on an instance basis 
throu gh Text Properties

1 Select the text or text box whose properties you want to
change.

2 From the Edit menu, select Text Properties to display th
Text Properties dialog box.
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If you decide you don’t want to 
apply the changes you have 
made, click the Restore Defaults 
button to restore the settings 
selected in the Display 
Preferences dialog box. The 
Restore Defaults button works at 
any time before closing the 
dialog box or after re-entering it.
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3 Select the appropriate properties for the text selected.

Note In addition to changing the text properties, you can 
change the properties of the text box itself in the 
Frame area.

4 Click OK.

Settin g the default text properties throu gh 
Displa y Preferences

1 From the Options menu, select Display Preferences to 
display the Display Preferences dialog box.

2 Select one or more text layers from the Display Layers li
(see 3-35 for how to select more than one layer).
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Note Changes made in the 
Display Preferences dialog 
box become the default 
settings for all schematics, 
but may be changed at any 
time.

The Annotation Graphics toolbar 
is available for placing graphics 
on your schematic.
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3 Click the Text tab.

4 Select the appropriate properties.

5 Click Apply to apply the changes immediately and keep t
dialog box open for further changes, or click OK to apply
the changes and close the dialog box.

Graphics

Addin g Graphics

Graphics can be added directly onto your schematic.

Addin g annotation graphics

1 From the Draw menu, select arc, box, circle, or polyline.

See Editing Existing Symbols on page 6-20 for a description 
of the available graphics and how to create them.
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An arrow will display when you 
drag the pointer over a handle to 
indicate that it may be resized.

You can also double-click the 
object or group of objects to 
display the Graphics Properties 
dialog box.

If you decide you don’t want to 
apply the changes you have 
made, click the Restore Defaults 
button to restore the settings 
selected in the Display 
Preferences dialog box. The 
Restore Defaults button works at 
any time before closing the 
dialog box or after re-entering it.
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Resizin g annotation graphics

1 Select the object to display its handles.

2 Click one of the handles and drag to resize the object.

Changing Graphics Properties

There are two ways to change the graphics properties in 
Schematics:

• changing properties can be changed on an instance bas
through the Graphics Properties dialog box

• setting the defaults for all annotation graphics properties
the Display Preferences dialog box (see Controlling the 
Display in Schematics on page 3-34 for further explanation)

Changing the graphics properties on an instance 
basis throu gh Graphics Properties

1 Select one or more objects whose properties you want t
change.

2 From the Edit menu, select Graphics Properties to displa
the Graphics Properties dialog box.

3 Select the appropriate properties for the objects selected

4 Click OK.
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box become the default 
settings for all schematics, 
but may be changed at any 
time.
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Settin g the default graphics properties throu gh 
Displa y Preferences

1 From the Options menu, select Display Preferences to 
display the Display Preferences dialog box (shown on 4-53).

2 From the Display Layers list, select the Annotation 
Graphics layer.

3 Click the Graphics tab.

4 Select the appropriate properties.

5 Click Apply to apply the change immediately and keep th
dialog box open for further changes, or click OK to apply
the changes and close the dialog box.



Adding Non-Electrical Information 4-57

), 

 

Note All imported graphics 
are imported by reference. If 
you move files that have been 
imported by reference, 
Schematics will not be able to 
locate the files to display 
them.

Note If you need to move the 
graphic to another location on 
the schematic, select it and 
move it as you would any 
other object.
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Importin g Bitmaps and Metafiles

You can import bitmap (.bmp, .dib), Windows metafiles (.wmf
or enhanced metafiles (.emf) onto the schematic. 

Importin g a graphic

1 From the Draw menu, select Insert Picture to display the
Open dialog box.

2 Select the file type: Bitmaps or Metafiles.

3 Select a file from the window or type the path of the file 
location in the File Name text box.

For example:

c:\graphics\msim.bmp

where c: is your local drive

4 Click Open and a rectangle the size of the graphic will 
appear attached to the pointer.

5 Click to place it.

Resizin g an imported graphic

1 Select the graphic to display its corner handles.

2 Drag one of the handles to resize the graphic to the 
appropriate size.

The graphic will size proportionally.
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Annotation S ymbols
Creating annotation symbols and adding them to a custom 
library allows you to easily use them in other designs. 

Creatin g annotation s ymbols

1 From the Edit menu, select Symbol to start the symbol 
editor.

2 From the File menu, select Open.

Select the existing library where the annotation symbol w
be saved.

3 From the Part menu, select New to display the Definition
dialog box.

a Type a name for the symbol in the Part Name text bo

b From the Type list, select Annotation.

c Click OK.

4 Use the symbol editor to add graphics to the symbol. (Se
Drawing Symbol Graphics on page 6-10.)

Note Because annotation symbols are non-electrical, do 
not use pins.

5 From the Part menu, select Attributes to display the 
Attributes dialog box.
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a Add any attributes to contain custom information for 
later use.

b Click OK.

6 From the File menu, select Save.

Movin g Non-Electrical 
Information

Movin g text, graphics, and annotation s ymbols

1 Select the object. 

2 Place the pointer on the edge of the object and the 
annotation movement cursor becomes attached to the 
pointer.

3 Drag and place the object at the desired location on the p
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Creatin g and Editin g 
Multi-sheet Desi gns
A schematic can contain one or more pages. As a schemati
grows beyond a single page, ports are used to establish 
connectivity. Off-page ports provide connectivity between 
pages of the same schematic. Global ports provide connecti
across schematic pages to other global ports of the same na
anywhere in the schematic hierarchy. Off-page and global po
are named the same as the nets that they are connected to.

The Navigate menu allows you to move between pages in m
sheet designs and provides the means to create new pages,
pages from other schematics, delete pages, and give each p
title.

Addin g a Page to a Desi gn
There are two ways to add additional pages to your schema
(1) creating a new page, or (2) copying a page from the curr
schematic or another schematic.

Creatin g a new pa ge

1 From the Navigate menu, select Create Page to display 
Create Page dialog box.

2 Type a title for the new page in the Page Title text box.

3 You can accept the next sequential number as the page
number for the new page or type in a different number.

4 Click OK to add the new page.
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Copying a page

1 From the Navigate menu, select Copy Page to display th
Copy Page dialog box.

2 Select the schematic file from the Directory list.

3 Select a page number, if the page to be copied is part of
multi-page schematic.

4 Click OK to add the page to the current schematic after t
current page and renumber all further pages.

Creatin g Connections Between 
Pages
Use off-page ports to create connections between pages. O
page ports can either be labeled or unlabeled. If an off-page 
is unlabeled, it must be connected to a labeled wire or bus.

Connectin g a signal between pa ges

1 Place an off-page port (OFFPAGE) on one schematic page

2 Connect a labeled wire or a bus signal to the off-page po

3 Repeat steps 1 and 2, using the same signal name, on t
other schematic pages.
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Viewin g Multiple Pa ges
To view pages in a multi-page design, use the Previous Pag
Next Page, and Select Page selections under the Navigate m

Viewin g the previous pa ge

1 From the Navigate menu, select Previous Page.

Viewin g the next pa ge

1 From the Navigate menu, select Next Page.

Viewin g a particular pa ge

1 From the Navigate menu, select the Select Page option.

2 Double-click the desired page number and title.

3 Click OK.

Viewin g multiple pa ges at the same time

1 From the Windows menu, select New.

2 From the Navigate menu, select Previous Page, Next Pa
or Select Page.

Cuttin g, Copying and Pastin g 
Between Pa ges
Cutting and pasting or copying from one page to another in 
multi-page design is done in almost the same manner as on
single sheet design. See Cutting, Copying, and Pasting on 
page 4-43.

1 Cut or copy the object.

2 Navigate to the page where the object is to be placed (s
Viewing Multiple Pages on page 4-62).

3 Paste the object.
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Deletin g a Page
To delete a page from a multi-page design, use Delete Page
under the Navigate menu.

Deletin g a page

1 Navigate to the page you want to delete.

2 From the Navigate menu, select Delete Page to display 
Delete Page confirmation dialog box.

3 Click OK to delete the page.
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Printin g Your Desi gn
Printing options allow you to print one or more pages, or a 
selected area of a schematic.

Printin g the current pa ge of the current 
schematic

1 Click the Print button.

The page is immediately sent to the current (default) printer

Printin g a selected area of the current pa ge

1 Select an area of the schematic. (See Selecting on 
page 4-40.)

2 Click the Print button.

The selected area is immediately sent to the current (defa
printer.

Printin g selectivel y

1 From the File menu, select Print to display the Print dialo
box.

2 Select the appropriate pages from the Pages list, or click
Select All to print all of the pages of the current schemat
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3 Select one of the scaling options. See Scaling on page 4-65.

4 Select an Orientation of either Landscape or Portrait. 

Most schematics are in landscape format. Landscape is
schematic editor default format.

5 Click OK.

Scalin g
Scaling options allow you to control the size of the printout.

Auto-Fit

Auto-fit scales the size of the page to print one schematic p
per sheet of printer paper. For example, if the schematic pa
(set through the Page Size selection in the Options menu) is
size and your printer paper is A-size, Auto-fit automatically se
a zoom factor of 50% so that the B-size drawing fits on the A
size paper as Example 1 of Figure 4-10 shows. If the orientat
is set to Portrait, as in Example 2, the zoom factor would be
automatically set to a smaller percentage to fit the entire 
schematic on the page.
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User-Definable Zoom Factor

User-definable zoom factor allows you to set a custom zoom
factor. For example, with the zoom factor set at 100%, a B-s
schematic will print on two A-size sheets of paper when the 
printer is configured in portrait mode, as shown in Figure 4-1

B-size

In Landscape 

In Portrait 

EXAMPLE 1

EXAMPLE 2

Figure 4-10 Printing with Auto-Fit Enabled

Schematic Page Printed Paper

Schematic Page Printed Paper

A-size

B-size A-size

A-size A-size

B-size A-size A-size

Figure 4-11 Zoom Factor Set to 100% with Printer 
Configured in Portrait Mode

Schematic Page Printed Paper



Printing Your Design 4-67

n 
 
 to 

 
-13:

er.

Scug.bk : 04DESGNS.FMK  Page 67  Monday, June 16, 1997  10:10 AM
With the zoom factor set to 200%, a B-size drawing will print o
eight sheets of paper as shown in Figure 4-12. Doubling the
zoom factor quadruples the number of printer pages needed
print a schematic.

      

With user-definable zoom enabled, the printer configured in
portrait mode and a 100% zoom factor, as shown in Figure 4

• An A-size schematic will print on two sheets of A-size 
paper.

• A B-size schematic will print on two sheets of A-size pap

Figure 4-12 Zoom Factor Set to 200% with Printer 
Configured in Portrait Mode

B-size

A-size A-size

A-size A-size

A-size A-size

A-size A-size

Schematic Page Printed Paper
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In landscape mode, using a 100% zoom factor, as shown in
Figure 4-14:

• An A-size schematic will print on one sheet of A-size pap

• A B-size drawing will print on four sheets of A-size pape

B-size

8 1/2 x 11 8 1/2 x 11
11 x 8 1/2

17 x 11

A-size

Figure 4-13 User-definable Zoom Enabled in Portrait Mode

8 1/2 x 11 8 1/2 x 11

Schematic Page Printed Paper

Schematic Page Printed Paper
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B-size

11x 8 1/2

Schematic Page

A-size

11x 8 1/2

Printed Paper

A-size

Figure 4-14 User-definable Zoom Enabled in Landscape 
Mode

17 x 11

11 x 8 1/2 11 x 8 1/2

11 x 8 1/211 x 8 1/2
Schematic Page Printed Paper
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Closin g the Schematic 
Editor
You can close the schematic editor, thereby closing all open
schematics. You can also close an open schematic without 
exiting the schematic editor.

Closin g the schematic editor

To exit the schematic editor and close all currently open 
schematics, do one of the following:

• From the File menu, select Exit.

• In the upper-right corner of the schematic editor window
click the Close button.

You will be prompted to save any unsaved open schema

Closin g a schematic

To close a schematic without closing the schematic editor:

• Select Close from the File menu.

• In the upper-right corner of the design window, click the 
Close button.

If the current schematic has not been saved, you will be 
prompted to save it.
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Overview
The symbol editor enables you to do the following tasks:

• create and edit symbols for use in the schematic editor

• edit existing libraries

• create new libraries

This chapter provides background information about the sym
editor, which includes:

Starting the Symbol Editor on page 5-5 describes procedures for
starting and closing the symbol editor.

Symbol Editor Window on page 5-7 describes the use of menus
the Toolbar and toolbar buttons, the status line and the keybo
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Changing Text Characteristics on page 5-12 describes 
procedures for changing the text characteristics of attribute te
pin name and number display, and free-standing text.

Changing Grid and Gravity on page 5-16 describes enabling and
disabling grid, setting grid spacing, setting gravity and using
text grid.

Zooming and Panning on page 5-20 references the zoom and 
pan features of the symbol editor.

Printing Symbols on page 5-21 describes how to print the 
symbols created with the symbol editor.
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Components
A component or device has several aspects associated with

• symbol—the graphical representation used in drawing 
schematics

• packaging information—defines the names of the packa
types (footprints) in which the component is available, th
pin number assignments for those package types, and th
number of gates (for multi-gate components)

• footprint—used for board layout

• simulation model—if the component can be simulated wi
PSpice A/D

Symbols
Symbols are created and modified with the symbol editor, a
are stored in symbol libraries (.slb). Symbols consist of 
graphics, pins (for electrical symbols), and attributes.

Packaging Information
Packaging information for a component is closely related to 
symbol but is kept separately in a package definition. Packa
definitions are stored in package libraries (.plb).   The 
association of the symbol and the packaging definition is by
name. Generally, you will create a symbol with a given nam
and a package definition with the same name. If you use the
Symbol Creation Wizard in Schematics to create symbols, it w
automatically create a package definition for you.
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Package definitions are created and modified with the 
Schematics symbol editor. They are also used, and can be 
created and modified, in the MicroSim PCBoards PCB layou
editor.

Footprints
The footprint for a component is the definition of its mechanic
outline, pad pattern, identifiers, and physical extent (boundar
The package definition for a symbol defines the names of th
footprints (package types) in which it is available. For each 
footprint, the package definition defines the physical pin 
number assignments for the pins. When a symbol is placed o
schematic, the PKGTYPE attribute defines the name of the 
footprint to be used in the layout.

Footprints themselves are created and maintained with the 
MicroSim PCBoards PCB layout editor. Refer to the Creating 
Footprints using the Footprint Editor chapter in the MicroSim 
PCBoards User’s Guide.

Simulation Models
If a component can be simulated, it will have an associated 
simulation model. The MODEL attribute on a symbol defines
the name of the simulation model. Simulation models are sto
in model libraries (.lib). You can create new simulation mode
with Parts or with a text editor. Refer to the Creating Models 
chapter in your PSpice user’s guide.
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A quick way to edit a symbol for 
a part used on a schematic:

1 Click the part on the 
schematic to select it.

2 Click the Edit Symbol button 
on the toolbar.

The symbol editor is started, the 
library containing the symbol is 
loaded, and the symbol is 
displayed for editing.
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Startin g the Symbol 
Editor
Startin g the s ymbol editor

In the schematic editor, click the Edit Symbol button to creat
new symbol editor document window if one does not alread
exist. 

If you already have a symbol editor window open, you will b
prompted to save any unsaved changes to the active symbo
You can only have one symbol editor window open at a time

When you save the symbol library, any open schematics are
updated with the changes made in the symbol editor.

Loadin g a Librar y for Editin g
To edit or create symbols or package definitions in an existi
library, you must first load the library for editing. You can als
create a new library to contain the symbols or package 
definitions that you create.

Openin g an existin g librar y

1 Click the Open File button on the toolbar.

2 Type the name of the library in the Open dialog box.

3 Click OK.

Creatin g a new librar y

1 Click the New File button on the toolbar.

2 You are prompted to name the library when you save th
first symbol.

Any symbol or package definition you create will be saved in t
new library.
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Savin g your Chan ges
To save newly created symbols or changes to existing symb

1 Click the File Save button on the toolbar.

If the library is not configured for use in the schematic editor
you will be asked if you want to configure the library. Answe
YES to make the symbols in the library available for use in 
Schematics.

If the library is already configured, any schematics using 
symbols you have changed will be updated to use the new 
symbol.

Returnin g to the Schematic 
Editor
To return to the schematic editor and keep the symbol edito
window open for additional symbol editing, do one of the 
following:

• minimize the symbol editor window

• click in the schematic editor window

• select the schematic editor window from the Window me

When you are finished with the symbol editor, close the symb
editor window by clicking the Close button in the upper-right
corner, or select Close from the File menu.

Startin g Automaticall y
If you are going to use the symbol editor more than the 
schematic editor, you can have the symbol editor start 
automatically when you start Schematics. Add the -sym opti
to the Command Line in the Windows Program Item Propert
dialog box for the Schematics icon. For example:

C:\MSIM\psched.exe -sym
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Symbol Editor Window
When you start the symbol editor, the symbol editor window
displays.

Note You can only open one symbol editor window at a 
time and you can only edit one symbol at a time.

Refreshin g the Screen
To clean up and refresh the screen, click the Redraw button
the toolbar.

Menus
There are a series of menus from which you can select the 
function you want to perform.

The display and operation of the menus and submenus follo
the standard Windows layout and operation.
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Schematics provides different menus for the schematic edito
and for the symbol editor. The menus change as you chang
active windows.

Toolbar
Toolbar buttons provide shortcuts for performing common 
actions. 

To enable or disable the Toolbar display:

1 From the View menu, select Toolbar.

A check mark next to the Toolbar menu item indicates th
the toolbar is displayed.

Table 5-1 Symbol Editor Toolbar Buttons

Buttons Name Function Pa ge

New File creates a new symbol file 5-5

Open File opens an existing symbol file5-5

Save File saves the active symbol file 5-6

Zoom In views smaller area of the 
symbol

3-42

Zoom Out views a larger area of the 
symbol

3-42

Zoom Area views a selected area of the 
symbol

3-44

Zoom to Fit 
Symbol

fits the symbol view to the 
page

3-44

Draw Arc draws an arc shape on the 
symbol

6-10

Draw Box draws a box on the symbol 6-11

Draw Circle draws a circle on the symbol 6-11
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Draw 
Polyline

draws a polyline or line on 
the symbol

6-11

Place Pins places pins on the symbol 6-12

Draw Text places a text string on the 
symbol

6-12

Insert 
Picture

imports a bitmap (.bmp, 
.dib) or Windows metafiles 
(.wmf, .emf)

4-57

Edit 
Attributes 

edit the attributes of a symbol6-44

Get New 
Part

gets a symbol from a symbol 
library for editing

6-20

New 
Symbol

starts the Symbol Wizard 6-3

Redraw refreshes the symbol editor 
screen display

5-7

Table 5-1 Symbol Editor Toolbar Buttons

Buttons Name Function Pa ge
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Title Bar
The symbol editor window title bar displays the name of the
symbol library and the symbol currently being edited. For 
example:

[C:\MSIM\LIB\PORT.SLB:GLOBAL]

When you open a symbol editor window and have not specif
a symbol for editing, the title bar displays:

<new>:<new>

This indicates you are editing a new symbol in a new library
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and 8 are toggle keys. 
Pressing the key enables the 
feature, and pressing S 
plus the key disables the feature.
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Keyboard
Table 5-2 lists the function keys you can use instead of menu 
selections to enable or disable certain functions. For those 
functions that toggle, pressing the function key enables the 
feature, and pressing S plus the function key disables the
feature. 

Table 5-2 Symbol Editor Function Keys

Key Action Menu Selection

1 Help Help

2 grid on Options Display Options

4 text stay-on-grid Options Display Options

5 auto-scroll Options Pan & Zoom

6 stay-on-grid Options Display Options

8 auto-repeat Options Auto-Repeat

0 current errors File Current Errors
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Changing Text 
Characteristics
For any text placed on your symbol, such as free standing te
pin names, attribute names, and values, there are options to
the desired text size, orientation, horizontal justification, and
vertical justification.

Attribute Text
You can change the text characteristics of any attributes of 
symbol. The text characteristic changes you make are only 
applied to the attribute that you are currently editing.

Changing attribute text characteristics

1 Double-click the text to display the Change Attribute dialo
box.

Change any of the characteristics of the text in the Displ
Characteristics frame of the dialog box, as shown in 
Table 5-3.
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2 Click OK.

Table 5-3 Display Characteristics

Characteristic Explanation

Orient: Enables you to position the text 
horizontally, vertically, upside down, or 
down in relation to the defining point of the 
text string.

Layer: Specifies a text display level as defined by 
the Set Display Level function under the 
Options menu. Defaults to Attribute Text 
Layer. You can specify a user defined layer

Size: Determines the size of the text of a 
displayed text item. The size is expressed a
a percentage of the default size (the defaul
size is the font size for the selected layer).

Hjust: Sets the horizontal justification for the 
placement of text items (left, center, or 
right).

Vjust: Sets the vertical justification for placing 
text items (top, normal, or bottom).
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Pin Name and Number

Changing pin name text characteristics

1 Double-click the pin name or pin number to display the 
Change Pin dialog box.

2 Change any of the text characteristics as shown in 
Table 5-3.

3 Click OK.

Changing pin number text characteristics

1 Double-click the pin name or pin number to display the 
Change Pin dialog box.

2 Click Edit Attributes to display the Attributes dialog box.
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3 Click to select an item in the list.

Change any of the characteristics of the text in the Displ
Characteristics frame of the dialog box, as shown in 
Table 5-3.

4 Click OK.

5 In the Change Pin dialog box, click OK.

Free-Standin g Text
You can change the text characteristics of any of the free-
standing text that you have placed on the symbol. The chan
you make are only applied to the text item you are currently
editing.

Changing free-standin g text characteristics

1 Double-click the text to display the Change Text dialog bo

Change the orientation, justification or size, as shown in
Table 5-3 on 5-13.

2 Click OK.
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Changing Grid and 
Gravit y
The grid and gravity functions of Schematics eases your 
drawing tasks and can help make your schematic more prec

Grid On
When Grid On is enabled, the grid is displayed in the drawin
area of the schematic editor window.

Enablin g or disablin g the grid displa y

1 Select Display Options from the Options menu to display
the Display Options dialog box.

2 Select or clear the Grid On check box to enable or disab
the grid display.

A check mark in the check box indicates that the grid is 
enabled.

3 Click OK.

Stay-on-Grid
Stay-on-grid controls the method of object placement. When
Stay-on-Grid is enabled, the objects are forced onto grid wh
placed. We recommend that you enable this so that electric
connections are made correctly.

Enablin g or disablin g stay-on-grid

1 Select Display Options from the Options menu.

2 Select or clear the Stay-on-Grid check box to enable or 
disable Stay-on-Grid.

3 Click OK.
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Snap-to-Grid
Snap-to-grid controls the movement of the object while bein
moved for placement. If Snap-to-Grid and Stay-on-Grid are 
both enabled, movement during object placement is in 
increments equal to the current grid spacing. If Snap-to-Grid
Stay-on-Grid is not selected, the object moves smoothly.

Enablin g or disablin g snap-to- grid

1 From the Options menu, select Display Options.

2 Select or clear the Snap-to-Grid check box to enable or 
disable snap-to-grid.

3 Click OK.

Grid Spacin g
Grid Spacing defines the horizontal and vertical grid spacing
your drawing area. The default spacing is 10 units. This 
corresponds to (and displays as) 0.10 inches for US-standa
page sizes, and 2.5 millimeters for metric page sizes. The 
minimum grid spacing allowed is 0.01 inch, or .25 millimeter

Specif ying grid spacin g

1 From the Options menu, select Display Options.

2 In the Grid Spacing text box, type the grid spacing value

3 Click OK.

Gravit y
The gravity setting determines how close the pointer must be
an object for the object to be selected when you click the poin
The default is .03 inches (or .75mm).
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Specif ying gravit y

1 From the Options menu, select Display Options.

2 In the Gravity text box, type the snap-to-pin gravity value

3 Click OK.
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Text Grid
Text Grid allows you to set the grid spacing for text separate
from the normal grid spacing. The text grid is usually set to so
smaller percentage of the regular drawing grid. This allows y
to align text along smaller increments of the regular grid.

Enablin g text grid and specif ying text grid size

1 From the Options menu, select Display Options.

2 Select the Text Stay-on-Grid check box to enable the tex
grid.

A check mark in the check box indicates that the text grid
ON.

3 Type the text grid spacing value in the Spacing text box.

4 Click OK.
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Zoomin g and Pannin g
The zoom and pan features in the symbol editor are the sam
they are in the schematic editor. Refer to Zooming and Panning 
in Schematics on page 3-42.
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Printin g Symbols
Printin g a symbol

1 From the File menu, select Print to display the Print dialo
box.

 

2 To select the part or parts to be printed, do the following

a Select the Current Symbol Only check box to print th
symbol being edited.

b Select one or more parts from the Parts list.

c Click Select All Parts to print all parts in the open 
library.

3 In the Content Options frame, select the check box to ena
printing. The Content Options are described in Table 5-4.

4 Select one of the Scaling options.

• Auto-fit expands the symbol to full page size. 

• User-definable enables you to specify the zoom fact
for the size of the symbol.

5 Select an Orientation: Landscape or Portrait.

6 Click OK.
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Table 5-4 Content Options

Option Description

Symbol Image specifies printing the graphics of the 
selected symbol

Attributes specifies printing the attributes and 
the attribute values of the selected 
symbol

Symbol Data specifies printing the description, 
type, Bbox dimensions, and origin 
position of the selected symbol

Pin Data specifies printing the pin data of the 
selected symbol
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Creatin g and Editin g 
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Overview
This chapter describes how to use the symbol editor to copy
create and edit symbols, which includes:

Creating New Symbols on page 6-3 describes the four essentia
methods of creating a new symbol.

Drawing Symbol Graphics on page 6-10 describes the 
assortment of drawing tools provided for creating and editing
symbol.

Editing Existing Symbols on page 6-20 describes the editing 
features for defining and editing pins, and for defining and 
editing packaging definitions.

Editing Symbol Attributes on page 6-30 describes how to add 
and edit the properties of a symbol.

Using Symbol Aliases on page 6-33 describes how to give a 
symbol an alternate name.

Specifying Part Packaging Information on page 6-34 describes 
procedures for defining packaging information.
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Configuring Custom Libraries on page 6-48 describes the 
procedure for making a custom library available in Schemat
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If you are creating a symbol for 
an existing simulation model, 
refer to the Creating Symbols for 
Models chapter in your PSpice 
user’s guide.
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Creatin g New Symbols
Following are the four methods for creating a new symbol:

1 Using the Symbol Wizard. 

• Use the wizard to create symbols from scratch. The 
wizard guides you through the steps for creating a 
symbol and also creates packaging information for th
symbol.

• Use the wizard to create symbols automatically for 
existing models.

2 Making a copy of an existing symbol under another nam
and modifying the copy.

3 Importing a symbol definition exported by another 
Schematics user.

4 Creating an A Kind Of (AKO) symbol, which is a referenc
of any existing symbol.

Usin g the Symbol Wizard
The Symbol Wizard helps you to create new symbols.

Following are some of the features and benefits of using the
Symbol Wizard:

• eases the creation of symbols by guiding you through ea
step of the process

• provides simple point-and-click dialog boxes

• provides feedback as you make decisions

• avoids using complicated mouse or keyboard interaction

• enables you to navigate through the symbol creation proc
by backing up to repeat a step and moving forward

When you start the Symbol Wizard you are taken through a
progression of screens, which provide you with information, a
you questions, and present you with choices, based on your
selection in the first screen (shown below). 
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Startin g the Symbol Wizard

1 From the Part menu, select Symbol Wizard.

2 Follow the instructions that appear on the screen.
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If there is packaging information 
associated with the symbol, use 
the Copy selection from the 
Packaging menu to similarly 
copy the package definition.
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Creatin g a Symbol b y Copying 
Another S ymbol
An easy way to create a symbol is to make a copy of a simil
symbol and modify the copy.

Makin g a Copy of a Symbol

Copying a symbol from another librar y

1 From the Part menu, select Copy to display the Copy Pa
dialog box.

2 Click Select Lib in the Open dialog box, and select a libra

Schematics lists all of the library parts in the Parts box.

3 Type the name of the part to be copied in the Existing P
Name text box, or select it from the Part list.

4 Type a new name for the part in the New Part Name tex
box.

5 Click OK.

You can now edit the symbol. Saving the symbol places it in 
current library.

Creatin g a new s ymbol in a different  librar y

1 From the Part menu, select Save to Library.

2 Type the name of the library (.slb) where the symbol is to 
saved.
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Importin g a symbol definition
Import enables you to import a symbol that has been previou
exported (see Exporting a symbol on page 6-6) and incorporate 
it into a symbol library file.

Importin g a symbol

1 From the Part menu, select Import to display the Import 
dialog box.

2 In the File Name text box, type the name of the file to be
imported, or select the file name from the file selection li

3 In the Part Name text box, type the name to be given to 
imported symbol.

4 Click OK.

Exportin g a symbol

Export allows you to write a symbol definition from the open
symbol library to a text file, enabling you to transfer symbols
from one library to another, or from one platform to another,
without having to transfer the entire symbol library.

1 From the Part menu, select Export to display the Export 
Parts dialog box.
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2 In the Part Name text box, enter the name of the symbo
be exported, or select it from the list.

3 In the File Name text box, enter the name of the file to whi
the part definition is to be written.

4 Click OK.

Usin g AKO Symbols
Some of the MicroSim symbol libraries are made up of a few
base symbols and several AKO (A Kind Of) symbols. In the 
bipolar.slb  symbol library, for example, the qnpn and qpn
symbols are base symbols. All other symbols reference one
these two base symbols.

A base symbol must be contained in the same library as the
AKO symbols that reference it. Base symbols do not, however, 
have to be displayed in the Part Browser.

If you copy an AKO symbol from another library (see Creating 
a Symbol by Copying Another Symbol on page 6-5), you must 
also copy its base symbol.

Creatin g a base s ymbol in a custom s ymbol 
librar y

1 From the Part menu in the symbol editor, select New.
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2 Enter a name for the part in the Part Name text box 
(TestCase, for example).

3 Enter a description of the part in the Description text box

4 Leave the AKO Name text box blank, and select Do not 
display in the Part Browser check box.

5 Click OK.

Savin g the s ymbol to a librar y

1 From the File menu, select Save.

2 In the File Name text box, type the name of the library.

3 Click OK.

4 In the Configure dialog box, answer Yes to “Add to list o
Schematics configured libraries?”

Now you can draw a symbol using the procedures given in 
Drawing Symbol Graphics on page 6-10 and Defining and 
Editing Pin Types on page 6-23.

You have defined this to be a base symbol by leaving the AK
Name text box blank and selecting the Do not display in the P
Browser check box.

After you have created the base symbol, you can create oth
symbols that reference the base symbol (that is, AKO symbo
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Creatin g an AKO s ymbol

1 From the Part menu in the symbol editor, select New.

2 In the Part Name text box, type a name for the part.

3 In the Description text box, type a description of the part

4 In the AKO Name text box, type the name of the base 
symbol (or example, AKO Test).

5 Click OK.

The symbol graphics of the base symbol display in the symb
editor window.

Select Save from the File menu to save the custom symbol 
library.
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Drawin g Symbol 
Graphics
There are several graphics tools available for drawing symbo
With these tools you can draw circles, lines, arcs, and boxes
You can also place pins and text on your symbol. The defau
properties of the individual display layers, such as colors, lin
width, and style are set in the Display Preferences dialog bo
See Controlling the Display in Schematics on page 3-34 or 
Adding Non-Electrical Information on page 4-50 for 
information on how to change display properties.

Elements of a S ymbol
A symbol consists of various elements, such as arcs, boxes
lines, circles, polylines, text, and pins placed in specific 
locations.

Arc

Drawin g an arc

1 Click the Draw Arc button to change the pointer to a pen
shape.

2 Click to establish an end-point for the arc.

3 Click again to establish the other end-point for the arc.

A straight dotted line connects the two end-points.

4 Move the pointer out from the last end point, and the dott
line becomes an arc. When the arc reaches the desired sh
click to fix the arc at that location.
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Box

Drawin g a box

1 Click the Draw Box button to change the pointer to a pen
shape.

2 Click at the location for the upper-left corner of the box.

3 Move the pointer down and to the right.

A dotted box outline follows the pointer.

4 Click to set the lower-right corner of the box.

Circle

Drawin g a circle

1 Click the Draw Circle button to change the pointer to a 
pencil shape.

2 Click the location of the center of the circle.

3 Move outward from the center of the circle.

A dotted circle outline follows the pointer.

4 Click when the diameter reaches the size you want.

Polyline

A polyline is one object, regardless of the number of vertices
contains. It can be manipulated using editing functions such
move, cut, copy, and delete. A polyline may also be resized
clicking on any of its handles and stretching it to a new size

Drawin g a pol yline

1 Click the Draw Polyline button to change the pointer to a
pencil shape.

2 Click to establish the beginning point of the polyline.

As you move the pointer, a dotted line outlines the shap

3 Click to place as many vertices as needed.
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When the pointer is over a 
handle, it will change shape to 
indicate the object may be 
resized (see 6-19).

If you decide you don’t want to 
apply the changes you have 
made, click the Restore Defaults 
button to restore the settings 
selected in the Display 
Preferences dialog box. The 
Restore Defaults button works at 
any time before closing the 
dialog box or after re-entering it.

Note When placing pins, the 
pin type defaults to the type 
that was last placed, or to the 
type last specified.

The procedures for defining and 
editing pins begin on 6-23.
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4 Double-click to establish the end point of the polyline, or
right-click at any point to stop drawing.

Addin g arrowheads to pol ylines

1 Select one or more polylines.

2 From the Edit menu, select Graphics Properties.

3 Select the appropriate arrowhead properties.

4 Click OK.

Pins

Addin g pins to a s ymbol

1 Click the Place Pins button to change the pointer to a pi
outline.

2 Move the pin outline to the desired location and click to 
place the pin.

A small ‘x’ appears on one end marking the connectivity
point of the pin.

3 Click at each location to place additional pins.

4 Do one of the following:

• Double-click to place the last pin.

• Right-click to stop placing pins without placing an 
additional pin.

Text

Addin g text

1 Click the Draw Text button to display the Add Text dialog
box.
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2 Type the text in the text box.

3 Click OK.

An outline box follows the pointer that indicates the outlin
of the text string.

4 Move the outline to the desired location and click to plac
the text.

The outline box remains on the screen. You can click to 
place the same text string in several locations.

5 To stop placing the text string, do one of the following:

• Double-click to place the last instance of the text.

• Right-click to stop placing the text string without 
placing an additional one.

Editin g a text strin g or chan ging text 
characteristics

1 Double-click the text string to display the Change Text 
dialog box.

2 Make the desired changes to the text and its characteris

Instructions for setting text characteristics are included in
the previous chapter. See Changing Text Characteristics on
page 5-12.

3 Click OK.

Picture

You can import bitmap (.bmp, .dib), Windows metafiles (.wmf
or enhanced metafiles (.emf) into a symbol while working in t
symbol editor.

Importin g a graphic

1 From the Graphics menu, select Insert Picture to display 
Open dialog box.

See Importing Bitmaps and Metafiles on page 4-57 for further 
instruction regarding importing bitmaps and metafiles.
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Selectin g

Selectin g an element of a drawin g

1 Click to select the element.

The object color (the default is set in the Display 
Preferences dialog box) indicates it is selected.

2 Move or edit the object as necessary.

Selecting a new object causes any previously selected ite
to be unselected.

Selectin g more than one element

1 Hold down S while selecting the elements.

The selected elements change color.

Selectin g all elements within a given area of the 
drawin g

1 Select the area by dragging the pointer across the desire
area.

A selection rectangle appears to indicate the selection 
boundary. Only items entirely contained within the 
boundary are selected.
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You can also double-click 
shapes to display the Graphics 
Properties dialog box.

Note Polylines do not have to 
be closed to be filled.

If you decide you don’t want to 
apply the changes you have 
made, click the Restore Defaults 
button to restore the settings 
selected in the Display 
Preferences dialog box. The 
Restore Defaults button works at 
any time before closing the 
dialog box or after re-entering it.
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Fillin g Shapes
Shapes that have been drawn using either the schematic ed
or the symbol editor may be filled with color. In the symbol 
editor you can fill circles, rectangles, and polylines. Use the
Graphics Properties dialog box to change properties on an 
instance basis, but use the Display Preferences dialog box to
the defaults of those properties (see Changing Graphics 
Properties on page 4-55).

Fillin g a shape after it has been drawn

1 Select one or more shapes to fill.

2 From the Edit menu, select Graphics Properties.

3 Select a color, width, and line style for the frame of the 
graphic.

4 Select a color to fill the shape with.

5 Click OK.
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Example: Object number one 
was in front of two and three, but 
the Send to Back operation 
moved it behind objects two and 
three.
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Orderin g Drawin g Objects
When you draw or paste an object in the symbol editor, 
Schematics places it in front of all other objects on the page
in a graphics frame. If the object is filled, it can obscure othe
objects. You can control how objects overlap by putting them
front or in back of other objects.

Movin g objects in back of other ob jects

1 Select the object you want to place behind another obje

2 From the Edit menu, select Send to Back, which will plac
the object behind the other object.

Movin g objects in front of other ob jects

1 Select the object you want to place in front of another obje

2 From the Edit menu, select Bring to Front, which will plac
the object in front of the other object.
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Default

Rotated once

Rotating a Drawing Element

Default

Flipped once

Flipping a Drawing Element
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Rotatin g and Flippin g Elements
In the symbol editor, you can rotate and flip (mirror) elemen
currently being drawn, elements already drawn, and entire ar
of a drawing. A rotated element is rotated 90° counter-
clockwise. A flipped element is mirrored about the Y-axis.

Rotating and flipping must occur during one of the following

• while dragging (before placement)

• after placement

Rotatin g Elements

Rotatin g an element before placin g it

1 Select an element to be placed.

2 Press C+R to rotate it while still in the drag mode.

The image rotates 90° counter-clockwise. Each time you
press C+R, the image will rotate 90° counter-clockwise

Rotatin g an alread y placed element

1 Select the element.

2 Press C+R to rotate it 90° counter-clockwise.

Rotatin g an area of the drawin g

1 Drag the pointer to select and outline the area to be rota

2 Press C+R to rotate the area.

The selected area rotates 90° counter-clockwise about t
center point of the selected area.

Flippin g Elements

Flippin g an element before placin g it on the 
drawin g

1 Press C+F to flip the element, while still in the drag 
mode.
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Flippin g an alread y placed element

1 Select the element.

2 Press C+F to flip it.

Flippin g an area of the drawin g

1 Drag the mouse to select and outline the area to be flipp

2 Press C+F to flip the area about its vertical axis.
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An arrow will display when you 
drag the pointer over a handle to 
indicate that it may be resized.

Scug.bk : 06SYMBLS.FMK  Page 19  Monday, June 16, 1997  10:10 AM
Movin g

Movin g an ob ject

1 Select an object (or group of objects).

2 Place the pointer on the edge of the object or selected a
and the annotation movement cursor becomes attached
the pointer.

3 Drag and place the object at the desired location on the p

Resizin g
Objects that have already been drawn can be resized by usin
appropriate handles. 

Resizin g an ob ject

1 Select the object that you want to resize.

2 Click one of the handles and drag to resize the object.
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Editin g Existin g 
Symbols
To edit an existing symbol, you must first load the library tha
the symbol is stored in. After the symbol is loaded, it can be
edited by using all of the common editing functions that are 
available. To edit packaging information for a symbol, see 
Editing a Package Definition on page 6-37.

Accessin g Symbols

Loadin g a symbol librar y

1 Click the File Open button on the toolbar.

2 Type a library name in the Open dialog box.

3 Click OK.

Selectin g a part for editin g

1 From the Part menu, select Get to display the Get dialog
box.

2 Select a part from the list.

3 Click Edit.



Editing Existing Symbols 6-21

s are 
ard 

 

e 
on. 

d in 

Shortcut: press C+X

Shortcut: press C+C
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Cuttin g, Copying, and Pastin g
The symbol editor has editing functions to cut, copy, paste, 
repeat, delete, and undelete selected objects. These function
available under the Edit menu, or can be accessed with keybo
shortcuts.

The cut, copy, and delete functions apply only to selected 
objects. See Selecting on page 6-14 to learn how to select single
and multiple objects as well as objects within a given area.

Cuttin g

Cut deletes the selected object (or group of objects) from th
drawing and copies it to a buffer for use with the Paste functi
Only the last objects cut are retained.

Cuttin g a selected ob ject

1 Select the object to cut.

2 From the Edit menu, select Cut.

Copying

Copy makes a copy of the selected object for pasting. The 
selected object remains on the schematic and a copy is place
the buffer.

Copying a selected ob ject

1 Select the object to copy.

2 From the Edit menu, select Copy.
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Shortcut: press C+V
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Pastin g

Paste places one or more copies of the last object stored in
buffer (from a cut or copy operation) onto the drawing.

Pastin g an ob ject

1 From the Edit menu, select Paste to change the pointer to
shape of the object that was last cut or copied.

2 Click to place the object on the schematic.

Continue moving the pointer to various locations and clicking
place additional copies of the object.

3 To stop pasting the object, do one of the following:

• Double-click to paste the last instance of the object.

• Right-click to stop pasting without pasting another objec

With Auto-Repeat enabled, use M to place repeated copies o
items from the buffer without using the Paste function.

Deletin g

Delete removes an object (or set of objects). A deleted obje
cannot be copied or pasted.

Deletin g a selected ob ject

1 Select the object to delete.

2 Press D.
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Definin g and Editin g Pin 
Types
Pins establish the input and output terminals for symbols. Fo
pin you can:

• select the type of graphic to display.

• specify a pin name.

• specify a pin number.

• choose to display the name, the number, or both.

Specif ying Pin Types
Figure 6-1 shows the twelve types of pins that you can place
using Schematics.

Figure 6-1 Pin Types

Normal

Bubble

Clock

Bubble Clock

ANSI Inverted Out

ANSI Inverted In

ANSI Inverted Clock

Zero Length

Normal (Long)

Bubble (Long)

Clock (Long)

Bubble Clock (Long)
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Shortcut: press C+T

The Float= and Modeled Pin 
boxes in the Change Pin dialog 
are only relevant for symbols that 
are going to be simulated with 
PSpice. For additional 
information, refer to your PSpice 
user’s guide.
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Selectin g a default pin t ype

Note To specify the default pin type, do not select a 
specific pin when performing the following 
procedure. If a pin is selected, the pin type will only 
apply to that pin.

1 From the Edit menu, select Pin Type to display the Pin Ty
dialog box. (You can also double-click the pin to display th
Change Pin dialog box.)

2 Click the appropriate option to select the pin type.

3 Click OK.

Changing the t ype of a placed pin

1 Select the pin and from the Edit menu, select Change.

2 In the Type list box, select a pin type.

3 Click OK.

The change is only in effect for the selected pin.
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To create pin names with 
overbars, use the ‘\’ character, 
for example, \CLK\

Use the Pin List selection from 
the Part menu to view and edit 
the list of all pins for the symbol.
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Changing the pin name

As you placed pins, default names were assigned. 

To change the name of a pin, do the following:

1 Double-click the pin or pin name.

2 In the Change Pin dialog box, type the pin name in the P
Name text box.

3 Click OK.

Note Pin names MUST be unique.

Changing the pin number

As you placed pins, default pin numbers were assigned. 

To change the pin number for a pin, do the following:

1 Double-click the pin or pin number of the displayed pin t
display the Change Pin dialog box.

2 In the Pin text box, type the pin number.

3 Click OK.

Displa ying the pin name

By default, pins you place on symbols will have their pin nam
displayed. 

To disable pin names, do the following:

1 Double-click the pin or pin name to display the Change P
dialog box.

2 Select the Display Name check box to disable the name
display.

3 Click OK.

Displa ying the pin number

By default, pins you place on symbols will have their pin 
numbers displayed. 

To disable pin numbers, do the following:

1 Double-click the pin or pin number to display the Chang
Pin dialog box.
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2 Click the Edit Attributes button to display the Edit 
Attributes dialog box.

3 Select the PIN= entry in the list.

4 In the What to Display frame, select None to disable the p
number display.

5 Click Save Attr.

6 Click OK.

7 In the Change Pin dialog box, click OK
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If you set the visibility off, you 
must supply the name of a 
connecting net (typically a global 
net like $G_DPWR or 
$G_DGND) for the pin in the Net 
text box.

You can also select the pin and 
select Change from the Edit 
menu.

When you place the part on a 
schematic, you can change the 
power or ground net to which the 
part is connected, by changing 
the value of the attribute.
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Definin g and Editin g Hidden 
Power and Ground Pins
With the symbol editor, you can set a pin to be invisible. If yo
set the visibility off, you must supply the name of a connecti
net (typically a global net like $G_DPWR or $G_DGND) for th
pin in the Net text box. The net is recorded as a symbol attrib
(not a pin attribute). The IPIN(<pinname>)=<net name> attribute 
conveys the net name.

If $G_<net names> are used for simulation reasons (this is 
case in MicroSim supplied libraries), they can be mapped to
more conventional menu for printed circuit board purposes 
through the .xnt files. For a specific printed circuit board layo
editor, there is a <toolname>.xnt file that will convert a 
schematic net name into a different one. 

Note It is possible to map two distinct schematic net 
names into the same PCB net name, shorting the 
two together.

Definin g a hidden pin

1 Double-click the pin to display the Change Pin dialog bo

2 Select the Hidden check box.

3 In the Net text box, type the name of the net to which the
hidden pin is to be connected.

4 Click OK.
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Changing Symbol Ori gin and 
Boundin g Box
The origin is designated for placing a part, and is the point t
part is rotated around. By default, the origin is at (0,0). It is 
maintained as a point of reference on the schematic.

The bounding box defines the selection area of the symbol w
placed on a schematic. After drawing a symbol, all of the 
elements of the symbol must be enclosed in the bounding b

Origin

By default, part symbols in the symbol libraries have the orig
on the point of connection, on the upper-left pin. You can mo
the origin to any point on the symbol.

Note When creating a symbol from scratch, the origin is 
placed in the upper-left corner of the bounding box. 
You can move it to a location of your choice after 
creating the symbol.

If you change the origin of a symbol in the symbol editor (thu
changing the location of the symbol graphics relative to that
point), the symbol graphics relocate accordingly in the 
schematic editor whenever you edit previously created 
schematics.

Editin g a part ori gin

1 From the Graphics menu, select Origin to change the poin
to a pencil shape.

2 Move the pointer to the point on the object where you wa
to place the origin and double-click to fix the origin at tha
point.
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• All pins must be contained 
within the bounding box for 
proper connections to be 
made in the schematic editor.

• Hidden pins, like those found 
on digital parts, do not have 
to be, and in most cases are 
not, contained within the 
bounding box.

• Attributes do not need to be 
contained within the 
bounding box.
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Boundin g Box

The bounding box is the rectangular dotted line surrounding 
symbol. When you click a part from within the schematic edito
the area in which you can click and have that part be selecte
defined by the bounding box of the symbol.

Resizin g the boundin g box

1 From the Graphics menu, select Bbox to change the poin
to a pencil shape.

2 Click to begin sizing the bounding box.

3 Move the pointer down and to the right. A dotted box outlin
follows the pointer.

4 Click at the location of the lower-right corner of the 
bounding box.
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Editin g Symbol 
Attributes
You can add attributes (properties) to a symbol. When you a
an attribute, you specify a name and a default value. This va
can be changed when the symbol is used on a schematic. Y
can specify whether or not to display the attribute.

There are two attributes that are automatically added to symb
that are created. 

• The REFDES attribute, whose default value is U?, specif
the reference designator pattern to use in the schematic
editor.

• The PART attribute displays the symbol’s name. 

Note When the symbol is placed on the schematic, 
Schematics automatically fills in the value of the 
PART attribute to be the name you used to place 
the symbol. For example, if the symbol has several 
aliases, it fills in the alias that you used. Therefore, 
you can assign a value in the symbol editor and 
use it to place the text on the symbol, but when the 
symbol is used, the value will be reassigned.

Addin g an attribute

1 From the Part menu, select Attributes to display the 
Attributes dialog box.
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2 In the Name text box, type the name of the attribute.

3 Optionally, type in the default value in the Value text box

4 By default, the attribute Value only displays on the symbo
To disable any display, select None in the What to Displ
frame.

5 By default, the attribute value can be changed in the 
schematic editor on an instance-by-instance basis. To 
prevent changes to the attribute value, clear the Change
In Schematic check box to disable this function.

6 By default, attributes that are displayed do not have thei
text rotated if the symbol is rotated on the schematic (to
make it more readable). To have it rotate with the symbo
select the Keep relative rotation check box.

7 Click Save Attr.

8 Click OK.



6-32 Creating and Editing Symbols

s, 

Scug.bk : 06SYMBLS.FMK  Page 32  Monday, June 16, 1997  10:10 AM
Editin g a displa yed attribute

1 Double-click the displayed attribute.

To edit an undisplayed attribute, or to make multiple change
click the Edit Attributes button on the toolbar.
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The PART attribute you define 
on a symbol will have its value 
filled in when you place it on the 
schematic. The name that you 
call it up with will get filled in as 
the PART attribute’s value.
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Usin g Symbol Aliases
A symbol has a name. It can also have one or more aliases
associated with it. Aliases are alternative names that the de
represented by the part are known by. For example, you can
have a symbol named 74AC269,  which has as one of its aliase
HD74AC269P.

When defining an alias, keep in mind that the aliased device w
share the same graphics, pins and attributes as the primary
symbol. When you place it on the schematic, however, it is 
treated as a separate part type. The name displayed on the
schematic is that of the alias. Each alias requires its own 
packaging information. 

Addin g an alias for a s ymbol

1 From the Part menu, select Definition to display the 
Definition dialog box.

2 Type the name of the alias in the Alias list text box.

3 Click Add.

4 Click OK.
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Specif ying Part 
Packaging Information
If you are going to use a symbol for PCB layout, you will nee
to specify package or device information.

Package information consists of:

• the number of gates per package

• a list of package types (footprints) where the device is 
available

• one or more pin assignment lists

• functionally equivalent pins that can be swapped in layo

Package information is used by Schematics to package toge
gates and to generate layout netlists. It is also used by MicroS
PCBoards.

Pin Assi gnment Lists
A pin assignment list is a list of physical pin number 
assignments for each package type in which a device is 
available. Because a device may be available in several pack
types (DIP14, LCC20, and so on), and each may have differ
pin number assignments, a single package definition can con
more than one pin assignment list. Each pin assignment list
associated with a list of package types (footprints) that the p
number assignments are valid for.
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Note If you created a symbol 
with the Symbol Wizard, it will 
include creating a package 
definition.

Shortcut: press C+E
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Packaging Definitions
Packaging information is kept in a package definition, separ
from the symbol definition. Both are maintained using the 
symbol editor. By default, the name of the package definition 
a symbol corresponds to the symbol name. This can be 
overridden by explicitly adding a COMPONENT attribute to the 
symbol. Such an attribute is generally used for devices that h
non-standard part names such as BJTs, those with names t
begin with a ‘Q,’ or for those with more than one type of gate

Package definitions are stored in package libraries. These 
libraries typically have the same name as the corresponding
symbol libraries, but a different extension (“.plb”). Package 
libraries are similar to symbol libraries in that they must be 
configured into the schematic editor’s list of libraries.

With the Packaging menu in the symbol editor, you can crea
and edit package definitions.

Creatin g a New Packa ge 
Definition
You can quickly create a package definition for an existing 
symbol.

Creatin g a packa ge definition for an existin g 
symbol

1 Load the symbol in the symbol editor.

2 From the Packaging menu, select Edit.

3 Click OK to start the Package Wizard.

4 Follow the instructions on the screen.

Creatin g a packa ge definition from scratch

1 From the Packaging menu, select New to start the Pack
Wizard.

2 Follow the instructions on the screen.
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Copying a Package Definition
With the Copy function in the Packaging menu, you can cre
a new package definition from an existing one. It is the same
the Copy function under the Parts menu, the definition may 
copied from the active library or a different library. See 
“Making a Copy of a Symbol” on page 5.

Copying a packa ge definition

1 From the Packaging menu, select Copy to display the Co
Package Definition dialog box.

2 Type the name of the package to be copied in the Existi
Pkg Name text box. To select a package definition from 
another library, click Select Lib and select a library from th
File Open dialog box.

3 Type a new name for the package in the New Pkg Name 
box.

4 Click OK.
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Editin g a Package Definition
You can edit a package definition for the active symbol or fo
any package definition in the open package library.

Editin g the packa ge definition for the active 
symbol

1 From the Package menu, select Edit to display the Pack
definition dialog box.

The options within the dialog box are discussed in the 
following sections.

2 When you are finished with the dialog box, click OK.

Editin g a packa ge definition in the open packa ge 
librar y

1 From the Packaging menu, select Get to display the Ge
Package Definition dialog box.

2 Type the name of the package in the Pkg Name text box
click a name from the list.

3 Click Edit to display the Package Definition dialog box wit
the values for the requested package listed.

The options within the dialog box are discussed in the 
following sections.

4 When you are finished with the Package Definition dialo
box, click OK.

Editin g Package Types

When you are editing a package definition, you can specify 
package types in which a component is available. The pack
type name defines the footprint name to be used in layout.



6-38 Creating and Editing Symbols

pes 

es 

the 
pe 

Shortcut: press C+E

Note The Configured 
Package Types List is a list of 
commonly used package 
types; it is not an exhaustive 
list.

Scug.bk : 06SYMBLS.FMK  Page 38  Monday, June 16, 1997  10:10 AM
Addin g a packa ge type for a component

To add a new package type to the list of available package ty
for the component:

1 From the Packaging menu, select Edit to display the 
Package Definition dialog box with the values for the 
symbols listed.

2 Click Edit Package Types to display the Edit Package Typ
dialog box.

3 In the Package Types per Pin Assignment text box, type 
name of the package (for example, DIP14) or select a ty
from the Configured Package Types scroll list.

4 Click Add.

5 Click OK.
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If there are multiple package 
types with the same pin-outs, 
you can type them all on the 
same line, separating them with 
commas (for example, DIP14, 
SO14). Otherwise, repeat steps 
3 and 4 for each package type.
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6 In the Package Definition dialog box, click OK.
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alphanumeric.
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Specif ying physical pin numbers

For each package type (or group of package types that share
same pin-out) the physical pin numbers for each pin must b
defined. The Pin Assignments frame in the Package Definiti
dialog box shows the pin numbers assigned for each logical
on the symbol (for the active package type). 

Note The pin name must  match that used in the symbol. 
If the pin name does not match that used on the 
symbol, or you need to make a change, perform 
the following procedure.

Editin g pin numbers

1 From the Packaging menu, select Edit to display the 
Package Definition dialog box (shown on 6-38).

2 In the Package Types list, select the package type to be
edited.

3 Click Edit Pins to display the Pin Assignments dialog bo

4 In the list in the lower left of the dialog box, click the pin 
you want to edit.

The pin name and pin number appear in the boxes direc
above the list.

5 Make your changes in the Pin Name and Pin No. text box

6 Click Save Assignment.

Any changes you make to a pin assignment are not in eff
until you select Save Assignment. If you make a change
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a pin and then select another pin from the list without 
saving, the changes are not implemented.

7 When you are finished editing pins, click OK.

8 In the Package Definition dialog box, click OK.

Specif ying Information for Multi- gate 
Components

Definin g the number of gates and their gate 
names

1 From the Packaging menu, select Edit to display the 
Package Definition dialog box (see 6-38).

2 Click Edit Gate Types to display the Edit Gate Types dialo
box.

Parts that have the same gates have only one type of ga
(gate 1 by default). By defining the names of each gate, you 
also define the number of gates.

3 Select the entry in the list labeled 1.

4 In the Gates text box, type the names of the gates separ
by commas (for example, A,B,C,D).

5 Click Change.

6 Click OK.

7 In the Package Definition dialog box, click OK.



6-42 Creating and Editing Symbols

x 

r 

he 

After you have defined the 
names of the gates, you must 
define pin numbers for each pin 
in each gate.

On the symbol for the gate 
defined above, if there are any 
shared power pins, ground pins 
or both, you have to define them 
as hidden pins.
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Definin g pin number assi gnments

1 From the Packaging menu, select Edit to display the 
Package Definition dialog box (see 6-38).

2 Click Edit Pins to display the Pin Assignments dialog bo
(see 6-40).

3 In the Pin No. text box, type a pin number for each pin fo
each gate defined in the previous procedure.

4 Click Save Assignment.

5 Click OK.

6 In the Package Definition dialog box, click OK.

Definin g shared power and ground pins

1 From the Packaging menu, select Edit to display the 
Package Definition dialog box (see 6-38).

2 Click Edit Shared Pins to display the Shared Pin 
Assignments dialog box.

3 Type the name of the pin (as defined on the symbol) in t
Pin Name text box.

4 Type the physical pin number in the Pin No. text box.

5 Click Add.

6 Click Save Assignment.

7 Click OK.

8 In the Package Definition dialog box, click OK.



Specifying Part Packaging Information 6-43

r 
t to 

x.

nt 

 by 

ons 

Scug.bk : 06SYMBLS.FMK  Page 43  Monday, June 16, 1997  10:10 AM
Specif ying Which Pins Can Be Swapped

Pins within a gate that are logically equivalent to one anothe
can be swapped. Pin swapping is usually done during layou
minimize the complexities of circuit routing.

Enablin g pin swappin g

1 From the Packaging menu, select Edit to display the 
Package Definition dialog box (see 6-38).

2 Click Edit Pin Swaps to display the Pin Swaps dialog bo

3 In the Pin Names list, select two or more pins that you wa
to swap.

4 Click Assign.

The pin numbers appear in the Pin Swaps list separated
commas.

5 Repeat steps 3 and 4 for any other pin number combinati
that you want to swap.

6 Click OK.

7 In the Package Definition dialog box, click OK.
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Creatin g Components With Multiple Gate T ypes

Some components consist of two or more different types of 
gates (for example, ECL devices). Each type of gate will hav
different logical symbol with a unique name, but reference th
same package definition. For these types of components, yo
have to perform several additional steps in defining the pack

Associatin g more than one s ymbol with a 
component

For each symbol:

1 From the Part menu, select Attributes to display the 
Attributes dialog box.

2 Type a new attribute name COMPONENT in the Name text 
box.

3 Type a value in the Value text box that explicitly specifie
the package definition name.

Example: For a 10102 package, you could have two 
symbols: 10102NOR and 10102ORNOR. Both symbols 
could have the attribute COMPONENT = 10102.

4 Click Save Attr.

5 Type a new attribute name GATETYPE in the Name text box.
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6 Type a value in the Value text box corresponding to one
the gate types specified in the package definition.

Example: 

For the 10102NOR symbol, GATETYPE = 1  (gates A,B,C); 
for the 10102ORNOR symbol, GATETYPE = 2  (gate D).

7 Click Save Attr. 

8 Click OK to exit the dialog box.

9 In the procedure for specifying information for multi-gate
components (see Specifying Information for Multi-gate 
Components on page 6-41), define the different gate types
comprising the package.

Example: Type 1 is the NOR gate and type 2 is the ORNO
gate.

10 For each gate type, define the gates and the pin assignm
for each gate (see Specifying Information for Multi-gate 
Components on page 6-41).

The pin assignments define the pin numbers for each ga
that correspond to each pin name.

Deletin g a Package Definition
Use the Remove function to delete one or more package 
definitions from the library.

Deletin g a packa ge definition

1 From the Packaging menu, select Remove to display the
Remove Package Definition dialog box.

2 Type the name of the package to be deleted, or click to se
a package from the list.

3 Click Delete to delete the selected item.

4 Click Close.
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Confi gurin g Package Types
When you create package definitions and specify package ty
for a device, you can pick from a list of commonly used packa
type names or enter one of your own. To add to the list of 
commonly used package type names that are presented, us
Configure Package Types selection from the Packaging me
Also use this selection to configure package types into the 
package classes that are used when you package a design.

When you package a design, you can assign priorities to us
when deciding which package type to assign to devices that
available in more than one type. For example, all DIP packa
types (DIP8, DIP14, and so on) are assigned to the DIP clas
You can indicate that you want to use DIP package types 
whenever possible. Or you might change the priorities to ass
SMT package types if possible.

Addin g a packa ge type

1 From the Packaging menu, select Configure Package Ty
to display the Configure Package Types dialog box.

2 In the Package Types text box, type in the new package t
name.

3 In the Class list, select one of the existing classes for the n
package type. If you need to create a class, do the follow

a Click Edit Classes.

b Type in the name of the new class in the Package Cl
text box.

c Click Add.
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d Click OK.

4 Click Add.

5 Click OK.
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Note When you save 
changes to a library, you will 
be asked if you want to add 
the library to the list of 
configured libraries. Answer 
yes if you want to make the 
library available to all 
schematics.
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Confi gurin g Custom 
Libraries
When you create a library, whether it is a library of symbols 
a library of packaging information, the symbols and packagi
information are not available for use in the schematic editor u
the library is configured. Configuration consists of adding th
library file to the list of configured files.

Makin g a symbol librar y available in Schematics

1 From the schematic editor, select Editor Configuration fro
the Options menu to display the Editor Configuration dialo
box (see 3-18).

2 Click Library Settings to display the Library Settings dialo
box.

3 Type the name of the new symbol library in the Library 
Name text box (without the .slb extension).

4 Select the Symbol check box to indicate that the new libra
is a symbol library. Symbol libraries are searched in the 
order in which they are listed in the Library Settings dialo
box.

5 To add a symbol library at a specific point in the list:

a Click the library name above where you want to includ
the one you are adding to the list.
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b Type the name of the one you are adding in the Libra
Name text box. Be sure the appropriate check boxes 
selected to indicate whether you are configuring just t
symbol library, or the symbol and package library.

6 Click Add.

7 Click OK.

Note You may need to modify the Library Path (in the 
upper-right corner of the Editor Configuration 
dialog box) to include any directory paths that 
contain library files you added in the previous 
dialog.

When exiting the Editor Configuration dialog box, Schematic
reloads all of the symbol libraries in the list, making the symbo
contained in them immediately usable in the schematic edito
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When creating a symbol, it is not 
necessary to have already 
defined a subcircuit or model. 
The issue of having a model or 
subcircuit definition will only 
become important when you are 
ready to simulate the design. 
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Example—Creatin g 
Symbols from Scratch
You can create custom symbols from scratch in Schematics
Creating custom symbols includes:

• drawing the graphics

• adding pins

• changing the grid size

• defining attributes

• configuring the new symbol library

To quickly create common symbols, use the Symbol Creatio
Wizard (see Using the Symbol Wizard on page 6-3), or for 
examples of creating common symbols by copying existing on
(see Creating a Symbol by Copying Another Symbol on 
page 6-5), or using AKOs (see Using AKO Symbols on 
page 6-7).

The following example demonstrates how to create a symbol
a diode bridge rectifier. 

Diode Brid ge Rectifier
For this example, assume there is a subcircuit definition nam
BRIDGE stored in a library file called mylib.lib  on your local 
drive. The subcircuit definition would look like the following:

.SUBCKT BRIDGE 1 2 3 4

D1 4 1 D1N914

D2 1 3 D1N914

D3 4 2 D1N914

D4 2 3 D1N914

.ENDS

The symbol to be created will look very similar to Figure 6-2
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Note that the file status is 
<new>:<new> (at the top of the 
window). This means it is a new 
file (and a new symbol). Keep in 
mind that new also means 
undefined.

Answering yes adds the file to 
the list of symbol libraries that 
Schematics reads in each time it 
is started. 
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Figure 6-2 Example of Diode Bridge Rectifier Symbol

Openin g or Creatin g a Symbol Librar y

To open or create a s ymbol librar y

1 In the schematic editor, from the File menu, select Edit 
Library to open the symbol editor. 

2 To add this symbol to an existing symbol library:

a From the File menu, select Open.

b Navigate to your file and open it.

3 If you want to create a new library:

a From the File menu, select Save As. 

b After you type in a name, click Yes to add it to the lis
of configured libraries. 

4 From the Part menu, Select New to open the Definition 
dialog box. 

5 Enter:

• A description of the device (optional)—it will display 
when you browse for a symbol in the schematic edito

• A name—a symbol name to get the part in Schemat
(in this case it is Bridge).
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 This example does not use 
AKOs or aliases.

This produces a finer drawing 
grid, approximately .02 inches 
between grid dots. 

 It does not matter where you 
begin drawing because it can be 
moved later. 
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• The type of the part—the part type is most commonl
“component,” as it is in this example.

• An AKO or alias—use AKO if you want it to inherit the
graphics and attributes from another symbol. Use Ali
to assign additional names that this symbol can be us
for. 

Drawin g the Graphics

After the symbol has a definition, the next step is to draw th
graphics. For this example, it is possible to copy the graphic
from the regular diode symbol, however, that particular graph
is oriented vertically and horizontally, while this example cal
for one that is at a 45-degree angle.

To draw the graphics

1 From the Options menu, select Display Options and set 
Grid Spacing to 00.02.

a If not already enabled, select Stay-on-Grid.

b If not already enabled, select Snap-to-Grid.

Enabling these features will assist in lining up the 
segments of the symbol.

c Click OK.

2 From the Graphics menu, select Draw Polyline to chang
the cursor to a pencil.

3 Draw the diode that is located in the upper right part of t
symbol:

a Click once to start drawing.

b Make a horizontal line 6 grid dots long. (Do not count 
the starting grid dot.)

c Click once to anchor the end, move the cursor up 6 g
dots, and click to anchor the line midpoint.

d Continue drawing and close the triangle by double-
clicking at the starting point.

e Draw a line at a 45-degree angle across the right an
of the symbol already created to denote the cathode
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You can rotate graphics by 
selecting Rotate from the Edit 
menu. The cursor can still be 
used to select menu commands, 
even when in the process of 
placing a graphic. 

 

If you make a mistake, S+ 
click, and hold the right mouse 
button, to select and drag the 
box corner to a new location.
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4 Place three copies of this diode:

a Drag the mouse to select the area that includes the 
graphics.

Release the mouse to turn the lines red. If they do n
turn red, reselect the area, or S+ click the 
unselected items to add them to the selected group.

b From the Edit menu, select Copy.

c From the Edit menu, select Paste.

d Place one copy nearby; another copy will remain 
attached to the cursor.

e Before placing the next two copies, rotate the graphi
by pressing C+ R.

There are now four diode symbols: two pointing to th
upper right and two pointing to the lower right. 

5 From the Options menu, select Display Options and rese
the grid to 00.10. 

Verify that Stay-on-Grid and Snap-to-Grid are still enable

6 From the Graphics menu, select Draw Box to start the b
drawing mode:

a Click once (approximately) one grid square southeast
the small origin box.

b Drag to the lower-right corner position.

c When you have the lower-right corner in position, clic
to anchor it in place. 

7 Select the diode symbols and move them to their 
approximate locations inside of the box.

Placin g Pins

To place pins

1 From the Graphics menu, select Place Pins.

2 To place the pins:

a Place the IN+ and IN- pins as shown in Figure 6-2.
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You can also click the pin to 
change the name.

To disable or modify the way the 
pin numbers are displayed:

1 Double-click the pin.

2 In the Change Pin box, click 
Edit Attributes.

3 In the Attributes box, select 
pin=<number>.

4 Under What to Display, click 
the option you want.

5 Click Save Attr.

6 Click OK.

This example has pin numbers 
set to display ‘None’.
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b Press C+ R to rotate the pin that is attached to the 
cursor.

c Place the OUT+ and OUT- pins as shown in Figure 6

3 Double-click the default name (pin1 through pin 4) of eac
pin to change their names to the following:

IN+

IN-

OUT+

OUT- 

4 Single-click the names or numbers to move them to thei
appropriate position.

Keep in mind that the ‘X’ on the pin is the point where th
wires will connect, and Schematics will expect to find the
connection points on the 00.10 grid

Finishin g Touches

1 From the Options menu, select Display Options and set 
grid size to 00.01.

2 From the Graphics menu, select Draw Polyline to draw t
connecting lines between the diodes in the bridge and a
to the tail end of the pins.

If necessary, select Display Options from the Options me
to turn off Stay-on-Grid. This will enable you to move 
graphics without being restricted to the grid. 

Note Do not move the pins. If they are not on 10-unit 
boundaries, you will not be able to connect to them 
when in Schematics.

3 From the Graphics menu, select Draw Text to place the 
labels D1 through D4 on the diode symbols. 

4 To change the size of the text, double-click the text and 
adjust the size. 

The number is a percentage relative to the usual size.
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If you click anywhere within the 
area of the boundary box in 
Schematics, the symbol will be 
selected.

The origin is the point the symbol 
will rotate around when in 
Schematics. Usually it is on the 
hot spot of the top left pin, but it 
is not required.

You can also set it to: BRIDGE? 
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5 From the Graphics menu, select Box and click once to att
the bounding box to the cursor.

a Move the cursor to the lower right so that the boundin
box encloses the entire symbol. 

b Click again to freeze the box; all pin connection poin
must lay on, or inside of, the boundary box. The 
boundary box defines the area of the symbol in 
Schematics.

6 From the Graphics menu, select Origin and click to attac
the origin to the cursor.

a Move it into position.

b Click again to drop it.

Settin g the Attributes

The last step in creating a symbol is to set up the attributes so
symbol can be used for simulation.

1 From the Part menu, select Attributes to display the 
following attributes in the Attributes dialog box:

REFDES

PART

MODEL

TEMPLATE

a Click REDES and set its value to:

U?

This is the reference designator that appears in your
schematic and in the netlist.

b Click Save Attr.

2 Click PART.

a Set its value to the name that you used in the origina
definition box.

b Click Save Attr.
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MODEL and TEMPLATE are 
only required if you are going to 
simulate.

Notice that the names used 
match the pin NAME as defined 
on the pins in the symbol; the 
ORDER of the pins in the 
TEMPLATE are listed in the 
same ORDER as those in the 
subcircuit. 

Looking at the symbol on page 
one, note that IN+ is the same as 
node 1 in the subcircuit 
definition. 
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3 Click MODEL.

a Set its value to the same value as in your model or 
subcircuit definition. 

b Click Save Attr. 

4 Click TEMPLATE. 

The TEMPLATE attribute is the template for generating th
netlist entry for this device. The TEMPLATE for this 
example looks like the following:

X^@REFDES %IN+  %IN-  %OUT+  %OUT-  
@MODEL

5 Click Save Attr.

6 Click OK.

7 Make any last changes and select Save from the File me

You can now call up the diode bridge symbol for use in a
design.

Confi gurin g the Models

The diode bridge symbol is now ready for use in Schematics,
the model library must also be configured if the design is goi
to be simulated.

1 From the Analysis menu, select Library and Include File

2 If the required library is not already in the Library section
click Browse.

Parameter Description

X references a subcircuit definition

^@REFDES appends the hierarchical path (if there is one) 
and the reference designator to the ‘X’ in the 
netlist

% indicates that the item following will be a pin 
name

@MODEL indicates the value of the MODEL attribute will 
be placed here
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3 Locate the library and click Open to put the library with it
path in the File Name field.

4 Select either Add Library* or Add Library. 

The ‘*’ causes the file to be added as a global library. A 
global library will be available to every schematic until it i
removed from the list. Local libraries are available only t
the active design, but can be added to another, or made
global if needed in the future.
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Overview
This chapter explains the procedures for creating and editin
hierarchical design. Many of the procedures used for creatin
and editing a hierarchical design are the same as those for 
creating and editing a design as explained in Chapter 
4,Creating and Editing Designs.

This chapter has the following sections that explain the 
procedures that are unique to hierarchical designs:

Creating and Editing Hierarchical Blocks on page 7-4 describes 
how to create and edit hierarchical blocks placed on a schem

Creating and Editing Hierarchical Symbols on page 7-9 
describes how to use the symbol editor to create hierarchica
symbols.

Using Interface Ports on page 7-12 describes how to specify 
connections to lower-level schematics.

Setting Up Multiple Views on page 7-13 describes how to set up
and use alternate representations for a hierarchical block or
symbol.
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Navigating Through Hierarchical Designs on page 7-15 
describes how to move between pages in a hierarchical des

Assigning Instance-Specific Part Values on page 7-17 describes 
how to assign instance-specific parts values.

Passing Information Between Levels of Hierarchy on page 7- 
describes how to define the parameters of hierarchical block
and symbols without concern for how deeply their contents a
nested.

Example—Creating a Hierarchical Design on page 7-20 
provides the step-by-step procedures for creating the top-le
schematic with the block symbol representing the lower-leve
schematic and creating the lower-level schematic.
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Hierarchical design is a useful 
way to structure large projects, 
especially those starting from a 
block diagram and those with 
multiple occurrences of common 
circuitry. Use the method of 
design that best fits your design 
needs for each circuit you create.
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Hierarchical Desi gn 
Methods
You can create a hierarchical drawing in either of two ways:

• Create a block and later assign a schematic to the block (
down method).

• Create a schematic and turn it into a symbol to be used 
higher level design (bottom-up method).

Top-down method

By creating one or more blocks and wiring them together, yo
can establish a functional block diagram. The block diagram c
be used as a top-level sketch for your design.

After you have mapped out the block circuitry, you can push
into each block and start drawing a new schematic, or assign
existing schematic to the block.

You can also set the view that each schematic will represent 
(such as a PCB or a transistor).

Bottom-up method

If you already have a schematic that you would like to use in
larger designs, you can create a hierarchical symbol to repre
the schematic. The hierarchical symbol can then be electrica
connected in another design.
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Creatin g and Editin g 
Hierarchical Blocks
A hierarchical block represents a collection of circuitry in the
form of one or more lower-level schematics. The block displa
on a schematic as a rectangle with a variable number of inp
and output ports.

You can place one or more instances of a hierarchical block
a schematic. After you place a block, you can stretch it, resh
it and move it. You can create a schematic to be represente
the block or associate an existing schematic with the block.

Wires and buses that end at any of the edges of the block 
automatically connect to the block. Pins are created where th
connections occur. A default pin name appears within the blo
this pin name can be changed.

Creatin g a hierarchical block

1 Click the Draw Block button to change the pointer to a 
rectangle representing the block.

2 Move the block to the desired location and click to place

3 Right-click to stop placing blocks.

The block is assigned a reference designator of HBn (where n is 
a sequential number beginning with 1). You can change the
reference designator of the block.
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e The block, as placed, is a 
standard size, orientation and 
shape. You can stretch and 
reshape the block.

To rotate the block, select it and 
press C+R. (See Rotating 
Parts on page 4-10.)

Shortcut: press 2

You can also double-click the 
block to achieve the same 
results as steps 1 and 2.
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Changing the reference desi gnator of the 
hierarchical block

1 Double-click the HBn reference designator to display the 
Edit Reference Designator dialog box.

2 Type the reference designator in the Package Referenc
Designator text box.

3 Click OK to close the dialog box.

Resizin g a hierarchical block

1 Select the block to display its handles.

2 Click one of the handles and drag to resize the block.

Creatin g a schematic for a hierarchical block

1 Select the block.

2 From the Navigate menu, select Push.

If the block is new, the Setup Block dialog box appears.
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The Implementation frame in this 
dialog will only display if you are 
using Design Lab.

Note Interface input and 
output ports are created 
automatically only the first 
time you push into the block. 
Thereafter, you must 
manually add any additional 
interface input and output 
ports.
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3 Type the new schematic name.

4 Click OK.

A new schematic displays and contains interface input and 
output ports corresponding to the pins connected to the bloc
The input ports correspond to the pins connected to the left s
of the block. The output ports correspond to the pins connec
to the right side of the block.

You can move the interface port symbols in the same way th
you move other symbols.

You can also associate an existing schematic with a hierarch
block. See Associating an Existing Schematic on page 7-8.



Creating and Editing Hierarchical Blocks 7-7

 

Double-click the pin to achieve 
the same results as steps 1 and 
2.
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Editin g a pin name on a hierarchical block

1 Select the pin on the hierarchical block.

2 Click the Edit Attributes button to display the Change Pin
dialog box.

3 Type the desired pin name in the Pin Name text box.

4 Click OK.

Deletin g a pin on a hierarchical block

1 Select the pin.

2 Press D.
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You can also double-click the 
block to display the Set Up Block 
dialog box.
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Associatin g an Existin g 
Schematic
Instead of pushing into the block to create a schematic (see 7-5), 
you can associate an existing schematic with a hierarchical 
block.

Associatin g an existin g schematic with a 
hierarchical block

1 Select the Draw block button.

2 Place the block and be sure it stays selected.

3 From the Navigate menu, select Push to display the Set
Block dialog box.

4 In the Filename text box, enter the name of the existing 
schematic to be associated with this block.

5 Click OK.

When you associate an existing schematic with a new block, 
pins will be automatically created on the block for each interfa
port on the sub-schematic.
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Most of the symbols provided in 
the Schematics symbol libraries 
are primitive. Note that a symbol, 
for example, a flip-flop, may be 
primitive for a PCB netlister, but 
hierarchical for PSpice.

There is no built-in limit to the 
number of levels of nesting 
allowed in a symbol. Nesting of 
hierarchical symbols or blocks 
within other hierarchical symbols 
or blocks is possible.
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Creatin g and Editin g 
Hierarchical S ymbols
Schematics uses two basic types of symbols: primitive and 
hierarchical.

Primitive s ymbols are low level symbols that explicitly 
contain all of the information required by the netlister. They c
be modified by editing their graphics, pins, and attribute lists
the symbol editor.

Hierarchical s ymbols have the same appearance as 
primitive symbols in Schematics. They contain one or more 
levels of schematics inside them while primitive symbols do n
They can also be modified by pushing into them from within t
schematic editor or symbol editor and editing the associated
schematics.

Creatin g a Hierarchical S ymbol
The Symbolize function automatically creates a symbol to 
represent a schematic. The symbol editor is then used to mo
any portion of the resulting symbol (graphics, pins, and 
attributes).

When preparing a schematic for symbolization, follow these
guidelines:

• Place input and output interface ports (IF_IN, IF_OUT) a
the inputs and outputs of the schematic. Interface ports 
mapped to I/O pins placed on the left (input) and right 
(output) of the new symbol.

• Place global ports (GLOBAL or BUBBLE) to bring out 
global nets or connections as hidden pins. Global ports 
mapped to hidden pins placed on the top and bottom of 
new symbol. An IPIN(xxx)  attribute, with a value that is 
the name of the net that it is connected to, is created for e
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File Menu

Note Avoid modifying the 
symbol libraries that were 
shipped with your software. 
Create a new symbol library 
for the custom symbols you 
create.
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hidden pin. Hidden pins are especially useful for global 
power and ground on digital parts ($G_DPWR, 
$G_DGND). 

Symbolizin g a schematic

1 Open the schematic.

2 From the File menu, select Symbolize to display the Sav
As dialog box.

3 Type the name of the symbol.

4 Click OK.

A file selection dialog box prompts for a symbol library to
save the symbol in.

5 Select a library.

6 Click OK.

When you symbolize a schematic, the resulting symbol is 
hierarchical (that is, it will have a schematic associated with
so you can push into the symbol and view that schematic).

After you have symbolized your schematic, you need to mak
the symbols in your new symbol library available to Schemat



Creating and Editing Hierarchical Symbols 7-11

k 

 

ock. 
at 
ne 
ing 

Edit Menu

Note Converting a block to a 
symbol is a one-way process. 
After you convert a block into 
a symbol, you cannot change 
that symbol back into a block.
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Convertin g Hierarchical Blocks 
to Symbols
When you finish editing a hierarchical block, you have the 
option of turning the block into a symbol. By making the bloc
a symbol, you make it available for use in other schematics.

Convertin g a block to a s ymbol

1 Select the block.

2 From the Edit menu, select Convert Block to display the
Save As dialog box.

3 Type a name for the symbol.

4 Click OK to display the Open dialog box.

5 Select a library.

6 Click OK.

Schematics creates a rectangular symbol to represent the bl
One pin is placed on the new symbol for each wire or bus th
was connected to the block. The width of the block shrinks o
unit on each side to accommodate symbol pins without requir
rewiring.
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Usin g Interface Ports
When you use a block or symbol to represent an underlying
schematic, connections to the underlying schematic are mad
means of the pins on the block or symbol. The pins on the blo
or symbol must correspond to interface ports placed on the 
underlying schematic, that is, for each pin there must be a 
corresponding interface port with the same name as the pin

If a bus is connected to the block or symbol, the pin name m
indicate the number of signals, such as, CLK[0:3]. The interfa
port would have the same name, such as, CLK[0:3].

If you make changes to the pins on a block or symbol, you m
make the corresponding changes on any underlying schema
it represents.

There are three interface port symbols available in “port.slb”

You can use the symbol editor to create custom interface po

If you... You Must...

add a pin add an interface port with the same nam
as the pin.

delete a pin delete the corresponding interface port.

change the name of a 
pin

change the label of the corresponding 
interface port.

IF_IN

IF_OUT

INTERFACE
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If you are also using PLSyn for 
programmable logic synthesis, 
you may also configure a view to 
be the name of a DSL file. Refer 
to the MicroSim PLSyn User’s 
Guide for more information.
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Settin g Up Multiple 
Views
A view is an underlying representation of a hierarchical block
symbol. A block can have more than one underlying 
representation by having multiple views.

For example, you can define a part that has a transistor-leve
schematic as one view and a behavioral model schematic a
another view. 

Note There are no restrictions on how many views a part 
can have, or on what the views are.

Hierarchical symbols have one or more views. Every 
hierarchical block or symbol always has a default view that i
initialized as the first schematic assigned to it. You can chan
the default view. You can create and associate additional vie
at any time. You can modify, delete or rename views. Each vi
is associated with a schematic, and multiple views can poin
the same schematic.

Translators
To take different views of a design, configure a translator to 
look for separate view attributes. A translator produces an 
alternate representation for a schematic. For example, the 
Schematics netlister is a translator that operates on a schem
to produce a PSpice netlist. A translator typically looks at 
information carried by the symbols on a schematic and may
may not also use the implicit connectivity.
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Settin g up an associated view for the Translator

1 From the Options menu, select Translators to display the
Translators dialog box.

2 Select a Translator from the list or type a name in the 
Translator text box.

3 Type the name of the view in the View text box.

4 Click Apply.

5 Click OK.
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Shortcut: press 2

Double-clicking the hierarchical 
block or symbol gives the same 
results as steps 1 and 2.

Shortcut: press 3

Navigate Menu
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Navigatin g Throu gh 
Hierarchical Desi gns
The Navigate menu has functions that enable you to move 
between pages, create new pages, delete pages, and copy 

You can move within a hierarchical design using functions fro
the Navigate menu. You can push into a block from the 
schematic, move up and down in hierarchical levels and iden
the hierarchical path of a selected symbol.

Movin g down in a hierarch y

1 Select the hierarchical block or symbol.

2 From the Navigate menu, select Push.

a If the selected item is represented by only one lower
level schematic, the schematic will display for editing

b If the selected item represents more than one schem
(that is, has multiple views), you can select the view 
be edited in a dialog box that will appear.

Movin g up in a hierarch y

1 From the Navigate menu, select Pop.

If you have made any changes to the present level in the 
hierarchy, you are prompted to save the modifications or to 
move up to the next higher level without saving changes.

Movin g to the top in a hierarch y

1 From the Navigate menu, select Top.

The top-level schematic appears in the active window.
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Findin g where active schematic fits in a hierarch y

1 From the Navigate menu, select Where to display the Wh
dialog box.

The dialog box shows where the open schematic fits in t
hierarchy of the open design.

2 Click OK.
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Shortcut: press 2

Navigate Menu

Shortcut: press 2
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Assi gnin g Instance-
Specific Part Values
The Edit Schematic Instance function enables you to view a
edit the instance specific attributes associated with the insta
of the block or hierarchical symbol that you pushed into. You
can only add, change, or delete attributes when this function
activated. Any changes only apply to this instance of the 
hierarchical block or symbol.

Editin g an instance of the schematic

1 From the Navigate menu, select Push to push into the 
hierarchical block or symbol.

2 From the Navigate menu, select Edit Schematic Instanc

A check mark appears next to the menu item to show tha
has been selected.

Note Any changes you make effect only this instance of 
the schematic. To make changes to the schematic 
itself, use the Edit Schematic Definition function.

Editin g the schematic definition

1 From the Navigate menu, select Push to push into the 
hierarchical block or symbol.

2 From the Navigate menu, select Edit Schematic Definitio

A check mark appears next to the menu item to show tha
has been selected.

You can now edit the schematic. Any changes that you 
make effect all instances of hierarchical blocks and symb
that reference this schematic.

Note Edit Schematic Instance and Edit Schematic 
Definition are mutually exclusive functions.
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Shortcut: Press C+S
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Passin g Information 
Between Levels of 
Hierarch y
With Schematics, you can create a lower-level schematic su
that different instances of it will have different component 
values. For instance, a lower-level schematic contains a cer
resistor. The hierarchical block or symbol representing the 
lower-level schematic defines the value of the resistor. The 
following procedure shows how you can place one instance o
block and define the resistor value to be 10K and another 
instance and have the resistor value be 20k.

1 In the lower-level schematic, double-click the resistor valu
to display the Set Attribute Value dialog box (refer to 4-29).

2 In the Value text box enter {@RESISTORVALUE}.

3 Click OK.

4 Save the lower-level schematic.

5 Place a block representing the lower-level schematic on 
top-level (or higher-level) schematic (see Creating and 
Editing Hierarchical Blocks on page 7-4).

6 Select the block.

7 From the Edit menu, select Attributes to display the 
Attribute Editing dialog box (refer to 4-12).

8 Add an attribute called RESISTORVALUE with a value of 
10k.

9 Click OK.

10 Place another block representing that same lower-level 
schematic on the top-level schematic.

When you netlist the top-level schematic, the two instances 
the lower-level schematic will have different resistor 
values.This is due to the way that attributes are evaluated in
Schematics.

• Schematics first searches for an attribute at the present le
of the hierarchy. If the attribute is not found at that level,
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Schematics then searches the parent level. It continues 
the hierarchy until it either finds a definition or until it 
reaches the top of the hierarchy.

• When Schematics finds an attribute, it evaluates the 
attribute at the level where it is found. If the attribute valu
refers to other attributes, those other attributes must exis
the present level or higher in the hierarchy.

For example, hierarchical symbol A defines two attributes: X=@Y 
and Y=10. Symbol A contains an instance of a symbol B; B 
contains an expression referring to the attribute X ({@X}) and 
defines the value of attribute Y to be 20 (Y=20) .

The evaluation of the expression {@X} is:

• X is searched for on the present level.

• There is no X attribute at this level, so the parent 
environment (symbol A) is searched.

• An attribute named X is found at this level—this 
attribute is evaluated in the environment supplied byA.

• The first stage of this evaluation delivers the result @Y—
this is then processed to yield the result 10.

• The final result is to make the result of the expression
B be {10} ({@X}={10}).

• The definition for Y in the environment supplied by 
symbol B is not used when evaluating X in A’s 
environment.
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Example—Creatin g a 
Hierarchical Desi gn
This example shows you how to create schematics from the
level down. The design consists of a simple schematic with 
block representing a CMOS inverter and a lower-level 
schematic for the inverter.

Follow this example to create the top-level circuit shown in 
Figure 7-1 and the inverter schematic shown in Figure 7-2.

Figure 7-1 Top-level Schematic Drawing for CMOS Inverte

Drawin g the Top-Level 
Schematic
To create the top-level schematic, start by placing a VSRC 
power supply connected as an input to a block representing
CMOS inverter. Draw the block, place a resistor and two grou
symbols, and connect the components.
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Note One of two Part 
Browser dialog boxes may 
appear: the Part Browser 
Advanced and the Part 
Browser Basic. The advanced 
browser contains many 
features that you don’t need 
to use for this example. If the 
Part Browser Advanced 
dialog box appears, click 
<<Basic to display the Part 
Browser Basic dialog box.
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Placin g the volta ge source

1 Click the Get New Part button to display the Part Browse
dialog box.

2 Enter VSRC in the Part field.

3 Click Place & Close.

4 Move the part symbol to the desired location and click to
place the symbol.

5 Right-click to stop placing parts.

Creatin g the block representin g the CMOS 
inverter

1 Click the Draw Block button to change the pointer to a 
rectangle. 

The rectangle represents the block to be drawn.

2 Press C+R to rotate the rectangle.

3 Move the pointer to the desired location and click to plac
the block symbol.

4 Right-click to stop placing blocks.
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5 Double-click the HB1 reference designator to display the
Edit Reference Designator dialog box.

6 Enter CMOSINV in the text box. This changes the value of th
REFDES attribute from HB1 to CMOSINV.

7 Click OK.

Drawin g the output load resistor

1 Click the Get New Part button to display the Part Browse
dialog box (see 7-21).

2 Type R  in the Part field.

3 Click Place & Close.

4 Press C+R to rotate the resistor symbol.

5 Move the resistor symbol to the desired location. Click to
place the symbol.

6 Right-click to stop placing parts.

Placin g the analo g ground s ymbols

1 Click the Get New Part button to display the Part Browse
dialog box (see 7-21).

2 Type AGND in the Part field.

3 Click Place & Close.

You can place the two grounds so that they connect to t
power source and the load resistor. This negates having
draw wires between the symbols.
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4 Move the ground symbol to the desired locations. Click t
place each symbol.

5 Right-click to stop placing parts.

Wirin g the Symbols

Now that you have placed all of the symbols, wire the symbo
to look like the schematic shown in Figure 7-1.

1 Click the Draw Wire button to change the pointer to a 
pencil.

2 Click the top of V1. Click at the location of the wire verte
(where it turns from the vertical to the horizontal). Click th
left side of the CMOS block. The wire is complete when 
shows connection on both ends.

3 Repeat step 2 to connect a wire from the right side of th
CMOS block to the top of the load resistor.

4 Right-click to stop wire drawing.

Changing the names of the pins on the block

1 Double-click the pin labeled P1 to display the Change P
dialog box.

2 Type IN  in the Pin Name text box.

3 Click OK.

4 Double-click the pin labeled P2 to display the Change P
dialog box.



7-24 Creating and Editing Hierarchical Designs

is 

ner 
nd 
 
, 
e 

Scug.bk : 07HIERCH.FMK  Page 24  Monday, June 16, 1997  10:10 AM
5 Type OUT in the Pin Name text box.

6 Click OK.

Savin g your work as a top-level schematic

1 Click the Save File button.

2 Type tlcmos  as the name of the file (the .sch extension 
assigned by default).

3 Click OK.

Drawin g the Lower-Level 
Schematic
The top-level design is complete. Now you can create the in
schematic of the CMOS inverter. To do so, select the block a
use the Push selection from the Navigate menu to push to a
lower level. Because you haven’t defined the lower-level yet
you are presented with a Setup Block dialog box to name th
new schematic.

Figure 7-2 Schematic of CMOS Inverter
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Shortcut: press 2

Double-clicking the block gives 
the same results as steps 1 and 
2.

You are presented with a new 
schematic containing one 
interface input port and one 
interface output port. (They 
represent the block you drew on 
the top-level schematic.) If you 
had connected more pins to the 
block, more interface ports would 
appear after pushing into the 
lower-level schematic.
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Selectin g the block and namin g the new 
schematic

1 Click the CMOSINV block to select it.

2 From the Navigate menu, select Push.

Because the block is new, the Setup Block dialog box 
appears.

3 Enter the new schematic name, cmos.

4 Click OK.

5 Move the interface port symbols in the same way you mo
other symbols:

a Click to select it.

b Drag it to the desired location.

c Release to complete the move.

Now draw the schematic for the CMOSINV block as shown 
Figure 7-2.

Drawin g the two MOSFET devices

1 Click the Get New Part button to display the Part Browse
dialog box (see 7-21).

2 Enter M2N6804 in the Part text box.

3 Click Place & Close.

4 Press C+R, C+R and C+F to rotate the symbol 
twice and flip it once so that the source and bulk pins app
at the top. (To verify M1, see Figure 7-2 on page 7-24.)

5 Move the part symbol to the desired location of M1 and 
click to place the part.
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6 Right-click to stop placing parts.

7 Click the Get New Part button to display the Part Browse
dialog box (see 7-21).

8 Enter M2N6802 in the Part text box.

9 Click Place & Close.

10 Move the part symbol to the desired location of M2 and 
click to place the part.

11 Right-click to stop placing parts.

If you want to clean-up your schematic, click each of the 
MOSFET device names (M2N6804 and M2N6802) and mov
them slightly so that the label does not overlap on one of the
pins.

Drawin g the volta ge source and specif ying the 
DC volta ge attribute

1 Click the Get New Part button to display the Part Browse
dialog box (see 7-21).

2 Enter VSRC in the Part text box.

3 Click Place & Close.

4 Move the symbol to the desired location and click to place

5 Right-click to stop placing parts.

Drawin g the two analo g ground s ymbols

1 Click the Get New Part button to display the Part Browse
dialog box (see 7-21).

2 Enter AGND in the Part text box.

3 Click OK.

4 Move the symbol to the desired location and click to plac
it. Repeat for the second ground symbol.

5 Right-click to stop placing parts.

Drawin g the wires

Click the Draw Wire button and draw wires to connect parts a
symbols as shown in Figure 7-2. 
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Savin g the file

Click the Save File button to save the schematic. You are no
prompted for a file name because the schematic was named
when you pushed into it from the top-level schematic.
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Preparin g Your Desi gn for 
Simulation
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Overview
This chapter provides guidelines for preparing your schema
for simulation and references further information contained i
your PSpice user’s guide.

A design that is targeted for simulation will have:

• parts that there are simulation models available and 
configured for (Refer to Linking a Symbol to a Model or 
Subcircuit Definition in your PSpice user’s guide.)

• sources of stimulus to the circuit (Refer to Minimum circuit 
design requirements tables in the list of tables in your 
PSpice user’s guide.)

In this chapter you will find the following sections:

Creating Designs for Simulation and Board Layout on page 8.

Specifying Simulation Model Libraries on page 8-5.

Editing Simulation Models from Schematics on page 8-6.

Editing Simulation Models from Schematics on page 8-6.
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Adding and Defining Stimulus on page 8-7.

Starting the Simulator on page 8-8.

Viewing Results on page 8-9.
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Creatin g Designs for 
Simulation and Board 
Layout
When creating designs for both simulation and printed circu
board layout, some of the parts you use will be for simulatio
only (for example, simulation stimulus parts like voltage 
sources), and some of the parts you use will have simulation
models that only model some of the pins of the real device.

Those parts that are to be used for simulation, but not for bo
layout, will have a SIMULATIONONLY attribute. To see an 
example of this, double-click a VDC voltage source to bring u
the Attribute Editing dialog box.

You can add this (or any) attributes to your own custom 
symbols.

Specif ying Part Attributes
1 In the symbol editor, select Attributes from the Part menu

display the Attribute Editing dialog box.

2 Double-click the Name text box and type 
SIMULATIONONLY.

3 Click Save Attr.

4 Click OK.

For more information on defining attributes on part symbols,
Refer to Defining Part Symbol Attributes in the Creating 
Symbols chapter of your PSpice user’s guide.
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Handlin g Unmodeled Pins
Parts that have some pins that are not modeled, will appear
broken when placed on the schematic. To see an example of
place an instance of the PM-741  part from the “opamp.slb” 
symbol library. The OS1 and OS2 pins are not modeled, so only
the +, -, V+, V-, and OUT pins are netlisted for simulation.

For the simulator, these pins appear as a large resistor conne
to the ground.

Double-click the part to display the Attribute Editing dialog bo
Note that the TEMPLATE attribute for the part only calls out the
+, -, V+, V- , and OUT pins. The OS1 and OS2 pins are not called 
out in the TEMPLATE because those two pins are not modele
in the simulation model for the PM-741  part. You can view the 
simulation model definition for the PM-741  part from 
Schematics.

Viewin g a simulation model for a part

1 Click the part to select it.

2 From the Edit menu, select Model.

3 Click Edit Instance Model (Text) to display the Schematic
Model Editor and view an instance of the simulation mod
definition.

4 Click Cancel to exit the Model Editor without saving.
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Specif ying Simulation 
Model Libraries
Refer to the Creating Models chapter of your PSpice user’s 
guide for information about creating and configuring simulatio
model libraries. Each part that you intend to simulate must ha
a simulation model defined.

Checkin g if a part has a simulation model defined

Double-click the part on the schematic to display the Attribu
Editing dialog box. If a simulation model is available for a pa
the part will have:

• a TEMPLATE attribute specifying the PSpice simulation 
netlisting syntax for the part

• a MODEL attribute specifying the name of the model or 
subcircuit

The simulation model specified by the MODEL attribute must be 
contained in a model library that is configured.

Checkin g if a simulation model librar y is 
confi gured

Select Library and Include Files from the Analysis menu to 
bring up the Library and Include Files dialog box.

The set of simulation model libraries configured are listed in t
Library Files area.

For information on configuring simulation model libraries, refe
to Configuring the Library section in the Creating Models 
chapter in your PSpice user’s guide.
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Editin g Simulation 
Models from 
Schematics
You can define and edit simulation models directly from 
Schematics. 

Models can be defined using the Parts utility or the text edit
(sometimes called the Model Editor).

The Parts utility is useful for characterizing specific models 
from data sheet curves. The text editor is useful if model 
parameters are already defined (for example, models from a
vendor) or if the model is not supported by the Parts utility.

Refer to the Using the Parts Utility and Using the Model Editor 
(Text Editor) sections of the Creating Models chapter in your 
PSpice user’s guide.
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View the Stimulus Editor Help for 
more information.
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Addin g and Definin g 
Stimulus
The Stimulus Editor is a utility that enables you to set up an
verify the input waveforms for a transient analysis. You can 
create and edit voltage sources, current sources, and digita
stimuli for your circuit. Menu prompts guide you to provide th
necessary parameters, such as the rise time, fall time, and pe
of an analog repeating pulse, or the complex timing relation
with repeating segments of a digital stimulus. Graphical 
feedback enables you to verify the waveform.

Placin g Stimulus Sources
Stimulus sources come from the source.slb  symbol library 
and are one of:

• VSTIM—voltage stimulus source for transient analysis

• ISTIM - current stimulus source for transient analysis

• DIGSTIM - digital stimulus source

You can place any of these sources by typing the name of t
source in the Get Recent Part list box on the toolbar. The AC 
DC sources are VAC and VDC, and can be placed similarly

1 Double-click in the Get Recent Part list box and type the
name of the source.

2 Press R and click to place the source.

3 Right-click to stop placing sources.

Usin g the Stimulus Editor
For information on using the Stimulus Editor, refer to Stimulus 
Editor Utility in the Transient Analysis chapter in your PSpice 
user’s guide.
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Settin g Up Anal yses
Refer to your PSpice user’s guide for information about setti
up and running the many different analysis types supported
PSpice A/D.

Startin g the Simulator
You can start the simulator directly from Schematics by clickin
on the Simulate button on the toolbar, or selecting Simulate
from the Analysis menu.

For more information, refer to the Starting Simulation section of 
the Setting Up Analyses and Starting Simulation chapter in your 
PSpice user’s guide.
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Viewin g Results
You can use Probe to view and perform waveform analysis 
the simulation results. For more information, refer to the 
Waveform Analysis chapter of your PSpice user’s guide.

Viewin g Bias Point Results
After simulating, you can display bias point information on yo
schematic so that you can quickly zero in on problem areas
your design. PSpice A/D calculates and saves the bias poin
voltages and currents. By default, Schematics reads all of th
information and displays voltages for every net in your 
schematic; currents on pins are not visible, but are available.
more information, refer to the Viewing Results on the Schemati
chapter in your PSpice user’s guide. 

Viewin g Results as You Simulate
You can configure Probe to run automatically when the 
simulation has finished, or to monitor waveforms as the 
simulation progresses.

These procedures are outlined in the What You Need to Know to
Run Probe section of the Waveform Analysis chapter in your 
PSpice user’s guide.

Usin g Markers
You can place markers on your schematic to indicate the po
that in Probe where you want to see waveforms displayed.

For more information on markers, refer to the Schematic 
Markers section of the Waveform Analysis chapter in your 
PSpice user’s guide.
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Confi gurin g Probe Displa y of 
Simulation Results
To configure what Probe displays when it is started, select Pr
Setup from the Analysis menu. You are given the following 
choices:

• Restore Last Probe Session—This restores the display 
characteristics from the last session of Probe.

• Show All Markers—This displays the waveforms at the 
points on the schematic that have been marked by mark

• Show Selected Markers—This displays the waveforms on
for those points on the schematic where the markers ha
been selected.

• None—This displays a blank Probe window, ready for yo
to select the traces that you want to add.
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Usin g Design Journal
 

9

Overview
This chapter provides introductory information about the 
Design Journal. 

In this chapter you will find the following sections:

Understanding Design Journal on page 9-2 describes the 
purpose and different uses of Design Journal.

Design Journal Help on page 9-3 describes where to find Design
Journal Help.
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A checkpoint schematic is a copy 
of the schematic you are working 
on, in its current stage of 
development.

If the first checkpoint schematic 
isn’t changed, it preserves the 
state of the working schematic at 
the point the first checkpoint 
schematic was created. 
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Understandin g Design 
Journal
Design Journal is a very powerful analysis and tracking tool
With it you can:

• document stages of development

• perform what-if analysis on your current schematic, whil
preserving the integrity of the original

• compare the results of one or more what-if scenarios to 
original schematic output, by simulating in PSpice A/D an
viewing the results in Probe

• create a record of modifications (that you may or may no
have implemented)

• capture the thought process of a design

• easily revert back to an earlier design stage

These functions are available to you as you create checkpoint 
schematics (a copy of the current state of the schematic you
working on). Each checkpoint schematic is stored in a separ
subdirectory, within the directory of the working schematic. 
Checkpoint schematics are named Checkpoint.xxx , where 
xxx is a sequential number starting with 001.

Figure 9-1 depicts a working schematic and two checkpoint 
schematics. The first checkpoint schematic is a copy of the 
working schematic. The second checkpoint schematic 
represents a progressive stage of development.
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Restoring a checkpoint 
schematic removes its 
checkpoint status and makes it a 
normal .sch type schematic.
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Figure 9-1 A Working Schematic and Two Checkpoint 
Schematics

When documenting development stages and performing wha
analysis, you can:

• perform all MicroSim Schematics, PSpice, and Probe 
operations on a checkpoint schematic

• create up to 999 checkpoint schematics 

• restore a checkpoint schematic to a working schematic 
status

Design Journal Help
For a detailed explanation of how to use Design Journal and h
it interacts with Probe, see Schematics Help.

1st checkpoint
schematic

working schematic
(MySchem)

(Checkpoint.001) (Checkpoint.002)

2nd checkpoint
schematic
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Targetin g Your Desi gn for 
Programmable Lo gic
10
Overview
This chapter provides an overview on using Schematics for 
designing circuits that contain programmable logic.

This chapter contains the following sections:

Targeting PLDs/CPLDs Using PLSyn on page 10-2.

Targeting Xilinx FPGAs on page 10-4.
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“implementation”.
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Targetin g PLDs/CPLDs 
Usin g PLSyn
Schematics running with PLSyn provides an integrated 
environment that enables you to design Programmable Log
Devices (PLDs). 

All or any part of a schematic can be programmed into PLD
parts. You can define programmable logic using logic symbo
such as gates and flip-flops, DSL (Design Synthesis Langua
blocks, or both. Programmable logic symbols and DSL block
can be placed anywhere on your schematic—on any page, 
at any level of hierarchy.

Usin g Schematic S ymbols to 
Define Pro grammable Lo gic
Programmable logic is defined on a schematic by placing 
generic logic symbols, such as NAND4 or JKFF, or specific 
74xx series symbols, such as 74LS04 or 74HC107, and set
the value of their IMPL attributes to PLSyn. The “dig_prim.slb
symbol library contains over 100 ready-to-use programmabl
logic symbols. Refer to the Programmable Logic Symbols 
section of the MicroSim PLSyn User’s Guide for more detail.

Creatin g and Editin g DSL Blocks
Design Synthesis Language (DSL) blocks are hierarchical 
blocks that have a language-based definition instead of a 
symbolic definition. When you place a block, instead of 
associating it with another schematic, you associate a .dsl f
containing the procedural definition for the block.

Refer to the DSL Blocks and Creating a DSL Block sections of 
the MicroSim PLSyn User’s Guide.
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Simulatin g a Programmable 
Logic Desi gn from Schematics
After you have entered a design that includes programmabl
logic, you may simulate it at any time, both before and after y
have chosen a physical implementation. You can specify the
simulation parameters by selecting Setup from the Analysis
menu. 

For additional details, refer to the Setting up and Starting 
Simulations section of the MicroSim PLSyn User’s Guide.

Usin g PLSyn
After you have described your design in Schematics, use PLS
to create the physical implementation of your programmable
logic.   

To start PLSyn from Schematics, select Run PLSyn from th
Tools menu.

Note This command only appears if you have PLSyn 
installed.

Refer to the Physical Implementation chapter in the MicroSim 
PLSyn User’s Guide.

Updatin g the Schematic with the 
PLDs
After you have created a physical implementation from the 
programmable logic symbols and DSL blocks on the schema
the PLDs can be back annotated from PLSyn to the schema
Then you can generate a netlist for PCB layout.

Refer to the Updating the Schematic chapter in the MicroSim 
PLSyn User’s Guide.
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Targetin g Xilinx FPGAs
MicroSim FPGA (Field Programmable Gate Array) is also 
available for use with MicroSim Schematics and MicroSim 
PSpice A/D, which enables you to enter designs for FPGA 
digital devices. 

The design you enter with Schematics can be a mixed desig
that incorporates an FPGA device with other components 
entered with Schematics, or it can be an FPGA-only device.

For more information on how to set up Schematics using FPG
devices, refer to the MicroSim FPGA User’s Guide.

Enterin g an FPGA onl y Design
An FPGA-only design is a design that represents only the FP
circuitry. The interface ports at the top-level define the input
and outputs of the FPGA. To define an FPGA-only design, 
select FPGA Settings from the Tools menu.

Refer to the MicroSim FPGA User’s Guide.

Enterin g an FPGA Block in a 
Mixed Desi gn
A mixed design is a design that can consist of one or more FP
blocks, plus additional circuitry. Each FPGA is represented b
schematic block, and any additional circuitry is connected to
pins of the block. 

The inputs and outputs of the block represent the inputs and
outputs of the FPGA. The schematic represented by the blo
must be designated as representing an FPGA. It can contain 
Xilinx Universal Library symbols or other hierarchical blocks
that use Xilinx symbols.
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Refer to the MicroSim FPGA 
User’s Guide.

Schematics supports XNF 
versions 5.0 through 6.1.
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When you push into a block for the first time, you designate th
the schematic it represents is for the implementation of an 
FPGA. 

Incorporatin g an Existin g Xilinx 
Schematic into a Desi gn
There are two ways to incorporate an existing Xilinx schema
into another design. You can set up the schematic in a block
you can convert the schematic into a symbol and then place
symbol.

Refer to the MicroSim FPGA User’s Guide.

Usin g an Existin g XNF File in a 
Schematic
You can create a block in your schematic that references an X
file. This is useful if you need to simulate your design with 
Xilinx FPGAs that were designed or synthesized by other too
When you create an XNF block, Schematics automatically ad
pins to the block corresponding to the I/O pads in the XNF f

When you simulate the design, a simulation model for the FP
will be created automatically.

Note The simulation model will contain timing 
information if the block’s XNF file contained timing 
information.

Refer to the MicroSim FPGA User’s Guide.

Runnin g XACTstep
After you have entered the circuit design for an FPGA, you c
start XACTstep from Schematics by selecting Run XACTste
from the Tools menu.
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XACTstep uses XNF netlist files for a schematic. When you
select Run XAct for the first time, the XNF files are created f
the schematic. 

Note This command only appears if you have 
DesignLab installed.

Refer to the MicroSim FPGA User’s Guide.

Runnin g Simulations
To simulate FPGA designs you must set up your design. Se
FPGA Settings from the Tools menu. You have the option o
doing either a functional or a timing simulation. 

Note This command only appears if you have 
DesignLab installed.
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Preparin g Your Desi gn for 
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11
Overview
This chapter describes how to prepare your design for use w
a board layout program and has the following sections:

Connectors on page 11-3 describes placing connectors to 
provide the interface between the PCB and the rest of the 
system. This section also describes how to create connecto
symbols.

Packaging the Parts in Your Design on page 11-6 describes the 
process of collecting individual gates into physical packages a
reassigning reference designators and gate names to reflect
they are packaged.

Generating a Bill of Materials Report on page 11-12 describes 
how to generate a report listing the quantities of each compon
type used in the design, along with corresponding reference
designators.

Swapping Pins on page 11-18 describes how to swap pins on a
given gate.
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Interfacing with MicroSim PCBoards on page 11-19 describes 
the procedures for using Schematics with MicroSim PCBoar

Interfacing to Other Board Layout Products on page 11-24 
describes the procedures for using Schematics with the boa
layout products from other vendors.
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During simulation, connectors 
are largely ignored except that 
you can attach a marker to a 
connector pin to view waveforms 
in Probe. You can also connect 
stimuli to connector pins to 
simulate the external interface to 
the circuit.
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Connectors
Connectors provide the interface between a PCB and the res
a system.

The distinction between connectors and ports on a schemat
important and is shown in Table 11-1. Off-page ports are no
physical connectors, so you cannot use an off-page port as 
connector or a connector as an off-page port. You may use th
together if you want to have both connectivity and a physica
part by attaching an off-page port to the pin of the connecto

Table 11-1 Distinctions Between Connectors and Ports

Placin g Connectors
Connectors are added by placing connector symbols on the
schematic. You can use the connector symbols shipped with
Schematics (found in the connect.slb  symbol library) or you 
can create your own using the symbol editor. (See Chapter 
5,Using the Symbol Editor.)

There are two styles of connector symbols:

• those representing the entire connector

• those representing a single pin of a connector

Connectors Ports

define physical connection 
points on the PCB

define logical connection points 
on the schematic

are not included in layout 
netlists

are included in layout netlists

cannot be used to create 
connectivity on the schematic

are used to create connectivity on 
the schematic

are not logical devices are not physical connectors
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Figure 11-1 Entire Connector 
Symbol

Figure 11-2 Single Pin Symbol
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Usin g Connector S ymbols that Represent the 
Entire Connector

These symbols will have as many pins as the physical conne
they represent. You can wire signals directly to the pins or 
connect labeled off-page (or global) ports to each pin. The la
indicates the signal name that will be connected to the pin. A
off-page ports in the design with that same signal name will 
connected to that connector pin.

Two connector symbols that represent an entire connector a
DB25F-B and EDGE4OM-B.

Usin g Connector S ymbols that Represent One 
Pin of a Connector

In cases where a connector has a large number of pins, you 
want to use a symbol that represents a single pin of the conne
so you can attach connector pins to nets spread over multip
pages.

When an instance of such a connector symbol is placed on 
schematic, it is assigned an arbitrary reference designator a
gate. The reference designator indicates which physical 
connector instance the connector pin is part of (P1, for examp
and the gate indicates which physical pin (such as, 1 or 2). 
Therefore, the entire connector is considered a multi-gate 
package with each gate having a single pin. All connector p
instances with the same reference designator are a part of t
same physical connector.

Usually, you would assign the reference designator and gat
manually. Otherwise, you could automatically package the pi
however, this will result in an arbitrary grouping of signals 
which is not usually desired. To change the reference 
designator, double-click the reference designator on the 
schematic. To change the pin number (gate), double-click th
pin number.

Two connector symbols that represent single pins of a conne
are DB25 and EDGE40.
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Creatin g Single-Pin Connector 
Symbols
When creating a connector pin symbol, you must correctly 
define the connector package for the layout netlist to be corr
For example, in creating a 62-pin edge connector, instead o
creating a single symbol for a 62-pin edge connector with all 
pins, you can create a symbol of a single connector pin and
attach to it PKGREF and GATE attributes (created and assigned
when the symbol is placed). You would then assign the attrib
values for each instance of the pin to make the correct pin 
assignment to the connector. Each pin in the connector is th
equivalent of a single gate in a multi-gate package. Therefo
by assigning to each connector pin instance a specific 
combination of PKGREF and GATE attribute values, you can 
define the wiring of the connector in the layout.
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Packaging the Parts in 
Your Desi gn
Symbols used in Schematics represent either an individual g
of a packaged device, or a complete device. When a symbo
representing a single gate is placed on a schematic, it is assig
a unique reference designator (if Auto-Naming is enabled), a
by default, is made the first gate in the package. Packaging is the 
process of collecting these individual gates into physical 
packages and reassigning reference designators and gate n
to reflect how they are packaged.

The packager uses the package definitions for devices that a
the package libraries. Package definitions contain informatio
such as the number of gates, gate names, and pin number 
assignments. Package definitions are created and maintaine
using the symbol editor. See Specifying Part Packaging 
Information on page 6-34 for more information.

The packager assigns reference designators, gates, and pac
type attributes to parts on the schematic.

• The PKGREF attribute is the reference designator for the 
package.

• The GATE attribute contains the gate identifier, if any.

• The PKGTYPE attribute contains the name of the physical
package (footprint) to be used (such as, DIP14, LCC20)

• The REFDES attribute is the reference designator normall
displayed on the schematic. It is a combination of the 
PKGREF and GATE attributes.

• For example, if PKGREF=U31 and GATE=a, the PKGREF 
will be U31a.

• The REFDES attribute cannot be edited directly.

• To change the REFDES, change either the PKGREF or the 
GATE attribute. The REFDES attribute will be 
automatically updated to reflect the change.

Pin numbers for devices with package definitions are 
determined from the package definition rather than from the
symbol.
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• Pin numbers are dependent on the gate (for multi-gate pa
and package type (for devices with alternative pin 
assignments based on package type).

Until both GATE and PKGTYPE attributes are assigned 
values, no pin numbers are shown.

• For single gate packages with no gate name (for examp
blank instead of A) no GATE attribute value is required.

• The pin number visibility and location information from the
symbol is used to determine if and where the pin numbe
from the package definition are to be shown on the 
schematic.

• If a device has no package definition, then the pin numb
information is determined by the symbol definition.

Assi gnin g Reference 
Designators Manuall y

Assi gnin g reference desi gnator

1 Double-click the displayed reference designator to displa
the Edit Reference Designator dialog box.

2 Type a new value in the Package Reference Designator 
box.

3 Click OK.
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If you have other parts that you want to automatically packa
together, use the All Except User-Assigned option when you
package the design.

Automaticall y packa ging at a later time

1 From the Tools menu, select Package to display the Pack
dialog box.

2 In the Set Values for area, click the All Except User-
Assigned option button.

Any manually assigned reference designator values and
gates will be kept.

3 Click OK.
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Note When you add parts to 
a design that has already 
been sent to layout, be sure to 
select the Only Unpackaged 
option in the Package dialog 
box. This will create the 
fewest changes to the netlist.
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Assi gnin g Reference 
Designators Automaticall y
Use the Package selection from the Tools menu to package
individual parts into physical packages.

Packaging and assi gnin g reference desi gnators

1 From the Tools menu, select Package to display the Pack
dialog box (shown on 11-8).

2 In the Function area, click the Package and Assign 
Reference Designators Only button.

3 In the Set Values for area, click one of the three option 
buttons to specify which parts will have either reference 
designator or package information, or both assigned.

a Choose All Except User-Assigned to restrict the 
function to those attributes that you have not manua
assigned.

b Choose Only Unpackaged to restrict the function to 
values for reference designator, gate, and package t
attributes that have not been assigned.

c Choose All to give the function unrestricted access to 
parts, overriding user-assigned attribute values.

If you want to change the package class priorities, see th
procedure in the following section.

4 If you want to specify the number of the first reference 
designator to be assigned other than the default value o
type a value in the Starting Designator text box.

5 If you want to specify the amount to add to the starting 
designator between pages of the schematic, type a valu
the Page Increment text box.

6 If you want to specify the amount to add to the starting 
designator between levels of hierarchy, type a value in t
Level Increment text box.

7 Click OK.
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For details on adding package 
types and classes, see 
Configuring Package Types on 
page 6-46.

Tools Menu
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Settin g Package Class Priorities
Priorities can be set (for the packager) to use in determining
which package type to assign when a part is available in mo
than one type. For example, you could specify that a DIP 
package type be used. If the part is not available in DIP, the
could assign SMT, and so forth.

This is done by grouping commonly used package types int
classes. For example, all sizes of DIP packages (such as, D
and DIP16) belong to the DIP class.

For each device to be assigned a package type, the package
go through the package classes in the order listed, and assig
first package type defined for that device which belongs to th
class. However, if only one package type is defined for the 
package, it will be used, whether it is in the list or not.

Settin g up priorities

1 From the Tools menu, select Package to display the Pack
dialog box (shown on 11-8).

2 Click Setup Priorities to display the Setup Package Clas
Priorities dialog box.

3 If you want to add a package class to the Class Priorities 
select a class from the Package Classes list and click Ad

The package class is added to the end of the Class Prior
list.

4 If you want to delete a class priority, select a class from t
Class Priorities list, then click Delete.
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5 If you want to insert a class into the Class Priorities list, fir
select a class from the Package Classes list, then select
item in the Class Priorities list and click Insert. 

The package class is added to the list before the item 
selected in the Class Priorities list.

6 Click OK.

7 In the Package dialog box, click OK.
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If you select a part in the Part 
Browser and the name you 
select is an alias (electrically 
equivalent) of the basic symbol 
name, the part you get will have 
the basic symbol name. It will not 
have the name you type, 
therefore, it will effect your Bill of 
Materials.
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Generatin g a Bill of 
Materials Report
A Bill of Materials report lists the quantities of each compone
type used in the design along with corresponding reference 
designators. You can also include information such as values
part instance attributes (VALUE and TOLERANCE) and user defined 
attributes contained in a component description file.

Figure 11-3 is an example of a Bill of Materials report generat
for the PCBEX schematic shipped with your MicroSim 
programs. The only optional attribute chosen for display is t
part instance VALUE attribute.

Figure 11-3 Bill of Materials Report
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Generatin g a Bill of Materials report

1 Select Reports from the File menu to display the Report
dialog box.

 

2 Click Display.

The Bill of Materials dialog box appears and you can prin
display, or save the report.

Closin g the Reports dialo g box

1 Click Close.

Printin g and Savin g the Report

Printin g a Bill of Materials report

1 If not already in the Reports dialog box, select Reports fro
the File menu.

2 In the Reports dialog box, click Print.

Writin g the Bill of Materials report to a file

1 If not already in the Reports dialog box, select Reports fro
the File menu.

2 In the Reports dialog box, click Save As to display a 
standard Save dialog box.
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Customizin g the Format of the 
Report
1 Click Setup to display the Report Setup dialog box.

2 In the Format text box, type the attributes to be displayed
the report according to the following syntax:

[descriptive text]@<attribute name>

where the ‘@’ sign indicates value substitution for the 
named attribute. Specify multiple attributes by using the 
preceding syntax in a comma-separated list. For examp
you could specify that the part instance VALUE attribute, and 
your own user defined attributes, COST and ADDR, be 
reported by typing the following into the Format text box

value = @VALUE, cost = @COST, address = 
@ADDR

3 In the Component Description File text box, enter the nam
of the component description file (.cdf ) to be used.

4 Choose a Print Output format.

Choose Text to format the Bill of Materials report in ASCI
format with one entry per component type. 

5 Click OK.
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Commas must not be used 
between attributes.

Each set of component attributes 
must have a unique 
manufacturing ID.

To display the attribute, it must 
be listed in the Reports Setup 
under the File menu.
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User Defined Component 
Information
You can display user-specific component information (such 
costs and in-house part numbers) in the Bill of Materials repo
The Bill of Materials report will take a component description
file as input.

The component description file (.cdf extension) is a user-
created and maintained text file that contains component 
information such as cost, supplier name and in-house order
numbers. To facilitate extraction of this information from an 
external component database, each file entry must be in com
separated format, without spaces, as follows:

<component name>,< footprint name>, <manufacturing 
ID>,< attribute name>,< attribute value>

When you specify more than one user-defined property for a
given component type, you must give each entry identical 
<component name>, <footprint name> and <manufacturing ID> 
values. For example, two entries for the LM124 component 
might appear as:

LM124,DIP14,LM124J-ND,COST,$4.05
LM124,DIP14,LM124J-ND,SUPPLIER,National 

Each Schematics software installation is shipped with a 
user.cdf  file that you can edit to create a custom compone
description file. 

Resistors and capacitors as a special case

When creating user defined attributes in the component 
description file, resistors and capacitors are a special case. 
Because different-valued resistors and capacitors (and othe
components with a value attribute) do not have unique 
manufacturing IDs, a VALUE entry must immediately preced
the corresponding set of entries containing user-defined 
properties for a given device.
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The COST entries for 10K and 1K resistors would appear in 
component description file as follows:

R,RC05,R1,VALUE,10K
R,RC05,R1,COST,.05
R,RC05,R2,VALUE,1K
R,RC05,R2,COST,.03

Specif ying user-defined component attribute 
descriptions

1 From the File menu, select Reports to display the Repor
dialog box (shown on 11-13).

2 Click Setup to display the Report Setup dialog box (show
on 11-14).

3 In the Component Description File text box, enter the nam
of the user defined file that you want to use.

4 Click OK.

5 In the Reports dialog box, click OK.

Exportin g to a Spreadsheet or 
Database Pro gram
The report can be created in a database format so you can us
report in a spreadsheet program.

Specif ying the format of the Bill of Materials 
report

1 From the File menu, select Reports to display the Repor
dialog box (shown on 11-13).

2 Click Setup to display the Report Setup dialog box (show
on 11-14).

3 In the Print Output Format area, click Database.

Select Database to format the Bill of Materials report wit
one attribute name or value pair per entry. This results in
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multiple entries for component types with multiple 
attributes.

4 Click OK.

5 In the Reports dialog box, click OK.
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names, not pin numbers.
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Swappin g Pins
To swap pins on a given gate, add a SWAP attribute with the 
value of the pin names of the two pins to be swapped. For 
example:

SWAP=A B

will swap pin A with pin B.

Swappin g pins

1 From the Edit menu, select Attributes to display the 
Attribute Editing dialog box.

2 In the Name text box, type SWAP.

3 In the Value text box, type A B .

4 Click Save Attr.

5 Click OK.
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Creating a Layout Netlist for 
MicroSim PCBoards Checklist:

1 Check that PCBoards is the 
configured layout editor using 
the Configure Layout Editor 
selection from the Tools 
menu.

2 From the Tools menu, select 
Package to package the 
schematic and assign distinct 
reference designators.

3 Define any special trace 
width, trace clearance for 
nets, or placement attributes 
for parts.

4 Generate a Bill of Materials 
report and check that the 
package types are correct for 
the parts.

5 Create a layout netlist using 
the Create Layout Netlist 
selection from the Tools 
menu.

6 From the Tools menu, select 
Run PCBoards to start 
MicroSim PCBoards.

Note The Run PCBoards 
menu item only appears on 
the Tools menu if you have 
MicroSim PCBoards as the 
configured layout editor.
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Interfacin g with 
MicroSim PCBoards
MicroSim PCBoards is a PCB layout editor that enables you
interactively specify printed circuit board structure as well as t
components, metal, and graphics required for fabrication. 
Designs created in Schematics can be easily transferred to 
PCBoards for layout. Placement and trace properties are 
specified on the schematic for use by PCBoards. Schematic
board layout changes are automatically tracked; forward an
backward annotation capabilities help to maintain consisten
between the schematic and the layout. 

Specif ying Trace Properties
You can specify trace widths, clearances, and padstacks to
used for vias for routing. You do this by adding the attributes
shown in Table 11-2 to wires on the schematic.

To specify one or more of the preceding trace properties for
net:

1 Select any segment of a wire that is part of the net.

Table 11-2 Trace Properties Attributes

Attribute Description

NET_TRACE_WIDTH Width (in mils or mm) of trace 
segments in this net. If units are not
specified, the value is interpreted as
inches.

NET_CLEARANCE Edge-to-edge space (in mils or mm
between the trace segments and 
other layout objects. If units are not 
specified, the value in interpreted 
as inches.

NET_PADSTACK Name of the padstack definition to 
be used for vias when routing 
traces.
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2 Click the Edit Attributes button to display the Attribute 
Editing dialog box.

3 Type one of the attribute names listed in Table 11-2 in th
Name text box.

4 In the value text box, type the width, clearance, or padsta
value.

5 Click Save Attr.

6 Click OK.

Specif ying Component 
Locations
You can specify the position and orientation to use in the lay
for parts on the schematic. Do this by adding one or more of 
attributes shown in Table 11-3 to the parts.

Table 11-3 Component Location Attributes

Attribute Description

COMP_LAYER Name of the PCBoards layer representing
the surface that the component is to be 
positioned on. By default, Solder is the 
bottom surface and Component is the top 
surface.

COMP_X X-axis coordinate position (in mils or 
mm) of the part (at its origin) in the board 
layout. If units are specified, the value is 
interpreted as inches.



Interfacing with MicroSim PCBoards 11-21

art 

 

e 

 

You can also cross-probe the 
schematic from MicroSim 
PCBoards. Refer to the Cross-
Probing section of the Arranging 
Components chapter in your 
MicroSim PCBoards User’s 
Guide.
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To specify one of the properties shown in Table 11-3 for a p
on the schematic:

1 Double-click the part to display the Edit Attributes dialog
box.

2 In the Name text box, type the property name, such as, 
COMP_X.

3 In the Value text box, type the property value.

4 Click Save Attr.

5 Click OK.

Cross-Probin g
You can select a part or wire in Schematics and highlight th
corresponding component or trace in the PCBoards layout.

Highli ghtin g the component in the la yout for a 
part on the schematic

1 From the Tools menu, select Cross-Probe Layout in 
Schematics.

2 Click the part with the component you wish to see in the
layout.

COMP_Y Y-axis coordinate position (in mils or 
mm) of the part (at its origin) in the board 
layout. If units are specified, the value is 
interpreted as inches.

COMP_ANGLE Orientation of the part specified as an 
angle in degrees.

COMP_FIXED If YES, it designates the part is 
immovable; COMP_X and COMP_Y 
must be specified. This attribute defaults 
to NO.

Table 11-3 Component Location Attributes

Attribute Description
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Highli ghtin g the trace in the la yout for a net on the 
schematic

1 From the Tools menu, select Cross-Probe Layout in 
Schematics.

2 Select any segment of any wire that is part of the net.

Highli ghtin g multiple components or traces at 
once

1 Select the parts or wires in the schematic.

2 From the Tools menu, select Cross-Probe Layout.

Appl ying Backward ECOs
Each time a change is made to the layout, such as placeme
a new component, deletion of an existing component, chang
a reference designator, addition of a net, or addition and dele
of pins from nets, MicroSim PCBoards notes the change. Wh
you save the layout, MicroSim PCBoards writes all changes
a backward ECO file (.bco ). The next time you load the design
into Schematics, the backward ECO file is checked and the 
backward ECO process begins.

Changes can be applied selectively to the schematic. Some
changes are handled automatically by Schematics (gate sw
pin swaps, reference designator changes); others must be 
manually applied (deletion or addition of components, deleti
or adding pins to a net, addition or deletion of nets). An aud
trail of ECO decisions—if changes are pending, ignored, or 
require manual insertion—is maintained in the backward EC
log file (.blg ).

Refer to the Applying Backward ECOs section of the MicroSim 
PCBoards User’s Guide for more details.
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Appl ying Forward ECOs
Changes made to the schematic can be communicated to 
MicroSim PCBoards and automatically applied to the layout
Refer to the Applying Forward ECOs section in the MicroSim 
PCBoards User’s Guide for details.
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Interfacin g to Other 
Board La yout Products
Schematics creates layout netlists in the formats shown in 
Table 11-4.

Selectin g a layout format

1 From the Tools menu, select Configure Layout Editor to 
display the Configure Tools dialog box.

2 From the Layout Netlist list, Select a format.

The layout netlist will be created with the name 
<schematic>.<netlist file name extension>.

Table 11-4 Supported Layout Packages and File Formats

Package Layout Netlist ECO File

PCBoards .nlf .bco 

PADS .pad .eco

P-CAD .alt (none)

Protel .pro .eco

Tango .tan .eco

CADSTAR .cdn .rin

SCICARDS .upl .sif

EDIF 2 0 0 .edf (none)
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3 Click OK.

Creatin g a Layout Netlist

1 From the Tools menu, select Create Layout Netlist.

Layout Mappin g Files
When creating layout netlists, Schematics uses mapping file
These files let you customize the handling by the layout netlis
of part, net, and package type names. Mapping files are text f
that you can edit with any text editor. Schematics is shipped w
mapping files containing defaults and sample entries.

Mapping files exist for each of the supported layout formats.

• <layout format>.xmp

Contains rules for creating entries in the parts list 
section of the netlist. If the part names used in 
Schematics are different than the names used in the
layout package, you can specify the substitution to b
done.

• <layout format>.xnt

Contains name mappings for nets. For example, in 
Schematics the default power net on some digital pa
is named $G_DPWR, while in most layout systems it
+12V.

• <layout format>.xpk

Contains name mappings for package types. For 
example, in Schematics a package type is called TO
and in the layout editor it is TO-33.
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Common S yntax

Each file (.xmp , .xnt  and .xpk ) consists of a number of lines.
Empty lines and those starting with the ‘#’ character are ignor
Otherwise, a line consists of one or more comma-separated
identifiers followed by either an AKO specification or a 
replacement string.

An AKO (A Kind Of) specifier consists of the keyword AKO, 
followed by an identifier. Schematics looks up AKO definition
until it finds a definition that is not an AKO, then uses this ne
definition (circular AKO chains are not allowed).

The replacement string is processed further by Schematics 
then becomes an entry for the part in the Partlist section of t
layout netlist.

Examples:

DIODE DIODE,@PART

2N2220,2N2221,2N2222 TRNPN

1N914,1N915 AKO DIODE

The first example is a replacement string rule. This says that
string DIODE is to be replaced by the string DIODE,@PART. The 
second example shows how more than one identifier can 
reference the same replacement string. The third example sh
an AKO specification. In this case, the string 1N914 references 
the DIODE rule. This is a replacement (that is, not another AKO
so the net result is that Schematics will replace 1N914 by 
DIODE,@PART.

A target identifier may end with the ‘*’ character to indicate a
match with a pattern containing the same leading characters
to the ‘*.’ For example, LCC* matches LCC20, LCC28, etc.

Rules are tested in the order found in the file. A default rule 
specified anywhere in the file will be used when no matching
pattern is found. Rules can be empty (that is, a line may con
of a pattern or patterns, only).



Interfacing to Other Board Layout Products 11-27

or 
e 
ing 
s 
ers 
 

 

r 
e of 
 

 by 

 the 

ore 
t 
).

e 

Scug.bk : 11LAYOUT.FMK  Page 27  Monday, June 16, 1997  10:10 AM
Parts List Mappin g (.xmp)

After Schematics has found a matching rule in the map file f
the COMPONENT or PART attribute of a part, it further processes th
replacement string. This processing is similar to the process
of the TEMPLATE attribute of a part when a simulation netlist i
created. Identifiers in the string prefixed by one of the charact
‘@,’ ‘?,’ ‘~,’ ‘#,’ and ‘`’ are treated as part attribute names. A
simple example would be a string such as @PART—this is 
replaced by the value of the PART attribute. An error occurs if the
PART attribute is not defined. 

When the ‘̀ ’ (backquote) character precedes a ‘@,’ ‘?,’ ‘~,’ o
‘#’ character, it acts as a modifier. It causes the mapped valu
an attribute (looked up in the .xpk  file) to be used instead of the
attribute value itself. For example, 

`@PKG

would be replaced by the value of the PKG attribute, mapped
any matching rule in the .xpk  file.

Examples

1 Capacitors

We need to be able to provide for a generic capacitor (where
designer has not provided any information beyond the 
capacitor’s value and possibly a tolerance), and also for a m
specialized capacitor (where the designer supplies the exac
package type as well as the component value and tolerance

To support the simple case, a rule of the following form will b
required in the .xpk  file:

CAP CAP,@value?tolerance|,@tolerance|

C AKO        CAP

These rules will match a part with a COMPONENT or PART 
attribute with a value of CAP or C. They will produce entries in 
the Part list like:
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C101 CAP,10uF

or

C102 CAP,10uF,20%

depending on whether or not a TOLERANCE attribute has been 
specified. The VALUE attribute must be defined; Schematics wi
issue a message if a capacitor has no assigned value.

To support the case where the designer wishes to specify a
particular capacitor type (for example, CAP\CR08\5G from th
PADS library), the designer places an instance of a capacito
and then sets the COMPONENT attribute to CAP\\CR08\\5G.

The following rule in the .xpk  file will support this:

CAP\\* ?component|@component||@part|,
@value?tolerance|,@tolerance|

This tells Schematics to use the value of the COMPONENT 
attribute if that is set, or else to use the value of the PART 
attribute. This is followed by the value (required) and toleran
(optional).

Note The general form of the rule will work for all similar 
types of capacitors such as CAP\CR20\3G, etc.

2 TTL Devices

In this case, a rule is needed that passes the COMPONENT or PART 
attribute (such as, 74LS04) through to the Part list, appendin
package specifier for chip carrier devices. This .xmp rule will 
work:

74* ?component|@component||@part|&`pkg_type

This outputs the value of COMPONENT or PART, then tests the 
PKGTYPE attribute to see if it is defined. If so, its value is applie
to the set of rules defined in the .xpk  file. The translated value 
is then output.

Consider handling package types such as DIP14 and DIP16
LCC20, and LCC28. DIP packages and the Partlist item mu
have no suffix (in other words, a DIP version of a 74LS04 is ju
a 74LS04). The chip carrier packages must have the suffix -CC.
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backward ECOs from ECO files 
generated by:

PADS
CADSTAR
Tango
Protel
SCICARDS
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The following rules in the .xpk  file will implement this:

DIP* 

CC*           -CC

Note that the DIP* rule is empty; it matches package classe
such as DIP14, but there is no resulting replacement string.

The LCC* rule matches all strings that start with LCC, so it w
match package classes such as LCC20 and LCC28. It appe
the string -CC to the COMPONENT (or PART) name.

Back Annotation
During the course of layout generation, a design can underg
changes that make the design information in the PCB layou
database inconsistent with that in the schematic database. W
this occurs, the schematic must be back annotated with the 
design changes made during layout to resynchronize the 
schematic and layout data.

Design changes are usually documented as Engineering Ch
Orders (ECOs). Design changes from the layout to the 
schematic are called Backward ECOs because the direction of 
the change is opposite to the regular flow of design data.

Schematics supports the following types of backward ECOs

• changing the reference designator of a part

• swapping two gates

• swapping two pins

If any of the other ECO operations are present, Schematics 
the warning and displays them as “Unsupported function” 
messages. You need to manually make the changes for any
the unsupported functions listed in the back annotation log. 
Back annotation messages are logged in the same manner 
other Schematics errors and warnings.
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Usin g back annotation

1 From the Tools menu, select Back Annotate to display th
Back Annotate dialog box.

2 Type the name of the ECO file generated by the layout 
package in the ECO File Name text box.

3 Select an ECO file format from the ECO File Format list.

4 Click OK.

In step 2, if you don’t know the file name, click Browse an
select a file using the standard open file dialog box.
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Importin g OrCAD SDT 
Schematics
-9
A

Overview
This appendix provides information regarding importing 
OrCAD SDT files.

In this chapter you will find the following sections:

Importing OrCAD Files on page A-2.

Differences between OrCAD SDT and Schematics on page A.
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Importin g OrCAD Files
A schematic created with OrCAD SDT can be loaded into 
Schematics for editing. The schematic and any symbols it u
are translated from the OrCAD SDT format into the Schemat
format. This is a one-way process. You can also translate 
individual OrCAD SDT libraries with this command. 

When translating OrCAD SDT schematics, Schematics uses
OrCAD SDT configuration file, sdt.cfg , to determine which 
OrCAD SDT symbol libraries to use to find symbols. Symbo
referenced by the schematic are translated and put in a 
Schematics local symbol library. The sdt.cfg  file must be 
either in the same directory as the OrCAD SDT schematic, o
the TEMPLATE subdirectory under the directory pointed to b
the environment variable ORCADPROJ. 

Importin g an OrCAD file

1 From the File menu, select Import to display the Input 
OrCAD File dialog box.

2 Type the name of the file to be imported in the Input File
text box, or click the Browse button in the Input File area 
select a file.

3 Type the name of the directory where the translated 
schematic is to be saved in the Destination Directory tex
box, or click the Browse button to select a file.

The translated schematic file is given the same name as
original OrCAD SDT schematic file (.sch  extension). A 
translated symbol library is given the same file name, bu
with a .scb  extension instead of .sch .
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4 Select the check box for the options you want to select. T
two options are explained on the following pages.

5 Click Translate.
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Import Options

Include Simulation Information

Select the Include Simulation Information option to add 
simulation attributes to symbols in the library. This option als
converts part field data (part properties) on the OrCAD SDT
schematic into information that can be used by the Schema
simulation netlister.

The default mapping between OrCAD SDT part field data an
Schematics attributes is contained in the files devmap.ini  and 
orc_map.txt . This information is based on the standard 
OrCAD SDT libraries. You can change or add additional par
to these files with any text editor.

Enable this option if you plan to simulate your designs using
PSpice or PLogic. If enabled, the PSpice Simulation Device
Types Dialog will be displayed (see page A-6).

Include PCB Information

Select this option to create package libraries in addition to 
symbol libraries during translation. 

Enable this option if you plan to netlist the schematic for layo
When you enable this option, the Package Types dialog box
appears.
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Package Types Dialo g Box
When you enable the Include PCB Information option in the
Import OrCAD File dialog box, the Package Types dialog bo
appears.

To assign package types (footprints) and create packaging 
information for the parts on your schematic, Schematics uses
file orc_map.txt  to search for default package types. A list 
created of all parts with no found entries. The Package Type
dialog box enables you to assign package types for these p
The default is to make the package type (footprint) name the
same as the part name.

Other options in the Packa ge Types dialo g box

• The Package Type section lists the package types to be
assigned to the corresponding parts. The initial default is
assign a footprint with the same name as the part.

• The Parts section lists the parts with no default package
information available.

• Package Types defines the name of the package type to
assign to the selected parts. You can enter a name or se
one from the list.

• Set Package Type assigns the package type to the sele
parts in the Package Types text box.
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PSpice Simulation Device T ypes 
Dialo g Box

To convert OrCAD SDT part field data needed for simulation
Schematics must know the PSpice device type for each par
placed on the schematic. An initial guess is made during 
translation, based on the first letter of the reference designa
The PSpice Simulation Device Types dialog box displays th
list of parts and the translator’s initial assignment of device typ
Use this dialog to review the list and make any necessary 
corrections.

Part field data conversion is determined by the devmap.ini  
mapping file. For each PSpice device type, the map file lists 
OrCAD SDT part field corresponding to the simulation devic
parameters for that device type. Devmap.ini  is a text file that 
you may need to modify depending on how you used OrCAD
SDT part fields.
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Other options in the PSpice simulation device 
types dialo g box

• Part/RefDes lists each part’s symbol name and referenc
designator on the schematic.

• Device lists the PSpice device types to be assigned to th
corresponding parts.

• Available Device lists all of the available PSpice simulatio
device types.

• Set Device Type assigns the device type in the Available
Device text box to the selected parts.

Translatin g Multi-Pa ge 
Schematics
To translate a multi-page schematic, translate the root page 
page containing the |LINK text that lists the files of the other
pages). All pages referenced by the |LINK text are translate
Schematics keeps all pages of a multi-page schematic in a si
file; therefore, there will only be one resulting schematic file—
the root—which contains all the pages.

Translatin g Hierarchical 
Schematics
To translate a hierarchical schematic, translate the topmost 
sheet. Any lower-level schematic referenced by sheet symb
will also be translated.



A-8 Importing OrCAD SDT Schematics

n of 

n an 

l 
and 

.

 

Scug.bk : A-ORCAD.FMK  Page 8  Monday, June 16, 1997  10:10 AM
Translatin g Large Designs
Large designs may take a very long time to translate. To 
facilitate the translating of large designs, a standalone versio
the translator, orctrans.exe , is provided.

Text Size
Text sizes on translated schematics or symbols are based o
8-point font size. See Changing Page Size on page 3-23 for 
information on how to change fonts in Schematics.

Connectin g Signal Via Labels
In OrCAD, if two wires have the same label, the netlister wil
connect them. In Schematics, by default, this is not the case 
you must connect each wire to a port. Use the following 
procedure to change the default behavior to emulate OrCAD

Enablin g connectivit y via labels

1 From the Options menu, select Restricted Operations to
display the Restricted Operations dialog box.

2 Select the Connectivity Via Wire Labels check box.

3 Click OK.
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Differences between 
OrCAD SDT
and Schematics
Although Schematics makes every attempt to translate the 
schematic completely, there may be discrepancies in the 
resulting schematic depending on how certain features of 
OrCAD SDT were used. Go through any errors and warning
that occur during the translation, in addition to reviewing the
resulting schematic.

Here are the differences to be considered when translating y
OrCAD SDT schematic:

Ports

• Schematics has fixed size ports; that is, they do not resi
based on the label. When an OrCAD SDT schematic is 
translated, port symbols are created for each port size.

• In OrCAD SDT, you can have ports with multiple 
connections. This is translated as two ports overlaid with
pins facing opposite directions.

Wires and buses

• In Schematics, wires connect directly to buses without us
special symbols such as bus entries. Buses must be labeled 
with the set of signals they represent. Wires connected t
buses must be labeled with the signal name within the b
that they correspond to.

Therefore, during translation: 

OrCAD SDT Bus Entry objects are converted into 
regular wires or buses.

Prior to translation, when drawing bus rippers, you 
must use the OrCAD SDT Bus Entry object. If you draw 
a typical wire at an angle to look like the regular bus
ripper or entry object, the wire will not be connected t
the bus.
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• Wires that cross pins exactly at the pin hotspot are transla
as connected.

• Unlabeled wires connected to buses are translated as 
unconnected wires, that is, they are not connected to the

• Wires and buses in Schematics can only have a single la
Any connections, bus mapping or splitting that use the 
OrCAD multiple label feature will not translate correctly. I
Schematics, you will need to manually reconnect these 
wires and buses.

In Schematics, you can split a bus directly by labeling th
subbus with a subset of the signals on the main bus. Fo
example, if the main bus is data[0..15], you can connect
bus to it and label it data[0..7] and connect this directly to
port or pin with a name of the same width, such as, 
inputData[0..7]. (See Splitting buses on page 4-31.)

• By default, Schematics does not consider wires with the
same label to be connected unless they are drawn as 
connected. You must connect them to offpage ports or 
enable the Connectivity Via Labels option.

To change the default, see Enabling connectivity via labels 
on page A-8.

Simulation

• Simulation attributes that are added to symbols are based
information from the OrCAD SDT standard libraries. 
Therefore, pin name references in these attributes can b
incorrect if a part (such as user-drawn) is being used that 
the same name as another part (from the standard librar
for example) on the schematic.
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Unsupported b y Schematics

• The OrCAD SDT feature—pins with a pin number of zer
are not drawn.
Therefore, some symbols are drawn with unexpected pin
with missing pins. Only the first representation of the 
symbol (GATE A) is translated.

• Text with a vertical orientation is translated into rotated te

• Dashed annotation lines are not included in the translate
schematic. 

• De-Morgan equivalents (convert symbols).
You get the non-converted version on your schematic.

• Fill patterns used in parts are not translated.

Stimulus, Trace, and Layout symbols on the OrCAD SDT 
schematic are not translated.
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Exportin g DXF Files
 

B

Overview
This appendix provides information regarding exporting DXF
files.

In this chapter you will find the following sections:

Exporting DXF Files on page B-2.

Exporting from the Schematic Editor on page B-3.

Exporting in the Symbol Editor on page B-4.
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Exportin g DXF Files
The Export function generates Drawing Interchange Format
(DXF) files. These files are also known as AutoCAD Format
D files. You can export the entire schematic drawing, a page
portion of a page, or symbol graphics to a DXF file. 
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File Menu

To select more than one page, 
hold down S while 
selecting other pages.

Note The Selected Area 
Only option is only enabled if 
an area is selected in the 
drawing area before the 
Export menu command is 
chosen.
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Exportin g from the 
Schematic Editor
1 From the File menu, select Export to display the Export 

dialog box.

2 Select one of the following options:

• Click Select All to export all pages of the schematic file.

• Select one of the entries in the Pages dialog box to expo
specific set of pages.

• Select the Selected Area Only check box to export the 
currently highlighted selection in the schematic editing ar

3 Click OK to display the Export File Specification dialog 
box.

 

4 Specify the export file name and format, and click OK to
begin exporting.
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File Menu

To select more than one symbol, 
hold down S while 
selecting other pages.

Note The Current Symbol 
Only option is only enabled if 
a specific symbol was 
selected in the drawing area 
before the Export menu item 
was chosen.
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Exportin g in the S ymbol 
Editor
1 From the File menu, select Export to display the Export 

dialog box.

2 Select one of the following options:

• Click Select All to export all symbols in the current symbo
library.

• Select any of the entries in the Symbols dialog box to exp
a specific set of symbols.

• Select the Selected Area Only check box to export the 
currently highlighted selection in the symbol editing area

3 Click OK to display the Export File Specification dialog bo
(shown on page B-3).

4 Enter the export file name and format, and click OK to beg
exporting.
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Librar y Expansion and 
Compression Utilit y
C

Overview
This Appendix explains the Library and Expansion 
Compression Utility that can be used with the Schematics 
libraries.

In this chapter you will find the following sections:

Using the Library Utility on page C-2.

Expanding Library Definitions into Text Files on page C-3.

Compressing Definition Files into a Library on page C-3.

Salvaging a Corrupted File on page C-4.

Reorganizing a Library File on page C-4.
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Usin g the Librar y Utilit y
MicroSim Schematics and MicroSim PCBoards include a 
library utility (LXCWin) that works with the symbol, package
and footprint libraries.

You can use LXCWin to:

• expand a library into definitions and create a list of those
definitions (.lst  file)

• compress definitions listed in the .lst  file into a library

• salvage corrupted library files

• reorganize library files

To activate LXCWin

1 From the Windows Start menu, point to Programs, point
the MicroSim program entry, and select LXCWin.
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The individual definition files are 
automatically removed.
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Expandin g Librar y 
Definitions into Text 
Files
When you use LXCWin to expand a library, it reads the 
selected library line by line, and writes each definition of 
a symbol (.sym), package (.pkg), or footprint (.fpd) in 
plain ASCII format, to a text file. It also creates a .lst  file, 
detailing the file name and the corresponding definition 
name. 

To expand a librar y into individual definition files:

1 From the Action frame, select Expand.

2 Click the Process File button.

3 Select a library.

Compressin g Definition 
Files into a Librar y
When you use LXCWin to compress definitions it reads 
the .lst  file (a file of the same name as the library you 
selected), and packs each listed file into a selected library, 
in the order read. Thus, symbol, package, and footprint 
libraries can be built from files generated by another 
process.

To compress individual definition files into a 
librar y:

1 In the Action frame, select Compress.

2 Click the Process File button.

3 Specify a library.
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Salvaging a Corrupted 
File
To salva ge a corrupted file or one that has 
carria ge returns and line feeds

1 In the Action frame, select Fix Index.

2 Click the Process File button.

3 Select a library.

Reorganizin g a Librar y 
File
To reor ganize a librar y file

1 Expand the library.

2 Edit the .lst  file with a text editor to add, delete, or 
rearrange files.

3 Compress the library.
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.lst  File Format

Example:

7400.sym 7400

Table 11-5 .lst  File Format

File Name Definition Name

xxxx.sym xxxx
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Runnin g LXCWin Usin g 
Command Line Options
You can also run LXCWin using command line options.

The options are:

Example:

LXCWin *.flb

-f Fix Index (default)

-x Expand

-c Compress

-n Do not delete definition files

<libnames> One or more library names; the names m
include wildcards (*. ?)
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Advanced Netlistin g 
Confi guration Items
 on 
D

Overview
This appendix contains information regarding advanced 
netlisting configuration.

In this chapter you will find the following sections:

Specifying PSpice Node Name Netlisting Preferences on 
page D-2.

Specifying Board Layout Node Name Netlisting Preferences
page D-3.

Customizing EDIF Netlists on page D-4.
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Specif ying PSpice Node 
Name Netlistin g 
Preferences
By default, the PSpice netlister assigns names such as $N_
to nodes that are not explicitly labeled.

You can change the format that the netlister uses to create th
names by using a text editor and editing the msim.ini  file in the 
Windows directory. Add a line to the [SCHEMATICS] sectio
in the form:

nltemplate=<prefix>%[minimum width]ld

The default value is:

nltemplate=$N_%04ld

The term ld must be in lowercase.

If [ minimum width] begins with a zero, leading 0’s are added 
the number of characters in the node number is less than th
minimum width. For example, N%ld would create node 
numbers N1, N2, N3 instead of $N_001, $N_002, $N_003.
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Specif ying Board 
Layout Node Name 
Netlistin g Preferences
To change any of these settings, use a text editor and edit t
msim.ini  file in the Windows directory.

PCBHIERPATHSEP is the separator character to use when 
creating hierarchal net names in layout netlisting.

The PCBTEMPLATE item specifies the form that the layout 
netlister uses for creating node names.

The default value is:

PCBTEMPLATE=NN_%04LD
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Customizin g EDIF 
Netlists
You can change the amount each level in the netlist is inden
by changing the EDIFINDENT item in the [SCHEMATICS] 
section of the msim.ini  initialization file. Use a text editor to 
edit the msim.ini  file in the Windows directory.

EDIFINDENT specifies the character to use to indent each le
in an EDIF netlist.

The default is:

EDIFINDENT=”” ““
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Attribute List
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n 
E

Overview
This appendix is a list of attribute names used by Schematics
descriptions of each of those attributes. When you use the 
symbol editor to create a new symbol, the PART, MODEL, REFDES, 
and TEMPLATE attributes are provided as a default set. You ca
provide any other attributes as needed.



E-2 Attribute List

Attribute Description

COMPONENT The name o
the package
COMPONENT a

GATE The gate wit
to. For exam
B, C, D), this
Valid values 
specified as 
appropriate .p
do not requir
parts, but als

When a part
first gate def
in the packag
the schemati
to manually a
or double-cli

GATETYPE The name o
one type of g
and a NOR g
type. Each o
value that is 
assignments
package def
type. The ide
must match 

MODEL The name of
match the na
model as it a
your design i
Q2N2222, th
be Q2N2222
TEMPLATE att
     TEMPLATE=
where REFDES

of Q_Q1 4 6
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Table E-1 Reserved Attributes

See 
Notes 

f the package definition to be used for a part.  If the name of 
 definition is the same as the part name, then the 
ttribute is not necessary.

2 5

hin the package that a particular part instance is assigned 
ple, if a part is one of four gates in a package (such as, A, 
 attribute specifies which gate the part is assigned to. 
for the GATE attribute (A, B, C, D in this example) are 
part of the package definition for the part (given in the 
lb  Package Library file). Packages with only one gate 
e a gate name. This terminology applies not only to digital 
o to analog parts with multiple gates in a package.

 is placed, the GATE attribute is assigned the value of the 
ined for that part, or nothing at all if there is only one gate 
e. The value of the GATE attribute will be reassigned when 
c is packaged. You can edit the value of the GATE attribute, 
ssign a gate, by selecting Attributes from the Edit menu 

cking the REFDES attribute. See REFDES below.

2 4

f the gate type of a part. If a package contains more than 
ate (for example, a package that contains an AND gate 
ate), then there will be different symbols to represent each 
f these symbols must have a GATETYPE attribute, with a 
used during packaging to identify the correct pin 
 within the package definition. For multi-part packages, the 
inition will contain a set of pin assignments for each gate 
ntifiers used in the package definition for each gate type 

the GATETYPE attributes on the symbols.

2 5

 the model referenced for simulation. This name must 
me of the .model or .subckt definition of the simulation 
ppears in the Model Library file (.lib ). For example, if 
ncludes a 2N2222 bipolar transistor, with the .model name 
en the MODEL attribute on the symbol for that part will 
. This MODEL attribute can then be referenced in the 
ribute for netlisting: 
Q^@REFDES %c %b %e @MODEL
=Q1 and MODEL=Q2N2222, could result in a netlist entry 
 8 Q2N2222.

1 3 5



Overview E-3

See 
Notes 

the MODEL attribute is 
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the Symbol Library and 
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te is only 
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are four gates in a package 
l four parts would be 
inguishes them (such 
rst component of the 

2 4

art. (Examples: DIP14, 
 part has only one 
attribute will be 
 the package type by 
ve the PKGTYPE attribute 

2 4

e of the REFDES attribute 
esignator (PKGREF) and 
GREF is U1 and your 
ill appear as such on 
rectly in the schematic 
th attributes instead. 

in the schematic 
ntrols: one for the 
e Gate. 
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Attribute Description

In the schematic editor Edit Attributes dialog, 
marked with an asterisk. This means that the a
using this dialog. You must select Model from
the Edit Model dialog box to either change the
create an instance model. To edit the underly
part, select Model from the Edit menu in the s
schematic editor.

PART The name of the part that was retrieved from 
placed. When you use Get New Part, to selec
PART attribute reflects the name of the part tha
of this attribute will not change, for instance, w
MODEL attribute. You can always see what par
to the value of this attribute, which is usually d
schematic for all devices (for breakout device
the one visible on the schematic). The PART attribu
changeable in the symbol editor.

PKGREF The Package Reference Designator. If there 
(such as, A, B, C, and D), then the PKGREF for al
the same (such as, U1) and the GATE attribute dist
as, U1A, U1B, U1C, U1D). The PKGREF is the fi
REFDES attribute. See REFDES below.

PKGTYPE The physical carrier type to be used for the p
LCC20, DIP8). If the package definition for the
available package type defined, then the PKGTYPE 
assigned this value. You can manually assign
editing or creating this attribute, or you may ha
assigned during packaging.

REFDES The Reference Designator of a part. The valu
is a combination of the Package Reference D
the gate (GATE) attributes. For example, if your PK

GATE is A, then your REFDES will be U1A (and w
your schematic).The REFDES cannot be edited di
editor. You must edit the PKGREF or the GATE, or bo
When you double-click the REFDES of a part with
editor, the dialog that appears has two edit co
Package Reference Designator and one for th
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Attribute Description

The REFDES o
REFDES is U?.
replaced by 
when you se
gives each p
hierarchy.

SIMULATION-
ONLY

If present, th
simulation. T
no layout ne
such as volta
breakout.slb

TEMPLATE The recipe fo
specified in t
The number 
those approp
referenced fo
in the symbo

Notes:

1 These attributes are not cha  by an 
asterisk in the Edit Attributes

2 These attributes pertain to p

3 These attributes pertain to P

4 These attributes are automa tic 
editor.

5 These attributes must be pro ol 
editor.   
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See 
Notes 

f a part is defined in the symbol editor. The default 
 In the schematic editor, the ‘?’ portion of the REFDES is 
a number when the part is placed on the schematic, or 
lect Annotate from the Tools menu. The number assigned 
art instance a unique reference designator within a level of 

is attribute indicates that the part only has meaning for 
here will be a netlist entry for parts with this attribute, but 
tlist entry. The SIMULATIONONLY  attribute identifies parts 
ge and current sources, breakout devices (found in 

) and special symbols (found in special.slb ).

2 5

r creating a netlist entry for simulation. The pin names 
he TEMPLATE must match the pin names on the symbol. 
and order of the pins listed in the TEMPLATE must match 
riate for the associated .model or .subckt definition 
r simulation. The TEMPLATE attribute is only changeable 
l editor. 

1 3 5

ngeable within the schematic editor. These are the attributes marked
 dialog. 

ackaging and board layout.

Spice.

tically provided by Schematics when a part is placed in the schema

vided by the user when creating or modifying a symbol in the symb
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Symbol Libraries
hat 
F

Overview
This appendix contains the contents of the symbol libraries t
are provided with Schematics.



F-2 Symbol Libraries

es 
 

cs 

Scug.bk : F-SYMLB.FMK  Page 2  Monday, June 16, 1997  10:10 AM
Usin g Symbol Libraries
Symbols are stored in symbol libraries. The symbol library fil
have a .slb  extension and contain graphical representations
and attributes of parts.

The contents of the symbol libraries provided with Schemati
are listed in Table F-1.

Parts from libraries marked with † do not have corresponding 
simulation models.

Table F-1 Symbol Libraries

Symbol 
Library File 
Name

Contents

7400.slb 7400-series TTL

74ac.slb Advanced CMOS

74act.slb TTL-compatible, Advanced CMOS

74als.slb Advanced low-power Schottky TTL

74as.slb Advanced Schottky TTL

74f.slb FAST

74h.slb High-speed TTL

74hc.slb High-speed CMOS

74hct.slb TTL-compatible, high-speed CMOS

74l.slb Low-power TTL

74ls.slb Low-power Schottky TTL

74s.slb Schottky TTL

abm.slb Behavioral modeling blocks

adv_lin.slb Advanced Linear Devices: operational amplifiers

analog.slb Passive and semiconductor primitives
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analog_p.slb Same devices as “analog.slb” with visible pin 
numbers for R, L, C, R_VAR and C_VAR 
devices

anl_misc.slb Timers, three-phase transformer, relays, CMOS
transistor array, variable impedance, variable 
admittance, time-dependent switches

anlg.slb† Multiplexers, DAC, ADC, voltage-to-frequency 
converters

anlg1.slb† DAC, ADC, sample-and-hold amplifiers

anlg2.slb† voltage references, voltage regulators, PWM, 
DAC, ADC, transceivers

anlg_dev.slb Analog Devices Inc.: operational amplifiers, 
transistor arrays, buffers, voltage references, 
analog multipliers, analog switches

apex.slb Apex Microtechnology Corporation: operational
amplifiers

atmel.slb† Atmel Corporation: EEPROM, PROM, SRAM, 
PLD

bipolar.slb Bipolar transistors

breakout.slb Parameterized devices for model purposes

broktree.slb† Brooktree Corporation: DAC, delay lines, 
comparators

burr_brn.slb Burr-Brown Corporation: operational amplifiers

cd4000.slb CD4000 digital devices

chips.slb† Chips and Technologies, Inc.: CPU

cmos.slb† counters, shift registers, PLL, buffers, 
modulators, gates, adders, switches, multipliers,
display drivers, timers, flip-flops, latches

comlinr.slb Comlinear Corporation: operational amplifiers

Table F-1 Symbol Libraries (continued)

Symbol 
Library File 
Name

Contents
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connect.slb Connectors

dallas.slb† Dallas Semiconductor: delay lines, SRAM, 
transceivers, timers, FIFO, microcontrollers

dataconv.slb† ADC, DAC

dig_ecl.slb Emitter coupled logic devices

dig_gal.slb Generic array logic devices

dig_misc.slb Miscellaneous digital devices

dig_pal.slb Programmable array logic devices

dig_prim.slb Digital primitives for use with PLSyn as well as 
general simulation purposes

diode.slb Diodes, Zener diodes, current regulator diodes,
varactors

ebipolar.slb European bipolar transistors

ecl.slb† Motorola Corp., National Semiconductor Inc.: 
DRAM, gates, multiplexers, level translators, 
prescalers, error correction/detection

ediode.slb European diodes and rectifiers

elantec.slb Elantec Inc.: operational amplifiers, transistor 
arrays

epwrbjt.slb European power bipolar transistors

exel.slb† Exel Microelectronics Inc.: EEPROM

filtsub.slb Filters

fujitsu.slb† Fujitsu Limited: PROM, DRAM, SRAM, 
EEPROM

fwbell.slb F.W. Bell: Hall effect devices

goldstar.slb† Goldstar Semiconductor Group: ROM, DRAM, 
SRAM

Table F-1 Symbol Libraries (continued)

Symbol 
Library File 
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har_dig.slb Harris Semiconductor Corp.: PROM, 
microprocessors, VART, interface, transceivers,
controllers, SRAM

harris.slb Harris Semiconductor Corp.: operational 
amplifiers, MCT, bridge drivers, transistor 
arrays, power MOSFET

hughes.slb† Hughes Microelectronic Center: display drivers, 
CPU, SRAM

hyundai.slb† Hyundai Electronic Inc. Ltd.: PLD, DRAM, 
SRAM

intel.slb† Intel Corp.: EPROM, CPU, math co-processors, 
microcontrollers, SRAM, network processors

jbipolar.slb Japanese bipolar transistors

jdiode.slb Japanese diodes, rectifiers, Zener diodes, 
varactors, Schottky diodes

jfet.slb Junction field-effect transistors

jjfet.slb Japanese junction field-effect transistors

jopamp.slb Japanese operational amplifiers

jpwrbjt.slb Japanese power bipolar transistors

jpwrmos.slb Japanese power MOSFETs

lin_tech.slb Linear Technology Corporation: operational 
amplifiers

magnetic.slb Magnetic cores, inductor coupling devices

marker.slb Probe markers (this file is automatically accesse
by Schematics and should not be included in the
list of configured library files)

mcpwrsys.slb† Micro Power Systems: ADC, DAC, data 
acquisition, voltage references

Table F-1 Symbol Libraries (continued)

Symbol 
Library File 
Name

Contents
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mcrndram.slb
†

Micron Semiconductor, Inc.: DRAM

mcrnram2.slb
†

Micron Semiconductor, Inc.: DRAM

mcrnsram.slb† Micron Semiconductor, Inc.: SRAM

memory.slb† EPROM, PROM, SRAM, PAL, DRAM, 
EEPROM

misc.slb Timers, CMOS transistor arrays, variable 
admittance, variable impedance, three-phase 
transformers, relays, DC motor, time-dependent
switches

mitmem.slb† Mitsubishi Electric Corporation: EEPROM, 
PROM, DRAM, SRAM

mitram.slb† Mitsubishi Electric Corporation: DRAM, SRAM

mitrom.slb† Mitsubishi Electric Corporation: EPROM

mix_misc.slb Timers, DC motors, relays

mosel.slb† Mosel-Vitolic Inc.: SRAM, FIFO

moto.slb† Motorola Corp.: CPU, microcontrollers

moto7.slb† Motorola Corp.: SCR, triac

motoramp.slb Motorola Corp.: operational amplifiers

motormos.slb Motorola Corp.: power MOSFET

motor_rf.slb Motorola Corp.: RF bipolar transistors

nat_semi.slb National Semiconductor Inc.: operational 
amplifiers

nsclnapp.slb† National Semiconductor Inc.: video sync 
generators, power drivers, level translators, 
display drivers, PLL, switches, noise reduction 
processors, power amplifiers, timers

Table F-1 Symbol Libraries (continued)

Symbol 
Library File 
Name

Contents



Using Symbol Libraries F-7

Scug.bk : F-SYMLB.FMK  Page 7  Monday, June 16, 1997  10:10 AM
nsdram.slb† National Semiconductor Inc.: error detection/
correction, DAC, memory controllers

nsnetwk.slb† National Semiconductor Inc.: interface 
controllers, network interface

nsucont.slb† National Semiconductor Inc.: microcontrollers

oki.slb† OKI Semiconductor: display drivers, DRAM, 
EEPROM, EPROM, DRAM, SRAM, 
microcontrollers, clock, speech synthesis, 
recorders, CODEC, modems

opamp.slb Operational amplifiers, voltage comparators, 
voltage regulators, voltage references

opto.slb Opto couplers

pansonc.slb† Panasonic Industrial Group: ROM, DRAM, 
SRAM, FIFO

polyfet.slb PolyFet RF Devices: RF MOSFET

port.slb Global ports, off-page ports, interface ports, 
ground symbols

pwrbjt.slb Power bipolar transistors

pwrmos.slb Power MOSFET

seeq.slb† Seeq Technology Inc.: data link controllers, 
Manchester code converters

sgsthom.slb† SGS_Thompson Microelectronics: EPROM, 
SRAM, FIFO, EEPROM

sipex.slb† Sipex Corporation: ADC, DAC, voltage 
references, sample-and-hold amplifiers, data 
acquisition

smos.slb† S-MOS Systems: DC/DC converters, voltage 
regulators, display drivers, SRAM

sony.slb† Sony Corporation: ADC, gates, ALU, 
multiplexers, SRAM

Table F-1 Symbol Libraries (continued)

Symbol 
Library File 
Name

Contents
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source.slb Voltage and current stimulus devices

special.slb Simulation pseudocomponents (IC, NODESET,
etc.)

swit_rav.slb Averaged switched-mode power supply blocks

swit_reg.slb Switched-mode regulators

tex_inst.slb Texas Instruments Inc.: operational amplifier, 
voltage comparators

thyristr.slb SCR, triac, UJT

ti1.slb† Texas Instruments Inc.: line drivers, transceivers
display drivers, ADC, switches

ti2.slb† Texas Instruments Inc.: SRAM, EPROM, 
DRAM, PROM, memory controllers

tilsi.slb† Texas Instruments Inc.: FIFO, error detection/
correction, multipliers, pipeline registers, flip-
flops, bus transceivers, memory controllers

tline.slb Transmission lines

ttl.slb† Multiplexers, counters, flip-flops, bus 
transceivers, gates, monostable multivibrators, 
encoders, FIFO, buffers, adders, decoders

vlsitec.slb† VLSI Technology Inc.: ALU, UART, memory 
controllers, CPU, display drivers

weitek.slb† Weitek Corp.: math co-processors

wsi.slb† WaferScale Integration Inc.: PROM, EEPROM, 
CPU, multipliers

Xc2000p.slb Xilinx: FPGAs 2000 Family

Xc 3000p.slb Xilinx: FPGAs 3000 Family

Xc4000p.slb Xilinx: FPGAs 4000 Family

Xc4000ep.slb Xilinx: FPGAs 4000e Family

Table F-1 Symbol Libraries (continued)

Symbol 
Library File 
Name

Contents
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Xc5200p.slb Xilinx: FPGAs 5200 Family

xicor.slb† XICOR Inc.: SRAM, EEPROM, potentiometers

xtal.slb Quartz crystals

zilog.slb† Zilog Inc.: I/O controllers, CPU, counters

Table F-1 Symbol Libraries (continued)

Symbol 
Library File 
Name

Contents
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ABM Analog behavioral model. A view of a hierarchical schematic used for 
analysis. See also View.

AKO “A Kind Of” symbol. Symbols must either contain graphics or refer to an 
AKO symbol. The AKO defines the symbol in terms of the graphics and pin
of another part. Both must exist in the same symbol library file.

alias An exact electrical equivalent that can be used to reference a symbol.

annotation A means by which parts are labeled when they are placed, either automatic
or manually.

annotation
symbols

A symbol with no electrical significance, used to clarify, point out or define 
items on the schematic.

attribute Special characteristics (a name and an associated value) contained in a pa
instance or definition. For example, a MOSFET may contain specific length
and width parameters that are represented as attributes on the symbol or p
Attributes may be changed through the schematic editor, the symbol editor
both.

back annotation Annotation of a schematic using an ECO file from the selected layout edito

block A user defined rectangle placed on a schematic. It is used to represent or h
the place for a collection of circuitry. The block is treated as a black box by 
Schematics. Schematics is aware of the connections going into and out of 
block, but ignores the contents of the block until netlisting.



Glossary-2

e 

rts, 

 a 

 

ion 

n 
 

ed 

in 

Scug.bk : GLOSSARY.FMK  Page 2  Monday, June 16, 1997  10:10 AM
boundin g box A rectangular dotted line containing the graphics for a symbol and all visibl
pin connection points. In terms of the schematic editor, the position of the 
bounding box determines whether a point falls on a part when selecting pa
or whether it falls on the pin of a part when checking for electrical 
connections. Box defines the selection area of the symbol when placed on
schematic.

bundle A collection of named wires or buses of the same type or purpose.

bus A collection of homogeneously named signals.

circuit A configuration of electrically connected components or devices.

connector A physical device that is used for external connections to a circuit board. A
connector has no electrical significance until it is connected on a PCB.

current sensor Displays the bias point current flow in a given direction.

desi gn A schematic drawing or set of drawings representing a circuit or PCB.

display map A portion of the initialization file that specifies which schematic items are 
turned on and off for display and printing. 

ECO Engineering change order. A design change usually requiring back annotat
of the schematic.

ERC Electrical rules check, a process performed before generating a netlist or 
running the simulator. The ERC performs a preliminary connectivity check o
the schematic. If the schematic is part of a hierarchical design, the check is
performed only for the current hierarchical level.

fileset The set of files required to perform a certain function. 

flat schematic A flat, single-level schematic containing only primitive symbols from the 
component libraries. A flat schematic can be either single or multiple page.

gate A subset of a package, and corresponds to a part instance.

global editin g Editing of a symbol, attribute or attribute value, saved in a library, and appli
to all designs using that particular symbol.

global port Provides a connection to another global port of the same name anywhere 
the schematic.
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gravity The property of a drawing object to snap to the nearest grid or pin when be
placed on a drawing or moved about a drawing.

gravity radius The distance between the cursor and an object on the schematic in which 
object can be selected.

grid A pattern of horizontal and vertical lines that aid in placing objects on a 
schematic or symbol drawing.

hidden pins Pins that are not connected by wires and buses, but through an attribute th
names the net that they belong to.

hierarchical
desi gn

A design of more than one level wherein a portion of the design (lower-leve
schematic) is represented by a block or symbol on a higher-level schemati

hotspot The point at the end of a pin that forms a junction when it intersects with a 
wire or bus segment

instance name A unique name for a part instance.

interface port A port providing connectivity to the pins of hierarchical symbols or blocks.

junction A graphical indication that wires, buses, and pins are electrically connected

marker Notations placed on a schematic to identify locations for observing voltage
current or digital signal levels, or waveform behavior when the circuit is 
analyzed.

messa ge A character string generated by an application, describing some kind of 
condition, status or other information, and displayed by the Message Viewe

model definition An underlying description of the electrical behavior of a part using a set of 
variable parameters. Used by PSpice.

msim.ini file The initialization file, usually contained in the Windows directory, containing
start-up and configuration information for MicroSim programs, including 
Schematics.

navi gation The process of moving between pages in a multi-sheet schematic, or betw
levels in a hierarchical design.

net A set of electrically connected part pins. A net may be anonymous or named. 
An anonymous net might be the junction of two resistors. A named net cou
be a wire labeled CLOCK connecting two digital parts.
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netlist A list providing the circuit definition and connectivity information in 
simulation netlist format.

nodeset A symbol containing one or two pins, permitting you to initialize a node 
voltage for simulation.

off-pa ge port A port connecting pages of a schematic. Off-page ports may or may not 
contain a LABEL attribute.

ori gin The point on a symbol designated for placing a part. When a symbol is rota
on the schematic, it is rotated about this point.

packa ge A physical device consisting of one or more gates.

packa ge library
definition

The use of a mathematical model to represent the physical operation of a 
circuit design.

packa ge type An attribute specifying the type of physical package that the actual circuit 
board will use. For example, DIP14, chip carrier, surface mount.

packa ge type
class

An attribute specifying grouping of similar package types. For example, DIP
would be the class for all sizes of dip package types (DIP14, for example).

page One sheet of a multiple-sheet schematic. A page may contain both parts 
(represented by symbols), port instances, connectors, and annotation symb
A page may or may not have a title. Each schematic page represents a sin
page of a circuit design.

part An electrical component that is represented by a schematic symbol.   A pa
refers to the logical rather than the physical component.

part description Describes the symbol in terms of its symbol type, such as 2-input NAND.

part instance Refers to an occurrence of a symbol in a schematic.

part outline Consists of the symbol for a part (graphics and pins), minus any text.

pin Contained in parts, ports and off-page connectors. Parts can contain multip
pins. Each part contains specific pin names associated with the part. Pins m
connect to a wire, a bus or another pin.

pin definition Provides the pin number, the location of each pin relative to the symbol orig
and the electrical attributes of the pin.
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pin name A name that uniquely identifies the pin on a part.

pin number The physical device pin number.

pin-to-pin
spacin g

Determines the size of the symbols as they appear on the printed page. Th
distance between pins is set during the initial installation, but may be chang

port Provides connectivity across schematic pages. A port provides the anchor f
single pin. Ports are chosen from library files, placed, moved, and deleted 
the same way as are parts. Ports may have multiple connections. Ports co
of three types: global, interface, and off-page (defined in this Appendix).

primitive symbol A symbol that is an individual component for a specific netlister. That is, it i
completely specified electrically for the purpose it is required to perform.

reference
desi gnator

An attribute used as a unique name on a given schematic level. For examp
resistor with the reference designator “R5,” would indicate that it is the 5th 
instance of the resistor (R) on a particular schematic. For package parts, it
consists of concatenation of the package’s reference designator followed b
the gate name assigned to the part. The reference designator is used as a
for the simulation netlist. Reference designators can be either automatically
manually assigned. Reference designators represent a unique name used
reference a physical device. Parts with the same reference designator are 
packaged into the same physical device.

schematic A drawing consisting of the following components: one or more pages, a se
symbols representing local part definitions, or parts in a library file and text

selection area When drawing or editing a schematic or symbol, the area identified and 
enclosed by a region-of-interest (ROI) box for the purpose of performing som
operation on the objects within the area.

setpoint A special symbol used to specify initial node voltages during simulation.

simulation The use of a mathematical model to represent the physical operation of a 
circuit design.

stimulus Symbols placed on a schematic to identify digital and analog voltage and 
signal sources used during simulation.

symbol Consists of the graphical representation of a logical or physical electronic p
on the schematic. A symbol may have one or more associated attributes.
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symbol
definition

Consists of the data from which the netlist is generated. A symbol or part 
definition consists of the following: the part name and any aliases, its 
attributes, primitive definition (also called the circuit definition), and pin 
definitions.

symbolize Creating a symbol to represent a schematic.

translator (1) Another name for a netlister

(2)The process of reading a schematic created by another design program
converting it to a Schematics file.

view A mechanism for allowing hierarchical symbols to have more than one 
underlying representation, for example, defining a flip-flop to have a transist
view or a gate view.

viewpoint A special symbol used to display bias point voltages and currents during 
simulation.

volta ge
viewpoint

Displays the bias point voltage at a pin. Any pin on part or a port may have
viewpoint attached.

wire A graphical indication of a connection between pins, buses and other wires
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Index
A
a kind of, See AKO
ABM, Glossary-1
accessing symbols, 6-20
Add Text dialog box, 4-51
adding

annotation graphics, 4-54
annotation text, 4-50
attributes, 4-14
library, 3-18
multiple line text, 4-50
non-electrical information, 4-50
package type, 6-46
package type for a component, 6-38
page to design, 4-60
pins to a symbol, 6-12
stimulus, 8-7
symbol alias, 6-33
text to schematic, 4-51
text to symbol, 6-12
wire segment, 4-28

Additional Info dialog box, 3-49
advanced netlisting configuration items, D-1
AKO

creating, 6-9

definition of, Glossary-1
specifier, 11-26
symbols, 6-7

alias
definition of, Glossary-1
using, 6-33

analog behavioral model, See ABM
Analysis Setup button, 3-10
annotation

back, 4-13, 11-29, Glossary-1
definition of, Glossary-1
page border, 3-4
symbols, 3-4, 4-58
title block, 3-4

annotation graphics
adding, 4-54
importing, 4-57, 6-13
resizing, 4-55

Annotation Graphics toolbar, 3-12
annotation symbols

creating, 4-58
definition of, Glossary-1
non-electrical information, 4-58

annotation text
adding, 4-50

App Settings dialog box, 3-38, 3-40
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arc, drawing, 6-10
archive, 2-6
assigning

annotation, 4-13
attribute names, E-1
attribute value, 4-17
instance-specific part values, 7-17
package types, A-5
pin numbers, 6-42
pins, 6-34, 6-40
reference designator, 1-14, 4-21, 7-4, 11-7

attribute
definition of, Glossary-1
deleting, 4-14
editing, 4-12
enabling display, 4-15
global editing, 4-17
intrinsic property, 4-12
list, E-1
non-changeable, 4-13
selecting, 4-40
simulation, 8-3
SWAP, 11-18
system defined, 4-13
text, 5-12
value, 3-4, 4-12
view, 7-13

Attribute Editing dialog box, 4-12
attribute text

changing, 5-12
attribute values

multiple parts, 4-17
attributes

adding, 4-14
changing display, 4-14
display choices, 4-15
part instance display characteristics, 4-15

Attributes dialog box, 5-14, 6-44
auto-fit, 4-65, 5-21
automatic panning, 3-45
automatically

assigning reference designators, 11-9
labeling buses, 4-32
labeling wires, 4-32

auto-naming, 1-13, 4-21, 4-22, 4-32
Auto-Naming dialog box, 1-13, 4-21
auto-repeat, 1-9, 4-19, 4-22, 4-44, 6-22
Auto-Repeat dialog box, 4-19
autosave interval, 3-32

B
Back Annotate dialog box, 11-30
back annotation, 4-13, 11-29

definition of, Glossary-1
base symbol, 6-7
Bbox, 6-29
behavioral model, 7-13
bill-of-materials report

customizing, 11-14
exporting, 11-16
generating, 11-12
printing, 11-13

bitmaps
importing, 4-57, 6-13

block
definition of, Glossary-1
drawing, 3-9
See also hierarchical block

Block View dialog box, 7-8
board layout, preparing design for, 11-1
border style

changing, 3-26
outline, 3-27
setting, 3-24
zoned, 3-27

bounding box, 6-29
definition of, Glossary-2

box, drawing, 6-11
browse

attributes, 4-17
browser

library, 1-8, 1-16, 4-8
part, 1-8, 1-16, 4-6

browsing
symbol libraries, 4-8

bundle
definition of, Glossary-2

bus
definition of, Glossary-2
drawing, 1-12, 3-9, 4-30, 4-31
labeling, 1-12, 4-30, 4-31, 4-32
orthogonal, 4-33
placing, 4-22
selecting, 4-40
splitting, 4-31

bus label
editing, 4-31

buttons
Draw Wire, 7-23
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C
CADSTAR layout format, 11-24
Change Attribute dialog box, 4-15, 5-12
Change Pin dialog box, 5-14, 6-24, 7-7, 7-23
Change Text dialog box, 5-15, 6-13
changing

a placed pin type, 6-24
application settings, 3-38
attribute text, 5-12
attribute value, 4-17
border style, 3-26
bounding box size, 6-29
custom libraries, 4-18
default value, 4-18
display characteristics of attributes, 4-15
drawing area, 3-28
free-standing text, 5-15
graphics properties, 4-55, 4-56
gravity, 3-29
grid, 3-29
hierarchical block reference designator, 7-5
library search order, 3-21
page title, 4-46
part values, 1-14
pin name text, 5-14
pin names on blocks, 7-23
pin number text, 5-14
pin numbers, 6-25
reference designators, 1-14
search path, 3-22
text characteristics, 5-12
text properties, 4-52, 4-53
value of attribute, 4-12

changing properties
on instance basis, 4-52, 4-55

checking
library configuration, 1-7
part has simulation model defined, 8-5

checklist, simulation, 4-4
circle, drawing, 6-11
circuit

definition of, Glossary-2
clipboard

copying to, 4-45
pasting from, 4-45

closing
Message Viewer, 3-49
schematic editor, 4-70
single schematic, 4-70

symbol editor, 5-6
color

configuration, 3-37
component locations, 11-20
components

aspects of, 5-3
description file, 11-15
multi-gate, 6-41
multiple gate types, 6-44
of design, 3-3
with more than one symbol, 6-44

Configure Tools dialog box, 11-24
configured package types list, 6-38
configuring

application settings, 3-38
autosave interval, 3-32
colors, 3-37
custom libraries, 6-48
display, 3-34
fonts, 3-36
library, 3-16
MicroSim Schematics, 3-15
msim.ini file, 3-39
netlist, D-1
package types, 6-46
page settings, 3-24
select recent part list size, 3-41
simulation library, 8-5
symbol libraries, 1-7, 3-16

Configuring Package Types
dialog box, 6-46

connecting
inter-page signals, 4-61
schematic pages, 3-4
signals via labels, A-8
wire to a bus, 4-29
wires to bus, 1-12, 4-31

connections, 3-5, 4-30
connectivity

implicit, 7-13
in multi-sheet designs, 4-60
OrCAD schematics, A-8
orthogonal, 4-33
rubberbanding, 4-35
rules, 4-30

connector
definition of, Glossary-2
placing, 11-3
symbol, 11-5

controlling display, 3-34
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conventions
mouse, iv
typographical, iv

Copy Package Definition dialog box, 6-36
Copy Page dialog box, 4-61
Copy Part dialog box, 4-18, 6-5
copying

between pages, 4-62
package definition, 6-36
page, 4-61
part, 4-18
selected object, 6-21
symbol, 6-5
to clipboard, 4-45

Create Page dialog box, 4-60
creating

AKO symbol, 6-9
annotation items, 4-50
annotation symbols, 4-58
base symbol, 6-7
connections between pages, 4-61
connector symbols, 11-5
custom title block, 4-48
design, 1-2
design for board layout, 8-3
design for simulation, 8-3
DSL blocks, 10-2
ground symbol, 4-27
hierarchical block, 7-4
hierarchical design, 1-2, 7-20
hierarchical symbols, 7-9
interface ports, 7-6
multiple-gate components, 6-44
multi-sheet designs, 4-60
new attribute, 4-12
new page, 4-60
new symbols, 6-3
package definition, 6-35, A-5
power symbol, 4-27
schematic for hierarchical block, 7-5
symbol, 1-2
symbol by copying, 6-5
title block, 4-46

cross probing, 11-21
Current Marker button, 3-10
current sensor

definition of, Glossary-2
current stimulus source, 8-7
custom libraries

changing, 4-18

configuring, 6-48
customizing bill-of-materials report, 11-14
cutting

between pages, 4-62
selected object, 4-43, 6-21

D
default

package types, A-5
pin type, 6-12
pin types, 6-23
symbol attribute, 4-18
view, 7-13

defining
connector package, 11-5
gate names, 6-41
hidden power and ground pins, 6-27
number of gates, 6-41
pin number assignments, 6-42
pin types, 6-23
shared power and ground pins, 6-42
stimulus, 8-7

definition
AKO, 11-26
model, 4-4
package, 4-4, 11-6

Definition dialog box, 6-33
Delete Page dialog box, 4-63
deleting

attributes, 4-14
package definition, 6-45
page, 4-63
pin on hierarchical block, 7-7
selected object, 4-44, 6-22

de-selecting
selected objects, 4-41

design
components of, 3-3
creating, 1-2
definition of, Glossary-2
editing, 1-2
hierarchical, 7-3, Glossary-3
methods, 7-3
multi-sheet, 4-60
packaging parts in, 11-6
printing, 4-64
starting new, 1-6

Design Manager, 2-1
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design synthesis language block, See DSL block
dialog boxes

Add Text, 4-51
Additional Info, 3-49
App Settings, 3-38, 3-40
Attribute Editing, 4-12
Attributes, 5-14, 6-44
Auto-Naming, 1-13, 4-21
Auto-Repeat, 4-19
Back Annotate, 11-30
Block View, 7-8
Change Attribute, 4-15, 5-12
Change Pin, 5-14, 6-24, 7-7, 7-23
Change Text, 5-15, 6-13
Configure Tools, 11-24
Configuring Package Types, 6-46
Copy Package Definition, 6-36
Copy Page, 4-61
Copy Part, 4-18, 6-5
Create Page, 4-60
Definition, 6-33
Delete Page, 4-63
Display Options, 3-30, 3-31, 4-34, 5-8, 5-16
Display Preferences, 3-36
Edit Attributes, 4-59, 11-18
Edit Gate Types, 6-41
Edit Package Definition, 6-35
Edit Package Types, 6-38
Edit Reference, 7-22
Edit Reference Designator, 1-14, 7-5, 11-7
Editor Configuration, 3-18, 6-48
Export file specification, B-3
Export Parts, 6-6
Find, 4-42
Font, 3-36
Get Package Definition, 6-37
Global Edit Attributes, 4-17
Graphics Properties, 6-15
Import, 6-6
Import OrCAD File, A-2, B-3
Library Browser, 1-8, 4-8, 4-39
Library Settings, 3-18, 6-48
Package, 11-8
Package Definition, 6-35
Package Types, A-5
Page Info, 4-46
Page Settings, 3-28
Page Size, 3-23
Pan & Zoom, 3-43, 3-45
Part Browser, 1-8, 1-9, 1-16, 4-6, 7-21

Pin Assignments, 6-40
Pin Swaps, 6-43
Pin Type, 6-24
Place Text, 6-12
Print, 4-64, 5-21
Remove Package Definition, 6-45
Replace Part, 4-24
Report Setup, 11-14
Reports, 11-13
Schematics Export, B-3
Select Page, 4-62
Set Attribute Value, 1-11, 4-29, 7-18
Set Up Block, 7-24
Set Up Block dialog box, 7-5
Setup Package Class Priorities, 11-10
Shared Pin Assignments, 6-42
Symbol Wizard, 6-4
Symbols Export, B-4
Toolbars, 3-7
Translators, 7-14
Where, 7-16

digital stimulus source, 8-7
disabling

auto-repeat, 4-20
grid display, 5-16
snap-to-pin, 3-31, 4-34, 5-17
stay-on-grid, 3-30, 5-16
toolbar display, 3-7, 5-8

display map
definition of, Glossary-2

display options
gravity, 4-35
grid on, 3-29, 5-16
grid spacing, 4-35
rubberbanding, 4-35
text grid, 5-19

Display Options dialog box, 3-30, 3-31, 4-34, 5-8, 5-
16

display preferences, 3-34, 3-36, 3-37
changing graphics properties, 4-56
changing text properties, 4-53

Display Preferences dialog box, 3-36
displaying

pin names, 6-25
pin numbers, 6-25
toolbars, 3-7

distinction between connectors and ports, 11-3
dockable toolbars, 3-7
Draw Arc button, 3-12, 5-8, 6-10
Draw Block button, 3-9, 7-4
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Draw Box button, 3-12, 5-8, 6-11
Draw Bus button, 1-12, 3-9, 4-22
Draw Circle button, 3-12, 5-8, 6-11
Draw Polyline button, 3-12, 5-9, 6-11
Draw Text Box button, 3-12
Draw Text button, 3-12, 4-51, 5-9, 6-12
Draw Wire

button, 3-9
Draw Wire button, 1-11, 4-23, 7-23
Drawing

toolbar, 3-9
drawing

additional pages, 4-60
arc, 6-10
area, 3-28
block, 3-9
box, 6-11
bus, 1-12, 3-9, 4-30, 4-31
circle, 6-11
connections, 4-31
custom power and ground symbols, 4-27
line, 6-11
lower-level schematic, 7-24
options, 4-33
orthogonal wires and buses, 4-33
symbol graphics, 6-10
text, 3-12, 4-51, 6-12
text box, 3-12, 4-50
top-level schematic, 7-20
wire, 1-11, 3-9, 4-28

DSL blocks
creating and editing, 10-2

DXF files
exporting, B-1

E
ECO, 11-29

applying backward, 11-22
applying forward, 11-23
definition of, Glossary-2
file formats, 11-24

EDIF 2 0 0, 11-24
edit attributes, 5-14
Edit Attributes button, 3-9, 4-17, 5-9, 6-44, 7-7
Edit Attributes dialog box, 4-59, 11-18
Edit Gate Types dialog box, 6-41
Edit Package Definition dialog box, 6-35
Edit Package Types dialog box, 6-38

Edit Reference Designator dialog box, 1-14, 7-5, 11-7
Edit Reference dialog box, 7-22
Edit Symbol button, 3-9, 4-18, 5-5
editing

annotation items, 4-50
annotation text, 4-52
attribute, 4-12, 4-17
bounding box, 6-29
bus label, 4-31
design, 1-2
DSL blocks, 10-2
existing symbols, 6-20
global, 4-17
hidden power and ground pins, 6-27
hierarchical block, 7-4
hierarchical design, 1-2
hierarchical symbols, 7-9
instance of schematic, 7-17
multi-sheet designs, 4-60
open package library, 6-37
package definition, 6-37
package definition, active symbol, 6-37
package types, 6-37
page title, 4-46
part attributes, 4-12
part origin, 6-28
parts, 4-9
pin name on hierarchical block, 7-7
pin numbers, 6-40
pin types, 6-23
schematic definition, 7-17
selecting part, 6-20
simulation models, 8-6
single line text, 4-53
symbol, 1-2
symbol default attribute, 4-18
text within text box, 4-51
title block, 4-46

editor configuration, 6-48
Editor Configuration dialog box, 3-18, 6-48
electrical rules check, See ERC

definition of
elements of a symbol, 6-10
Enable Bias Current Display button, 3-10
Enable Bias Voltage Display button, 3-10
enabling

automatic panning, 3-45
auto-repeat, 4-19
grid display, 3-29, 5-16
orthogonal drawing, 4-34
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pin swapping, 6-43
rubberbanding, 4-37
snap-to-grid, 5-17
snap-to-pin, 3-31, 4-34, 5-17
stay-on-grid, 3-30, 5-16
text grid, 3-32, 5-19
toolbar display, 3-7, 5-8

ERC, Glossary-2
examples

creating hierarchical design, 7-20
drawing a schematic, 1-4
using auto-naming, 4-22
using auto-repeat, 4-22

existing file
opening, 4-3

existing schematic
associating with a hierarchical block, 7-8

Export file specification dialog box, B-3
Export Parts dialog box, 6-6
exporting

bill-of-materials report, 11-16
DXF Files, B-1
from the schematics editor, B-3
in the Symbol Editor, B-4
symbol, 6-6

F
file

management, 2-1
opening, 3-7
saving, 3-7

fileset
definition of, Glossary-2

filling shapes, 6-15
Find dialog box, 4-42
finding

most recently placed part, 4-5
part, 4-4, 4-42

fitting view to page, 3-44
flat schematic

definition of, Glossary-2
flipping

area of drawing, 6-18
area of schematic, 4-11
elements of a symbol, 6-17
part, 4-10

Font dialog box, 3-36
fonts

changing, 3-36
footprints

for a component, 5-4
footprints, See package types
FPGA

creating a block in a mixed design, 10-4
entering an FPGA-only design, 10-4
running simulations, 10-6
running XACTstep, 10-5
targeting Xilinx, 10-4

function keys, 3-14, 5-11

G
gate

definition of, Glossary-2
Get New Part button, 4-6, 5-9
Get Package Definition dialog box, 6-37
Get Recent Part list, 4-5
Global Edit Attributes dialog box, 4-17
global editing

definition of, Glossary-2
global editing of attributes, 4-17
global library, 1-7
global port, 4-39

definition of, Glossary-2
labeling, 4-39
placing, 4-38, 7-9
symbol, 4-26, 4-38
using, 4-38

graphical representation, 4-4
graphics properties

changing, 4-55, 4-56
filling shapes, 6-15

Graphics Properties dialog box, 6-15
gravity

definition of, Glossary-3
settings, 3-29
specifying, 3-31, 4-35, 5-17
with snap-to-pin enabled, 4-35

gravity radius
definition of, Glossary-3

grid
definition of, Glossary-3
display options, 3-29
enabling or disabling display, 5-16
settings, 3-29
spacing, 3-31, 4-35, 5-17
stay on, 3-30, 5-16
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grid on
display options, 5-16

H
hidden pins, 3-5

definition of, Glossary-3
editing, 6-27

hierarchical block
converting to symbol, 7-11
creating, 7-4
creating a schematic for, 7-5
editing, 7-4
pin names, 7-7
reference designator, 7-4
resizing, 7-5
selecting, 7-15

hierarchical design
creating, 1-2, 7-20
definition of, Glossary-3
editing, 1-2
methods, 7-3
navigating through, 7-15
passing information between levels, 7-18

hierarchical parts, 3-3
hierarchical symbol, 7-9

selecting, 7-15
horizontal offset, 4-20
hotspot

definition of, Glossary-3
HP users, iv

I
Import dialog box, 6-6
Import OrCAD File dialog box, A-2, B-3
importing

annotation graphics, 4-57
bitmaps, 4-57
graphics, 6-13
in the schematic editor, 4-57
in the symbol editor, 6-13
into Microsoft Word, 4-45
metafiles, 4-57
OrCAD SDT file, A-2
OrCAD SDT schematic, A-2
symbol, 6-6

indicated severity of message, 3-48
insert picture, 6-13

Insert Picture button, 3-12, 4-57, 6-13
instance name

definition of, Glossary-3
interface

input ports, 7-6
output ports, 7-6
port, 7-12

interface port
definition of, Glossary-3

interface ports, 4-38
symbols, 7-6

interfacing
to MicroSim PCBoards, 11-19
to other board layout products, 11-24

J
joining pins and wires, 3-5
junction, 3-5

definition of, Glossary-3

K
keyboard, 3-14, 5-11

L
label template, 4-32
labeling

bus, 1-12, 4-30, 4-31, 4-32
global port, 4-39
ports, 1-17
wire, 1-11, 1-13, 4-29, 4-32

layout netlist
creating, 11-25
file formats, 11-24
mapping files, 11-25

libraries
searching for parts, 4-6

library
browser, 4-8
configuring, 3-16
custom, 4-18
list of, F-1
model, 4-4
name, 6-49
package, 4-4
path, 6-49
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removing, 3-20
simulation model, 8-5
symbol, 3-16, 4-4, 6-5, F-1

Library Browser dialog box, 1-8, 4-8, 4-39
library expansion and compression utility, C-1
Library Settings dialog box, 3-18, 6-48
line, drawing, 6-11
loading

symbol libraries, 6-20
locating

new library, 3-19
pointer on schematic, 1-9, 3-13
source of message, 3-48

M
main functions of MicroSim Schematics, 1-2
main window, 3-6
managing files, 2-1
mapping files, 11-25
marker

attaching, 11-3
definition of, Glossary-3
using, 8-9

Marker Color button, 3-10
menus, 3-6, 5-7
message

definition of, Glossary-3
Message Viewer, 3-48

additional information, 3-49
closing, 3-49
severity indicator, 3-48
using, 3-47

metafiles
importing, 4-57, 6-13

mirroring, See flipping
model

behavioral, 7-13
definition, 4-4
library, 4-4
name, E-2
simulation, 8-4, F-2

model definition
definition of, Glossary-3

More Info button, 3-49
mouse conventions, iv
moving

down in hierarchy, 7-15
interface port symbols, 7-6

non-electrical information, 4-59
object on schematic, 4-41
parts, 1-15
symbol element, 6-19
text, 1-15
to top of hierarchy, 7-15
up in hierarchy, 7-15
wires, 1-15

msim.ini file
configuring, 3-39
definition of, Glossary-3

multiple elements
selecting in symbol editor, 6-14

multiple line text
adding, 4-50

multiple pages
viewing, 4-62

multi-sheet designs
connectivity, 4-60

N
navigating

moving down in hierarchy, 7-15
moving up in hierarchy, 7-15
through hierarchical designs, 7-15
to top of hierarchy, 7-15

navigation, Glossary-3
nesting

hierarchical symbols, 7-9
net

definition of, Glossary-3
netlist

definition of, Glossary-4
simulation, 8-8

netlisting
configuration items, D-1
EDIF, D-4
levels of schematics, 7-18
preferences, D-3

new attributes
creating, 4-12

new features of release, vii
new file

opening, 4-3
New File button, 3-7, 4-3, 5-8
New Symbol button, 5-9, 6-4
node names

netlisting preferences, D-3
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nodeset
definition of, Glossary-4

non-electrical information
adding, 4-50
annotation symbols, 4-58

O
off-page port

definition of, Glossary-4
symbol, 4-38
using, 4-38

offset
horizontal, 4-20
vertical, 4-20

online Help, 3-48
Open File button, 3-7, 4-3, 5-8
opening

existing file, 4-3
file, 3-7
new file, 4-3

options
auto-fit, 4-65
auto-naming, 1-13, 4-32
auto-repeat, 1-9, 4-19
configuration, 3-15
drawing, 4-33
editor configuration, 1-7
grid spacing, 5-17
OrCAD importing, A-4
orthogonality, 4-33
printing, 4-64
scaling, 4-65
specifying gravity, 5-17
text grid, 5-19

OrCAD
differences between OrCAD SDT and Schematics, 

A-9
import options, A-4
importing, A-2

origin, 6-28
definition of, Glossary-4

orthogonal
connectivity, 4-33
drawing wires and buses, 4-33
enabling, 4-34
with rubberbanding enabled, 4-36

Outline border style, 3-27

P
package

definition of, Glossary-4
information, 6-34
library, 4-4

package class priorities, 11-10
package definition

active symbol, 6-37
contents, 11-6
copying, 6-36
creating, 6-35, A-5
creating new, 6-35
deleting, 6-45
editing, 6-35
how used, 11-6
name, E-2
open package library, 6-37
where stored, 4-4

Package Definition dialog box, 6-35
Package dialog box, 11-8
package library

definition of, Glossary-4
package type class

definition of, Glossary-4
package types

adding, 6-46
assigning, A-5
configuring, 6-46
definition of, Glossary-4
editing, 6-37
list of, 6-34
multiple, 6-39
per pin assignment, 6-38
symbol, 5-4

Package Types dialog box, A-5
packager, 11-6
packaging, 6-35

automatically, 11-8
information, 5-3
parts in design, 11-6
reference designators, 11-9

PADS layout, 11-24
page

border, 3-4
changing settings, 3-24
changing size, 3-23
connecting, 4-61
copying, 4-61
creating new, 4-60
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definition of, Glossary-4
deleting, 4-63
title, 4-46
title changing, 4-46
viewing, 4-62
viewing multiple, 4-62

Page Info dialog box, 4-46
Page Settings dialog box, 3-28
Page Size dialog box, 3-23
Pan & Zoom dialog box, 3-43, 3-45
panning

automatic, 3-45
new center, 3-44

part
auto-repeat, 4-19
copying, 4-18
definition of, Glossary-4
finding, 4-4, 4-42
flipping, 4-10
graphical representation, 3-3
hierarchical, 3-3
instance, 4-14
moving, 1-15, 4-41
packaging, 6-34
placing, 4-9, 4-22
primitive, 3-3
replacing, 4-24
rotating, 4-10
searching, 4-41
selecting, 4-5, 4-40, 4-41

part attributes
specifying, 8-3

part browser, 4-6
advanced, 4-6
basic, 4-6

Part Browser dialog box, 1-8, 1-9, 1-16, 4-6, 7-21
part description

definition of, Glossary-4
part instance

changing display of attributes, 4-15
definition of, Glossary-4

part origin
editing, 6-28

part outline
definition of, Glossary-4

part value, changing, 1-14
parts

placing and editing, 4-9
stopping placement, 4-9

passing information between levels of hierarchy, 7-18

pasting
between pages, 4-62
selected object, 4-43, 6-22

P-CAD layout, 11-24
PCBoards layout, 11-24
pin

adding to a symbol, 6-12
assignments, 6-38
broken, 8-4
definition of, Glossary-4
hidden, 3-5, Glossary-3
name, 5-14, 6-40
number, 5-14
shared power and ground, 6-42
snap to, 3-31, 4-34, 5-17
swapping, 6-43, 11-18
text characteristics, 5-14
unmodeled, 4-4, 8-4

pin assignment list, 6-34
Pin Assignments dialog box, 6-40
pin definition

definition of, Glossary-4
pin names

changing on the block, 7-23
definition of, Glossary-5
displaying, 6-25

pin numbers
assigning, 6-42
changing, 6-25
definition of, Glossary-5
determining, 11-6
displaying, 6-25
editing, 6-40
specifying physical, 6-40

pin on hierarchical block
deleting, 7-7

Pin Swaps dialog box, 6-43
Pin Type dialog box, 6-24
pin types

available, 6-23
changing, 6-24
defining, 6-23
selecting a default, 6-24

pin-to-pin spacing, 3-29
definition of, Glossary-5

Place Pins button, 5-9, 6-12
Place Text dialog box, 6-12
placing

bus and part, 4-22
connectors, 11-3
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global ports, 4-39, 7-9
interface ports, 7-9
parts, 1-8, 4-9
ports, 1-16
power and ground symbols, 1-17, 4-26
previously selected part, 4-5
repeating, 4-19
resistors, 1-9
stimulus sources, 8-7
symbol, 4-9
voltage source, 7-21

PLD(s)
updating the schematic, 10-3

PLD(s)/CPLD(s)
targeting using PLSyn, 10-2

PLSyn
targeting PLD(s)/CPLD(s), 10-2

pointer behavior, 4-55
popping, 7-15
port

definition of, Glossary-5
global, 4-38, Glossary-2
interface, 7-6, 7-12, Glossary-3
labeling, 1-17
off-page, 4-38, 4-61, Glossary-4
placing, 1-16
where used, 3-4

Ports and connectors
distinctions between, 11-3

power and ground symbols, 1-17, 4-26
power symbols, custom, 4-27
prerequisite to drawing schematic, 1-2
primitive parts, 3-3
primitive symbol, 7-9

definition of, Glossary-5
Print button, 3-7, 4-64
Print dialog box, 4-64, 5-21
printing

bill-of-materials report, 11-13
design, 4-64
options, 4-64
schematic, 4-64
selected area, 4-64
symbol, 5-21

programmable logic
simulating design from Schematics, 10-3
symbols, 10-3
targeting parts for, 10-2

programmable logic devices, See PLD
properties

changing, 4-52
Protel layout format, 11-24
pushing, 7-15

into block, 7-3

R
Redraw button, 3-8, 3-13, 5-7, 5-9
reference designator

assigning, 4-21, 11-7
auto-naming, 4-21
changing, 1-14, 7-5
definition of, Glossary-5
value, E-3

refreshing the screen, 3-13
Remove Package Definition dialog box, 6-45
removing

configured library, 3-20
package definition, 6-45

repeating part placement, 4-19
Replace Part dialog box, 4-24
replacing

multiple parts, 4-25
parts, 4-24
same name parts, 4-25
single part, 4-24

Report Setup dialog box, 11-14
Reports dialog box, 11-13
resistor

changing default value, 4-18
resizing

annotation graphics, 4-55
bitmap, 4-57
bounding box, 6-29
hierarchical block, 7-5
imported graphic, 4-57
text box, 4-51, 4-52
Windows metafile, 4-57

returning
to schematic editor, 5-6

rewiring, 4-29
rotating

area of drawing, 6-17
area of schematic, 4-10
elements of a symbol, 6-17
part, 1-9, 4-10

rubberbanding
connectivity, 4-35
enabling, 4-37
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orthogonal
disabled with rubberbanding enabled, 4-36

with orthogonal enabled, 4-36
rules of connectivity, 4-30
running simulations

for FPGA in Xilinx, 10-6

S
Save File button, 3-7, 5-8, 7-24
saving

bill-of-materials report, 11-13
file, 3-7, 7-24, 7-27
schematic, 1-18
symbol, 6-8
to a library, 6-8

scale factor setting, 3-43
scaling, 4-65
schematic

associating with hierarchical block, 7-8
definition of, Glossary-5
editing definition, 7-17
editing instance of, 7-17
locating in hierarchy, 7-16
symbolizing, 7-10
translating, 7-13

schematic editor
closing, 4-70
exporting, B-3
importing graphics, 4-57
returning, 5-6
simulating a Programmable Logic Design, 10-3
using, 3-1

Schematics Export dialog box, B-3
SCICARDS layout format, 11-24
search criteria, 4-42
searching

for parts, 4-6, 4-41
for schematic in hierarchy, 7-16

Select Page dialog box, 4-62
Select Part button, 3-9, 7-21
select recent part list size, 3-41
selecting

area of schematic, 4-40
area of symbol drawing, 6-14
area of view, 3-42
attribute of object, 4-40
auto-repeat, 4-19
default pin types, 6-24

element of drawing, 6-14
fonts, 3-36
library, 4-8
multiple elements, 6-14
multiple objects, 4-40
objects on schematic, 4-40
part by description, 4-7
part by name, 4-5
part for editing, 6-20
part from symbol library, 4-8
parts, 1-8

selection area
definition of, Glossary-5

selection rectangle, 4-40
Set Attribute Level dialog box, 7-18
Set Attribute Value dialog box, 1-11, 4-29
Set Up Block dialog box, 7-5, 7-24
setpoint

definition of, Glossary-5
setting

autosave interval, 3-32
border style, 3-24
default properties, 3-34
outline border, 3-24
package class priorities, 11-10
scale factor, 3-43
zoned border, 3-24
zoom parameters, 3-43

Setup Package Class Priorities dialog box, 11-10
shapes, filling, 6-15
Shared Pin Assignments dialog box, 6-42
shortcuts

function keys, 3-14, 5-11
toolbar buttons, 3-7

Show/Hide Currents on Selected Part(s) button, 3-10
Show/Hide Voltage on Selected Net(s) button, 3-10
Simulation

toolbar, 3-10
simulation

attaching markers, 11-3
attribute, 8-3
checklist, 4-4
definition of, Glossary-5
include information, A-4
models, 4-4, 5-4, 8-4, F-2
of programmable logic design, 10-3
parts designated for, E-4

Simulation button, 3-10
simulation library

configuring, 8-5
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simulation model
defined, 8-5
editing, 8-6
library, 8-5

single line text
editing, 4-53

snap-to-grid
enabling or disabling, 5-17

snap-to-pin, 3-31, 4-34, 5-17
source

current stimulus, 8-7
digital stimulus, 8-7
voltage stimulus, 8-7

spacing, pin-to-pin, 3-29
specifying

multi-gate component information, 6-41
par packaging information, 6-34
part attributes, 8-3
physical pin numbers, 6-40
pin types, 6-23
text grid size, 5-19

splitting
bus, 4-31

Standard Schematics
toolbar, 3-7

starting
new design, 1-6
schematic editor, 4-3
simulator, 8-8
symbol editor, 4-58, 5-5
symbol editor automatically, 5-6

starting Schematics
Motif , 1-6

status bar, 3-13
stay-on-grid, 3-30, 5-16

with snap-to-grid enabled, 4-34, 5-17
stimulus

adding, 8-7
defining, 8-7
definition of, Glossary-5
editor, 8-7
source, 4-4

swapping pins, 11-18
symbol

accessing, 6-20
annotation, 3-4
as element of a component, 5-3
base, 6-7
connector, 11-5
converting from block, 7-11

copying, 6-5
creating, 1-2, 6-3
default attribute, 4-18
definition of, Glossary-5, Glossary-6
editing, 1-2, 4-18, 6-20
elements of, 6-10
exporting, 6-6
global port, 4-26
hierarchical, 7-9
library, 3-16, 4-4, 6-5, F-1
placing, 4-9
port, 3-4
primitive, 7-9
printing, 5-21
stopping placement, 4-9
wiring, 7-23

symbol aliases, 6-33
symbol attribute

COMPONENT, E-2
GATE, E-2
GATETYPE, E-2
MODEL, E-2
PART, E-3
PKGREF, E-3
PKGTYPE, E-3
REFDES, E-3
SIMULATION- ONLY, E-4
TEMPLATE, E-4

symbol editor
automatically starting, 5-6
closing, 5-6
creating annotation symbols, 4-58
exporting, B-4
importing graphics, 6-13
part attributes, 8-3
rotating and flipping, 6-17
selecting an area, 6-14
shape filling, 6-15
starting, 5-5
window, 5-7

symbol graphics
drawing, 6-10

symbol libraries, 6-48
browsing, 4-8
loading, 6-20
making available in Schematics, 6-48
table of, F-2
See also library

Symbol Wizard, 6-3
Symbol Wizard dialog box, 6-4
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symbolize, 7-9
definition of, Glossary-6

symbolizing a schematic, 7-10
symbols

annotation, 4-58
Symbols Export dialog box, B-4
syntax

bus labeling, 4-30

T
TangoPro layout format, 11-24
targeting parts for programmable logic, 10-2
text

adding to a symbol, 6-12
attribute, 5-12
characteristics, 5-12
drawing, 3-12
free-standing, 5-15
grid, 3-32, 5-19
moving, 1-15

text box
drawing, 4-50
editing text within, 4-51
resizing, 4-51

text grid
enabling, 5-19

text properties
changing, 4-52
changing in display preferences, 4-53
changing on instance basis, 4-52

text wrap, 4-51, 4-52
title bar, 5-10
title block

changing attributes, 4-47
creating, 4-46
creating a custom, 4-48
editing, 4-46
use, 3-4

toolbar buttons
Analysis Setup, 3-10
Current Marker, 3-10
Draw Arc, 3-12, 5-8, 6-10
Draw Block, 3-9, 7-4
Draw Box, 3-12, 5-8, 6-11
Draw Bus, 1-12, 3-9, 4-22
Draw Circle, 3-12, 5-8, 6-11
Draw Polyline, 3-12, 5-9, 6-11
Draw Text, 3-12, 4-51, 5-9, 6-12

Draw Text Box, 3-12
Draw Wire, 1-11, 3-9, 4-23
Edit Attributes, 3-9, 4-17, 5-9, 6-44, 7-7
Edit Symbol, 3-9, 4-18, 5-5
Enable Bias Current Display, 3-10
Enable Bias Voltage Display, 3-10
Get New Part, 4-6, 5-9
Insert Picture, 3-12, 4-57, 6-13
Marker Color, 3-10
More Info, 3-49
New File, 3-7, 4-3, 5-8
New Symbol, 5-9, 6-4
Open File, 3-7, 4-3, 5-8
Place Pins, 5-9, 6-12
Print, 3-7, 4-64
Redraw, 3-8, 3-13, 5-7, 5-9
Save File, 3-7, 5-8, 7-24
Select Part, 1-8, 3-9, 7-21
Show/Hide Currents on Selected Part(s), 3-10
Show/Hide Voltage on Selected Net(s), 3-10
Simulation, 3-10
Voltage/Level Marker, 3-10
Zoom Area, 3-8, 3-42, 5-8
Zoom In, 3-8, 3-42, 5-8
Zoom Out, 3-8, 3-42, 5-8
Zoom to Fit Page, 3-8, 3-44, 5-8

toolbars, 5-8
Annotation Graphics, 3-12
display of, 3-7
Drawing, 3-9
how to dock, 3-7
Simulation, 3-10
Standard Schematics, 3-7

trace properties, 11-19
translating

hierarchical schematics, A-7
large designs, A-8
multi-page schematics, A-7
OrCAD SDT to MicroSim Schematics, A-2
schematic, 7-13
setting up associated view, 7-14

translator, 7-13
definition of, Glossary-6

Translators dialog box, 7-14
tutorial, See examples
typographical conventions, iv
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U
Undo/Redo, 4-44
UNIX users, iv
unmodeled pins, 4-4, 8-4
updating

the schematic with the PLD(s), 10-3
user definable

zoom factor, 4-66
user defined component information, 11-15
using

AKO symbols, 6-7
auto-naming, 4-22
auto-repeat, 4-22
back annotation, 11-30
Design Manager, 2-1
global ports, 4-38
interface ports, 7-12
marker, 8-9
Message Viewer, 3-47
MicroSim PLSyn, 10-3
schematic editor, 3-1
stimulus editor, 8-7
symbol in schematic, 6-27
this guide, iv

utilities
library compression, C-1
library expansion, C-1

V
value

instance-specific part, 7-17
of attribute, 3-4

vertical offset, 4-20
view

associated, 7-14
behavioral model, 7-13
definition of, Glossary-6
setting up, 7-14
setting up multiple, 7-13

viewing
multiple pages, 4-62
page, 3-44
particular page, 4-62
selected area, 3-42
simulation model, 8-4
simulation results, 8-9

viewpoint

definition of, Glossary-6
voltage stimulus source, 8-7
voltage viewpoint

definition of, Glossary-6
Voltage/Level Marker button, 3-10

W
Where dialog box, 7-16
where to find programs, 3-38
wildcard characters, 4-6, 4-7, 4-42
window

main, 3-6
symbol editor, 5-5, 5-7

wire
definition of, Glossary-6
drawing, 1-11, 3-9, 4-28
labeling, 1-11, 1-13, 4-29, 4-32
moving, 1-15
orthogonal, 4-33
rewiring segment, 4-29
selecting, 4-40

wire segment
adding, 4-28

wiring
symbols, 7-23

wizard
symbol creation, 6-3

workspaces, 2-1

X
XACTstep

running in FPGA, 10-5
Xilinx

targeting Xilinx FPGAs, 10-4

Z
zoned border style, 3-27
Zoom Area button, 3-8, 3-42, 5-8
zoom factor, 4-66
Zoom In button, 3-8, 3-42, 5-8
Zoom Out button, 3-8, 3-42, 5-8
zoom parameters

setting, 3-43
Zoom to Fit Page button, 3-8, 3-44, 5-8
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